gdome2-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. %define nam gdome2
  2. %define ver 0.8.1
  3. %define rel 1%{?_dist_release}
  4. Summary: DOM level2 library for accessing XML files
  5. Summary(ja): XML 用 DOM レベル 2 ライブラリ
  6. Name: %nam
  7. Version: %ver
  8. Release: %rel
  9. License: LGPL
  10. Group: System Environment/Libraries
  11. URL: http://gdome2.cs.unibo.it/
  12. Source: http://gdome2.cs.unibo.it/tarball/%{nam}-%{ver}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: libxml2-devel >= 2.4.26
  15. BuildRequires: glib2-devel gtk-doc
  16. %description
  17. gdome2 is a fast, light and complete DOM level2 implementation
  18. based on libxml2. Although it has been written for the GNOME project,
  19. it can be used stand-alone.
  20. A DOM implementation (also called a host implementation) is what
  21. makes a parsed XML or HTML document available for processing via the
  22. DOM interface.
  23. gdome2 currently supports the "Core", "XML", "Events" and
  24. "MutationEvents" modules from the DOM2 Recommendation (see
  25. http://www.w3.org/TR/DOM-Level-2-Core/ and http://www.w3.org/TR/DOM-L
  26. evel-2-Events/), and is supposed to become a full implementation of
  27. all the DOM Level2 standard.
  28. Now gdome2 also partially supports the XPath module from the DOM
  29. level 3 drafts.
  30. %package devel
  31. Summary: Development files for gdome2
  32. Summary(ja): gdome2 の開発用ファイル
  33. Group: Development/Libraries
  34. Requires: gdome2 = %{ver}-%{rel}
  35. Requires: glib2-devel
  36. Requires: libxml2-devel >= 2.4.26
  37. %description devel
  38. This package contains the header files and static libraries for
  39. developing with gdome2.
  40. gdome2 is a fast, light and complete DOM level2 implementation
  41. based on libxml2. Although it has been written for the GNOME project,
  42. it can be used stand-alone.
  43. A DOM implementation (also called a host implementation) is what
  44. makes a parsed XML or HTML document available for processing via the
  45. DOM interface.
  46. gdome2 currently supports the "Core", "XML", "Events" and
  47. "MutationEvents" modules from the DOM2 Recommendation (see
  48. http://www.w3.org/TR/DOM-Level-2-Core/ and http://www.w3.org/TR/DOM-L
  49. evel-2-Events/), and is supposed to become a full implementation of
  50. all the DOM Level2 standard.
  51. Now gdome2 also partially supports the XPath module from the DOM
  52. level 3 drafts.
  53. %prep
  54. %setup -q
  55. %build
  56. if [ ! -f configure ]; then
  57. ./autogen.sh --prefix=%{_prefix}
  58. fi
  59. %configure
  60. if [ "$SMP" != "" ]; then
  61. (make "MAKE=make -k -j $SMP"; exit 0)
  62. make
  63. else
  64. make
  65. fi
  66. make
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. %makeinstall
  70. ## remove unuse files
  71. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  72. %clean
  73. rm -rf $RPM_BUILD_ROOT
  74. %post -p /sbin/ldconfig
  75. %postun -p /sbin/ldconfig
  76. %files
  77. %defattr(-, root, root)
  78. %doc AUTHORS MAINTAINERS ChangeLog INSTALL NEWS README COPYING COPYING.LIB
  79. %{_libdir}/lib*.so.*
  80. %files devel
  81. %defattr(-, root, root)
  82. #doc gtk-doc/html/*.html
  83. %{_mandir}/man1/gdome-config.1*
  84. %{_bindir}/gdome-config
  85. %{_includedir}/*
  86. %{_libdir}/lib*.so
  87. %{_libdir}/*a
  88. %{_libdir}/*.sh
  89. %{_datadir}/aclocal/gdome2.m4
  90. %{_datadir}/gtk-doc/html/*
  91. %{_libdir}/pkgconfig/gdome2.pc
  92. %changelog
  93. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1vl5
  94. - applied new versioning policy, spec in utf-8
  95. - removed *.la
  96. - added japanease summary
  97. * Sat Dec 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.1-0vl2
  98. - updated BuildRequires
  99. - changed Group to System Environment/Libraries
  100. * Tue Sep 07 2004 Satoshi MACHINO <machino@vinelinux.org> 0.8.1-0vl1
  101. - new upstream version
  102. * Sat Jan 17 2004 IWAI, Masaharu <iwai@alib.jp> 0.8.0-0vl1
  103. - build for VineSeed Plus
  104. - fix BuildRequires: glib-devel
  105. * Sun Dec 29 2002 Paolo Casarini <paolo@casarini.org>
  106. patch provided by Oron Peled <oron@actcom.co.il>
  107. - %defattr(-,root,root) wasn't set for documents in the devel
  108. package. This cause wrong ownership of docs in non-root builds.
  109. - Update URL: and Source: locations
  110. - s/Copyright:/License:/
  111. * Sun Mar 31 2002 Paolo Casarini <paolo@casarini.org>
  112. - updated descriptions and summaries
  113. * Sat Dec 15 2001 Paolo Casarini <paolo@casarini.org>
  114. - updated descriptions and summaries
  115. * Tue Oct 23 2001 Paolo Casarini <paolo@casarini.org>
  116. - added the gdome-config.1 man page
  117. * Mon Aug 6 2001 Paolo Casarini <paolo@casarini.org>
  118. - Merge of the Andrew release with mine
  119. * Thu Aug 2 2001 Andrew Chatham <andrew.chatham@duke.edu>
  120. - Spec file created
  121. * Tue Jul 3 2001 Paolo Casarini <paolo@casarini.org>
  122. - Initial release