gengetopt-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218
  1. Name: gengetopt
  2. Version: 2.23
  3. Release: 1%{?_dist_release}
  4. Summary: Tool to write command line option parsing code for C programs
  5. License: GPLv3+
  6. URL: https://www.gnu.org/software/gengetopt/
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
  10. BuildRequires: gcc-c++
  11. BuildRequires: gcc
  12. BuildRequires: valgrind
  13. BuildRequires: texinfo
  14. Provides: bundled(gnulib)
  15. %description
  16. Gengetopt is a tool to generate C code to parse the command line arguments
  17. argc and argv that are part of every C or C++ program. The generated code uses
  18. the C library function getopt_long to perform the actual command line parsing.
  19. %prep
  20. %setup -q
  21. # Suppress rpmlint error.
  22. chmod 644 ./AUTHORS
  23. chmod 644 ./ChangeLog
  24. chmod 644 ./COPYING
  25. chmod 644 ./LICENSE
  26. chmod 644 ./NEWS
  27. chmod 644 ./README
  28. chmod 644 ./THANKS
  29. chmod 644 ./TODO
  30. chmod 644 ./doc/README.example
  31. chmod 644 ./doc/index.html
  32. chmod 644 ./src/parser.yy
  33. chmod 644 ./src/scanner.ll
  34. find . -name '*.c' -exec chmod 644 {} ';'
  35. find . -name '*.cc' -exec chmod 644 {} ';'
  36. find . -name '*.cpp' -exec chmod 644 {} ';'
  37. find . -name '*.h' -exec chmod 644 {} ';'
  38. find . -name '*.ggo' -exec chmod 644 {} ';'
  39. %build
  40. %configure
  41. # Parallel build doesn't work.
  42. make
  43. %install
  44. %make_install INSTALL="%{__install} -p"
  45. rm -frv %{buildroot}%{_infodir}/dir
  46. # Use %%doc macro to install instead.
  47. rm -frv %{buildroot}%{_docdir}/%{name}
  48. mkdir ./examples
  49. pushd ./doc
  50. cp -p README.example ../examples
  51. cp -p main1.cc sample1.ggo ../examples
  52. cp -p main2.c sample2.ggo ../examples
  53. popd
  54. %check
  55. make check
  56. %files
  57. %doc AUTHORS ChangeLog NEWS README THANKS TODO
  58. %doc doc/index.html doc/%{name}.html
  59. %doc examples/
  60. %license COPYING LICENSE
  61. %{_bindir}/%{name}
  62. %{_datadir}/%{name}/
  63. %{_infodir}/*.info*
  64. %{_mandir}/man1/%{name}.1*
  65. %changelog
  66. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.23-2
  67. - initial build for Vine Linux.
  68. * Mon Sep 9 2019 Mosaab Alzoubi <moceap[At]hotmail[Dot]com> - 2.23 -1
  69. - Update to 2.23
  70. * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-15
  71. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  72. * Thu Mar 7 2019 Tim Landscheidt <tim@tim-landscheidt.de> - 2.22.6-14%{dist}
  73. - Remove obsolete requirements for %%post/%%preun scriptlets
  74. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-13
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  76. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-12
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  78. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-11
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  80. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-10
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  82. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-9
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  84. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-8
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  86. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-7
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  88. * Mon Aug 24 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 2.22.6-6
  89. - Valgrind is not available only on s/390
  90. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.6-5
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  92. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 2.22.6-4
  93. - Rebuilt for GCC 5 C++11 ABI change
  94. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.6-3
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  96. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.6-2
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  98. * Thu Feb 20 2014 Christopher Meng <rpm@cicku.me> - 2.22.6-1
  99. - Update to 2.22.6
  100. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.5-4
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  102. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.5-3
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  104. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.5-2
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  106. * Sat May 5 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.22.5-1
  107. - Update to 2.22.5-1 to fix FTBFS
  108. - valgrind supported on ARM too
  109. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.3-4
  110. - Rebuilt for c++ ABI breakage
  111. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.3-3
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  113. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.3-2
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  115. * Wed Nov 04 2009 Debarshi Ray <rishi@fedoraproject.org> - 2.22.3-1
  116. - Version bump to 2.22.3. (Red Hat Bugzilla #512414)
  117. * enum option values can contain + and -.
  118. * Fixed compilation problems due to macro FIX_UNUSED which was not in the
  119. right place.
  120. * New command line switches --header-output-dir and --src_output-dir to
  121. store cmdline.h separately from cmdline.c.
  122. * Use #include <getopt.h> in the generated files, instead of "getopt.h".
  123. * Generated functions use prototypes with char ** instead of char *const *.
  124. * Removed compilation warnings for generated files.
  125. * Fixed a compilation problem for files generated with --include-getopt
  126. with some versions of stdlib.h.
  127. * Use PACKAGE_NAME, if defined, for printing help and version.
  128. - Encoding of ChangeLog and THANKS fixed by upstream.
  129. - Removed spurious executable permissions from a bunch of files.
  130. * Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 2.22.1-3
  131. - Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  132. * Tue Feb 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 2.22.1-2
  133. - Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  134. * Mon Jun 02 2008 Debarshi Ray <rishi@fedoraproject.org> - 2.22.1-1
  135. - Version bump to 2.22.1. (Red Hat Bugzilla #444335)
  136. * Removed compilation warnings for generated files.
  137. * Fixed a bug with --long-help and enum options.
  138. * The outputs of --help and output of --show-help correspond with each other.
  139. * Fixed a compilation problem in generated output with mode options.
  140. - Parallel build problems fixed by upstream.
  141. * Fri Mar 07 2008 Debarshi Ray <rishi@fedoraproject.org> - 2.22-1
  142. - Version bump to 2.22. (Red Hat Bugzilla #428641)
  143. - Fixed build failure with gcc-4.3.
  144. - Trimmed the 'BuildRequires' list.
  145. - Changed character encodings from ISO8859-1 to UTF-8.
  146. - Disabled parallel make to prevent failure with -j2.
  147. - Added 'make check-valgrind' for ix86, x86_64, ppc and ppc64 in check stanza.
  148. - Fixed Texinfo scriptlets according to Fedora packaging guidelines.
  149. * Tue Aug 07 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.21-2
  150. - Removed 'BuildRequires: source-highlight' to prevent build failure.
  151. * Sat Aug 04 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.21-1
  152. - Version bump to 2.21. (Red Hat Bugzilla #250817)
  153. - License changed to GPLv3 or later.
  154. - Parallel build problems fixed by upstream.
  155. - README.example added by upstream.
  156. * Tue Jun 12 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.20-1
  157. - Version bump to 2.20.
  158. * Tue Jun 12 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.19.1-3
  159. - Added 'BuildRequires: ...' for check stanza.
  160. - Added a check stanza.
  161. - Removed -devel package.
  162. * Mon Jun 11 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.19.1-2
  163. - Used variables name and version in Source0.
  164. - Mentioned /sbin/install-info as a requirement for post and preun.
  165. - Used _datadir instead of defining sharedir.
  166. - Disabled parallel make to prevent failure with -j2.
  167. - Removing /usr/share/info/dir in the install stanza.
  168. - Replaced '$RPM_BUILD_DIR' with '.' in the install stanza.
  169. * Sun Jun 10 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.19.1-1
  170. - Initial build.
  171. - Added README.example from Debian.
  172. - Changed version and date in online manual page to 2.19.1 from 2.19rc.