glslang-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167
  1. Name: glslang
  2. Summary: OpenGL and OpenGL ES shader front end and validator
  3. Version: 11.2.0
  4. Release: 1%{?_dist_release}
  5. Group: programming
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: BSD and GPLv3+ and ASL 2.0
  9. URL: https://github.com/KhronosGroup
  10. Source0: %url/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  11. Patch1: glslang-default-resource-limits_staticlib.patch
  12. # Patch to build against system spirv-tools (rebased locally)
  13. #Patch3: https://patch-diff.githubusercontent.com/raw/KhronosGroup/glslang/pull/1722.patch#/0001-pkg-config-compatibility.patch
  14. Patch3: 0001-pkg-config-compatibility.patch
  15. BuildRequires: cmake
  16. BuildRequires: gcc-c++
  17. BuildRequires: ninja
  18. BuildRequires: spirv-tools-devel
  19. %description
  20. %{name} is the official reference compiler front end for the OpenGL
  21. ES and OpenGL shading languages. It implements a strict
  22. interpretation of the specifications for these languages.
  23. %package devel
  24. Summary: Development files for %{name}
  25. Group: programming
  26. Requires: %{name}%{?_isa} = %{version}-%{release}
  27. %description devel
  28. %{name} is the official reference compiler front end for the OpenGL
  29. ES and OpenGL shading languages. It implements a strict
  30. interpretation of the specifications for these languages.
  31. %debug_package
  32. %prep
  33. %autosetup -p1 -n %{name}-%{version}
  34. # Fix rpmlint warning on debuginfo
  35. find . -name '*.h' -or -name '*.cpp' -or -name '*.hpp'| xargs chmod a-x
  36. %build
  37. %cmake -DCMAKE_BUILD_TYPE=Release \
  38. -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
  39. -DCMAKE_SKIP_RPATH:BOOL=yes \
  40. -DBUILD_SHARED_LIBS=OFF \
  41. -GNinja
  42. %cmake_build
  43. %install
  44. %cmake_install
  45. # we don't want them in here
  46. rm -rf %{buildroot}%{_includedir}/SPIRV
  47. %ifnarch s390x ppc64
  48. %check
  49. pushd Test
  50. ./runtests localResults ../%{_vpath_builddir}/StandAlone/glslangValidator ../%{_vpath_builddir}/StandAlone/spirv-remap
  51. popd
  52. %endif
  53. # Install libglslang-default-resource-limits.a
  54. install -pm 0644 %{_vpath_builddir}/StandAlone/libglslang-default-resource-limits.a %{buildroot}%{_libdir}/
  55. %files
  56. %doc README.md README-spirv-remap.txt
  57. %{_bindir}/glslangValidator
  58. %{_bindir}/spirv-remap
  59. %files devel
  60. %{_includedir}/glslang/
  61. %{_libdir}/libHLSL.a
  62. %{_libdir}/libOGLCompiler.a
  63. %{_libdir}/libOSDependent.a
  64. %{_libdir}/libSPIRV.a
  65. %{_libdir}/libSPVRemapper.a
  66. %{_libdir}/libglslang.a
  67. %{_libdir}/libGenericCodeGen.a
  68. %{_libdir}/libMachineIndependent.a
  69. %{_libdir}/libglslang-default-resource-limits.a
  70. %{_libdir}/pkgconfig/glslang.pc
  71. %{_libdir}/pkgconfig/spirv.pc
  72. %{_libdir}/cmake/*
  73. %changelog
  74. * Sun Mar 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 11.2.0-1
  75. - new upstream release.
  76. - updated Patch1 and 3.
  77. * Wed Jul 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.13.3743-1
  78. - initial build for Vine Linux.
  79. - new upstream release.
  80. * Wed Apr 22 2020 Dave Airlie <airlied@redhat.com> - 8.13.3559-2
  81. - Update to latest git snapshot
  82. * Wed Jan 29 2020 Dave Airlie <airlied@redhat.com> - 8.13.3559-1
  83. - Update to latest git snapshot
  84. * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.13.3496-3.20191102.git7f77b2e
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  86. * Thu Dec 19 2019 Leigh Scott <leigh123linux@googlemail.com> - 7.13.3496-2.20191102.git7f77b2e
  87. - Add patch for 'Fix a couple relative header paths in header'
  88. * Wed Nov 13 2019 Dave Airlie <airlied@redhat.com> - 7.13.3496-1
  89. - Latest upstream snapshot for validation layers build
  90. * Sat Aug 03 2019 Dave Airlie <airlied@redhat.com> - 7.11.3214-3
  91. - Latest upstream snapshot for validation layers build
  92. * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.11.3214-2
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  94. * Mon Jun 10 2019 Robert-André Mauchin <zebob.m@gmail.com> - 7.11.3214-1
  95. - Release 7.11.3214
  96. - Add patch to build against system spirv-tools
  97. * Fri Mar 29 2019 Dave Airlie <airlied@redhat.com> - 3.1-0.13.20190329.gite0d59bb
  98. - Update for vulkan 1.1.101.0
  99. * Tue Feb 12 2019 Dave Airlie <airlied@redhat.com> - 3.1-0.12.20190212.git05d12a9
  100. - Update for vulkan 1.1.92.0
  101. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.11.20180727.gite99a268
  102. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  103. * Tue Aug 07 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.10.20180727.gite99a268
  104. - Update for vulkan 1.1.82.0
  105. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.9.20180416.git3bb4c48
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  107. * Mon Apr 23 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.8.20180416.git3bb4c48
  108. - Update for vulkan 1.1.73.0
  109. * Wed Mar 07 2018 Adam Williamson <awilliam@redhat.com> - 3.1-0.7.20180205.git2651cca
  110. - Rebuild to fix GCC 8 mis-compilation
  111. See https://da.gd/YJVwk ("GCC 8 ABI change on x86_64")
  112. * Fri Feb 09 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.6.20180205.git2651cca
  113. - Update for vulkan 1.0.68.0
  114. * Fri Feb 09 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.5.20171028.git715c353
  115. - Use ninja to build
  116. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.4.20171028.git715c353
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  118. * Wed Jan 03 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.3.20171028.git715c353
  119. - Exclude s390x and ppc64 from check section
  120. * Wed Jan 03 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.2.20171028.git715c353
  121. - Add check section to run tests
  122. - Split binaries into main package
  123. * Thu Jul 13 2017 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.1.20171028.git715c353
  124. - First build