gnome-panel-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751
  1. %bcond_with systemd
  2. %define use_eds 1
  3. %define gettext_package gnome-panel-2.0
  4. %define gnome_desktop3_version 2.91.0
  5. %define glib2_version 2.25.2
  6. %define gtk3_version 3.22.0
  7. %define libgnome_version 2.32.0
  8. %define orbit_version 2.14.19
  9. %define libwnck3_version 3.4.6
  10. %define gconf_version 2.32.0
  11. %define gnome_menus_version 3.7.90
  12. %define evolution_data_server_version 3.5.3
  13. %define cairo_version 1.0.0
  14. %define dbus_version 1.4.0
  15. %define dbus_glib_version 0.88
  16. %define libgweather_version 3.17.1
  17. %define libcanberra_version 0.25
  18. %define gobject_introspection_version 0.9.8
  19. Summary: GNOME panel
  20. Summary(ja): GNOME パネル
  21. Name: gnome-panel
  22. Version: 3.40.0
  23. Release: 1%{_dist_release}%{?with_systemd:.systemd}
  24. Group: desktop-gnome
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. URL: http://www.gnome.org/
  28. License: GPL
  29. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  30. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  31. # Remove this line and next line when upstream adopt Source1
  32. Source2: vine6-panel-default-setup.entries
  33. Source5: vine-panel-backwards-compat-config.schemas
  34. Source12: gnome-compiler-flags.m4
  35. Source13: panel-default-layout.layout.vine
  36. Patch1000: gnome-panel-3.40.0-elogind.patch
  37. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  38. Requires: %{name}-libs = %{version}-%{release}
  39. Requires: gnome-desktop3 >= %{gnome_desktop3_version}
  40. Requires: libwnck3 >= %{libwnck3_version}
  41. Requires: gnome-menus >= %{gnome_menus_version}
  42. Requires: vine-menus >= 1.1
  43. Requires(post,postun): gtk3
  44. %if %{use_eds}
  45. Requires: evolution-data-server >= %{evolution_data_server_version}
  46. %endif
  47. Requires: libSM
  48. #BuildRequires: libxml2-python
  49. BuildRequires: intltool
  50. BuildRequires: gettext
  51. BuildRequires: automake
  52. BuildRequires: autoconf
  53. BuildRequires: libtool
  54. BuildRequires: libxslt
  55. BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
  56. BuildRequires: gtk3-devel >= %{gtk3_version}
  57. BuildRequires: libwnck3-devel >= %{libwnck3_version}
  58. BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
  59. BuildRequires: cairo-devel >= %{cairo_version}
  60. BuildRequires: yelp-tools
  61. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  62. BuildRequires: gtk-doc
  63. BuildRequires: pango-devel
  64. BuildRequires: libX11-devel
  65. BuildRequires: libXau-devel
  66. %if %{use_eds}
  67. BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
  68. #BuildRequires: ORBit2-devel >= %{orbit_version}
  69. BuildRequires: dbus-devel >= %{dbus_version}
  70. %endif
  71. BuildRequires: libgweather-devel >= %{libgweather_version}
  72. BuildRequires: libcanberra-devel >= %{libcanberra_versino}
  73. BuildRequires: librsvg2-devel
  74. BuildRequires: libSM-devel
  75. BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
  76. BuildRequires: dconf-devel
  77. BuildRequires: polkit-devel
  78. #BuildRequires: telepathy-glib-devel
  79. BuildRequires: desktop-file-utils
  80. BuildRequires: gdm-devel
  81. %if %{with systemd}
  82. BuildRequires: systemd-devel
  83. %else
  84. BuildRequires: elogind-devel
  85. %endif
  86. Obsoletes: gnome-netstatus < 2.29
  87. %description
  88. The GNOME panel provides the window list, workspace switcher, menus, and other
  89. features for the GNOME desktop.
  90. %description -l ja
  91. GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
  92. 特徴を GNOME デスクトップに提供します。
  93. %package libs
  94. Summary: Libraries for use in panel applets of GNOME
  95. Summary(ja): GNOME のパネルアップレットで使用するライブラリ
  96. Group: system
  97. %description libs
  98. Libraries for use in panel applets of GNOME.
  99. %description libs -l ja
  100. GNOME のパネルアプレットで使用するライブラリ
  101. %package devel
  102. Summary: Development environment for panel applets of GNOME
  103. Summary(ja): GNOME のパネルアップレット用開発環境
  104. Group: programming
  105. Requires: %{name}-libs = %{version}-%{release}
  106. Requires: pkgconfig
  107. Requires: glib2-devel >= %{glib2_version}
  108. Requires: gtk3-devel >= %{gtk3_version}
  109. %description devel
  110. Header files and libraries for building a panel applets of GNOME.
  111. %description devel -l ja
  112. GNOME のパネルアプレットをビルドするためのヘッダファイル及びライブラリ集
  113. %debug_package
  114. %prep
  115. %setup -q
  116. %if !%{with systemd}
  117. %patch1000 -p1 -b .elogind
  118. %endif
  119. cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
  120. cp -f %{SOURCE12} m4
  121. cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
  122. cp -f %{SOURCE13} data/panel-default-layout.layout
  123. %build
  124. autoreconf -vif
  125. %configure \
  126. --disable-gtk-doc \
  127. --enable-introspection=yes \
  128. %if %{use_eds}
  129. --enable-eds=yes
  130. %else
  131. --enable-eds=no
  132. %endif
  133. %__make %{?_smp_mflags}
  134. %install
  135. rm -rf $RPM_BUILD_ROOT
  136. make install DESTDIR=$RPM_BUILD_ROOT
  137. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  138. /bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  139. %find_lang %{gettext_package} --all-name --with-gnome
  140. %clean
  141. rm -rf $RPM_BUILD_ROOT
  142. %post
  143. touch --no-create %{_datadir}/icons/hicolor
  144. %postun
  145. touch --no-create %{_datadir}/icons/hicolor
  146. %files -f %{gettext_package}.lang
  147. %defattr(-,root,root)
  148. %license COPYING COPYING.LESSER
  149. %doc AUTHORS COPYING-DOCS NEWS README.md
  150. %{_bindir}/*
  151. %{_libdir}/%{name}/modules/*.so
  152. %{_datadir}/applications/*.desktop
  153. %{_datadir}/icons/hicolor/*/*/*
  154. %{_datadir}/glib-2.0/schemas/*.xml
  155. %{_datadir}/gnome-panel
  156. %{_mandir}/man*/*
  157. %files libs
  158. %{_libdir}/*.so.*
  159. %files devel
  160. %{_libdir}/pkgconfig/*.pc
  161. %{_includedir}/gnome-panel*
  162. %{_libdir}/*.so
  163. %{_datadir}/gtk-doc
  164. %changelog
  165. * Sun Mar 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.40.0-1
  166. - new upstream release.
  167. - updated Patch1000.
  168. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.2-1
  169. - new upstream release.
  170. * Sun Dec 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-1
  171. - new upstream release.
  172. * Sat Jan 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.1-1
  173. - new upstream release.
  174. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
  175. - new upstream release
  176. * Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  177. - new upstream release
  178. - add Source13 (panel-default-layout.layout.vine)
  179. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  180. - new upstream release
  181. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  182. - new upstream release
  183. - remove Patch0 (gnome-panel-3.5.91-configure.patch)
  184. - change BuildRequires: yelp-tools instead of gnome-doc-utils
  185. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
  186. - new upstream release
  187. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  188. - new upstream release
  189. - add BuildRequires: polkit-devel
  190. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  191. - new upstream release
  192. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  193. - new upstream release
  194. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  195. - new upstream release
  196. - remove BuildRequires: polkit-gnome-devel
  197. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-2
  198. - rebuild with evolution-data-server-3.1.90
  199. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
  200. - new upstream release
  201. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
  202. - new upstream release
  203. - drop old Patches
  204. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  205. - change BuildRequires: libwnck3-devel instead of libwnck-devel
  206. - add BuildRequires: dconf-devel, telepathy-glib-devel
  207. - add Obsoletes: gnome-netstatus
  208. - add Patch0 (gnome-panel-3.0.2-configure.patch)
  209. * Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
  210. - update SOURCE2(vine6-panel-default-setup.entries)
  211. - remove bottom panel
  212. - move window_list and workspace_switcher applet to top panel
  213. * Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
  214. - update Source1 (clock.gnome-2.32.ja.po)
  215. * Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
  216. - remove Provides: gnome-panel-devel
  217. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  218. - new upstream release
  219. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
  220. - new upstream release
  221. - add BuildRequires: gobject-introspection-devel
  222. - remove BuildRequires: libgnomeui-devel
  223. - remove SOURCE3 and SOURCE4
  224. - drop Patch11
  225. - add configure option (--enable-introspection=yes)
  226. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
  227. - rebuild with rpm-4.8.1 for pkg-config file
  228. * Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
  229. - create -libs and -devel package
  230. * Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  231. - new upstream release
  232. * Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
  233. - rebuild with evolution-data-server-2.30.2
  234. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  235. - new upstream release
  236. - update Patch8, Patch9 (from FC package)
  237. - add BuildRequires: libcanberra-devel
  238. * Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
  239. - update translation of clock applet manual
  240. - add translation of fish applet manual
  241. * Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
  242. - add libSM(-devel) to (Build)Requires
  243. - add desktop-file-utils to BuildRequires
  244. * Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
  245. - update translation of clock applet manual
  246. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  247. - new upstream release
  248. - updated Patch0 and 2
  249. * Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  250. - new upstream release
  251. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
  252. - rebuild with gtk2-2.16.3
  253. * Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  254. - add empty gconf entries to vine-panel-default-setup.entries
  255. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  256. - new upstream release
  257. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  258. - new upstream release
  259. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
  260. - update vine-panel-default-setup.entries again..
  261. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
  262. - update vine-panel-default-setup.entries
  263. * Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
  264. - remove mixer applets from default panel setup
  265. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  266. - new upstream release
  267. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
  268. - new upstream release
  269. - added BuildRequires: PolicyKit-gnome-devel
  270. * Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  271. - new upstream release
  272. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  273. - new upstream release
  274. * Tue Jun 3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
  275. - new upstream release
  276. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
  277. - new upstream release
  278. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
  279. - new upstream release
  280. - removed Patch25,26,27,29 and 30 (merged into upstream)
  281. * Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
  282. - added Patches from FC
  283. * Fri Mar 28 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-8
  284. - Fix editing of locations in the clock applet
  285. * Fri Mar 28 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-7
  286. - Convert the edit and find location windows to dialogs
  287. * Thu Mar 27 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-6
  288. - Improve the time settings window
  289. * Thu Mar 27 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-5
  290. - Make the find-location window of the clock larger
  291. * Sat Mar 15 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-4
  292. - Only save the session when the users wants it
  293. * Fri Mar 14 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-3
  294. - Populate the location list before showing the preference window
  295. * Sat Mar 8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
  296. - Add "About This Computer" item to System menu if it exists
  297. * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
  298. - Try harder to avoid resizing the popup
  299. - updated BuildRequires
  300. * Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  301. - new upstream release
  302. - added BuildRequires: libgweather-devel
  303. * Tue Jan 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
  304. - new upstream release
  305. - updated %post and %postun section
  306. - added %pre and %preun section
  307. - added Patches from Fedora
  308. * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
  309. - Sharper icons
  310. * Wed Oct 3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
  311. - Make it possible to start s-c-d from the clock menu again (#316921)
  312. * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
  313. - Don't pop up an error if an applet from the default
  314. configuration is missing
  315. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
  316. - Turns out we need requires for applets in the default config (#293261)
  317. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
  318. - Drop the requires for fast-user-switch-applet (#253831)
  319. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
  320. - new upstream release
  321. - dropped Patch22 (merged into upstream)
  322. * Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  323. - new upstream release
  324. * Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
  325. - add missing BuildRequires to gnome-menus-devel (<BTS:319>)
  326. * Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
  327. - new upstream release
  328. - fix panel-default-setup.entries to change the name of
  329. firefox desktopfile (<BTS:229>)
  330. * Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
  331. - add patch 11 to fix disappearing of recent documents list.
  332. <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
  333. * Sat Jun 3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  334. - new upstream release
  335. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  336. - new upstream release
  337. * Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  338. - run gtk-update-icon-cache in %%post script.
  339. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  340. - new upstream release
  341. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
  342. - update vine-panel-default-setup.entries
  343. - replace mozilla by firefox
  344. - remove nautilus
  345. - add notification area applet on top panel
  346. - add trashbox applet on bottom panel
  347. - cleanup %%post script
  348. * Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
  349. - new upstream release
  350. * Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
  351. - new upstream release
  352. - added Prereq: scroolkeeper, GConf2
  353. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  354. - new upstream release
  355. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  356. - new upstream release
  357. * Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
  358. - new upstream release
  359. * Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
  360. - new upstream release
  361. * Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  362. - new upstream release
  363. * Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
  364. - disable evolution-data-server
  365. * Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  366. - new upstream release
  367. * Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
  368. - add Patch10 to fix hard-coded desktop file name.
  369. * Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  370. - new upstream version
  371. * Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
  372. - new upstream release
  373. - run scrollkeeper at %post, %postun
  374. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  375. - new upstream release
  376. * Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
  377. - add Patch10 to fix egg-recent-model.c.
  378. save old umask value before create ".recently-used" file.
  379. * Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
  380. - fix location of nautilus launcher in panel-default-setup.entries.
  381. - do not add wireless monitor in %%post when no interfaces are available.
  382. - add Japanese summary and description
  383. - add BuildRequires: startup-notification-devel, gcc-c++.
  384. - disable libtoolize: version mismatch is bad
  385. * Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  386. - new upstream release
  387. * Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  388. - new upstream release
  389. * Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
  390. - rebuilt against new toolchain
  391. * Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
  392. - add --disable-schemas-install option to %%configure
  393. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  394. - new upstream release
  395. * Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
  396. - add missing files
  397. - add vine default panel entries
  398. * Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
  399. - new upstream release
  400. * Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
  401. - new upstream release
  402. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
  403. - new upstream release
  404. * Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
  405. - remove vine's panel-per-panel-config.schemas
  406. This should be added again in a future version.
  407. * Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
  408. - new upstream release
  409. * Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  410. - new upstream release
  411. - remove old ja.po
  412. * Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
  413. - new upstream release
  414. * Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
  415. - remove clockaddon, system-tray-applet
  416. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  417. - new upstream release
  418. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
  419. - add patch1 from rawhide package.
  420. * Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
  421. - new upstream release
  422. * Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
  423. - add system-tray-applet
  424. - modify default panel menu.
  425. - update ja.po
  426. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
  427. - add Requires: vine-menus
  428. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  429. - new upstream release
  430. * Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
  431. - remove redhatize patch.
  432. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  433. - build for Vine Linux
  434. - new upstream release from gnome-2.1.4
  435. * Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  436. - fix postun script
  437. * Tue Oct 8 2002 Havoc Pennington <hp@redhat.com>
  438. - 2.0.9 with menu edit stuff
  439. - system-tray-applet 0.15 that doesn't crash all the time
  440. - merge/remove patches as appropriate
  441. * Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
  442. - Fix problem with "hold down print screen" (71432)
  443. * Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
  444. - panel-properties OnlyShowIn=GNOME;
  445. - somehow the po file got screwed up. Works now
  446. - update po files
  447. * Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
  448. - fix from #71762 for clock applet popdown key
  449. - no WIN_POS_MOUSE fixes #72167
  450. - fix for #72540 from George
  451. * Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
  452. - system tray applet 0.11 with a small memleak fix and a couple translations
  453. * Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
  454. - menu tweaks
  455. * Wed Aug 14 2002 Tim Powers <timp@redhat.com>
  456. - bump release
  457. * Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
  458. - put battery applet on panel for laptops (#67296)
  459. * Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
  460. - 2.0.6 final from gnome 2.0.1
  461. - remove gnome-panel-screenshot patch now upstream
  462. * Thu Aug 8 2002 Jonathan Blandford <jrb@redhat.com>
  463. - new system-tray-applet version
  464. - Fix gnome-panel-screenshot
  465. * Tue Aug 6 2002 Havoc Pennington <hp@redhat.com>
  466. - 2.0.4
  467. - replace gnome-logo-icon-transparent.png with redhat-main-menu.png
  468. for the foot menu
  469. * Fri Aug 2 2002 Havoc Pennington <hp@redhat.com>
  470. - fix desktop (logout/lock) menu item location
  471. in Alt+F1 and in new menu applets
  472. - remove Screenshot... menu item
  473. * Fri Aug 2 2002 Havoc Pennington <hp@redhat.com>
  474. - move around default applets, remove some of them
  475. - system tray 0.9
  476. - change default menu flags
  477. - blow unpackaged files out of build root
  478. * Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
  479. - 2.0.3
  480. - own libexecdir stuff
  481. * Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
  482. - new system tray that's prettier and doesn't clip the icon
  483. * Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
  484. - system tray 0.7 that doesn't crash on startup
  485. - get Mozilla desktop file right so we get web browser launcher
  486. * Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
  487. - system tray 0.6 with server file fixed (work dammit)
  488. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  489. - tweak applet positions but I think it's just broken
  490. - system tray 0.5 moved back to libdir not libexecdir
  491. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  492. - remove ltmain.sh hack
  493. - new system-tray-applet that works
  494. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  495. - put office suite stuff on the panel
  496. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  497. - 2.0.2.90 cvs snap
  498. * Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
  499. - update the clock patch to be a little smarter in a couple ways
  500. * Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
  501. - Fix problem where system tray applet was being looked for in /unst
  502. - Fix a crash in the system tray applet
  503. * Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
  504. - Fix typo in the pt_BR translation that was causing GConf problems
  505. * Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
  506. - add the system tray applet
  507. - add system tray applet by default
  508. - add more launcher by default
  509. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  510. - automated rebuild
  511. * Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
  512. - use correct gettext package name, and add check for missing translations
  513. * Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
  514. - add the calendar and configuration patch
  515. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  516. - 2.0.0
  517. - add control center desktop file to file list
  518. - add gnome-panelrc to file list
  519. - try fixing panel size (blind, no text box at home)
  520. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  521. - rebuild in different environment
  522. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  523. - updates to default configuration
  524. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  525. - fix schemas installation
  526. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  527. - unset old panel schemas when installing new ones
  528. - put in a broken panel config to see errors about
  529. - add a patch to give some decent error messages about what's wrong
  530. with the default panel config
  531. * Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
  532. - rebuild in different environment
  533. * Sun Jun 9 2002 Havoc Pennington <hp@redhat.com>
  534. - don't provide/obsolete gnome-core
  535. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  536. - rebuild in different environment
  537. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  538. - 1.5.24
  539. - ldconfig
  540. * Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
  541. - rebuild in different environment
  542. * Fri May 31 2002 Havoc Pennington <hp@redhat.com>
  543. - 1.5.23
  544. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  545. - automated rebuild
  546. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  547. - rebuild in different environment
  548. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  549. - 1.5.22
  550. - provide gnome-core
  551. - add a bunch of extra build requires so build system
  552. won't get confused
  553. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  554. - 1.5.19
  555. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  556. - add the keep-libtool-from-relinking hack so
  557. we get the gen util applet
  558. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  559. - obsoletes gnome-core-devel
  560. - include libdir/*.so
  561. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  562. - get libpanel-applet in the package
  563. * Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
  564. - Initial build.