gnome-shell-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352
  1. %bcond_with systemd
  2. Summary: Window management and application launching for GNOME
  3. Summary(ja): GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
  4. Name: gnome-shell
  5. Version: 40.0
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: desktop-gnome
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2+
  11. URL: http://live.gnome.org/GnomeShell
  12. %global shortver %(echo %{version} | cut -d . -f 1)
  13. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  14. Requires: mutter
  15. Requires: ca-certificates
  16. Requires: at-spi2-atk
  17. Requires: network-manager-applet
  18. Requires: gnome-tweak-tool
  19. Requires: xdg-desktop-portal-gtk
  20. BuildRequires: meson
  21. BuildRequires: pkgconfig
  22. BuildRequires: python3
  23. BuildRequires: sassc
  24. BuildRequires: libxslt
  25. BuildRequires: gnome-common
  26. BuildRequires: at-spi2-atk-devel
  27. BuildRequires: evolution-data-server-devel
  28. BuildRequires: gcr-devel
  29. BuildRequires: gtk4-devel
  30. BuildRequires: gdk-pixbuf-devel
  31. BuildRequires: gobject-introspection-devel
  32. BuildRequires: glib2-devel
  33. BuildRequires: gjs-devel
  34. BuildRequires: libxml2-devel
  35. BuildRequires: clutter-devel
  36. BuildRequires: cogl-devel
  37. BuildRequires: mutter-devel
  38. BuildRequires: polkit-devel
  39. BuildRequires: startup-notification-devel
  40. BuildRequires: ibus-devel
  41. BuildRequires: libX11-devel
  42. BuildRequires: gsettings-desktop-schemas-devel
  43. BuildRequires: gnome-desktop3-devel
  44. BuildRequires: gnome-bluetooth-devel
  45. BuildRequires: gstreamer1-devel
  46. BuildRequires: NetworkManager-libnm-devel
  47. BuildRequires: libsecret-devel
  48. %if %{with systemd}
  49. BuildRequires: systemd-devel
  50. %endif
  51. BuildRequires: pulseaudio-libs-devel
  52. BuildRequires: gnome-autoar-devel
  53. BuildRequires: json-glib-devel
  54. BuildRequires: bash-completion
  55. BuildRequires: asciidoc
  56. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  57. %description
  58. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  59. It provides core interface functions like switching to windows and launching
  60. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  61. hardware and introduces innovative user interface concepts to provide a delightful
  62. and easy to use experience.
  63. %package docs
  64. Summary: Documentation for %{name}
  65. Summary(ja): %{name} 用のドキュメント
  66. Group: documentation
  67. Requires: %{name} = %{version}-%{release}
  68. BuildArch: noarch
  69. %description docs
  70. This package contains documentation for %{name}.
  71. %debug_package
  72. %prep
  73. %setup -q
  74. %build
  75. export LANG=ja_JP.UTF-8
  76. %meson \
  77. %if !%{with systemd}
  78. -Dsystemd=false \
  79. %endif
  80. -Dgtk_doc=true
  81. %meson_build
  82. %install
  83. export LANG=ja_JP.UTF-8
  84. %{__rm} -rf %{buildroot}
  85. %meson_install
  86. %find_lang %{name}
  87. %clean
  88. %{__rm} -rf ${RPM_BUILD_ROOT}
  89. %post
  90. touch --no-create %{_datadir}/icons/hicolor
  91. %postun
  92. touch --no-create %{_datadir}/icons/hicolor
  93. %files -f %{name}.lang
  94. %defattr(-,root,root,-)
  95. %license COPYING
  96. %doc NEWS README.md
  97. %dir %{_sysconfdir}/xdg
  98. %dir %{_sysconfdir}/xdg/autostart
  99. %{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
  100. %{_bindir}/gnome-*
  101. %{_libdir}/%{name}/*
  102. %{_libexecdir}/gnome-shell-calendar-server
  103. %{_libexecdir}/gnome-shell-hotplug-sniffer
  104. %{_libexecdir}/gnome-shell-overrides-migration.sh
  105. %{_libexecdir}/gnome-shell-perf-helper
  106. %{_libexecdir}/gnome-shell-portal-helper
  107. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  108. %{_datadir}/applications/*.desktop
  109. %{_datadir}/dbus-1/interfaces/*.xml
  110. %{_datadir}/dbus-1/services/*.service
  111. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  112. %{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
  113. %{_datadir}/%{name}/*
  114. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
  115. %dir %{_datadir}/xdg-desktop-portal
  116. %dir %{_datadir}/xdg-desktop-portal/portals
  117. %{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
  118. %{_mandir}/man1/*.1*
  119. %dir %{_datadir}/bash-completion
  120. %dir %{_datadir}/bash-completion/completions
  121. %{_datadir}/bash-completion/completions/gnome-extensions
  122. %{_datadir}/icons/hicolor/scalable/apps/*
  123. %{_datadir}/icons/hicolor/symbolic/apps/*
  124. %{_datadir}/metainfo/*
  125. %if %{with systemd}
  126. %{_userunitdir}/*
  127. %endif
  128. %files docs
  129. %defattr(-,root,root,-)
  130. %{_datadir}/gtk-doc/html/shell
  131. %{_datadir}/gtk-doc/html/st
  132. %changelog
  133. * Fri Aug 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.5-1
  134. - new upstream release.
  135. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.4-1
  136. - new upstream release.
  137. * Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.2-1
  138. - new upstream release.
  139. - dropped Patch102: session tracker was switched to elogind.
  140. - added Patch105.
  141. * Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.4-1
  142. - new upstream release.
  143. * Sun Jul 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-2
  144. - new upstream release
  145. - add Patch104 (gnome-shell-3.20.3-vine-themes.patch)
  146. * Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-1
  147. - new upstream release
  148. - update Patch104 (gnome-shell-3.20.0-vine-themes.patch)
  149. * Fri Nov 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
  150. - new upstream release
  151. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  152. - new upstream release
  153. * Thu Nov 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  154. - new upstream release
  155. - update Patch104 (gnome-shell-3.18.1-vine-themes.patch)
  156. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
  157. - new upstream release
  158. * Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
  159. - add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
  160. * Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
  161. - add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
  162. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  163. - new upstream release
  164. * Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  165. - new upstream release
  166. * Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  167. - new upstream release
  168. - add BuildRequires: python3-devel
  169. - update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
  170. * Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
  171. - rebuilt with libical 1.0.1
  172. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
  173. - new upstream release
  174. * Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  175. - new upstream release
  176. * Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
  177. - new upstream release
  178. - update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
  179. - add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
  180. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  181. - new upstream release
  182. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  183. - new upstream release
  184. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  185. - new upstream release
  186. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
  187. - new upstream release
  188. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
  189. - new upstream release
  190. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  191. - new upstream release
  192. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
  193. - new upstream release
  194. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  195. - new upstream release
  196. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  197. - new upstream release
  198. * Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  199. - new upstream release
  200. - update Patch101 (gnome-shell-vine-settings.patch)
  201. - add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
  202. - add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
  203. - create %%{name}-docs subpackage
  204. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
  205. - new upstream release
  206. - remove Source102 (gnome-shell.gnome-3-6.ja.po)
  207. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  208. - new upstream release
  209. - add Source102 (gnome-shell.gnome-3-6.ja.po)
  210. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  211. - new upstream release
  212. - remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
  213. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  214. - rebuild with telepathy-logger-0.6.0
  215. - add Patch0 (gnome-shell-3.4.1-git20121031.patch)
  216. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  217. - new upstream release
  218. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  219. - new upstream release
  220. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  221. - update Patch101 (gnome-shell-vine-settings.patch)
  222. - change BuildRequires: ca-certificates instead of openssl
  223. - add BuildRequires: libcanberra-gtl3-devel
  224. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  225. - new upstream release
  226. - remove Patch103 (gnome-shell-ja.po-date.patch)
  227. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  228. - new upstream release
  229. - update Patch101,103
  230. - remove Patch0,102
  231. - add BuildRequires: gcr-devel
  232. - remove BuildRequires: GConf2-devel
  233. - add Requires: at-spi2-atk
  234. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  235. - new upstream release
  236. - remove Patch1
  237. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  238. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  239. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  240. - rename Patch103 (gnome-shell-ja.po-date.patch)
  241. - drop Patch102
  242. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  243. - new upstream release
  244. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  245. - new upstream release
  246. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  247. - new upstream release
  248. - update Patch101
  249. - update Patch102
  250. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  251. - add BuildRequires: libgudev1-devel, openssl
  252. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  253. - new upstream release
  254. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  255. - add Requires: caribou
  256. - remove Patch0
  257. - update Patch101
  258. - update Patch102
  259. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  260. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  261. - rebuild with gnome-menus-3.1.5
  262. - add Patch0 (gnome-shell-git20110821.patch)
  263. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  264. - new upstream release
  265. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  266. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  267. - remove BuildRequires: xulrunner-devel
  268. - add Patch101 (gnome-shell-vine-settings.patch)
  269. - add Patch102 (gnome-shell-vine-customize.patch)
  270. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  271. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  272. - add Requires: mutter
  273. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  274. - new upstream release
  275. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  276. - initial build for Vine Linux