imake-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. %global makedepend_version 1.0.6
  2. %global gccmakedep_version 1.0.3
  3. %global xorg_cf_files_version 1.0.6
  4. %global lndir_version 1.0.3
  5. Summary: imake source code configuration and build system
  6. Name: imake
  7. Version: 1.0.8
  8. Release: 1%{?_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: MIT/X11
  13. URL: https://www.x.org/
  14. Source0: https://www.x.org/pub/individual/util/%{name}-%{version}.tar.bz2
  15. Source1: https://www.x.org/pub/individual/util/makedepend-%{makedepend_version}.tar.bz2
  16. Source2: https://www.x.org/pub/individual/util/gccmakedep-%{gccmakedep_version}.tar.bz2
  17. Source3: https://www.x.org/pub/individual/util/xorg-cf-files-%{xorg_cf_files_version}.tar.bz2
  18. Source4: https://www.x.org/pub/individual/util/lndir-%{lndir_version}.tar.bz2
  19. Patch2: xorg-cf-files-1.0.5-redhat.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  21. BuildRequires: pkgconfig
  22. BuildRequires: xorg-x11-util-macros
  23. BuildRequires: xorg-x11-proto-devel
  24. Provides: ccmakedep cleanlinks gccmakedep imake lndir makedepend makeg
  25. Provides: mergelib mkdirhier mkhtmlindex revpath xmkmf
  26. %description
  27. Imake is a deprecated source code configuration and build system which
  28. has traditionally been supplied by and used to build the X Window System
  29. in X11R6 and previous releases. As of the X Window System X11R7 release,
  30. the X Window system has switched to using GNU autotools as the primary
  31. build system, and the Imake system is now deprecated, and should not be
  32. used by new software projects. Software developers are encouraged to
  33. migrate software to the GNU autotools system.
  34. %debug_package
  35. %prep
  36. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
  37. pushd xorg-cf-files-%{xorg_cf_files_version}
  38. %patch2 -p1 -b .redhat
  39. popd
  40. %build
  41. # Build everything
  42. {
  43. for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
  44. pushd $pkg-*
  45. case $pkg in
  46. imake|xorg-cf-files)
  47. %configure --with-config-dir=%{_datadir}/X11/config
  48. ;;
  49. *)
  50. %configure
  51. ;;
  52. esac
  53. make
  54. popd
  55. done
  56. }
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. # Install everything
  60. {
  61. for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
  62. pushd $pkg-*
  63. case $pkg in
  64. # xorg-cf-files)
  65. # make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_datadir}
  66. # ;;
  67. *)
  68. make install DESTDIR=$RPM_BUILD_ROOT
  69. ;;
  70. esac
  71. popd
  72. done
  73. }
  74. %clean
  75. rm -rf $RPM_BUILD_ROOT
  76. %files
  77. %defattr(-,root,root,-)
  78. %doc
  79. %{_bindir}/ccmakedep
  80. %{_bindir}/cleanlinks
  81. %{_bindir}/gccmakedep
  82. %{_bindir}/imake
  83. %{_bindir}/lndir
  84. %{_bindir}/makedepend
  85. %{_bindir}/makeg
  86. %{_bindir}/mergelib
  87. %{_bindir}/mkdirhier
  88. %{_bindir}/mkhtmlindex
  89. %{_bindir}/revpath
  90. %{_bindir}/xmkmf
  91. %dir %{_datadir}/X11
  92. %dir %{_datadir}/X11/config
  93. %{_datadir}/X11/config/*.cf
  94. %{_datadir}/X11/config/*.def
  95. %{_datadir}/X11/config/*.rules
  96. %{_datadir}/X11/config/*.tmpl
  97. #%dir %{_mandir}/man1x
  98. %{_mandir}/man1/ccmakedep.1.*
  99. %{_mandir}/man1/cleanlinks.1.*
  100. %{_mandir}/man1/gccmakedep.1.*
  101. %{_mandir}/man1/imake.1.*
  102. %{_mandir}/man1/lndir.1.*
  103. %{_mandir}/man1/makedepend.1.*
  104. %{_mandir}/man1/makeg.1.*
  105. %{_mandir}/man1/mergelib.1.*
  106. %{_mandir}/man1/mkdirhier.1.*
  107. %{_mandir}/man1/mkhtmlindex.1.*
  108. %{_mandir}/man1/revpath.1.*
  109. %{_mandir}/man1/xmkmf.1.*
  110. %changelog
  111. * Mon Mar 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.8-1
  112. - imake-1.0.8.
  113. - makedepend-1.0.6.
  114. - xorg-cf-files-1.0.6.
  115. * Sun Nov 2 2014 Ryoichi INAAGKI <ryo1@toki.waseda.jp> 1.0.7-2
  116. - moved to Development/Tools Group
  117. * Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
  118. - imake-1.0.7
  119. - gccmakedep-1.0.3
  120. - makedepend-1.0.5
  121. - xorg-cf-files-1.0.5
  122. - update Patch2 (xorg-cf-files-1.0.5-redhat.patch)
  123. * Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
  124. - imake-1.0.5
  125. - lndir-1.0.3
  126. - makedepend-1.0.4
  127. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
  128. - xorg-cf-files-1.0.4
  129. - update Patch2 (xorg-cf-files-1.0.4-redhat.patch)
  130. - delete Patch0,1,3
  131. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  132. - imake-1.0.4
  133. - lndir-1.0.2
  134. - makedepend-1.0.3
  135. - xorg-cf-files-1.0.3
  136. - update Patch2 (xorg-cf-files-1.0.3-redhat.patch)
  137. - update Patch3 (xorg-cf-files-1.0.3-xprint.patch)
  138. - fix %%files
  139. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
  140. - rebuilt with new toolchain
  141. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  142. - new versioning policy
  143. * Fri Jan 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  144. - initial build for Vine Linux
  145. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-5
  146. - Rebuild for build id
  147. * Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1.0.2-4
  148. - makedepend 1.0.1
  149. * Tue Jul 18 2006 Than Ngo <than@redhat.com> 1.0.2-3
  150. - cleanup patch files
  151. - update source files
  152. * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-2
  153. - rebuild
  154. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
  155. - Update to imake-1.0.2, gccmakedep-1.0.2, xorg-cf-files-1.0.2
  156. * Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
  157. - Fix ExtraXawReqs to reflect reality (libXp is unneeded)
  158. * Mon Mar 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
  159. - Updated xorg-cf-files-1.0.1-redhat.patch with fix for (#178177)
  160. * Wed Mar 01 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-2
  161. - Buildrequires: xorg-x11-proto-devel
  162. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  163. - bump again for double-long bug on ppc(64)
  164. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  165. - rebuilt for new gcc4.1 snapshot and glibc changes
  166. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  167. - Updated all packages to version 1.0.1 from X11R7.0
  168. * Wed Dec 21 2005 Than Ngo <than@redhat.com> 1.0.0-4
  169. - final fix for #173593
  170. * Tue Dec 20 2005 Than Ngo <than@redhat.com> 1.0.0-3
  171. - add correct XAppLoadDir #173593
  172. - add more macros for fedora
  173. * Mon Dec 19 2005 Than Ngo <than@redhat.com> 1.0.0-2
  174. - add some macros to fix problem in building of manpages
  175. * Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  176. - Updated all packages to version 1.0.0 from X11R7 RC4
  177. - Added new lndir, gccmakedep tarballs. (#173478)
  178. - Changed manpage dirs from man1x to man1 to match upstream RC4 default.
  179. - Removed all previous 'misc' patch, as we now pass --with-config-dir to
  180. configure to specify the location of the Imake config files.
  181. - Renamed imake patch to xorg-cf-files-1.0.0-ProjectRoot.patch as it did not
  182. patch imake at all. This should probably be changed to be a custom Red Hat
  183. host.def file that is added as a source line instead of randomly patching
  184. various files.
  185. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> 0.99.2-5.1
  186. - rebuilt
  187. * Mon Nov 28 2005 Than Ngo <than@redhat.com> 0.99.2-5
  188. - add correct ProjectRoot for modular X
  189. * Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-4
  190. - add missing host.conf
  191. * Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-3
  192. - fix typo
  193. * Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-2
  194. - fix xmkmf to look config files in /usr/share/X11/config
  195. instead /usr/%%{_lib}/X11/config/
  196. - add host.conf
  197. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  198. - Updated to imake-0.99.2, xorg-cf-files-0.99.2, makedepend-0.99.2 from
  199. X11R7 RC2.
  200. * Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
  201. - Initial build.