123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210 |
- %define _sysconfdir /etc/lam
- %define _romiodocdir /usr/share/lam/doc
- Summary: LAM/MPI (Local Area Multicomputer) programming environment
- Summary(ja): MPIメッセージパッシング形式の並列アプリケーション作成環境
- Name: lam
- Version: 7.1.4
- Release: 3%{?_dist_release}
- License: BSD
- Group: Development/Libraries
- Source: lam-%{version}.tar.gz
- Patch: lam-helppath.patch
- URL: http://www.lam-mpi.org/
- ExcludeArch: ia64
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: gcc-gfortran
- Provides: mpi
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- LAM (Local Area Multicomputer) is an MPI programming environment and
- development system for heterogeneous computers on a network. With
- LAM/MPI, a dedicated cluster or an existing network computing
- infrastructure can act as one parallel computer solving one problem.
- LAM/MPI is considered to be "cluster friendly", in that it offers
- daemon-based process startup/control as well as fast client-to-client
- message passing protocols. LAM/MPI can use TCP/IP and/or shared
- memory for message passing (different RPMs are supplied for this
- see the main LAM web site for details).
- LAM features a full implementation of MPI-1 (with the exception that
- LAM does not support cancelling of sends), and much of MPI-2.
- Compliant applications are source code portable between LAM/MPI and
- any other implementation of MPI. In addition to providing a
- high-quality implementation of the MPI standard, LAM/MPI offers
- extensive monitoring capabilities to support debugging. Monitoring
- happens on two levels. First, LAM/MPI has the hooks to allow a
- snapshot of process and message status to be taken at any time during
- an application run. This snapshot includes all aspects of
- synchronization plus datatype maps/signatures, communicator group
- membership, and message contents (see the XMPI application on the main
- LAM web site). On the second level, the MPI library is instrumented
- to produce a cummulative record of communication, which can be
- visualized either at runtime or post-mortem.
- %prep
- %setup -q
- chmod -R o-w $RPM_BUILD_DIR/lam-%{version}
- %build
- %configure \
-
-
-
-
-
- make %{?_smp_mflags} all
- %install
- rm -rf $RPM_BUILD_ROOT
- %makeinstall
- rm -f $RPM_BUILD_ROOT/usr/include/mpi++.h
- ln -s mpi2c++/mpi++.h $RPM_BUILD_ROOT/usr/include/mpi++.h
- for file in README README_LAM COPYRIGHT; do
- mv $RPM_BUILD_DIR/lam-%{version}/romio/$file \
- $RPM_BUILD_DIR/lam-%{version}/romio/romio-$file
- done
- mv $RPM_BUILD_DIR/lam-%{version}/romio/doc/users-guide.ps.gz \
- $RPM_BUILD_DIR/lam-%{version}/romio/doc/romio-users-guide.ps.gz
- rm -f $RPM_BUILD_ROOT/%{_libdir}/lib*.la
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root)
- %doc LICENSE HISTORY INSTALL README
- %doc examples
- %doc doc
- *
- %{_includedir}
|