mate-panel-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290
  1. %define major_ver 1.20
  2. %define ver %{major_ver}.1
  3. %define rel 1
  4. Summary: The MATE Panel
  5. Name: mate-panel
  6. Version: %{ver}
  7. Release: %{rel}%{?_dist_release}
  8. Source0: http://pub.mate-desktop.org/releases/%{major_ver}/%{name}-%{version}.tar.xz
  9. Source1: vine.layout
  10. # for Vine
  11. Patch2000: mate-panel-1.6.1-about-vine.patch
  12. Patch2001: mate-panel-1.12.0-vine-layout.patch
  13. License: GPLv2, LGPLv2 and GFDLv1.1
  14. Group: User Interface/Desktops
  15. URL: http://mate-desktop.org/
  16. BuildRequires: mate-common
  17. BuildRequires: mate-desktop-devel >= 1.17.0
  18. BuildRequires: mate-menus-devel >= 1.10.0
  19. BuildRequires: libmateweather-devel >= 1.17.0
  20. BuildRequires: gtk3-devel >= 3.14
  21. BuildRequires: libSM-devel
  22. BuildRequires: dbus-glib-devel
  23. BuildRequires: libwnck3-devel
  24. BuildRequires: librsvg2-devel
  25. BuildRequires: gtk-doc
  26. BuildRequires: itstool
  27. BuildRequires: autoconf
  28. BuildRequires: automake
  29. Requires: vine-menus
  30. Requires(postun): glib2
  31. Requires(post,postun): gtk2
  32. Requires(post,postun): desktop-file-utils
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: Takemikaduchi, iwaim
  37. %description
  38. mate-panel contains the MATE panel, the libmate-panel-applet library and
  39. several applets:
  40. + the MATE panel is the area on your desktop from which you can run
  41. applications and applets, and perform other tasks.
  42. + the libmate-panel-applet library allows to develop small applications
  43. which may be embedded in the panel. These are called applets.
  44. Documentation for the API is available with gtk-doc.
  45. + the applets supplied here include the Workspace Switcher, the Window
  46. List, the Window Selector, the Notification Area, the Clock and the
  47. infamous 'Wanda the Fish'.
  48. %package devel
  49. Summary: Development tools for mate-panel
  50. Summary(ja): mate-panel の開発環境
  51. Group: Development/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: pkgconfig
  54. %description devel
  55. Header files and libraries for building a extension library for the
  56. mate-panel.
  57. %package docs
  58. Summary: Documentation for mate-panel
  59. Summary(ja): mate-panel 用のドキュメント
  60. Group: Documentation
  61. Requires: %{name} = %{version}-%{release}
  62. Obsoletes: %{name}-doc < 1.10.1
  63. BuildArch: noarch
  64. %description docs
  65. This package contains documentation for mate-panel.
  66. %prep
  67. %setup -q
  68. %patch2000 -p1 -b .vine
  69. %patch2001 -p1 -b .vine
  70. %build
  71. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
  72. %configure \
  73. --libexecdir=%{_libexecdir}/mate \
  74. --disable-static \
  75. --enable-introspection
  76. %{__make} %{?_smp_mflags}
  77. %install
  78. %{__rm} -rf ${RPM_BUILD_ROOT}
  79. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  80. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  81. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  82. install -c -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{name}/layouts/
  83. %find_lang %{name}
  84. %clean
  85. %{__rm} -rf ${RPM_BUILD_ROOT}
  86. %post
  87. /sbin/ldconfig
  88. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  89. touch --no-create %{_datadir}/icons/hicolor
  90. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  91. %postun
  92. /sbin/ldconfig
  93. if [ $1 -eq 0 ]; then
  94. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  95. touch --no-create %{_datadir}/icons/hicolor
  96. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  97. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  98. fi
  99. %posttrans
  100. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  101. %files -f %{name}.lang
  102. %defattr(-,root,root,-)
  103. %doc COPYING* ChangeLog NEWS README
  104. %{_bindir}/mate-desktop-item-edit
  105. %{_bindir}/mate-panel
  106. %{_bindir}/mate-panel-test-applets
  107. %{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
  108. %{_libdir}/libmate-panel-applet-*.so.*
  109. %{_libexecdir}/mate/clock-applet
  110. %{_libexecdir}/mate/fish-applet
  111. %{_libexecdir}/mate/notification-area-applet
  112. %{_libexecdir}/mate/wnck-applet
  113. %{_datadir}/applications/mate-panel.desktop
  114. %{_datadir}/dbus-1/services/*.service
  115. %{_datadir}/glib-2.0/schemas/org.mate.panel.applet.clock.gschema.xml
  116. %{_datadir}/glib-2.0/schemas/org.mate.panel.applet.fish.gschema.xml
  117. %{_datadir}/glib-2.0/schemas/org.mate.panel.applet.window-list.gschema.xml
  118. %{_datadir}/glib-2.0/schemas/org.mate.panel.applet.workspace-switcher.gschema.xml
  119. %{_datadir}/glib-2.0/schemas/org.mate.panel.enums.xml
  120. %{_datadir}/glib-2.0/schemas/org.mate.panel.gschema.xml
  121. %{_datadir}/glib-2.0/schemas/org.mate.panel.menubar.gschema.xml
  122. %{_datadir}/glib-2.0/schemas/org.mate.panel.object.gschema.xml
  123. %{_datadir}/glib-2.0/schemas/org.mate.panel.toplevel.gschema.xml
  124. %{_datadir}/icons/hicolor/*/*/*
  125. %{_datadir}/help
  126. %{_datadir}/mate-panel
  127. %{_mandir}/man1/mate-panel.1.gz
  128. %{_mandir}/man1/mate-desktop-item-edit.1.gz
  129. %{_mandir}/man1/mate-panel-test-applets.1.gz
  130. %files devel
  131. %defattr(-,root,root,-)
  132. %{_includedir}/mate-panel-4.0/
  133. %{_libdir}/libmate-panel-applet-*.so
  134. %{_libdir}/pkgconfig/libmatepanelapplet-4.0.pc
  135. %{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
  136. %files docs
  137. %defattr(-,root,root,-)
  138. %{_datadir}/gtk-doc/html/mate-panel-applet
  139. %changelog
  140. * Fri May 4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.20.1-1
  141. - update to 1.20.1
  142. * Sat Jan 13 2018 Toshiaki Ara <ara_t@384.jp> 1.18.7-1
  143. - update to 1.18.7
  144. * Thu May 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.2-1
  145. - update to 1.18.2
  146. * Tue Apr 11 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.1-1
  147. - update to 1.18.1
  148. * Sun Apr 2 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.0-1
  149. - update to 1.18.0
  150. - move to GTK3+
  151. - drop ja.po patch (Patch2002); upstream merged
  152. - drop unrecognized options:
  153. - '--disable-scrollkeeper' and '--enable-matecomponent'
  154. - update BuildRequires
  155. - drop
  156. - gtk2-devel
  157. - libwnck-devel
  158. - libcanberra-devel
  159. - evolution-data-server-devel
  160. - NetworkManager-devel
  161. - dconf-devel
  162. - add
  163. - gtk3-devel
  164. - libwnck3-devel
  165. * Sun Mar 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.1-1
  166. - update to 1.16.1
  167. * Sun Nov 27 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.0-1
  168. - new upstream release
  169. - update ja.po patch (Patch2002)
  170. - update License
  171. - update Packager
  172. * Wed Jun 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.1-1
  173. - new upstream release
  174. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
  175. - new upstream release
  176. * Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  177. - new upstream release
  178. * Tue Dec 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
  179. - new upstream release
  180. * Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  181. - new upstream release
  182. - update Patch2001 (mate-panel-1.12.0-vine-layout.patch)
  183. - update Patch2002 (mate-panel-1.12.0-ja.po.patch)
  184. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-2
  185. - add Patch2002 (mate-panel-1.10.1-ja.po.patch)
  186. * Sat Jul 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
  187. - new upstream release
  188. * Sat May 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  189. - new upstream release
  190. - remove Patch2002 (mate-panel-1.8.0-ja.po.patch)
  191. * Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
  192. - rename Source (vine.layout)
  193. * Sun Jun 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-2
  194. - rename Source (vine.layout)
  195. - add Patch2001 (mate-panel-1.8.0-vine-layout.patch)
  196. - add Patch2002 (mate-panel-1.8.0-ja.po.patch)
  197. * Tue Apr 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  198. - new upstream release
  199. - change BuildRequires: libwnck-devel instead of libmatewnck-devel
  200. - add BuildRequires: itstool
  201. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-3
  202. - rebuild with VineSeed environment
  203. * Wed Sep 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-2
  204. - change Source1 (panel-default-layout.mate.vine)
  205. - add Patch2000 (mate-panel-1.6.1-about-vine.patch)
  206. - add Requires: vine-menus
  207. * Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
  208. - new upstream release
  209. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
  210. - new upstream release
  211. - remove BuildRequires: mate-conf-devel, libmatecomponentui-devel
  212. - add BuildRequires: dconf-devel
  213. * Wed Aug 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  214. - new upstream release
  215. - remove Patch0 (mate-panel-1.2.1-configure.patch)
  216. - change BuildRequires: libmatewnck-devel instead of libwnck-devel
  217. * Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  218. - new upstream release
  219. - add Patch0 (mate-panel-1.2.1-configure.patch)
  220. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
  221. - change category
  222. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
  223. - initial build for Vine Linux