123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255 |
- Name: perl-GD
- Summary: Perl interface to the GD graphics library
- Summary(ja): GD ライブラリの Perl 用インターフェイス
- Version: 2.53
- Release: 1%{?_dist_release}
- Group: Development/Libraries
- License: GPL+ or Artistic
- URL: http://search.cpan.org/dist/GD/
- Source0: http://www.cpan.org/authors/id/L/LD/LDS/GD-%{version}.tar.gz
- Patch0: perl-GD-2.41-Group.patch
- Patch1: perl-GD-skip-3.patch
- # see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=628522
- # and https://rt.cpan.org/Public/Bug/Display.html?id=67990
- Patch2: perl-GD-ccflags.patch
- Buildroot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: gd-devel >= 2.0.28
- BuildRequires: perl(ExtUtils::MakeMaker)
- BuildRequires: freetype2-devel, libpng-devel, zlib-devel
- BuildRequires: libX11-devel
- BuildRequires: libXpm-devel
- Requires: gd >= 2.0.28, libjpeg, freetype2
- Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
- %{?perl_default_filter}
- %description
- This is a autoloadable interface module for GD, a popular library
- for creating and manipulating PNG files. With this library you can
- create PNG images on the fly or modify existing files. Features
- include:
- a. lines, polygons, rectangles and arcs, both filled and unfilled
- b. flood fills
- c. the use of arbitrary images as brushes and as tiled fill patterns
- d. line styling (dashed lines and the like)
- e. horizontal and vertical text rendering
- f. support for transparency and interlacing
- For full information on usage, see the accompanying man and html
- documentation.
- %prep
- %setup -q -n GD-%{version}
- %patch0 -p1
- %ifarch %{ix86}
- %patch1 -p1
- %endif
- #patch2 -p1
- %{__perl} -pi -e 's|/usr/local/bin/perl\b|%{__perl}|' \
- qd.pl demos/{*.{pl,cgi},truetype_test}
- chmod -c 644 bdf_scripts/* demos/*
- chmod -c 755 qd.pl
- %build
- rm -rf %{buildroot}
- %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
- make %{?_smp_mflags} OPTIMIZE="%{optflags}"
- %install
- make pure_install PERL_INSTALL_ROOT=%{buildroot}
- find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
- find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
- find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
- chmod -R u+w %{buildroot}/*
- %check
- %ifarch ppc
- # testsuite fails on ppc
- %else
- make test
- %endif
- %ifarch %{ix86}
- perl t/GD.t --write
- : This is the file that should contain some blue color:
- base64 t/test.out.3.png_new
- %endif
- %files
- %defattr(-,root,root,-)
- %doc ChangeLog README* demos/ bdf_scripts
- %{_bindir}/*
- %{perl_vendorarch}/auto/GD
- %{perl_vendorarch}/GD*
- %{perl_vendorarch}/qd.pl
- %{_mandir}/man1/*.1*
- %{_mandir}/man3/*.3pm*
- %changelog
- * Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.53-1
- - new upstream release
- - built with perl-5.16.3.
- * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.44-1
- - updated to 2.44
- - spec revamped based on Fedora's 2.44-10
- - previous Vine changelogs as follows:
- - Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35-2
- - rebuild with perl-5.12.3
- - add BuildRequires: libX11-devel, libXpm-devel
-
- - Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.35-1vl5
- - applied new versioning policy, spec in utf-8
- - built with perl-5.10.0
-
- - Sun Sep 3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.35-0vl1
- - new upstream release
- - changed Group to Development/Libraries
-
- - Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28-0vl1
- - new upstream release
- - added Japanese summary
-
- - Sun Jan 2 2005 IWAI, Masaharu <iwai@alib.jp> 2.19-0vl1
- - new upstream release
- - update {Build,}Requires
-
- - Tue Nov 11 2003 IWAI, Masaharu <iwai@alib.jp> 2.11-0vl1
- - initial build
- * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.44-10
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Thu Nov 10 2011 Iain Arnell <iarnell@gmail.com> 2.44-9
- - Rebuild for libpng 1.5
- * Sat Jun 18 2011 Iain Arnell <iarnell@gmail.com> 2.44-8
- - patch to avoid issue with ExtUtils::MakeMaker and CCFLAGS
- see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=628522
- - clean up spec for modern rpmbuild
- - use perl_default_filter
- * Wed Jun 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 2.44-7
- - Perl mass rebuild
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.44-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.44-5
- - 661697 rebuild for fixing problems with vendorach/lib
- * Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.44-4
- - Mass rebuild with perl-5.12.0
- * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 2.44-3
- - rebuild against perl 5.10.1
- * Thu Oct 29 2009 Stepan Kasal <skasal@redhat.com> - 2.44-2
- - give up tests on ppc
- * Mon Oct 5 2009 Stepan Kasal <skasal@redhat.com> - 2.44-1
- - new upstream version
- - run tests always
- - do not add bdf_scripts/ to docs
- - switch off the test that fails in i686 koji
- * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.41-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Mon Mar 16 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 2.41-2
- - fix Makefile.PL to install GD/Group.pm (bz 490429)
- * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 2.41-1
- - update to 2.41
- * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.39-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Mon Jul 21 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.39-1
- - update to 2.39
- * Fri Apr 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.35-7
- - tests work fine locally, one fails in mock, maybe needs a desktop?
- conditionalized them, default off.
- * Fri Apr 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.35-6
- - license fix
- * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.35-5
- - Rebuild for perl 5.10 (again)
- * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.35-4
- - Autorebuild for GCC 4.3
- * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.35-3
- - rebuild for new perl
- * Mon Oct 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 2.35-2.1
- - add BR: perl(ExtUtils::MakeMaker)
- * Sun Oct 8 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.35-2
- - Removed a duplicate file (bdf_scripts/bdf2gdfont.PLS).
- * Tue Sep 5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.35-1
- - Update to 2.35.
- * Sat Jun 3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.34-1
- - Update to 2.34.
- * Wed Mar 8 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.32-1
- - Update to 2.32.
- * Tue Feb 21 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.31-1
- - Update to 2.31.
- * Wed Feb 15 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.30-3
- - Missing BR: fontconfig-devel.
- * Mon Feb 13 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.30-2
- - Modular X (libX11-devel, libXpm-devel).
- * Fri Oct 21 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.30-1
- - Update to 2.30.
- * Mon Aug 8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.28-1
- - Update to 2.28.
- * Tue Jul 19 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.25-1
- - Update to 2.25.
- * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.23-2
- - rebuilt
- * Wed Mar 9 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 2.23-1
- - Update to 2.23.
- * Thu Dec 09 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:2.19-1
- - Update to 2.19.
- - GIF support has been restored in gd 2.0.28.
- - Module autoconfigures itself with the gdlib-config program.
- * Mon Jun 28 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:2.12-0.fdr.3
- - Avoid RPATH problem in FC1 (bug 1756).
- - Replaced hardcoded value by rpmmacro (%%{__perl}) (bug 1756).
- * Mon Jun 14 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:2.12-0.fdr.2
- - Bring up to date with current fedora.us perl spec template.
- * Sat Feb 7 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:2.12-0.fdr.1
- - Update to 2.12.
- - Reduce directory ownership bloat.
- * Tue Nov 18 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.11-0.fdr.1
- - Update to 2.11.
- * Sat Oct 11 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.41-0.fdr.1
- - First build.
|