123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128 |
- Name: perl-Net-Daemon
- Version: 0.48
- Release: 4%{?_dist_release}
- Summary: Perl extension for portable daemons
- Group: Development/Libraries
- License: GPL+ or Artistic
- URL: http://search.cpan.org/dist/Net-Daemon/
- Source0: http://search.cpan.org/CPAN/authors/id/M/MN/MNOONING/Net-Daemon/Net-Daemon-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildArch: noarch
- BuildRequires: perl
- # for perldoc
- BuildRequires: groff
- # Correct for lots of packages, other common choices include eg. Module::Build
- BuildRequires: perl(ExtUtils::MakeMaker) perl(Pod::Perldoc) perl(Test::Simple)
- Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- Net::Daemon is an abstract base class for implementing portable server
- applications in a very simple way. The module is designed for Perl 5.006 and
- ithreads (and higher), but can work with fork() and Perl 5.004.
- The Net::Daemon class offers methods for the most common tasks a daemon
- needs: Starting up, logging, accepting clients, authorization, restricting
- its own environment for security and doing the true work. You only have to
- override those methods that aren't appropriate for you, but typically
- inheriting will safe you a lot of work anyways.
- %prep
- %setup -q -n Net-Daemon-%{version}
- # generate our other two licenses...
- perldoc perlgpl > LICENSE.GPL
- perldoc perlartistic > LICENSE.Artistic
- %build
- %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
- make %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- make pure_install PERL_INSTALL_ROOT=%{buildroot}
- find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
- # Remove the next line from noarch packages (unneeded)
- find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
- find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
- chmod -R u+w %{buildroot}/*
- %check
- %{?!_with_network_tests:
- # Disable tests which will fail under mock
- rm t/config*
- rm t/fork*
- rm t/ithread*
- rm t/loop*
- rm t/single.t
- rm t/unix.t
- }
- make test
- %clean
- rm -rf %{buildroot}
- %files
- %defattr(-,root,root,-)
- %license LICENSE.*
- %doc ChangeLog README
- %{perl_vendorlib}/*
- %{_mandir}/man3/*.3*
- %changelog
- * Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.48-4
- - rebuilt with perl-5.26.
- - dropped Patch0: fixed in upstream.
- * Wed Jun 04 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.48-3
- - build with Perl 5.16
- * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.48-2
- - rebuild; spec revamped
- * Fri Mar 25 2011 IWAI, Masaharu <iwai@alib.jp> 0.48-1
- - build for Vine Linux
- - new upstream release
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-11
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.44-10
- - 661697 rebuild for fixing problems with vendorach/lib
- * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.44-9
- - Mass rebuild with perl-5.12.0
- * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.44-8
- - rebuild against perl 5.10.1
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-7
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Mon Oct 13 2008 Petr Lautrbach <plautrba@redhat.com> 0.44-5
- - "--with network_tests" - don't remove network tests
- * Mon Oct 6 2008 Petr Lautrbach <plautrba@redhat.com> 0.44-4
- - Description and License fixed
- - Patch without backup
- * Mon Oct 6 2008 Petr Lautrbach <lautrba@redhat.com> 0.44-3
- - Requires: fixed
- * Fri Oct 3 2008 Petr Lautrbach <lautrba@redhat.com> 0.44-2
- - only-ithreads patch added
- - disabled tests which fail under mock
- * Fri Sep 26 2008 Petr Lautrbach <lautrba@redhat.com>
- - initial rpm release
|