123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212 |
- Name: perl-Package-Stash
- Version: 0.38
- Release: 1%{?_dist_release}
- Summary: Routines for manipulating stashes
- Group: Development/Libraries
- License: GPL+ or Artistic
- URL: http://search.cpan.org/dist/Package-Stash/
- Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-%{version}.tar.gz
- Patch0: Package-Stash-0.32-EU::MM-version.patch
- Patch1: Package-Stash-0.32-old-Test::More.patch
- Patch2: Package-Stash-0.31-no-Test::Requires.patch
- Patch3: Package-Stash-0.32-no-Test::LeakTrace.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
- Vendor: Project Vine
- Distribution: Vine Linux
- BuildArch: noarch
- #BuildRequires: perl(Carp)
- #BuildRequires: perl(Dist::CheckConflicts) >= 0.02
- #BuildRequires: perl(ExtUtils::MakeMaker)
- #BuildRequires: perl(Scalar::Util)
- #BuildRequires: perl(Package::DeprecationManager)
- #BuildRequires: perl(Package::Stash::XS) >= 0.24
- #BuildRequires: perl(Pod::Coverage::TrustPod)
- Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
- # For performance and consistency
- #Requires: perl(Package::Stash::XS)
- # Not found by rpm auto-provides
- Provides: perl(Package::Stash::Conflicts) = 0
- %description
- Manipulating stashes (Perl's symbol tables) is occasionally necessary, but
- incredibly messy, and easy to get wrong. This module hides all of that behind
- a simple API.
- %prep
- %setup -q -n Package-Stash-%{version}
- %build
- perl Makefile.PL INSTALLDIRS=vendor
- make %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- make pure_install DESTDIR=%{buildroot}
- find %{buildroot} -type f -name .packlist -exec rm -f {} \;
- find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
- %{_fixperms} %{buildroot}
- %check
- #make test AUTHOR_TESTING=1 RELEASE_TESTING=1
- %clean
- rm -rf %{buildroot}
- %files
- %defattr(-,root,root,-)
- %license LICENSE
- %doc Changes README
- %{_bindir}/package-stash-conflicts
- %{perl_vendorlib}/Package/
- %{_mandir}/man1/*
- %{_mandir}/man3/Package::Stash.3pm*
- %{_mandir}/man3/Package::Stash::PP.3pm*
- %changelog
- * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38-1
- - new upstream release.
- - rebuilt with perl-5.26.
- * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.36-1
- - update to 0.36
- * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.33-1
- - initial build for Vine Linux
- * Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 0.33-2
- - Fedora 17 mass rebuild
- * Thu Sep 29 2011 Paul Howarth <paul@city-fan.org> - 0.33-1
- - Update to 0.33
- - Add conflict on MooseX::Method::Signatures 0.36
- - BR: perl(Carp)
- * Tue Sep 6 2011 Paul Howarth <paul@city-fan.org> - 0.32-1
- - Update to 0.32
- - Bring the behavior of has_symbol for nonexistant scalars into line with the
- XS version
- - Invalid package names (for instance, Foo:Bar) are not allowed
- - Invalid stash entry names (anything containing ::) are not allowed
- - Update patches to apply cleanly
- - Bump perl(Package::Stash::XS) version requirement to 0.24
- * Tue Aug 9 2011 Paul Howarth <paul@city-fan.org> - 0.31-1
- - Update to 0.31
- - Fix ->add_symbol('$foo', qr/sdlfk/) on 5.12+
- - Fix ->add_symbol('$foo', \v1.2.3) on 5.10+
- - Update patch for old Test::More versions
- - Update patch for no Test::Requires
- * Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 0.30-2
- - Perl mass rebuild
- * Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 0.30-1
- - Update to 0.30
- - Fix compiler detection in Makefile.PL
- - Update patch for old ExtUtils::MakeMaker versions
- - Drop usage of macros for commands
- - Drop redundant %%{?perl_default_filter}
- - perl(Pod::Coverage::TrustPod) now available everywhere
- * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.29-2
- - Perl mass rebuild
- * Wed Apr 6 2011 Paul Howarth <paul@city-fan.org> - 0.29-1
- - Update to 0.29
- - Really skip the package-stash-conflict script in the compile test
- * Wed Mar 30 2011 Paul Howarth <paul@city-fan.org> - 0.28-1
- - Update to 0.28
- - META.json fixes
- - Update patch for old ExtUtils::MakeMaker versions to apply cleanly
- * Mon Mar 28 2011 Paul Howarth <paul@city-fan.org> - 0.27-1
- - Update to 0.27
- - Skip the package-stash-conflicts script in the compile test
- * Sat Mar 5 2011 Paul Howarth <paul@city-fan.org> - 0.26-1
- - Update to 0.26
- - Make the namespace cache lazy and weak, in case the stash is deleted
- - However, this doesn't work on 5.8, so disable the namespace caching
- entirely there
- - Update patches to apply cleanly
- - Bump perl(Package::Stash::XS) version requirement to 0.22
- - Bump perl(Dist::CheckConflicts) version requirement to 0.02
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Tue Jan 25 2011 Paul Howarth <paul@city-fan.org> - 0.25-1
- - Update to 0.25 (make the leak tests author-only, since some smokers run
- release tests)
- - Update patches to apply cleanly
- - Bump perl(Package::Stash::XS) version requirement to 0.21
- - Drop buildreq perl(Test::Exception), no longer needed
- * Tue Jan 18 2011 Paul Howarth <paul@city-fan.org> - 0.24-1
- - Update to 0.24 (reinstate Test::Requires dependency)
- * Wed Jan 12 2011 Paul Howarth <paul@city-fan.org> - 0.23-1
- - Update to 0.23
- - Lower perl prereq to 5.8.1
- - Make the leak tests release-only
- - Update patches to apply cleanly
- - Add patch to skip memory leak tests if we don't have Test::LeakTrace
- * Thu Jan 6 2011 Paul Howarth <paul@city-fan.org> - 0.22-1
- - Update to 0.22 (bump Package::Stash::XS version requirement since a bug was
- fixed there)
- - Update patches for old ExtUtils::MakeMaker and Test::More versions
- - BR/R perl(Package::Stash::XS) >= 0.19
- - Content-free manpages for package-stash-conflicts and
- Package::Stash::Conflicts dropped upstream
- * Tue Jan 4 2011 Paul Howarth <paul@city-fan.org> - 0.20-1
- - Update to 0.20
- - Methods were renamed for brevity: s/_package//
- - Convert Package::Stash into a module which loads either the XS or pure perl
- implementation, depending on what's available
- - Use Test::Fatal instead of Test::Exception
- - Use Dist::CheckConflicts
- - Silence deprecation warnings for the method renaming for now
- - New script and manpage: package-stash-conflicts
- - New modules and manpages: Package::Stash::Conflicts and Package::Stash::PP
- - New build requirements:
- - perl(Dist::CheckConflicts)
- - perl(Package::DeprecationManager)
- - perl(Package::Stash::XS)
- - perl(Test::LeakTrace)
- - perl(Test::Requires)
- - perl(Test::Script)
- - Update patches for old ExtUtils::MakeMaker and Test::More versions
- - Add new patch to work around absence of Test::Requires in EPEL-4
- - Require perl(Package::Stash::XS) for performance and consistency
- - Manually provide perl(Package::Stash::Conflicts), hidden from auto-provides
- * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.08-2
- - Rebuild to fix problems with vendorarch/lib (#661697)
- * Mon Sep 20 2010 Paul Howarth <paul@city-fan.org> - 0.08-1
- - Update to 0.08 (re-enable the caching of the stash)
- - Update patch for old ExtUtils::MakeMaker and Test::More versions
- * Wed Jun 16 2010 Paul Howarth <paul@city-fan.org> - 0.05-1
- - Update to 0.05
- - Bump Test::More requirement for done_testing
- - Update packaging stuff
- - BR: perl(Test::EOL) and perl(Test::NoTabs)
- - Unify spec for all active branches, adding patches for back-compatibility
- * Mon Jun 14 2010 Paul Howarth <paul@city-fan.org> - 0.04-1
- - Update to 0.04 (get_package_symbol now doesn't autovivify stash entries; a
- new method get_or_add_package_symbol can now be used for that behavior)
- * Mon Jun 14 2010 Paul Howarth <paul@city-fan.org> - 0.03-2
- - Incorporate package review suggestions (#602597)
- - Use %%{?perl_default_filter}
- - Use DESTDIR instead of PERL_INSTALL_ROOT
- * Mon Jun 7 2010 Paul Howarth <paul@city-fan.org> - 0.03-1
- - Initial RPM version
|