123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131 |
- # Recognize terminal size
- %bcond_with perl_Term_Table_enables_terminal
- # Respect Unicode rules when breaking lines
- %bcond_with perl_Term_Table_enables_unicode
- Name: perl-Term-Table
- Version: 0.013
- Release: 3%{?_dist_release}
- Summary: Format a header and rows into a table
- License: GPL+ or Artistic
- URL: https://metacpan.org/release/Term-Table
- Source0: https://cpan.metacpan.org/authors/id/E/EX/EXODIST/Term-Table-%{version}.tar.gz
- Vendor: Project Vine
- Distribution: Vine Linux
- BuildArch: noarch
- BuildRequires: make
- BuildRequires: perl >= 2:5.26.2
- BuildRequires: perl(ExtUtils::MakeMaker)
- BuildRequires: perl(strict)
- BuildRequires: perl(warnings)
- # Run-time:
- BuildRequires: perl(Carp)
- BuildRequires: perl(Config)
- BuildRequires: perl(Importer)
- BuildRequires: perl(List::Util)
- BuildRequires: perl(Scalar::Util)
- # Optional run-time:
- %if %{with perl_Term_Table_enables_terminal}
- # Term::ReadKey 2.32 not used if Term::Size::Any is available
- # Prefer Term::Size::Any over Term::ReadKey
- BuildRequires: perl(Term::Size::Any)
- %endif
- %if %{with perl_Term_Table_enables_unicode}
- BuildRequires: perl(Unicode::GCString)
- %endif
- # Tests:
- BuildRequires: perl(base)
- #BuildRequires: perl(Test2::API)
- #BuildRequires: perl(Test2::Tools::Tiny)
- BuildRequires: perl(Test::More)
- BuildRequires: perl(utf8)
- Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
- Requires: perl(Importer) >= 0.024
- %if %{with perl_Term_Table_enables_terminal}
- Suggests: perl(Term::ReadKey)
- # Prefer Term::Size::Any over Term::ReadKey
- Recommends: perl(Term::Size::Any)
- %endif
- %if %{with perl_Term_Table_enables_unicode}
- Recommends: perl(Unicode::GCString)
- %endif
- # Remove under-specified dependencies
- %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Importer\\)$
- %description
- This Perl module is able to format rows of data into tables.
- %prep
- %setup -q -n Term-Table-%{version}
- %build
- perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
- make %{?_smp_mflags}
- %install
- make pure_install DESTDIR=$RPM_BUILD_ROOT
- %{_fixperms} $RPM_BUILD_ROOT/*
- %check
- %if %{with perl_Term_Table_enables_terminal}
- unset TABLE_TERM_SIZE
- make test
- %endif
- %files
- %license LICENSE
- %doc Changes README
- %{perl_vendorlib}/*
- %{_mandir}/man3/*
- %changelog
- * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.013-3
- - initial build for Vine Linux.
- * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.013-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
- * Wed Dec 05 2018 Petr Pisar <ppisar@redhat.com> - 0.013-1
- - 0.013 bump
- * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.012-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
- * Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.012-3
- - Perl 5.28 rebuild
- * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.012-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Fri Oct 20 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.012-1
- - 0.012 bump
- * Wed Oct 11 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.011-1
- - 0.011 bump
- * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.008-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.008-2
- - Perl 5.26 rebuild
- * Mon Mar 20 2017 Petr Pisar <ppisar@redhat.com> - 0.008-1
- - 0.008 bump
- * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.006-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
- * Wed Jan 11 2017 Petr Pisar <ppisar@redhat.com> - 0.006-1
- - 0.006 bump
- * Mon Jan 02 2017 Petr Pisar <ppisar@redhat.com> - 0.005-1
- - 0.005 bump
- * Wed Dec 21 2016 Petr Pisar <ppisar@redhat.com> - 0.004-1
- - 0.004 bump
- * Tue Dec 20 2016 Petr Pisar <ppisar@redhat.com> 0.002-1
- - Specfile autogenerated by cpanspec 1.78.
|