phonon-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %define qt4_ver 4.8.6
  2. # Qt4 version auto-detection
  3. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  4. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  5. %define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix})
  6. %global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
  7. #define bootstrap 1
  8. Name: phonon
  9. Summary: Multimedia framework api
  10. Summary(ja): マルチメディアフレームワーク API
  11. Version: 4.9.0
  12. Release: 1%{?_dist_release}
  13. Group: System Environment/Libraries
  14. License: LGPLv2+
  15. URL: http://phonon.kde.org/
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Provides: phonon-experimental = %{version}-%{release}
  19. %if 0%{?bootstrap}
  20. Provides: phonon-backend%{?_isa} = 4.7
  21. %else
  22. Requires: phonon-backend%{?_isa} => 4.7
  23. %endif
  24. Source0: http://download.kde.org/stable/phonon/%{version}/phonon-%{version}.tar.xz
  25. ## Upstream patches
  26. ## upstreamable patches
  27. Patch10: phonon-rpath_use_link_path.patch
  28. Patch11: phonon-DEFAULT_SOURCE.patch
  29. ## Vine patches
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. BuildRequires: automoc4 >= 0.9.86
  32. BuildRequires: cmake >= 2.6.2
  33. BuildRequires: glib2-devel
  34. BuildRequires: libqzeitgeist-devel
  35. BuildRequires: libxcb-devel
  36. BuildRequires: libxml2-devel
  37. BuildRequires: qt4-devel >= 4.6.0
  38. BuildRequires: openssl-devel
  39. BuildRequires: pulseaudio-libs-devel >= 0.9.15
  40. BuildRequires: extra-cmake-modules
  41. BuildRequires: pkgconfig(Qt5DBus) pkgconfig(Qt5Designer) pkgconfig(Qt5OpenGL) pkgconfig(Qt5Widgets)
  42. BuildRequires: pkgconfig(Qt5Declarative)
  43. # TODO: enable the following Requires in next release
  44. Requires: pulseaudio-libs >= %{pulseaudio_version}
  45. Requires: qt4 >= %{_qt4_version}
  46. %description
  47. Phonon is a cross-platform portable Multimedia Support Abstraction,
  48. which allows you to play multiple audio or video formats with the same
  49. quality on all platforms, no matter which underlying architecture is
  50. used.
  51. %package devel
  52. Summary: Development files for phonon
  53. Summary(ja): phonon の開発用ファイル
  54. Group: Development/Libraries
  55. Provides: phonon-experimental-devel = %{version}-%{release}
  56. Requires: %{name} = %{version}-%{release}
  57. Requires: qt4-devel >= %{_qt4_version}
  58. %description devel
  59. Header files for developing applications using phonon
  60. %package qt5
  61. Summary: phonon for Qt5
  62. Summary(ja): Qt5用phonon
  63. %{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
  64. %if 0%{?bootstrap}
  65. Provides: %{name}-qt5-backend%{?_isa} = 4.7
  66. %else
  67. Requires: %{name}-qt5-backend%{?_isa} => 4.7
  68. %endif
  69. %description qt5
  70. Phonon is a cross-platform portable Multimedia Support Abstraction,
  71. which allows you to play multiple audio or video formats with the same
  72. quality on all platforms, no matter which underlying architecture is
  73. used.
  74. %package qt5-devel
  75. Summary: Developer files for %{name}-qt5
  76. Summary(ja): %{name}-qt5の開発者向けファイル
  77. Requires: %{name}-qt5%{?_isa} = %{version}-%{release}
  78. %description qt5-devel
  79. Header files for developing applications using phonon-qt5
  80. %prep
  81. %setup -q
  82. %patch10 -p1 -b .10
  83. %patch11 -p1 -b .11
  84. %build
  85. %ifarch x86_64
  86. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  87. %endif
  88. mkdir -p %{_target_platform}
  89. pushd %{_target_platform}
  90. %cmake \
  91. -DCMAKE_BUILD_TYPE:STRING="Release" \
  92. -DPHONON_INSTALL_QT_COMPAT_HEADERS:BOOL=ON \
  93. -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=ON \
  94. ..
  95. popd
  96. make %{?_smp_mflags} -C %{_target_platform}
  97. mkdir -p %{_target_platform}-Qt5
  98. pushd %{_target_platform}-Qt5
  99. %cmake \
  100. -DCMAKE_BUILD_TYPE:STRING="Release" \
  101. -DPHONON_BUILD_PHONON4QT5:BOOL=ON \
  102. -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=ON \
  103. ..
  104. popd
  105. make %{?_smp_mflags} -C %{_target_platform}-Qt5
  106. %install
  107. rm -rf $RPM_BUILD_ROOT
  108. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  109. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}-Qt5
  110. # own these dirs
  111. mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
  112. mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
  113. mkdir -p %{buildroot}%{_qt5_plugindir}/phonon4qt5_backend
  114. %check
  115. export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
  116. test "$(pkg-config --modversion phonon)" = "%{version}"
  117. test "$(pkg-config --modversion phonon4qt5)" = "%{version}"
  118. %clean
  119. rm -rf $RPM_BUILD_ROOT
  120. %post
  121. /sbin/ldconfig
  122. %postun
  123. /sbin/ldconfig
  124. # https://bugzilla.redhat.com/show_bug.cgi?id=1223956
  125. # replacing symlink with a dir
  126. %pretrans devel -p <lua>
  127. path = "%{_includedir}/phonon/Phonon"
  128. st = posix.stat(path)
  129. if st and st.type == "link" then
  130. os.remove(path)
  131. end
  132. %files
  133. %defattr(-,root,root)
  134. %license COPYING.LIB
  135. %{_libdir}/libphonon.so.4*
  136. %{_libdir}/libphononexperimental.so.4*
  137. %{_qt4_plugindir}/designer/*.so
  138. # kde4-specific dirs
  139. %dir %{_libdir}/kde4/plugins/phonon_backend
  140. %dir %{_datadir}/kde4/services/phononbackends
  141. %dir %{_datadir}/phonon/
  142. %files devel
  143. %defattr(-,root,root)
  144. %dir %{_includedir}/KDE
  145. %{_includedir}/KDE/Phonon/
  146. %{_includedir}/phonon/
  147. %{_libdir}/libphonon.so
  148. %{_libdir}/libphononexperimental.so
  149. %dir %{_libdir}/cmake/
  150. %{_libdir}/cmake/phonon/
  151. %{_libdir}/pkgconfig/phonon.pc
  152. %{_datadir}/phonon/buildsystem/
  153. %{_qt4_datadir}/mkspecs/modules/qt_phonon.pri
  154. %{_datadir}/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
  155. %files qt5
  156. %license COPYING.LIB
  157. %dir %{_datadir}/phonon4qt5
  158. %{_libdir}/libphonon4qt5.so.4*
  159. %{_libdir}/libphonon4qt5experimental.so.4*
  160. %{_qt5_plugindir}/designer/phononwidgets.so
  161. %dir %{_qt5_plugindir}/phonon4qt5_backend/
  162. %files qt5-devel
  163. %{_datadir}/dbus-1/interfaces/org.kde.Phonon4Qt5.AudioOutput.xml
  164. %{_datadir}/phonon4qt5/buildsystem/
  165. %dir %{_libdir}/cmake/
  166. %{_libdir}/cmake/phonon4qt5/
  167. %{_includedir}/phonon4qt5/
  168. %{_libdir}/libphonon4qt5.so
  169. %{_libdir}/libphonon4qt5experimental.so
  170. %{_libdir}/pkgconfig/phonon4qt5.pc
  171. %{_qt5_archdatadir}/mkspecs/modules/qt_phonon4qt5.pri
  172. %changelog
  173. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.8.2-2
  174. - rebuilt with new toolchain.
  175. * Fri Nov 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.8.2-1
  176. - new upstream release
  177. * Tue Dec 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.1-1
  178. - new upstream release
  179. - update Patch1
  180. - remove Patch50 (phonon-4.5.57-plugindir.patch)
  181. * Sat Jan 7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
  182. - new upstream release
  183. * Sat Nov 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  184. - new upstream release
  185. * Sat Oct 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
  186. - added Patch100 and 200 to build with pulseaudio-1.0
  187. * Sun Jun 5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  188. - new upstream release
  189. - added BR: libqzeitgeist-devel
  190. * Tue Mar 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-2
  191. - rebuilt with qt4-4.7.2
  192. * Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
  193. - new upstream release
  194. - rebuilt with qt4-4.7.1 on VineSeed
  195. * Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
  196. - new upstream release
  197. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
  198. - added sybolic link in %%{_qt4_headerdir}
  199. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  200. - new upstream release
  201. - dropt Patch51 and 57
  202. - rebuilt with rpm-4.8.1
  203. * Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
  204. - new upstream release
  205. - dropt Patch1, 50, 54 and 100
  206. - added Patch57
  207. * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
  208. - F11: patch/modularize pa device-manager bits
  209. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
  210. - added qmake path to PATH (if x86_64)
  211. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
  212. - new upstream release
  213. - built with new toolchain
  214. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
  215. - added Patch102 and 103 from FC
  216. * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
  217. - fix for '#' in filenames
  218. * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
  219. - restore patches to the xine backend
  220. * Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
  221. - added Patch100 and 101 from FC
  222. * Tue Mar 3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
  223. - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
  224. - added backend sub-pakcages
  225. * Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
  226. - new upstream release
  227. - add BuildPrereq: cmake
  228. * Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
  229. - new upstream release
  230. * Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
  231. - new upstream release
  232. - update %%files
  233. - add BuildPrereq: xine-lib-devel libxcb-devel
  234. * Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
  235. - new upstream release
  236. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
  237. - added script to append qmake path
  238. - added option -DLIB_INSTALL_DIR at cmake
  239. * Tue Oct 7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
  240. - initial release for VineSeed