123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192 |
- %global with_python3 1
- Name: python-pycparser
- Summary: C parser and AST generator written in Python
- Version: 2.20
- Release: 1%{?_dist_release}
- Group: programming
- Vendor: Project Vine
- Distribution: Vine Linux
- License: BSD
- URL: http://github.com/eliben/pycparser
- Source0: https://github.com/eliben/pycparser/archive/release_v%{version}.tar.gz#/pycparser-%{version}.tar.gz
- Source1: pycparser-0.91.1-remove-relative-sys-path.py
- BuildArch: noarch
- BuildRequires: python-rpm-macros
- BuildRequires: python2-rpm-macros
- BuildRequires: python-devel python-setuptools
- %{?python_provide:%python_provide python-pycparser}
- %if 0%{?with_python3}
- BuildRequires: python3-rpm-macros
- BuildRequires: python3-devel python3-setuptools
- %endif # if with_python3
- BuildRequires: dos2unix
- %description
- pycparser is a complete parser for the C language, written in pure Python.
- It is a module designed to be easily integrated into applications that
- need to parse C source code.
- %if 0%{?with_python3}
- %package -n python3-pycparser
- Summary: C parser and AST generator written in Python
- Group: programming
- %{?python_provide:%python_provide python3-pycparser}
- %description -n python3-pycparser
- pycparser is a complete parser for the C language, written in pure Python.
- It is a module designed to be easily integrated into applications that
- need to parse C source code.
- %endif # if with_python3
- %prep
- %setup -q -n pycparser-release_v%{version}
- # examples
- %{__python2} %{SOURCE1} examples
- dos2unix LICENSE
- %build
- %py2_build
- pushd build/lib/pycparser
- %{__python2} _build_tables.py
- popd
- %if 0%{?with_python3}
- %py3_build
- pushd build/lib/pycparser
- %{__python3} _build_tables.py
- popd
- %endif # with_python3
- %install
- %py2_install
- %if 0%{?with_python3}
- %py3_install
- %endif # with_python3
- %check
- #%{__python2} tests/all_tests.py
- %if 0%{?with_python3}
- #%{__python3} tests/all_tests.py
- %endif # with_python3
-
- %files
- %license LICENSE
- %doc examples
- %{python_sitelib}/pycparser/
- %{python_sitelib}/pycparser-*.egg-info
- %if 0%{?with_python3}
- %files -n python3-pycparser
- %license LICENSE
- %doc examples
- %{python3_sitelib}/pycparser/
- %{python3_sitelib}/pycparser-*.egg-info
- %endif # with_python3
- %changelog
- * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.20-1
- - new upstream release.
- * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.19-1
- - initial build for Vine Linux.
- - new upstream release.
- * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.14-15
- - Rebuilt for Python 3.7
- * Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.14-14
- - Update Python 2 dependency declarations to new packaging standards
- (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
- * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.14-13
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Wed Sep 27 2017 Troy Dawson <tdawson@redhat.com> - 2.14-12
- - Cleanup spec file conditionals
- * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.14-11
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.14-10
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
- * Fri Jan 6 2017 Orion Poplawski <orion@cora.nwra.com> - 2.14-9
- - Ship python2-pycparser
- - Modernize spec
- * Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.14-8
- - Rebuild for Python 3.6
- * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14-7
- - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
- * Fri Jul 8 2016 Tom Callaway <spot@fedoraproject.org> - 2.14-6
- - rebuild to update yacctab.py
- * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.14-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 2.14-4
- - Rebuilt for Python3.5 rebuild
- * Tue Jul 14 2015 Stephen Gallagher <sgallagh@redhat.com> - 2.14-3
- - Rebuild alongside python-ply 3.6
- * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Tue Jun 09 2015 Nathaniel McCallum <npmccallum@redhat.com> - 2.14-1
- - Update to 2.14
- * Wed Aug 20 2014 Eric Smith <brouhaha@fedoraproject.org> 2.10-1
- - Update to latest upstream.
- * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.09.1-9
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
- * Mon May 12 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.09.1-8
- - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
- * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.09.1-7
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
- * Tue Jul 23 2013 Eric Smith <brouhaha@fedoraproject.org> 2.09.1-6
- - Added Python 3 support.
- * Mon Jul 22 2013 Eric Smith <brouhaha@fedoraproject.org> 2.09.1-5
- - Renumbered Fedora-specific Patch1 to Patch100
- - Added new Patch1 to fix table generation when the build system
- already has a python-pycparser package installed.
- - Submitted Patch0 and Patch1 as upstream issues.
- - Added comments about patches.
- * Sun Jul 21 2013 Eric Smith <brouhaha@fedoraproject.org> 2.09.1-4
- - Upstream repository is now on github.
- - Fix rpmlint strange-permission complaint.
- - Rename patches, Source1 to all start with pycparser-{version}, to
- simplify updating patches for future upstream releases.
- * Sun Jul 21 2013 Eric Smith <brouhaha@fedoraproject.org> 2.09.1-3
- - Run _build_tables.py to build the lextab.py and yacctab.py; otherwise
- they have to be regenerated at runtime for no benefit.
- * Tue Mar 19 2013 Jos de Kloe <josdekloe@gmail.com> 2.09.1-2
- - remove the embedded ply code
- * Fri Jan 18 2013 Scott Tsai <scottt.tw@gmail.com> 2.09.1-1
- - upstream 2.09.1
|