123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124 |
- %global pypi_name sphinxcontrib-serializinghtml
- # when bootstrapping sphinx, we cannot run tests yet
- %bcond_with check
- Summary: Sphinx extension for serialized HTML
- Name: python-%{pypi_name}
- Version: 1.1.4
- Release: 3%{?_dist_release}
- Group: programming
- Vendor: Project Vine
- Distribution: Vine Linux
- License: BSD
- URL: http://sphinx-doc.org/
- Source0: %{pypi_source}
- BuildArch: noarch
- BuildRequires: gettext
- BuildRequires: python3-rpm-macros
- BuildRequires: python3-devel
- BuildRequires: python3-setuptools
- %if %{with check}
- BuildRequires: python3-pytest
- BuildRequires: python3-sphinx >= 1:2
- %endif
- %description
- sphinxcontrib-serializinghtml is a sphinx extension which outputs "serialized"
- HTML files (json and pickle).
- %package -n python3-%{pypi_name}
- Summary: %{summary}
- Group: programming
- %{?python_provide:%python_provide python3-%{pypi_name}}
- %description -n python3-%{pypi_name}
- sphinxcontrib-serializinghtml is a sphinx extension which outputs "serialized"
- HTML files (json and pickle).
- %prep
- %autosetup -n %{pypi_name}-%{version}
- find -name '*.mo' -delete
- %build
- for po in $(find -name '*.po'); do
- msgfmt --output-file=${po%.po}.mo ${po}
- done
- %py3_build
- %install
- %py3_install
- # Move language files to /usr/share
- pushd %{buildroot}%{python3_sitelib}
- for lang in `find sphinxcontrib/serializinghtml/locales -maxdepth 1 -mindepth 1 -type d -not -path '*/\.*' -printf "%f "`;
- do
- test $lang == __pycache__ && continue
- install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
- mv sphinxcontrib/serializinghtml/locales/$lang/LC_MESSAGES/*.mo %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
- done
- rm -rf sphinxcontrib/serializinghtml/locales
- ln -s %{_datadir}/locale sphinxcontrib/serializinghtml/locales
- popd
- %find_lang sphinxcontrib.serializinghtml
- %if %{with check}
- %check
- %pytest
- %endif
- %files -n python3-%{pypi_name} -f sphinxcontrib.serializinghtml.lang
- %license LICENSE
- %doc README.rst
- %{python3_sitelib}/sphinxcontrib/
- %{python3_sitelib}/sphinxcontrib_serializinghtml-%{version}-py%{python3_version}-*.pth
- %{python3_sitelib}/sphinxcontrib_serializinghtml-%{version}-py%{python3_version}.egg-info/
- %changelog
- * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.4-3
- - initial build for Vine Linux.
- * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
- * Mon Jun 01 2020 Charalampos Stratakis <cstratak@redhat.com> - 1.1.4-1
- - Update to 1.1.4 (#1808637)
- * Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-8
- - Rebuilt for Python 3.9
- * Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-7
- - Bootstrap for Python 3.9
- * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
- * Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-5
- - Rebuilt for Python 3.8.0rc1 (#1748018)
- * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-4
- - Rebuilt for Python 3.8
- * Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-3
- - Bootstrap for Python 3.8
- * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
- * Mon May 20 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-1
- - Update to 1.1.3 (#1697444)
- * Mon Mar 04 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.1-1
- - Initial package.
|