123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208 |
- %global with_python3 1
- # For bootstrapping sphinxcontrib-websupport
- %bcond_with docs
- %global mod_name Whoosh
- Summary: Fast, pure-Python full text indexing, search, and spell checking library
- Name: python-whoosh
- Version: 2.7.4
- Release: 14%{?_dist_release}
- Group: programming
- Vendor: Project Vine
- Distribution: Vine Linux
- License: BSD
- URL: http://pythonhosted.org/Whoosh/
- Source0: https://pypi.python.org/packages/source/W/%{mod_name}/%{mod_name}-%{version}.tar.gz
- BuildArch: noarch
- BuildRequires: python-rpm-macros
- BuildRequires: python2-rpm-macros
- BuildRequires: python-devel
- BuildRequires: python-setuptools
- %if %{with docs}
- BuildRequires: python-sphinx
- %endif
- %{?python_provide:%python_provide python2-whoosh}
- %if 0%{?with_python3}
- BuildRequires: python3-rpm-macros
- BuildRequires: python3-devel
- BuildRequires: python3-setuptools
- %endif
- %description
- Whoosh is a fast, featureful full-text indexing and searching library
- implemented in pure Python. Programmers can use it to easily add search
- functionality to their applications and websites. Every part of how Whoosh
- works can be extended or replaced to meet your needs exactly.
- %if 0%{?with_python3}
- %package -n python3-whoosh
- Summary: Fast, Python3 full text indexing, search, and spell checking library
- %{?python_provide:%python_provide python%{python3_pkgversion}-whoosh}
- Group: programming
- %description -n python3-whoosh
- Whoosh is a fast, featureful full-text indexing and searching library
- implemented in pure Python. Programmers can use it to easily add search
- functionality to their applications and websites. Every part of how Whoosh
- works can be extended or replaced to meet your needs exactly.
- %endif
- %prep
- %setup -q -n %{mod_name}-%{version}
- %build
- %py2_build
- %if %{with docs}
- sphinx-build docs/source docs/html
- rm -f docs/html/.buildinfo
- rm -rf docs/html/.doctrees
- %endif
- %if 0%{?with_python3}
- %py3_build
- rm -f docs/html/.buildinfo
- rm -rf docs/html/.doctrees
- %endif
- %install
- %py2_install
- %if 0%{?with_python3}
- %py3_install
- %endif
- %if 0
- %check
- {__python2} setup.py test
- %if 0%{?with_python3}
- %{__python3} setup.py test
- %endif
- %endif
- %files
- %license LICENSE.txt
- %doc README.txt
- %if %{with docs}
- %doc docs/html/
- %endif
- %{python2_sitelib}/*.egg-info/
- %{python2_sitelib}/whoosh
- %if 0%{?with_python3}
- %files -n python%{python3_pkgversion}-whoosh
- %license LICENSE.txt
- %doc README.txt
- %if %{with docs}
- %doc docs/html/
- %endif
- %{python3_sitelib}/whoosh
- %{python3_sitelib}/*.egg-info/
- %endif
- %changelog
- * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7.4-14
- - rebuilt with python-3.8.
- * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7.4-13
- - initial build for Vine Linux.
- * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-12
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
- * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7.4-11
- - Rebuilt for Python 3.7
- * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7.4-10
- - Bootstrap for Python 3.7
- * Wed Feb 28 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.7.4-9
- - Update Python 2 dependency declarations to new packaging standards
- (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
- * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-8
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-7
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
- * Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.7.4-5
- - Enable tests
- * Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.7.4-4
- - Rebuild for Python 3.6
- - Disable python3 tests for now
- * Wed Oct 12 2016 Orion Poplawski <orion@cora.nwra.com> - 2.7.4-3
- - Ship python2-whoosh
- - Build python3 package for EPEL7
- - Modernize spec
- * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.4-2
- - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
- * Sun May 01 2016 Robert Kuska <rkuska@gmail.com> - 2.7.4-1
- - Update to version 2.7.4
- * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Mon Oct 12 2015 Robert Kuska <rkuska@redhat.com> 2.7.0-1
- - Update to version 2.7.0
- * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.7-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Wed Jul 30 2014 Robert Kuska <rkuska@redhat.com> - 2.7.5-4
- - Change spec for el6 and epel7
- * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.7-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
- * Fri May 16 2014 Robert Kuska <rkuska@redhat.com> - 2.7.5-2
- - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
- * Mon Mar 03 2014 Robert Kuska <rkuska@redhat.com> - 2.5.7-1
- - Rebase to 2.5.7
- * Mon Jan 27 2014 Robert Kuska <rkuska@redhat.com> - 2.5.6-1
- - Rebase to 2.5.6
- * Tue Nov 19 2013 Robert Kuska <rkuska@redhat.com> - 2.5.5-1
- - Rebase to 2.5.5
- * Mon Sep 09 2013 Robert Kuska <rkuska@redhat.com> - 2.5.3-1
- - Rebase to 2.5.3
- * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
- * Mon Jul 08 2013 Robert Kuska <rkuska@redhat.com> - 2.5.1-1
- - Update source
- - Add python3 subpackage (rhbz#979235)
- * Mon Apr 08 2013 Robert Kuska <rkuska@redhat.com> - 2.4.1-2
- - Review fixes
- * Fri Apr 05 2013 Robert Kuska <rkuska@redhat.com> - 2.4.1-1
- - Initial package
|