python3-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559
  1. %bcond_with run_test
  2. %define config_htmldir /var/www/html/python
  3. Summary: An interpreted, interactive, object-oriented programming language.
  4. Summary(ja): オブジェクト指向 Python3 インタプリタ
  5. Name: python3
  6. Version: 3.8.8
  7. Release: 2%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: Python
  12. URL: http://www.python.org/download/releases/%{version}
  13. %define majorver %(echo %{version} | cut -d . -f 1)
  14. %define libvers %(echo %{version} | cut -d . -f 1-2)
  15. %define binsuffix %{libvers}
  16. %define python_lib %{_libdir}/python%{libvers}
  17. %global py_SOVERSION 1.0
  18. %global py_INSTSONAME libpython%{libvers}.so.%{py_SOVERSION}
  19. Source0: https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
  20. Source1: https://docs.python.org/ftp/python/doc/%{version}/python-%{version}-docs-html.tar.bz2
  21. # (Patches taken from github.com/fedora-python/cpython)
  22. # 00001 # d06a8853cf4bae9e115f45e1d531d2dc152c5cc8
  23. # Fixup distutils/unixccompiler.py to remove standard library path from rpath
  24. # Was Patch0 in ivazquez' python3000 specfile
  25. Patch1: 00001-rpath.patch
  26. # 00102 # ec4353c0f646eb567cc0d63e1e41eb5e29cc3e81
  27. # Change the various install paths to use /usr/lib64/ instead or /usr/lib/
  28. #
  29. # Only used when "%%{_lib}" == "lib64".
  30. Patch102: 00102-lib64.patch
  31. # 00111 # 03918d404a40a50c9f5f93dc748b52e613d70d31
  32. # Don't try to build a libpythonMAJOR.MINOR.a
  33. #
  34. # Downstream only: not appropriate for upstream.
  35. #
  36. # See https://bugzilla.redhat.com/show_bug.cgi?id=556092
  37. Patch111: 00111-no-static-lib.patch
  38. # 00189 # adf51ed04ac74fd6fc39c642af35b87680c71dab
  39. # Instead of bundled wheels, use our RPM packaged wheels
  40. #
  41. # We keep them in /usr/share/python-wheels
  42. #
  43. # Downstream only: upstream bundles
  44. # We might eventually pursuit upstream support, but it's low prio
  45. Patch189: 00189-use-rpm-wheels.patch
  46. # The following versions of setuptools/pip are bundled when this patch is not applied.
  47. # The versions are written in Lib/ensurepip/__init__.py, this patch removes them.
  48. # When the bundled setuptools/pip wheel is updated, the patch no longer applies cleanly.
  49. # In such cases, the patch needs to be amended and the versions updated here:
  50. %global pip_version 20.1.1
  51. %global setuptools_version 47.1.0
  52. # 00251 # 2eabd04356402d488060bc8fe316ad13fc8a3356
  53. # Change user install location
  54. #
  55. # Set values of prefix and exec_prefix in distutils install command
  56. # to /usr/local if executable is /usr/bin/python* and RPM build
  57. # is not detected to make pip and distutils install into separate location.
  58. #
  59. # Fedora Change: https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
  60. # Downstream only: Awaiting resources to work on upstream PEP
  61. Patch251: 00251-change-user-install-location.patch
  62. # 00274 # 1e9258f6e8f70e86d5130113d3eed22993cf3da9
  63. # Upstream uses Debian-style architecture naming, change to match Fedora
  64. Patch274: 00274-fix-arch-names.patch
  65. # 00328 # 367fdcb5a075f083aea83ac174999272a8faf75c
  66. # Restore pyc to TIMESTAMP invalidation mode as default in rpmbuild
  67. #
  68. # Since Fedora 31, the $SOURCE_DATE_EPOCH is set in rpmbuild to the latest
  69. # %%changelog date. This makes Python default to the CHECKED_HASH pyc
  70. # invalidation mode, bringing more reproducible builds traded for an import
  71. # performance decrease. To avoid that, we don't default to CHECKED_HASH
  72. # when $RPM_BUILD_ROOT is set (i.e. when we are building RPM packages).
  73. #
  74. # See https://src.fedoraproject.org/rpms/redhat-rpm-config/pull-request/57#comment-27426
  75. # Downstream only: only used when building RPM packages
  76. # Ideally, we should talk to upstream and explain why we don't want this
  77. Patch328: 00328-pyc-timestamp-invalidation-mode.patch
  78. # security
  79. # (none)
  80. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  81. BuildRequires: autoconf
  82. BuildRequires: bzip2-devel
  83. BuildRequires: expat-devel
  84. BuildRequires: findutils
  85. BuildRequires: gcc-c++
  86. BuildRequires: gdbm-devel
  87. BuildRequires: glibc-devel
  88. BuildRequires: libdb-devel
  89. BuildRequires: libffi-devel
  90. BuildRequires: libnsl2-devel
  91. BuildRequires: libtirpc-devel
  92. BuildRequires: libxcrypt-devel
  93. BuildRequires: ncurses-devel
  94. BuildRequires: openssl-devel
  95. BuildRequires: pkgconfig
  96. BuildRequires: readline-devel
  97. BuildRequires: sqlite3-devel
  98. BuildRequires: tar
  99. BuildRequires: valgrind-devel
  100. BuildRequires: xz-devel
  101. BuildRequires: zlib-devel
  102. %description
  103. Python is an interpreted, interactive, object-oriented programming
  104. language. It incorporates modules, exceptions, dynamic typing, very high
  105. level dynamic data types, and classes. Python combines remarkable power
  106. with very clear syntax. It has interfaces to many system calls and
  107. libraries, as well as to various window systems, and is extensible in C or
  108. C++. It is also usable as an extension language for applications that need
  109. a programmable interface. Finally, Python is portable: it runs on many
  110. brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
  111. Mac.
  112. %package devel
  113. Summary: The libraries and header files needed for Python development.
  114. Group: programming
  115. Requires: %{name} = %{version}-%{release}
  116. Requires: libtirpc-devel
  117. %description devel
  118. The Python programming language's interpreter can be extended with
  119. dynamically loaded extensions and can be embedded in other programs.
  120. This package contains the header files and libraries needed to do
  121. these types of tasks.
  122. Install python-devel if you want to develop Python extensions. The
  123. python package will also need to be installed. You'll probably also
  124. want to install the python-docs package, which contains Python
  125. documentation.
  126. %package tkinter
  127. Summary: A graphical user interface for the Python scripting language.
  128. Group: programming
  129. Requires: %{name} = %{version}-%{release}
  130. Requires: tcl, tk, tix
  131. Requires: libX11, libxcb, libXau, libXdmcp
  132. BuildRequires: tcl-devel, tk-devel, tix
  133. BuildRequires: libX11-devel, libxcb-devel, libXau-devel, libXdmcp-devel
  134. %description tkinter
  135. The Tkinter (Tk interface) program is an graphical user interface for
  136. the Python scripting language.
  137. You should install the tkinter package if you'd like to use a graphical
  138. user interface for Python programming.
  139. %package tools
  140. Summary: A collection of development tools included with Python.
  141. Group: programming
  142. Requires: %{name} = %{version}-%{release}
  143. Requires: %{name}-tkinter = %{version}
  144. %description tools
  145. The Python package includes several development tools that are used
  146. to build python programs.
  147. %package docs
  148. Summary: Documentation for the Python programming language.
  149. Summary(ja): Python プログラミング言語のドキュメント
  150. Group: documentation
  151. %description docs
  152. The python-docs package contains documentation on the Python
  153. programming language and interpreter. The documentation is provided
  154. in ASCII text files and in LaTeX source files.
  155. Install the python-docs package if you'd like to use the documentation
  156. for the Python language.
  157. %debug_package
  158. %prep
  159. %setup -q -n Python-%{version}
  160. # Remove all exe files to ensure we are not shipping prebuilt binaries
  161. # note that those are only used to create Microsoft Windows installers
  162. # and that functionality is broken on Linux anyway
  163. find -name '*.exe' -print -delete
  164. # Remove bundled libraries to ensure that we're using the system copy.
  165. rm -r Modules/expat
  166. #
  167. # Apply patches:
  168. #
  169. %patch1 -p1
  170. %if "%{_lib}" == "lib64"
  171. %patch102 -p1
  172. %endif
  173. %patch111 -p1
  174. %if %{with rpmwheels}
  175. %patch189 -p1
  176. rm Lib/ensurepip/_bundled/*.whl
  177. %endif
  178. %patch251 -p1
  179. %patch274 -p1
  180. %patch328 -p1
  181. # security
  182. # (none)
  183. # Remove files that should be generated by the build
  184. # (This is after patching, so that we can use patches directly from upstream)
  185. rm configure pyconfig.h.in
  186. # Regenerate the configure script and pyconfig.h.in
  187. autoconf
  188. autoheader
  189. %build
  190. export CFLAGS="%{?extension_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
  191. export CFLAGS_NODIST="%{?build_cflags} -D_GNU_SOURCE -fPIC -fwrapv%{?with_no_semantic_interposition: -fno-semantic-interposition}"
  192. export CXXFLAGS="%{?extension_cxxflags} -D_GNU_SOURCE -fPIC -fwrapv"
  193. export CPPFLAGS="$(pkg-config --cflags-only-I libffi)"
  194. export OPT="%{?extension_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
  195. export LINKCC="gcc"
  196. export CFLAGS="$CFLAGS $(pkg-config --cflags openssl)"
  197. export LDFLAGS="%{?extension_ldflags} -g $(pkg-config --libs-only-L openssl)"
  198. export LDFLAGS_NODIST="%{?build_ldflags}%{?with_no_semantic_interposition: -fno-semantic-interposition} -g $(pkg-config --libs-only-L openssl)"
  199. ./configure \
  200. --prefix=%{_prefix} \
  201. --libdir=%{_libdir} \
  202. --enable-ipv6 \
  203. --enable-shared \
  204. --with-computed-gotos=yes \
  205. --with-dbmliborder=gdbm:ndbm:bdb \
  206. --with-system-expat \
  207. --with-system-ffi \
  208. --enable-loadable-sqlite-extensions \
  209. --with-lto \
  210. --with-ssl-default-suites=openssl \
  211. --with-valgrind \
  212. --without-ensurepip \
  213. --enable-optimizations \
  214. %{nil}
  215. make %{?_smp_mflags} CFLAGS_NODIST="$CFLAGS_NODIST" \
  216. regen-all PYTHON_FOR_REGEN="python%{binsuffix}"
  217. make %{?_smp_mflags} CFLAGS_NODIST="$CFLAGS_NODIST"
  218. %install
  219. [ -d "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  220. make DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir} install
  221. # replace path in pydoc
  222. if [ ! -z "%{binsuffix}" ]
  223. then
  224. (
  225. cd $RPM_BUILD_ROOT%{_bindir}
  226. mv pydoc%{libvers} pydoc.old
  227. sed 's|#!.*|#!%{_bindir}/env python'%{libvers}'|' \
  228. pydoc.old > pydoc%{libvers}
  229. chmod 755 pydoc%{libvers}
  230. rm -f pydoc.old
  231. )
  232. fi
  233. # Tools
  234. echo '#!%{_bindir}/env python%{binsuffix}' > ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  235. echo 'import os, sys' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  236. echo 'os.execvp("%{_bindir}/python%{binsuffix}", ["%{_bindir}/python%{binsuffix}", "%{python_lib}/idlelib/idle.py"] + sys.argv[1:])' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  237. echo 'print "Failed to exec Idle"' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  238. echo 'sys.exit(1)' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  239. chmod 755 $RPM_BUILD_ROOT%{_bindir}/idle%{binsuffix}
  240. #cp -a Tools $RPM_BUILD_ROOT%{python_lib}
  241. mkdir -p %{buildroot}%{_prefix}/lib/debug%{_libdir}
  242. cp -f Tools/gdb/libpython.py %{buildroot}%{_prefix}/lib/debug%{_libdir}/%{py_INSTSONAME}-%{version}-%{release}.%{_arch}.debug-gdb.py
  243. # Install pathfix.py to bindir
  244. # See https://github.com/fedora-python/python-rpm-porting/issues/24
  245. cp -p Tools/scripts/pathfix.py %{buildroot}%{_bindir}/pathfix%{binsuffix}.py
  246. # Install i18n tools to bindir
  247. # They are also in python2, so we version them
  248. # https://bugzilla.redhat.com/show_bug.cgi?id=1571474
  249. for tool in pygettext msgfmt; do
  250. cp -p Tools/i18n/${tool}.py %{buildroot}%{_bindir}/${tool}%{binsuffix}.py
  251. ln -s ${tool}%{binsuffix}.py %{buildroot}%{_bindir}/${tool}3.py
  252. done
  253. # Switch all shebangs to refer to the specific Python version.
  254. # This currently only covers files matching ^[a-zA-Z0-9_]+\.py$,
  255. # so handle files named using other naming scheme separately.
  256. LD_LIBRARY_PATH=./ ./python \
  257. Tools/scripts/pathfix.py \
  258. -i "%{_bindir}/python%{binsuffix}" -pn \
  259. %{buildroot} \
  260. %{buildroot}%{_bindir}/{2to3-,idle,pydoc}%{binsuffix} \
  261. %{buildroot}%{_bindir}/*%{binsuffix}.py \
  262. %{buildroot}%{_libdir}/python%{binsuffix}/cgi.py \
  263. %{buildroot}%{_prefix}/lib/debug%{_libdir}/*.py
  264. # Remove shebang lines from .py files that aren't executable, and
  265. # remove executability from .py files that don't have a shebang line:
  266. find %{buildroot} -name \*.py \
  267. \( \( \! -perm /u+x,g+x,o+x -exec sed -e '/^#!/Q 0' -e 'Q 1' {} \; \
  268. -print -exec sed -i '1d' {} \; \) -o \( \
  269. -perm /u+x,g+x,o+x ! -exec grep -m 1 -q '^#!' {} \; \
  270. -exec chmod a-x {} \; \) \)
  271. # make file lists
  272. rm -f mainpkg.files
  273. find "$RPM_BUILD_ROOT"%{python_lib} -type f |
  274. sed "s|^${RPM_BUILD_ROOT}|/|" |
  275. grep -v \
  276. -e '/python%{libvers}/config$' \
  277. -e '_tkinter.so$' \
  278. -e '_tkinter.cpython-' \
  279. -e '/tkinter/' \
  280. -e '/turtledemo/' \
  281. -e '/idlelib/' \
  282. >> mainpkg.files
  283. rm -f $RPM_BUILD_ROOT%{_prefix}/bin/2to3
  284. find "$RPM_BUILD_ROOT""%{_prefix}"/bin -type f -o -type l |
  285. sed "s|^${RPM_BUILD_ROOT}|/|" |
  286. grep -v \
  287. -e '/idlelib/' \
  288. -e '/bin/2to3-%{binsuffix}$' \
  289. -e '/bin/msgfmt%{binsuffix}.py' \
  290. -e '/bin/pathfix%{binsuffix}.py' \
  291. -e '/bin/pygettext%{binsuffix}.py' \
  292. -e '/bin/pydoc%{binsuffix}$' \
  293. -e '/bin/pydoc%{majorver}$' \
  294. -e '/bin/idle%{binsuffix}$' \
  295. -e '/bin/idle%{majorver}$' \
  296. >> mainpkg.files
  297. rm -f tools.files
  298. find "$RPM_BUILD_ROOT"%{python_lib}/idlelib \
  299. -type f |
  300. sed "s|^${RPM_BUILD_ROOT}|/|" > tools.files
  301. echo %{_bindir}/pydoc%{binsuffix} >> tools.files
  302. echo %{_bindir}/pydoc%{majorver} >> tools.files
  303. echo %{_bindir}/idle%{binsuffix} >> tools.files
  304. echo %{_bindir}/idle%{majorver} >> tools.files
  305. # docs
  306. mkdir -p "$RPM_BUILD_ROOT"%{config_htmldir}
  307. (
  308. cd "$RPM_BUILD_ROOT"%{config_htmldir}
  309. bunzip2 < %{SOURCE1} | tar x
  310. )
  311. %if %{with run_test}
  312. %check
  313. make test
  314. %endif
  315. %clean
  316. rm -fr $RPM_BUILD_ROOT
  317. %post -p /sbin/ldconfig
  318. %postun -p /sbin/ldconfig
  319. %files -f mainpkg.files
  320. %defattr(-, root, root)
  321. %license LICENSE
  322. %doc Misc/ACKS Misc/HISTORY Misc/NEWS Misc/Porting Misc/README
  323. %attr(755,root,root) %dir %{python_lib}/
  324. %{_libdir}/libpython*
  325. %{_mandir}/man1/python%{libvers}.1*
  326. %{_mandir}/man1/%{name}.1*
  327. %files devel
  328. %defattr(-,root,root)
  329. %{_bindir}/2to3-%{binsuffix}
  330. %{_bindir}/msgfmt%{binsuffix}.py
  331. %{_bindir}/pathfix%{binsuffix}.py
  332. %{_bindir}/pygettext%{binsuffix}.py
  333. %dir %{_includedir}/python%{libvers}
  334. %dir %{_includedir}/python%{libvers}/cpython
  335. %dir %{_includedir}/python%{libvers}/internal
  336. %{_includedir}/python%{libvers}/*.h
  337. %{_includedir}/python%{libvers}/cpython/*.h
  338. %{_includedir}/python%{libvers}/internal/*.h
  339. %{_libdir}/pkgconfig/*.pc
  340. %{_prefix}/lib/debug%{_libdir}/*.py
  341. %files -f tools.files tools
  342. %defattr(-,root,root)
  343. %files tkinter
  344. %defattr(-,root,root)
  345. %{python_lib}/__pycache__/turtle.*
  346. %{python_lib}/tkinter
  347. %{python_lib}/turtledemo
  348. %{python_lib}/lib-dynload/_tkinter.*.so*
  349. %files docs
  350. %defattr(-,root,root)
  351. %{config_htmldir}/*
  352. %changelog
  353. * Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.8-2
  354. - fixed %%files.
  355. * Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.8-1
  356. - new upstream release.
  357. - dropped Patch1000: fixed in upstream.
  358. * Wed Feb 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.7-1
  359. - new upstream release.
  360. - dropped Patch1000: fixed in upstream.
  361. - added Patch1000 to fix CVE-2021-3177.
  362. * Tue Nov 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.6-2
  363. - added Patch1000 to fix CVE-2020-27619.
  364. * Fri Oct 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.6-1
  365. - new upstream release.
  366. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.5-1
  367. - new upstream release.
  368. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.9-1
  369. - new upstream release.
  370. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-5
  371. - fixed %%files.
  372. * Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-4
  373. - rebuilt with tix-8.4.3-5.
  374. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-3
  375. - rebuilt with tcl/tk-8.6.9.
  376. * Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 3.5.7-2
  377. - rebuild with readline-8.0 and ncurses-6.1
  378. * Sun May 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-1
  379. - new upstream release.
  380. - rebuilt with gdbm-1.18.1.
  381. - added R:libtirpc-devel to python3-devel.
  382. * Thu Feb 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-3
  383. - added BR:libxcrypt-devel.
  384. - added BR:libtirpc-devel.
  385. - added BR:libnsl2-devel.
  386. * Sat Jan 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-2
  387. - rebuilt with new toolchain.
  388. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-1
  389. - new upstream release.
  390. - really rebuilt with openssl-1.1.1.
  391. * Fri Nov 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
  392. - rebuild with openssl-1.1.1
  393. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
  394. - new upstream release
  395. - update Patch1 (python-3.5.2-lib64.patch)
  396. * Sun Mar 27 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-2
  397. - rebuild with openssl-1.0.2g
  398. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
  399. - new upstream release
  400. - add Patch2 (python3-3.4.4-revert-makefile.patch)
  401. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
  402. - new upstream release
  403. * Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.4.2-2
  404. - rebuilt with readline 6.3
  405. - changed BuildRequires: tcl-devel, tk-devel instead of tcl, tk respectively
  406. - changed BuildRequires: libdb-devel instead of db4-devel
  407. * Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  408. - new upstream release
  409. - update Patch1 (python-3.4.2-lib64.patch)
  410. * Sun Sep 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-3
  411. - remove configure option "--enable-profiling"
  412. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-2
  413. - rebuild with libffi-3.0.13
  414. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-1
  415. - new upstream release
  416. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.2-1
  417. - updated python to 3.3.2
  418. * Sun Jan 6 2013 IWAI, Masaharu <iwai@alib.jp> 3.3.0-2
  419. - build with Tcl/Tk 8.5.7-1
  420. * Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.0-1
  421. - updated python to 3.3.0
  422. - update Patch1 (python-3.3.0-lib64.patch)
  423. - add BuildRequires: valgrind-devel
  424. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 3.2-1
  425. - updated python to 3.2
  426. - updated python-*-docs-html to 3.2
  427. - dropt all patchs
  428. - added python-3.2b2-lib64.patch
  429. - referred to the review Python-3.2/Misc/RPM/python-3.2.spec
  430. * Fri Jan 14 2011 Shu KONNO <owa@bg.wakwak.com> 3.1.3-2
  431. - rebuilt with openssl-1.0.0c
  432. * Mon Nov 29 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.3-1
  433. - updated python to 3.1.3
  434. - added python-3.1.3-locale.patch
  435. - dropt python-3.1.2-lib64.patch
  436. - added python-3.1.3-lib64-*.patchs
  437. python-3.1.3-lib64-Makefile.patch
  438. python-3.1.3-lib64-setup.patch
  439. python-3.1.3-lib64-site.patch
  440. python-3.1.3-lib64-install.patch
  441. python-3.1.3-lib64-sysconfig.patch
  442. python-3.1.3-lib64-getpath.patch
  443. python-3.1.3-lib64-test_install.patch
  444. - added run_test macro to run unit test
  445. - added BR: libffi
  446. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
  447. - rebuilt with rpm-4.8.1 for pkg-config
  448. * Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-3
  449. - spec in utf-8
  450. * Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-2
  451. - added missings in BuildRequires, Requires
  452. * Fri Jun 18 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
  453. - initial build for VineSeed