shotwell-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293
  1. Summary: A photo manager for the GNOME desktop
  2. Summary(ja): GNOME デスクトップ向けの写真管理ツール
  3. Name: shotwell
  4. Version: 0.30.10
  5. Release: 1%{?_dist_release}
  6. Group: graphics,desktop-gnome
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Packager: kudoh
  10. # LGPLv2+ for the code
  11. # CC-BY-SA for some of the icons
  12. License: LGPLv2+ and CC-BY-SA
  13. URL: https://wiki.gnome.org/Apps/Shotwell
  14. %global shortver %(echo %{version} | cut -d . -f 1-2)
  15. Source0: https://download.gnome.org/sources/shotwell/%{shortver}/shotwell-%{version}.tar.xz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: meson
  18. BuildRequires: GConf2-devel
  19. BuildRequires: LibRaw-devel
  20. BuildRequires: LibRaw-static
  21. BuildRequires: dbus-glib-devel
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: gettext
  24. BuildRequires: itstool
  25. BuildRequires: gtk3-devel
  26. #BuildRequires: gstreamer-devel
  27. #BuildRequires: gstreamer-plugins-base-devel
  28. BuildRequires: gstreamer1-devel
  29. BuildRequires: gstreamer1-plugins-base-devel
  30. BuildRequires: json-glib-devel
  31. BuildRequires: libexif-devel
  32. BuildRequires: libgee-devel
  33. BuildRequires: libgee-vala
  34. BuildRequires: libgphoto2-devel
  35. BuildRequires: eudev-libgudev1-devel
  36. BuildRequires: libgdata-devel
  37. BuildRequires: libgexiv2-devel >= 0.2.0
  38. BuildRequires: libsoup-devel
  39. BuildRequires: libxml2-devel
  40. BuildRequires: lcms2-devel
  41. BuildRequires: sqlite3-devel
  42. BuildRequires: unique3-devel
  43. BuildRequires: vala-devel >= 0.9.5
  44. BuildRequires: rest-devel
  45. BuildRequires: gnome-doc-utils
  46. BuildRequires: webkitgtk4-devel
  47. # used by shotwell-settings-migrator
  48. Requires: dconf
  49. %description
  50. Shotwell is a new open source photo manager designed for the GNOME desktop
  51. environment. It allows you to import photos from your camera, view and edit
  52. them, and share them with others.
  53. %description -l ja
  54. Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
  55. 画像管理ツールです。
  56. あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
  57. 他の人々と共有するなどができます。
  58. %debug_package
  59. %prep
  60. %setup -q -n %{name}-%{version}
  61. %build
  62. %meson \
  63. -Dinstall-apport-hook=false
  64. %meson_build
  65. %install
  66. rm -rf %{buildroot}
  67. %meson_install
  68. %find_lang %{name} --all-name --with-gnome
  69. %check
  70. desktop-file-validate %{buildroot}%{_datadir}/applications/shotwell.desktop
  71. desktop-file-validate %{buildroot}%{_datadir}/applications/shotwell-viewer.desktop
  72. %clean
  73. rm -rf %{buildroot}
  74. %post
  75. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  76. update-desktop-database &> /dev/null || :
  77. %postun
  78. if [ $1 -eq 0 ] ; then
  79. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  80. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  81. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  82. fi
  83. update-desktop-database &> /dev/null || :
  84. %posttrans
  85. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  86. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  87. %files -f %{name}.lang
  88. %defattr(-,root,root,-)
  89. %license COPYING
  90. %doc README MAINTAINERS NEWS THANKS AUTHORS
  91. %{_bindir}/shotwell
  92. %{_libdir}/*
  93. %{_libexecdir}/shotwell
  94. %{_datadir}/applications/shotwell.desktop
  95. %{_datadir}/applications/shotwell-viewer.desktop
  96. %{_datadir}/metainfo/*.xml
  97. %{_datadir}/glib-2.0/schemas/*.xml
  98. %{_datadir}/icons/hicolor/*/apps/shotwell.png
  99. %{_datadir}/icons/hicolor/symbolic/apps/shotwell-symbolic.svg
  100. %{_mandir}/man1/*
  101. %changelog
  102. * Sun Sep 13 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.30.10-1
  103. - new upstream release.
  104. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.23.2-1
  105. - new upstream release.
  106. - remove %%_smp_mflags: Makefile has wrong dependency(?).
  107. * Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.22.0-2
  108. - rebuild with exiv2-0.25
  109. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.22.0-1
  110. - new upstream release
  111. * Mon Feb 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.20.2-2
  112. - rebuild with libgphoto2-2.5.7
  113. * Mon Nov 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.20.2-1
  114. - new upstream release
  115. * Thu Jul 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.18.1-1
  116. - new upstream release
  117. - change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
  118. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.18.0-1
  119. - new upstream release
  120. - add BuildRequires: gnome-doc-utils
  121. * Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-4
  122. - rebuild with LibRaw-0.16.0
  123. * Sun Jan 19 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.1-3
  124. - rebuilt with LibRaw-0.15.4
  125. * Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-2
  126. - rebuild with exiv2-0.24
  127. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-1
  128. - new upstream release
  129. - remove Patch1 (0001-Port-to-GStreamer-1.0.patch)
  130. - change BuildRequires: libgee-devel instead of libgee06-devel
  131. - add BuildRequires: libgee-vala
  132. * Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> - 0.13.1-2
  133. - build with libgphoto2 2.5.0-1
  134. * Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.1-1
  135. - new upstream release
  136. - changed archive typr to xz
  137. - changed BuildRequires: libgee-devel to libgee06-devel
  138. - changed BuildRequires: gstreamer-devel and gstreamer-plugins-base-devel to
  139. gstreamer1-devel and gstreamer1-plugins-base-devel
  140. - added Requires: dconf
  141. - added Patch0,1 from Fedora
  142. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.3-2
  143. - rebuild with exiv2-0.23
  144. * Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
  145. - new upstream release
  146. - dropt Source2
  147. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
  148. - new upstream release
  149. - remove Patch0
  150. - change BuildRequires: gtk3-devel instead of gtk2-devel
  151. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  152. - change BuildRequires: unique3-devel instead of unique-devel
  153. - remove BuildRequires: hal-devel
  154. - add BuildRequires: rest-devel, lcms2-devel
  155. * Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
  156. - new upstream release
  157. * Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
  158. - new upstream release
  159. * Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
  160. - new upstream release
  161. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
  162. - new upstream release
  163. - add Patch0 (shotwell-0.11.1-vala-0.14.patch)
  164. - add BuildRequires: gstreamer-plugins-base-devel
  165. * Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
  166. - rebuilt with libgexiv2-0.2.2-2
  167. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
  168. - new upstream release
  169. * Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
  170. - add ja.po (Source2): fix <BTS:VineLinux:1142>
  171. - update Summary and description
  172. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
  173. - add hi-res icons (SOURCE1)
  174. - add LANG=en_US.utf8 to get gettext to actually generate translated strings
  175. * Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
  176. - dropt Patch0
  177. - added BuildRequires: LibRaw-static
  178. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
  179. - add Patch1 (shotwell-0.8.1-vala.patch)
  180. * Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
  181. - new upstream release
  182. - added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
  183. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
  184. - rebuilt with rpm-4.8.1 for pkg-config
  185. - fixed %%changelog in Tue Sep 14 2010
  186. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
  187. - new upstream release
  188. - changed source URL
  189. - added Patch0 to work around desktop file incorrect comment
  190. - changed BuildRequires: vala-devel >= 0.9.5
  191. * Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
  192. - new upstream release
  193. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
  194. - new upstream release
  195. - changed BuildRequires: libgexiv2-devel >= 0.2.0
  196. * Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
  197. - fixed LIB_DIRS in libraw-config (for lib64)
  198. * Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
  199. - new upstream release
  200. - added BuildRequires: LibRaw-devel, libgexiv2-devel
  201. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
  202. - new upstream release
  203. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  204. - new upstream release
  205. - added BuildRequires: libgudev1-devel
  206. - applied new naming policy to spec
  207. * Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
  208. - new upstream release
  209. - proved Japanese description
  210. * Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
  211. - new upstrema release
  212. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
  213. - intial build for VineSeed
  214. * Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
  215. * Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  216. - Update to 0.3.2
  217. * Tue Nov 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
  218. - Version 0.3.0
  219. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
  220. - Rebuild against new libgee
  221. * Wed Aug 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
  222. - Bring icon cache handling in sync with current guidelines
  223. * Sun Aug 9 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
  224. - Initial packaging