sox-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247
  1. ##
  2. ## disable gsm for Vine Linux
  3. %define nogsm 1
  4. ## disable libmad
  5. %define nomad 1
  6. Summary: A general purpose sound file conversion tool.
  7. Summary(ja): 汎用サウンドファイル変換ツール
  8. Name: sox
  9. Version: 14.4.2
  10. Release: 1%{?_dist_release}
  11. License: LGPL
  12. Group: Applications/Multimedia
  13. Source: http://prdownloads.sourceforge.net/sox/sox-%{version}.tar.bz2
  14. URL: http://sox.sourceforge.net/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: alsa-lib-devel
  17. BuildRequires: pulseaudio-lib-devel
  18. BuildRequires: flac-devel
  19. BuildRequires: libvorbis-devel
  20. Build%{?nomad:Conflicts}%{!?nomad:Requires}: libmad-devel
  21. Build%{?nogsm:Conflicts}%{!?nogsm:Requires}: gsm-devel
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. SoX (Sound eXchange) is a sound file format converter for Linux, UNIX
  26. and DOS PCs. The 'Swiss Army knife of sound tools,' SoX can convert
  27. between many different digitized sound formats and perform simple
  28. sound manipulation functions, including sound effects.
  29. %description -l ja
  30. SoX (Sound eXchange) は Linux, UNIX, DOS PC 用サウンドファイルフォーマット
  31. 変換ツールです.SoX は「サウンドツール界のスイスアーミーナイフ」で,
  32. 様々なデジタルサウンドフォーマットを相互に変換したり,
  33. 簡単なサウンドエフェクト等の処理も行うことが出来ます.
  34. %package -n sox-devel
  35. Summary: The SoX sound file format converter libraries.
  36. Summary(ja): SoX サウンドファイル変換ライブラリ
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}
  39. %description -n sox-devel
  40. This package contains the library needed for compiling applications
  41. which will use the SoX sound file format converter.
  42. Install sox-devel if you want to develop applications which will use
  43. SoX.
  44. %description -n sox-devel -l ja
  45. このパッケージには SoX サウンドファイルフォーマット変換ツールを
  46. 利用するアプリケーションをコンパイルするのに必要なライブラリが
  47. 収められています.
  48. SoX を利用するプログラムを開発する場合は sox-devel パッケージを
  49. インストールして下さい.
  50. %prep
  51. %setup -q
  52. %build
  53. %configure \
  54. --disable-static \
  55. --includedir=%{_includedir}/sox \
  56. %{!?nogsm: --with-gsm}
  57. make
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  61. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  62. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
  63. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
  64. make install DESTDIR=$RPM_BUILD_ROOT
  65. echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
  66. echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
  67. echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
  68. chmod 755 $RPM_BUILD_ROOT%{_bindir}/soxplay
  69. strip $RPM_BUILD_ROOT%{_bindir}/sox
  70. ln -snf play $RPM_BUILD_ROOT%{_bindir}/rec
  71. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
  72. ln -snf play.1 $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
  73. ln -snf sox.1 $RPM_BUILD_ROOT%{_mandir}/man1/soxmix.1
  74. mkdir -p $RPM_BUILD_ROOT%{_includedir}/sox
  75. install -m 644 src/*.h $RPM_BUILD_ROOT%{_includedir}/sox
  76. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  77. %clean
  78. rm -rf $RPM_BUILD_ROOT
  79. %post
  80. /sbin/ldconfig
  81. %postun
  82. /sbin/ldconfig
  83. %files
  84. %defattr(-,root,root)
  85. %doc Changelog README TODO INSTALL
  86. %{_bindir}/*
  87. %{_libdir}/libsox.so.*
  88. %{_mandir}/man1/*
  89. %files -n sox-devel
  90. %defattr(-,root,root)
  91. %{_includedir}/*
  92. %{_libdir}/libsox.so
  93. %{_libdir}/pkgconfig/sox.pc
  94. %{_mandir}/man3/*
  95. %{_mandir}/man7/*
  96. %changelog
  97. * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.4.2-1
  98. - new upstream release.
  99. - added R:sox to sox-devel.
  100. - dropped Patch100: fixed in upstream.
  101. * Thu Jan 8 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 14.4.1-2
  102. - add patch100 for fix CVE-2014-8145
  103. - add BR: flac-devel, libvorbis-devel
  104. - add Vendor/Distri tags
  105. * Sun Aug 03 2014 Yoji TOYODA <owa@bg.wakwak.com> 14.4.1-1
  106. - update to 14.4.1
  107. * Sat Nov 05 2011 Yoji TOYODA <owa@bg.wakwak.com> 14.3.2-1
  108. - new upstream release
  109. - add BuildRequires: pulseaudio-lib-devel
  110. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 12.18.1-2
  111. - rebuilt with rpm-4.8.1-3
  112. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 12.18.1-1vl5
  113. - applied new versioning policy, spec in utf-8
  114. * Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 12.18.1-0vl3
  115. - fix installing play.1 man page (<BTS:510>)
  116. - add BuildRequires: alsa-lib-devel (alsa stuffs are now in main repo)
  117. * Mon Sep 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 12.18.1-0vl2
  118. - add "%%define nomad 1" to disable libmad dependency
  119. * Fri Aug 25 2006 NAKAMURA Kenta <kenta@vinelinux.org> 12.18.1-0vl1
  120. - new upstream release
  121. - dropped sox-vorberr.patch and sox-CAN-2004-0557.patch
  122. * Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl2
  123. - add patch for buffer overflow in wav code (CAN-2004-0557, #128158)
  124. - fixed %files section
  125. * Thu Jul 3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl1
  126. - based on 12.17.3-12 from Rawhide
  127. - rebuild with new toolchains
  128. - to use License tag instead of Copyright
  129. - fix License (from distributable to LGPL)
  130. * Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  131. - 12.17.1-1vl1
  132. - based on 12.17.1-1 from Rawhide
  133. - use better macros (%%{_bindir}, %%{_libdir}, %%{_includedir})
  134. - added Japanese summary and description
  135. - disable gsm stuff for Vine Linux
  136. * Tue Jan 2 2001 Bill Nottingham <notting@redhat.com>
  137. - re-enable gsm stuff
  138. - update to 12.17.1
  139. * Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
  140. - rebuild because of broken fileutils
  141. * Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
  142. - update to 12.17
  143. - yank out gsm stuff
  144. * Mon Aug 7 2000 Bill Nottingham <notting@redhat.com>
  145. - fix playing of sounds on cards that don't support mono
  146. * Sat Aug 5 2000 Bill Nottingham <notting@redhat.com>
  147. - fix playing of sounds on cards that don't support 8-bit
  148. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  149. - automatic rebuild
  150. * Thu Feb 03 2000 Bill Nottingham <notting@redhat.com>
  151. - fix manpage link the Right Way(tm)
  152. * Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  153. - Fix rec manpage link - now that man pages are compressed, it should point to
  154. play.1.gz, not play.1
  155. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  156. - fix description
  157. * Tue Sep 28 1999 Bill Nottingham <notting@redhat.com>
  158. - Grrr. Arrrrgh. Fix link.
  159. * Fri Sep 24 1999 Bill Nottingham <notting@redhat.com>
  160. - add some more files to devel
  161. * Fri Sep 17 1999 Bill Nottingham <notting@redhat.com>
  162. - fix link
  163. * Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
  164. - update to 12.16
  165. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  166. - auto rebuild in the new build environment (release 4)
  167. * Wed Jan 20 1999 Bill Nottingham <notting@redhat.com>
  168. - allow spaces in filenames for play/rec
  169. * Wed Dec 9 1998 Bill Nottingham <notting@redhat.com>
  170. - fix docs
  171. * Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
  172. - update to 12.15
  173. * Sat Oct 10 1998 Michael Maher <mike@redhat.com>
  174. - fixed broken spec file
  175. * Mon Jul 13 1998 Michael Maher <mike@redhat.com>
  176. - updated source from Chris Bagwell.
  177. * Tue Jun 23 1998 Michael Maher <mike@redhat.com>
  178. - made patch to fix the '-e' option. BUG 580
  179. - added buildroot
  180. * Fri May 08 1998 Prospector System <bugs@redhat.com>
  181. - translations modified for de, fr, tr
  182. * Thu Nov 06 1997 Erik Troan <ewt@redhat.com>
  183. - built against glibc