123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459 |
- %bcond_with systemd
- %define _unpackaged_files_terminate_build 1
- Summary: An object database, tag/metadata database, search tool and indexer
- Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
- Name: tracker
- Version: 2.3.4
- Release: 1%{?_dist_release}%{?with_systemd:.systemd}
- Group: Applications/System
- Vendor: Project Vine
- Distribution: Vine Linux
- License: GPL
- URL: https://gnome.pages.gitlab.gnome.org/tracker/
- %define major_minor %(echo %{version} | sed -e 's/\.[0-9]*$//')
- Source0: https://download.gnome.org/sources/tracker/%{major_minor}/tracker-%{version}.tar.xz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: meson
- BuildRequires: graphviz
- BuildRequires: gtk-doc
- BuildRequires: intltool
- BuildRequires: libappstream-glib
- BuildRequires: vala
- BuildRequires: pkgconfig(gobject-introspection-1.0)
- BuildRequires: pkgconfig(icu-i18n)
- BuildRequires: pkgconfig(icu-uc)
- BuildRequires: pkgconfig(json-glib-1.0)
- BuildRequires: pkgconfig(libnm)
- BuildRequires: pkgconfig(libsoup-2.4)
- BuildRequires: pkgconfig(libxml-2.0)
- BuildRequires: pkgconfig(sqlite3)
- BuildRequires: libuuid-devel
- %if %{with systemd}
- BuildRequires: systemd
- %endif
- %if %{with systemd}
- %global systemd_units tracker-store.service
- %{?systemd_requires}
- %endif
- Obsoletes: %{name}-libs < 2.0.0
- Obsoletes: %{name}-search-tool < 2.0.0
- Provides: %{name}-libs = %{version}-%{release}
- Provides: %{name}-search-tool = %{version}-%{release}
- %description
- Tracker is a powerful desktop-neutral first class object database,
- tag/metadata database, search tool and indexer.
- It consists of a common object database that allows entities to have an
- almost infinte number of properties, metadata (both embedded/harvested as
- well as user definable), a comprehensive database of keywords/tags and
- links to other entities.
- It provides additional features for file based objects including context
- linking and audit trails for a file object.
- It has the ability to index, store, harvest metadata. retrieve and search
- all types of files and other first class objects
- %package devel
- Summary: Headers for developing programs that will use %{name}
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- This package contains the static libraries and header files needed for
- developing with tracker
- %package docs
- Summary: Documentation for tracker
- Group: Documentation
- Obsoletes: %{name}-doc < 0.15.0
- Provides: %{name}-doc = 0.15.0
- BuildArch: noarch
- %description docs
- This package contains documentation for tracker.
- %prep
- %setup -q
- %build
- %meson \
- -Dstemmer=disabled \
- %if %{with systemd}
- -Dsystemd_user_services=%{_userunitdir} \
- %endif
- -Ddocs=true
- %meson_build
- %install
- rm -rf %{buildroot}
- export LANG=ja_JP.UTF-8
- %meson_install
- rm -rf %{buildroot}%{_datadir}/tracker-tests
- %find_lang %{name}
- %if !%{with systemd}
- rm -rf %{buildroot}/usr/lib/systemd
- %endif
- %clean
- rm -rf %{buildroot}
- %post
- /sbin/ldconfig
- touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
- %if %{with systemd}
- %systemd_user_post %{systemd_units}
- %endif
- %posttrans
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
- glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
- %if %{with systemd}
- %preun
- %systemd_user_preun %{systemd_units}
- %endif
-
- %postun
- /sbin/ldconfig
- if [ $1 -eq 0 ] ; then
- touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
- glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
- fi
- %if %{with systemd}
- %systemd_user_postun_with_restart %{systemd_units}
- %endif
- %files -f %{name}.lang
- %defattr(-, root, root, -)
- %license COPYING
- %doc AUTHORS NEWS README.md
- %{_bindir}/tracker
- %{_libexecdir}/tracker-store
- %{_datadir}/tracker/
- %{_datadir}/dbus-1/services/org.freedesktop.Tracker1.service
- %{_libdir}/libtracker*-2.0.so.*
- %{_libdir}/tracker-2.0/
- %dir %{_libdir}/girepository-1.0
- %{_libdir}/girepository-1.0/Tracker-2.0.typelib
- %{_libdir}/girepository-1.0/TrackerControl-2.0.typelib
- %{_libdir}/girepository-1.0/TrackerMiner-2.0.typelib
- %{_mandir}/*/tracker*.gz
- %config(noreplace) %{_sysconfdir}/xdg/autostart/tracker-store.desktop
- %dir %{_datadir}/bash-completion
- %dir %{_datadir}/bash-completion/completions
- %{_datadir}/bash-completion/completions/tracker
- %{_datadir}/glib-2.0/schemas/*
- %if %{with systemd}
- %{_userunitdir}/tracker-store.service
- %endif
- %files devel
- %defattr(-, root, root, -)
- %{_includedir}/tracker-2.0/
- %{_libdir}/*.so
- %{_libdir}/pkgconfig/*.pc
- %dir %{_datadir}/vala
- %dir %{_datadir}/vala/vapi
- %{_datadir}/vala/vapi/*
- %dir %{_datadir}/gir-1.0
- %{_datadir}/gir-1.0/*
- %files docs
- %defattr(-, root, root, -)
- %{_datadir}/gtk-doc/html/libtracker-control
- %{_datadir}/gtk-doc/html/libtracker-miner
- %{_datadir}/gtk-doc/html/libtracker-sparql
- %{_datadir}/gtk-doc/html/ontology/
- %changelog
- * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
- - new upstream release.
- - built with icu-67.
- * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-3
- - rebuilt with icu-66.
- * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-2
- - rebuilt with icu-65.
- * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-1
- - new upstream release.
- - dropped Patch0.
- * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
- - new upstream release.
- - dropped all patches.
- - added Patch0.
- - dropped subpackages "libs" and "search-tool".
- * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.4-1
- - new upstream release.
- * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
- - new upstream release
- * Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
- - new upstream release
- * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
- - new upstream release
- * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
- - new upstream release
- * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-2
- - remove *.la files
- * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
- - new upstream release
- - add BuildRequires: libmediaart-devel, libvorbis-devel, flac-devel
- * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.5-1
- - new upstream release
- * Sun Nov 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
- - new upstream release
- - add Patch1 (tracker-1.2.3-revert-error_message.patch)
- * Sun Sep 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
- - rebuild with upower-0.99.1
- * Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
- - new upstream release
- * Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
- - new upstream release
- * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-3
- - rebuild with poppler-0.26.2
- * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
- - rebuild with libarchive-3.1.2
- * Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
- - new upstream release
- * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
- - rebuild with poppler-0.24.5
- * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
- - new upstream release
- * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.4-2
- - rebuild with VineSeed environment
- * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.4-1
- - new upstream release
- * Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.3-1
- - new upstream release
- * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.2-2
- - rebuild with icu-51.2
- * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.2-1
- - new upstream release
- * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
- - new upstream release
- * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
- - new upstream release
- - remove BuildRequires: gnome-panel-devel, gnome-applets
- - change BuildRequires: gstreamer1-devel instead of gstreamer-devel
- - add BuildRequires: libjpeg-turbo-devel, giflib-devel, libtiff-devel, exempi-devel, enca-devel, taglib-devel, libgxps-devel
- - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
- - change to %%{name}-docs subpackage from %%{name}-docs
- * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.5-1
- - new upstream release
- * Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.4-1
- - new upstream release
- * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.3-1
- - new upstream release
- * Sat Sep 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-2
- - create -libs subpackage
- - add BuildRequires: firefox, thunderbird
- * Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
- - new upstream release
- * Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
- - new upstream release
- * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
- - new upstream release
- * Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.9-1
- - new upstream release
- * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
- - new upstream release
- * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.4-1
- - new upstream release
- - create %%{name}-doc sub package
- * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-1
- - new upstream release
- - add Patch0 (tracker-0.12.3-sched.patch)
- * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
- - new upstream release
- - add BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel, NetworkManager-glib-devel
- - drop Patch0
- * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.25-1
- - new upstream release
- * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-1
- - new upstream release
- * Wed Jul 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.22-1
- - new upstream release
- - add BuildRequires: libicu-devel
- * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.18-1
- - new upstream release
- - add Patch0 (tracker-0.8.18-tracker_spawn.patch)
- - delete Patch1
- * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
- - rebuilt with poppler-0.16.3
- * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
- - rebuild with poppler-0.14.2
- * Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
- - new upstream release
- - add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
- - add configure option (--enable-tracker-search-bar)
- * Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
- - new upstream release
- * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
- - new upstream release
- - fix URL of Source0
- * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
- - new upstream release
- * Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
- - new upstream release
- * Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
- - new upstream release
- - fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
- * Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
- - new upstream release
- * Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
- - new upstream release
- - add BuildRequires: upower-devel, gnome-applets
- - change BuildRequires: dbus-glib -> dbus-glib-devel
- * Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
- - new upstream release
- - add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
- - fix BuildRequires: gmime-devel >= 2.4
- - add configure option (--enable-tracker-search-tool)
- * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
- - new upstream release
- * Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
- - rebuild with poppler-0.10.2
- - spec in UTF-8
- * Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
- - new upstream release
- - update Patch1
- - drop Patch10 (no more necessary)
- - add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
- - remove --enable-external-sqlite option (no more bundled sqlite exist)
- - apply new versioning policy
- * Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
- - new upstream release
- * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
- - add Patch10 to fix selecting video-extractor
- - use external video extractor(totem) instead of gstreamer/xine
- * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
- - initial build for Vine Linux
- * Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
- - Ship both autostart desktop files in the main package (BZ #233323)
- * Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
- - Package the deskbar plugin properly (BZ #228308)
- * Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
- - Split out tracker-search-tool sub-packages, for the GUI facility
- - Add proper requires for the -devel subpackage
- - Deal with the rpmlint complaints on rpath
- * Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
- - Update to 0.5.4
- * Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
- - Update to 0.5.3
- * Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
- - Apply patch on Makefile.am instead of Makefile.in
- - Add libtool to BR
- * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
- - Update to 0.5.2
- * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
- - Update to new version
- * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
- - Have the devel subpackage require pkgconfig
- - Make the description field not have more than 76 characters on a line
- - Fix up the RPM group
- * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
- - Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
- * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
- - Remove unneeded BRs (gnome-utils-devel and openssl-devel)
- * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
- - Add autostart desktop file.
- - Edit the package description as suggested in review
- * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
- - More cleaups to the spec file.
- * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
- - Add needed BRs
- * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
- - Initial packaging for Fedora Extras
|