chkconfig-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376
  1. Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
  2. Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
  3. Name: chkconfig
  4. Version: 1.3.61
  5. Release: 4%{?_dist_release}
  6. Group: system,admin-tools
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPL
  10. Source: %{name}-%{version}.tar.bz2
  11. Source2: chkconfig.8
  12. Source3: ntsysv.8
  13. Source4: update-alternatives.ja.8
  14. Patch1: chkconfig-1.3.51-vine.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: newt-devel
  17. BuildRequires: popt-devel
  18. Conflicts: initscripts <= 5.30-1
  19. %description
  20. Chkconfig is a basic system utility. It updates and queries runlevel
  21. information for system services. Chkconfig manipulates the numerous
  22. symbolic links in /etc/rc.d, to relieve system administrators of some
  23. of the drudgery of manually editing the symbolic links.
  24. %description -l ja
  25. chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
  26. runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
  27. 多数のシンボリックリンクを操作しますので、システム管理者は手動で
  28. シンボリックリンクをたびたびエディットしなくてもよい。
  29. %package -n ntsysv
  30. Summary: A tool to set the stop/start of system services in a runlevel.
  31. Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
  32. Group: system,admin-tools
  33. %description -n ntsysv
  34. Ntsysv provides a simple interface for setting which system services
  35. are started or stopped in various runlevels (instead of directly
  36. manipulating the numerous symbolic links in /etc/rc.d). Unless you
  37. specify a runlevel or runlevels on the command line (see the man
  38. page), ntsysv configures the current runlevel (5 if you're using X).
  39. %description -n ntsysv -l ja
  40. ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
  41. ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
  42. 操作することから解放する。
  43. %package -n alternatives
  44. Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
  45. Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  46. Group: system,admin-tools
  47. %description -n alternatives
  48. maintain symbolic links determining default commands (from Debian dpkg utilities)
  49. %description -n alternatives -l ja
  50. コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  51. %debug_package
  52. %prep
  53. %setup -q
  54. #%patch1 -p1
  55. %build
  56. %__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. %__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
  60. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  61. ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
  62. for n in 0 1 2 3 4 5 6; do
  63. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
  64. ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
  65. done
  66. mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
  67. cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
  68. # alternatives
  69. mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
  70. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
  71. mkdir -p $RPM_BUILD_ROOT/var/lib/alternatives
  72. install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
  73. ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
  74. # create compat symlinks
  75. mkdir -p $RPM_BUILD_ROOT/%{_sbindir}
  76. for i in alternatives update-alternatives chkconfig
  77. do
  78. ln -sf /sbin/$i $RPM_BUILD_ROOT/%{_sbindir}/$i
  79. done
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %post -n alternatives
  83. if [ "$1" -gt "1" ]; then
  84. if [ -d /var/lib/rpm/alternatives -a $(ls /var/lib/rpm/alternatives | wc --lines) -gt 0 ]; then
  85. mv -f /var/lib/rpm/alternatives/* /var/lib/alternatives/
  86. fi
  87. fi
  88. %files
  89. %defattr(-,root,root)
  90. /sbin/chkconfig
  91. %{_sbindir}/chkconfig
  92. /etc/init.d
  93. /etc/rc.d/init.d
  94. /etc/rc[0-6].d
  95. /etc/rc.d/rc[0-6].d
  96. %{_mandir}/*/chkconfig*
  97. %{_mandir}/ja/*/chkconfig*
  98. %{_localedir}/*/LC_MESSAGES/chkconfig.mo
  99. %files -n ntsysv
  100. %defattr(-,root,root)
  101. %{_sbindir}/ntsysv
  102. %{_mandir}/*/ntsysv.8*
  103. %{_mandir}/ja/*/ntsysv.8*
  104. %files -n alternatives
  105. %defattr (-, root, root)
  106. /sbin/alternatives
  107. /sbin/update-alternatives
  108. %{_sbindir}/alternatives
  109. %{_sbindir}/update-alternatives
  110. %{_sysconfdir}/alternatives
  111. %{_mandir}/man8/*
  112. %{_mandir}/ja/man8/*
  113. /var/lib/alternatives
  114. %changelog
  115. * Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.61-4
  116. - moved /var/lib/rpm/alternatives to /var/lib/alternatives.
  117. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.61-3
  118. - rebuilt with current environment.
  119. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.61-2
  120. - rebuild with VineSeed environment
  121. * Wed Nov 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.61-1
  122. - update to 1.3.61
  123. - create compat symlinks in %%{_sbindir}
  124. * Thu Jun 06 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.60-1
  125. - update to 1.3.60
  126. * Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.51-2
  127. - change BuildRequires: popt-devel intead of popt
  128. * Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
  129. - new upstream release
  130. - enable fedora version of alternatives
  131. - add alternatives subpackage, replace debian's alternatives
  132. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
  133. - new upstream release
  134. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
  135. - applied new versioning policy and spec in utf-8
  136. * Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
  137. - dropped obsoleted Makefile.x86_64.patch
  138. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
  139. - new upstream release
  140. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
  141. - add Makefile.x86_64.patch
  142. * Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
  143. - add Patch10 to skip xinetd parsing if not exist.
  144. * Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
  145. - rebuild
  146. * Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
  147. - Requires -> Conflicts.
  148. apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
  149. Conflicts/Pre-Depends-loop does not happen.
  150. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
  151. - Oops not PreReq but Requires. Fixed.
  152. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
  153. - change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
  154. to avoid Conflicts/Pre-Depends loop on apt
  155. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  156. - 1.2.17-1vl3
  157. - change checkbox color
  158. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  159. - 1.2.17-1vl2
  160. - rebuilt for VineSeed
  161. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
  162. - 1.2.17-1vl1
  163. * Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
  164. - ignore .rpmnew files (#18915)
  165. - fix typo in error message (#17575)
  166. * Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  167. - make xinetd config files mode 0644, not 644
  168. * Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
  169. - updated it and es translations
  170. * Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
  171. - get man pages in proper packages
  172. * Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
  173. - new translations
  174. * Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  175. - don't worry about extra whitespace on chkconfig: lines (#16150)
  176. * Thu Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  177. - i18n merge
  178. * Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
  179. - new translations for de fr it es
  180. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  181. - change prereqs
  182. * Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
  183. - fix ntsysv's handling of xinetd/init files with the same name
  184. * Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
  185. - fix segv when reading malformed files
  186. * Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
  187. - put links, rc[0-6].d dirs back, those are necessary
  188. * Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
  189. - add quick hack support for reading descriptions from xinetd files
  190. * Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  191. - don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
  192. * Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
  193. - move back to old file layout
  194. * Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
  195. - bump copyright date
  196. * Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
  197. - no %pre today. Maybe tomorrow.
  198. * Thu Jul 6 2000 Bill Nottingham <notting@redhat.com>
  199. - put initscripts %pre here too
  200. * Mon Jul 3 2000 Bill Nottingham <notting@redhat.com>
  201. - oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
  202. * Sun Jul 2 2000 Bill Nottingham <notting@redhat.com>
  203. - add xinetd support
  204. * Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
  205. - changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
  206. - fixed sumary and description where a global string replace nuked them
  207. * Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
  208. - what Bill said, but actually build this version
  209. * Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
  210. - don't own /etc/rc.*
  211. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  212. - typo in man page
  213. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  214. - fix description
  215. * Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
  216. - link chkconfig statically against popt
  217. * Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
  218. - fix querying alternate levels
  219. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  220. - don't use strchr to skip unwanted files, look at extension instead (#4166).
  221. * Thu Aug 5 1999 Bill Nottingham <notting@redhat.com>
  222. - fix --help, --verson
  223. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  224. - rebuilt ntsysv against newt 0.50
  225. * Mon Aug 2 1999 Jeff Johnson <jbj@redhat.com>
  226. - fix i18n problem in usage message (#4233).
  227. - add --help and --version.
  228. * Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
  229. - release for Red Hat 6.0
  230. * Thu Apr 8 1999 Matt Wilson <msw@redhat.com>
  231. - added support for a "hide: true" tag in initscripts that will make
  232. services not appear in ntsysv when run with the "--hide" flag
  233. * Thu Apr 1 1999 Matt Wilson <msw@redhat.com>
  234. - added --hide flag for ntsysv that allows you to hide a service from the
  235. user.
  236. * Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
  237. - fix glob, once and for all. Really. We mean it.
  238. * Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
  239. - revert fix for services@levels, it's broken
  240. - change default to only edit the current runlevel
  241. * Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
  242. - don't remove scripts that don't support chkconfig
  243. * Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
  244. - made glob a bit more specific so xinetd and inetd don't cause improper matches
  245. * Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
  246. - removed debugging output when starting ntsysv
  247. * Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
  248. - fixed globbing error
  249. - fixed ntsysv running services not at their specified levels.
  250. * Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
  251. - print the value of errno on glob failures.
  252. * Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
  253. - rebuilt for newt 0.40 (ntsysv)
  254. * Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
  255. - add ru.po.
  256. * Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
  257. - build for Raw Hide (slang-1.2.2)
  258. * Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
  259. - translation updates
  260. * Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
  261. - updated czech translation (and use cs instead of cz)
  262. * Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
  263. - added pt_BR translations
  264. - added more translatable strings
  265. - support for i18n init.d scripts description
  266. * Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
  267. - built against newt 0.30
  268. - split ntsysv into a separate package
  269. * Thu May 07 1998 Erik Troan <ewt@redhat.com>
  270. - added numerous translations
  271. * Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
  272. - added i18n support
  273. * Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
  274. - added --back