python-progressbar2-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. %bcond_with tests
  2. %global srcname progressbar2
  3. %global desc %{expand: \
  4. A text progress bar is typically used to display the progress of a long running
  5. operation, providing a visual cue that processing is underway.
  6. The ProgressBar class manages the current progress, and the format of the line
  7. is given by a number of widgets.
  8. The progressbar module is very easy to use, yet very powerful. It will also
  9. automatically enable features like auto-resizing when the system supports it.}
  10. Name: python-%{srcname}
  11. Version: 3.53.1
  12. Release: 1%{?dist}
  13. Summary: A Progressbar library to provide visual progress to long running operations
  14. Group: programming
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. License: BSD
  18. URL: https://pypi.python.org/pypi/%{srcname}
  19. Source0: %pypi_source
  20. BuildArch: noarch
  21. BuildRequires: python3-devel
  22. %description
  23. %{desc}
  24. %package -n python3-%{srcname}
  25. Summary: %{summary}
  26. Group: programming
  27. Requires: python3
  28. Requires: python3-six
  29. BuildRequires: python3-utils
  30. BuildRequires: python3-six
  31. BuildRequires: python3-setuptools
  32. BuildRequires: python3-sphinx
  33. %if %{with tests}
  34. BuildRequires: %{py3_dist freezegun} >= 0.3.10
  35. %endif
  36. # obsolete python-progressbar
  37. Obsoletes: python3-progressbar < 2.3-14
  38. Provides: python3-progressbar == %{version}
  39. %{?python_provide:%python_provide python3-%{srcname}}
  40. %description -n python3-%{srcname}
  41. %{desc}
  42. %prep
  43. %autosetup -n %{srcname}-%{version}
  44. rm -rfv %{srcname}.egg-info
  45. find . -name '*.pyc' -print -delete
  46. find . -name '*.swp' -print -delete
  47. rm -rfv tests/__pycache__/
  48. %build
  49. %py3_build
  50. %install
  51. %py3_install
  52. %check
  53. %if %{with tests}
  54. PYTHONPATH=. %pytest tests
  55. %endif
  56. %files -n python3-%{srcname}
  57. %license LICENSE
  58. %doc README.rst CHANGES.rst CONTRIBUTING.rst
  59. %{python3_sitelib}/%{srcname}-%{version}-py3.*.egg-info/
  60. %{python3_sitelib}/progressbar
  61. %changelog
  62. * Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.53.1-1
  63. - initial build for Vine Linux.
  64. - new upstream release.
  65. * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.52.1-2
  66. - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
  67. * Tue Sep 01 2020 Petr Viktorin <pviktori@redhat.com> - 3.52.1-1
  68. - Update to 3.52.1
  69. Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1873701
  70. The only behavior change is that ProgressBar gets a `start_time`
  71. keyword argument, which can override the starting time (e.g. for
  72. ETA calculations).
  73. * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.51.4-2
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  75. * Sat Jun 27 2020 Petr Viktorin <pviktori@redhat.com> - 3.51.4-1
  76. - Update to 3.51.4
  77. - Run pytest directly
  78. * Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 3.47.0-2
  79. - Rebuilt for Python 3.9
  80. * Wed Feb 12 2020 Petr Viktorin <pviktori@redhat.com> - 3.47.0-1
  81. - Update to latest upstream version
  82. https://github.com/WoLpH/python-progressbar/compare/v3.39.3...vv3.47.0
  83. Highlights:
  84. - Rate limiting
  85. - Added proper support for non-terminal output
  86. - Add MultiProgressBar
  87. * Wed Feb 12 2020 Petr Viktorin <pviktori@redhat.com> - 3.39.3-7
  88. - Remove linting BuildRequires
  89. https://bugzilla.redhat.com/show_bug.cgi?id=1795451
  90. - Fix egg-info glob to work for Python 3.10+
  91. * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.39.3-6
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  93. * Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 3.39.3-5
  94. - Rebuilt for Python 3.8.0rc1 (#1748018)
  95. * Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 3.39.3-4
  96. - Rebuilt for Python 3.8
  97. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.39.3-3
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  99. * Sun May 12 2019 Orion Poplawski <orion@nwra.com> - 3.39.3-2
  100. - Drop unneeded BR on pytest-cache
  101. * Wed Apr 10 2019 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 3.39.3-1
  102. - Update to 3.39.3
  103. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.39.2-3
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  105. * Wed Dec 19 2018 Petr Viktorin <pviktori@redhat.com> - 3.39.2-2
  106. - Provide python3-progressbar
  107. * Wed Dec 19 2018 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 3.39.2-1
  108. - Update to latest upstream commit
  109. - Should fix failing tests
  110. * Thu Dec 13 2018 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 3.38.0-1
  111. - Check tests and file issue upstream
  112. - Initial build
  113. - Drop py2 subpackage
  114. - Obsolete python-progressbar