python-rpm-macros-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209
  1. Name: python-rpm-macros
  2. Summary: The unversioned Python RPM macros
  3. Version: 3.8
  4. Release: 2%{?_dist_release}
  5. Group: programming
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. Packager: tomop
  9. License: MIT
  10. Source0: macros.python
  11. Source1: macros.python-srpm
  12. Source2: macros.python2
  13. Source3: macros.python3
  14. Source4: macros.platform-python
  15. Source100: python.attr
  16. Source101: pythondist.attr
  17. Source102: pythondistdeps.py
  18. # for apt (rich operators of dependencies are not supported)
  19. Patch1000: pythondistdeps.py-downgrade.patch
  20. BuildArch: noarch
  21. # For %%python3_pkgversion used in %%python_provide
  22. Requires: python-srpm-macros
  23. Requires: python3-packaging
  24. Obsoletes: python-macros < 3
  25. Provides: python-macros = %{version}-%{release}
  26. %description
  27. This package contains the unversioned Python RPM macros, that most
  28. implementations should rely on.
  29. You should not need to install this package manually as the various
  30. python?-devel packages require it. So install a python-devel package instead.
  31. %package -n python-srpm-macros
  32. Summary: RPM macros for building Python source packages
  33. %description -n python-srpm-macros
  34. RPM macros for building Python source packages.
  35. %package -n python2-rpm-macros
  36. Summary: RPM macros for building Python 2 packages
  37. # Would need to be different for each release - worth it?
  38. #Conflicts: python2-devel < 2.7.11-3
  39. Requires: python-rpm-macros
  40. Requires: python-srpm-macros
  41. %description -n python2-rpm-macros
  42. RPM macros for building Python 2 packages.
  43. %package -n python3-rpm-macros
  44. Summary: RPM macros for building Python 3 packages
  45. # Would need to be different for each release - worth it?
  46. #Conflicts: python3-devel < 3.5.1-3
  47. Requires: python-rpm-macros
  48. Requires: python-srpm-macros
  49. %description -n python3-rpm-macros
  50. RPM macros for building Python 3 packages.
  51. #%package -n platform-python-rpm-macros
  52. #Summary: RPM macros for building Platform-Python packages
  53. #%description -n platform-python-rpm-macros
  54. #RPM macros for building Platform-Python packages.
  55. %prep
  56. %setup -T -c
  57. cp -f %{SOURCE102} ./
  58. %patch1000 -p0
  59. %build
  60. %install
  61. mkdir -p %{buildroot}%{_rpmmacrodir}
  62. install -m 644 %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
  63. %{buildroot}%{_rpmmacrodir}/
  64. mkdir -p %{buildroot}%{_fileattrsdir}
  65. install -m 644 %{SOURCE100} %{SOURCE101} \
  66. %{buildroot}%{_fileattrsdir}/
  67. mkdir -p %{buildroot}%{_rpmconfigdir}
  68. install -m 755 pythondistdeps.py \
  69. %{buildroot}%{_rpmconfigdir}/
  70. sed -i -e 's|#!/usr/bin/python|#!/usr/bin/python3|' \
  71. %{buildroot}%{_rpmconfigdir}/pythondistdeps.py
  72. %files
  73. %{_rpmmacrodir}/macros.python
  74. %{_rpmconfigdir}/pythondistdeps.py
  75. %{_fileattrsdir}/*
  76. %files -n python-srpm-macros
  77. %{_rpmmacrodir}/macros.python-srpm
  78. %files -n python2-rpm-macros
  79. %{_rpmmacrodir}/macros.python2
  80. %files -n python3-rpm-macros
  81. %{_rpmmacrodir}/macros.python3
  82. #%files -n platform-python-rpm-macros
  83. #%{rpmmacrodir}/macros.platform-python
  84. %exclude %{_rpmmacrodir}/macros.platform-python
  85. %changelog
  86. * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.8-2
  87. - added scripts.
  88. * Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.8-1
  89. - updated to 3.8.
  90. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-26
  91. - updated macros.
  92. * Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-25
  93. - fixed a typo.
  94. * Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-24
  95. - fixed a path to install.
  96. * Tue Sep 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-23
  97. - initial build for Vine Linux.
  98. * Wed Aug 02 2017 Tomas Orsava <torsava@redhat.com> - 3-22
  99. - Add platform-python macros (https://fedoraproject.org/wiki/Changes/Platform_Python_Stack)
  100. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-21
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  102. * Fri Mar 03 2017 Michal Cyprian <mcyprian@redhat.com> - 3-20
  103. - Revert "Switch %%__python3 to /usr/libexec/system-python"
  104. after the Fedora Change https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
  105. was postponed
  106. * Fri Feb 17 2017 Michal Cyprian <mcyprian@redhat.com> - 3-19
  107. - Switch %%__python3 to /usr/libexec/system-python
  108. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-18
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  110. * Mon Jan 23 2017 Michal Cyprian <mcyprian@redhat.com> - 3-17
  111. - Add --no-deps option to py_install_wheel macros
  112. * Tue Jan 17 2017 Tomas Orsava <torsava@redhat.com> - 3-16
  113. - Added macros for Build/Requires tags using Python dist tags:
  114. https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  115. * Thu Nov 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-15
  116. - Make expanded macros start on the same line as the macro
  117. * Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-14
  118. - Fix %%py3_install_wheel (bug #1395953)
  119. * Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-13
  120. - Add missing sleeps to other build macros
  121. - Fix build_egg macros
  122. - Add %%py_build_wheel and %%py_install_wheel macros
  123. * Tue Nov 15 2016 Orion Poplawski <orion@cora.nwra.com> 3-12
  124. - Add %%py_build_egg and %%py_install_egg macros
  125. - Allow multiple args to %%py_build/install macros
  126. - Tidy up macro formatting
  127. * Wed Aug 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-11
  128. - Use %%rpmmacrodir
  129. * Tue Jul 12 2016 Orion Poplawski <orion@cora.nwra.com> 3-10
  130. - Do not generate useless Obsoletes with %%{?_isa}
  131. * Fri May 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-9
  132. - Make python-rpm-macros require python-srpm-macros (bug #1335860)
  133. * Thu May 12 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-8
  134. - Add single-second sleeps to work around setuptools bug.
  135. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3-7
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  137. * Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-6
  138. - Fix typo in %%python_provide
  139. * Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-5
  140. - Handle noarch python sub-packages (bug #1290900)
  141. * Wed Jan 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-4
  142. - Fix python2/3-rpm-macros package names
  143. * Thu Jan 7 2016 Orion Poplawski <orion@cora.nwra.com> 3-3
  144. - Add empty %%prep and %%build
  145. * Mon Jan 4 2016 Orion Poplawski <orion@cora.nwra.com> 3-2
  146. - Combined package
  147. * Wed Dec 30 2015 Orion Poplawski <orion@cora.nwra.com> 3-1
  148. - Initial package