rpmdevtools-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589
  1. %global spectool_version 1.1.0
  2. %global _emacs_sitestartdir /usr/share/emacs/site-lisp
  3. Name: rpmdevtools
  4. Summary: RPM Development Tools
  5. Version: 9.3
  6. Release: 1%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. # rpmdev-setuptree is GPLv2, everything else GPLv2+
  11. License: GPLv2+ and GPLv2
  12. URL: https://pagure.io/rpmdevtools
  13. Source0: https://releases.pagure.org/rpmdevtools/%{name}-%{version}.tar.xz
  14. # Use Accept-Encoding: identity together with decode_content=False
  15. # This is to avoid text files downloaded gzipped
  16. Patch1: https://pagure.io/rpmdevtools/pull-request/77.patch
  17. # Fedora-specific downstream patches
  18. ## Force legacy datestamp by default until rhbz#1715412 is resolved
  19. Patch1001: 0001-Force-legacy-datestamp-while-RHBZ-1715412-is-still-a.patch
  20. # Vine patch(es)
  21. Patch2000: rpmdevtools-vine.patch
  22. BuildArch: noarch
  23. # help2man, pod2man, *python for creating man pages
  24. BuildRequires: help2man
  25. BuildRequires: %{_bindir}/pod2man
  26. BuildRequires: perl
  27. BuildRequires: python3
  28. BuildRequires: python3-rpm
  29. BuildRequires: python3-requests
  30. BuildRequires: python3-progressbar2
  31. # emacs-common >= 1:22.3-3 for macros.emacs
  32. BuildRequires: emacsen-common
  33. BuildRequires: bash-completion
  34. Provides: spectool = %{spectool_version}
  35. Requires: curl
  36. Requires: diffutils
  37. Requires: fakeroot
  38. Requires: file
  39. Requires: findutils
  40. Requires: gawk
  41. Requires: grep
  42. Requires: rpm-build >= 4.16.0.0
  43. Requires: python3-rpm
  44. Requires: python3-requests
  45. Requires: python3-progressbar2
  46. Requires: sed
  47. %description
  48. This package contains scripts and (X)Emacs support files to aid in
  49. development of RPM packages.
  50. rpmdev-setuptree Create RPM build tree within user's home directory
  51. rpmdev-diff Diff contents of two archives
  52. rpmdev-newspec Creates new .spec from template
  53. rpmdev-rmdevelrpms Find (and optionally remove) "development" RPMs
  54. rpmdev-checksig Check package signatures using alternate RPM keyring
  55. rpminfo Print information about executables and libraries
  56. rpmdev-md5/sha* Display checksums of all files in an archive file
  57. rpmdev-vercmp RPM version comparison checker
  58. spectool Expand and download sources and patches in specfiles
  59. rpmdev-wipetree Erase all files within dirs created by rpmdev-setuptree
  60. rpmdev-extract Extract various archives, "tar xvf" style
  61. rpmdev-bumpspec Bump revision in specfile
  62. ...and many more.
  63. %prep
  64. %autosetup -p1
  65. grep -lF "%{_bindir}/python " * \
  66. | xargs sed -i -e "s|%{_bindir}/python |%{_bindir}/python3 |"
  67. %build
  68. %configure --libdir=%{_prefix}/lib
  69. %make_build
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. %make_install
  73. echo %%{_datadir}/bash-completion > %{name}.files
  74. [ -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d ] && \
  75. echo %%{_sysconfdir}/bash_completion.d > %{name}.files
  76. %if 0%{?fedora}
  77. for dir in %{_emacs_sitestartdir} %{_xemacs_sitestartdir} ; do
  78. %else
  79. for dir in %{_emacs_sitestartdir} ; do
  80. %endif
  81. install -dm 755 $RPM_BUILD_ROOT$dir
  82. ln -s %{_datadir}/rpmdevtools/rpmdev-init.el $RPM_BUILD_ROOT$dir
  83. touch $RPM_BUILD_ROOT$dir/rpmdev-init.elc
  84. done
  85. # For backwards compatibility
  86. ln -sr %{buildroot}%{_bindir}/rpmdev-spectool %{buildroot}%{_bindir}/spectool
  87. echo ".so man1/rpmdev-spectool.1" > %{buildroot}%{_mandir}/man1/spectool.1
  88. %files -f %{name}.files
  89. %license COPYING
  90. %doc NEWS
  91. %config(noreplace) %{_sysconfdir}/rpmdevtools/
  92. %{_datadir}/rpmdevtools/
  93. %{_bindir}/*
  94. %{_emacs_sitestartdir}/rpmdev-init.el
  95. %ghost %{_emacs_sitestartdir}/rpmdev-init.elc
  96. %if 0%{?fedora}
  97. %{_xemacs_sitestartdir}/rpmdev-init.el
  98. %ghost %{_xemacs_sitestartdir}/rpmdev-init.elc
  99. %endif
  100. %{_mandir}/man[18]/*.[18]*
  101. %changelog
  102. * Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 9.3-1
  103. - new upstream release.
  104. - updated patches.
  105. * Tue Sep 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.10-11
  106. - rpmdev-bumpspec: made to set %%_dist_release to %%nil.
  107. * Mon Aug 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.10-10
  108. - initial build for Vine Linux.
  109. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-9
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  111. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-8
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  113. * Wed Nov 28 2018 Neal Gompa <ngompa13@gmail.com> - 8.10-7
  114. - Fix regex substitution issues with Python 3.7 (rhbz#1651954)
  115. * Sun Sep 16 2018 Neal Gompa <ngompa13@gmail.com> - 8.10-6
  116. - Fix regex related deprecation warnings (rhbz#1598089)
  117. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-5
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  119. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-4
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  121. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-3
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  123. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-2
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  125. * Sat Jan 14 2017 Ville Skyttä <ville.skytta@iki.fi> - 8.10-1
  126. - Update to 8.10
  127. * Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 8.9-2
  128. - Rebuild for Python 3.6
  129. * Sat Jun 25 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.9-1
  130. - Update to 8.9
  131. * Sat Jun 25 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.8-1
  132. - Update to 8.8
  133. * Fri Jun 24 2016 Petr Písař <ppisar@redhat.com>
  134. - Add new mandatory perl build deps
  135. * Thu Jun 23 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.7-1
  136. - Update to 8.7
  137. - Specfile cleanups
  138. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 8.6-3
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  140. * Fri Jun 5 2015 Ville Skyttä <ville.skytta@iki.fi> - 8.6-2
  141. - Use python3 on > F-22
  142. * Sun May 10 2015 Ville Skyttä <ville.skytta@iki.fi> - 8.6-1
  143. - Update to 8.6
  144. * Mon Oct 20 2014 Ville Skyttä <ville.skytta@iki.fi> - 8.5-1
  145. - Update to 8.5
  146. - Mark COPYING as %%license where applicable
  147. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.4-3
  148. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  149. * Thu Oct 17 2013 Ville Skyttä <ville.skytta@iki.fi> - 8.4-2
  150. - Do not require devscripts in any scenario.
  151. * Mon Oct 7 2013 Ville Skyttä <ville.skytta@iki.fi> - 8.4-1
  152. - Update to 8.4.
  153. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.3-5
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  155. * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 8.3-4
  156. - Perl 5.18 rebuild
  157. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.3-3
  158. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  159. * Tue Oct 16 2012 Thomas Woerner <twoerner@redhat.com> - 8.3-2
  160. - xemacs is not available on RHEL (RHBZ#866841)
  161. * Sun Sep 2 2012 Ville Skyttä <ville.skytta@iki.fi> - 8.3-1
  162. - Update to 8.3.
  163. - Drop specfile constructs no longer needed with Fedora's rpm.
  164. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2-3
  165. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  166. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2-2
  167. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  168. * Sat Nov 12 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.2-1
  169. - Update to 8.2.
  170. * Tue Apr 26 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.1-1
  171. - Update to 8.1.
  172. * Tue Mar 1 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.0-3
  173. - Require xemacs-filesystem on F-15+ (#672093).
  174. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.0-2
  175. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  176. * Sun Feb 6 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.0-1
  177. - Update to 8.0, fixes #519061 and #657594.
  178. * Mon Sep 27 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.10-1
  179. - Update to 7.10, fixes #595135 and #619867.
  180. - Patch spectool to work with specfiles containing Icon or BuildArchitectures
  181. (#637000).
  182. * Thu May 20 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.9-1
  183. - Update to 7.9, fixes #588313 and #589705.
  184. * Fri Apr 16 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.8-2
  185. - Require %%{_bindir}/man instead of man (#582932).
  186. * Tue Feb 16 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.8-1
  187. - Update to 7.8, fixes #562316.
  188. * Tue Feb 2 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.7-1
  189. - Update to 7.7, fixes #558263.
  190. * Mon Dec 7 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.6-1
  191. - Update to 7.6, fixes #528907.
  192. * Thu Sep 17 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.5-1
  193. - Update to 7.5, fixes #502403.
  194. * Fri Aug 21 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.4-1
  195. - Update to 7.4, fixes #215927 and #466353.
  196. - Patch spectool to make -s and -p to work as documented (Todd Zullinger).
  197. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.3-2
  198. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  199. * Mon May 25 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.3-1
  200. - Release 7.3.
  201. * Sat May 23 2009 Ville Skyttä <ville.skytta@iki.fi>
  202. - Add rpmdev-packager - script for getting rpm packager info.
  203. - Use rpmdev-packager in rpmdev-bumpspec and rpmdev-init.el.
  204. - Fix rpmdev-extract MIME type comparisons with file(1) output containing
  205. parameters.
  206. * Wed May 20 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.2-1
  207. - Release 7.2.
  208. * Sun May 3 2009 Ville Skyttä <ville.skytta@iki.fi>
  209. - Add dummy spec template for ad-hoc testing.
  210. * Sat May 2 2009 Ville Skyttä <ville.skytta@iki.fi>
  211. - Improve newspec/newinit when only "-o foo" argument is given (#498588,
  212. thanks to Edwin ten Brink).
  213. - Try to get packager mail address for *Emacs rpm-spec-mode from ~/.fedora.cert
  214. if rpm-spec-user-mail-address is not set.
  215. - Add xz support to rpmdev-extract.
  216. * Sat Apr 18 2009 Ville Skyttä <ville.skytta@iki.fi>
  217. - Make bumpspec's use of "head" POSIX compliant.
  218. * Thu Apr 16 2009 Ville Skyttä <ville.skytta@iki.fi>
  219. - Add rpmdev-newinit for easier access to the init script template, move the
  220. template to %%{_sysconfdir}/rpmdevtools, improve reload action example.
  221. * Tue Apr 7 2009 Ville Skyttä <ville.skytta@iki.fi>
  222. - Speed up rpmls bash completion.
  223. * Sat Apr 4 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.1-1
  224. - 7.1.
  225. - Make rpmdev-md5 and friends work on non-srpm package files too.
  226. * Sun Mar 15 2009 Ville Skyttä <ville.skytta@iki.fi>
  227. - Add bash completion.
  228. * Mon Mar 9 2009 Ville Skyttä <ville.skytta@iki.fi>
  229. - Add query format option to rmdevelrpms, sort output by NEVRA.
  230. * Sun Feb 22 2009 Ville Skyttä <ville.skytta@iki.fi>
  231. - Use %%global instead of %%define in spec templates.
  232. - Handle %%global in addition to %%define in rpmdev-bumpspec.
  233. * Mon Jan 26 2009 Ville Skyttä <ville.skytta@iki.fi>
  234. - Add result dependent exit statuses to rpmdev-vercmp.
  235. * Fri Dec 26 2008 Ville Skyttä <ville.skytta@iki.fi>
  236. - Add minimum version to rpm-python dependency (for rpmdev-bumpspec).
  237. * Fri Dec 26 2008 Ville Skyttä <ville.skytta@iki.fi> - 7.0-1
  238. - 7.0.
  239. - Drop fonts spec template, adapt to new ones from Fedora fonts SIG (#477055).
  240. - Add man page for rpmdev-newspec.
  241. * Tue Dec 16 2008 Ville Skyttä <ville.skytta@iki.fi>
  242. - Add imake and intltool to internal list of devel packages in rmdevelrpms.
  243. * Sat Dec 13 2008 Ville Skyttä <ville.skytta@iki.fi>
  244. - Add rpmdev-sha*/*sum companions to rpmdev-md5 (ticket #7).
  245. * Wed Nov 26 2008 Ville Skyttä <ville.skytta@iki.fi>
  246. - Add vamp-plugin-sdk to internal list of non-devel packages in rmdevelrpms
  247. (#472641, Michael Schwendt).
  248. * Thu Nov 20 2008 Ville Skyttä <ville.skytta@iki.fi>
  249. - Drop "minimal buildroot" dependencies.
  250. - Drop fedora-rpmdevtools Obsoletes.
  251. * Mon Oct 13 2008 Ville Skyttä <ville.skytta@iki.fi>
  252. - Show available types in rpmdev-newspec --help (ticket #6, Todd Zullinger).
  253. * Fri Sep 26 2008 Ville Skyttä <ville.skytta@iki.fi>
  254. - Add -r/--rightmost option to rpmdev-bumpspec (ticket #1, Thorsten Leemhuis).
  255. - Add %%packager from rpm config to the set of defaults for rpmdev-bumpspec's
  256. user string.
  257. * Thu Sep 25 2008 Ville Skyttä <ville.skytta@iki.fi>
  258. - Bring rpmdev-bumpspec copyright holder closer to truth (Michael Schwendt).
  259. * Mon Sep 22 2008 Ville Skyttä <ville.skytta@iki.fi>
  260. - Switch to lzma compressed tarball.
  261. * Sun Sep 7 2008 Ville Skyttä <ville.skytta@iki.fi>
  262. - Improve arch specific %%files in perl spec template (#461177, Chris Weyl).
  263. * Sun Aug 3 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.7-1
  264. - 6.7.
  265. - Make rpmdev-diff, rpmdev-md5 and rpminfo honor TMPDIR.
  266. * Sat Apr 26 2008 Ville Skyttä <ville.skytta@iki.fi>
  267. - Make rpmls work with URLs.
  268. * Sun Apr 20 2008 Ville Skyttä <ville.skytta@iki.fi>
  269. - Include rpm arch in dir names created by rpmdev-extract (#443266).
  270. * Fri Apr 18 2008 Ville Skyttä <ville.skytta@iki.fi>
  271. - Remove duplicate "reload" from case block in init script template.
  272. - Fix exit status of "reload" in case service is not running in init
  273. script template (#442993).
  274. * Thu Mar 27 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.6-1
  275. - Fix man page generation.
  276. * Wed Mar 26 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.5-1
  277. - 6.5.
  278. * Sun Mar 23 2008 Ville Skyttä <ville.skytta@iki.fi>
  279. - Generate man pages at build time.
  280. * Sat Mar 22 2008 Ville Skyttä <ville.skytta@iki.fi>
  281. - Remove libgcj-devel and zlib-devel from rmdevelrpms' internal exclusion
  282. list, they're not essential on non-devel systems any more.
  283. * Mon Mar 17 2008 Ville Skyttä <ville.skytta@iki.fi>
  284. - Include ocaml spec template.
  285. * Tue Mar 11 2008 Ville Skyttä <ville.skytta@iki.fi>
  286. - Include Michael Schwendt's bumpspecfile.py (as rpmdev-bumpspec).
  287. * Tue Feb 12 2008 Ville Skyttä <ville.skytta@iki.fi>
  288. - Sync with qa-robot upstream.
  289. - Update spectool to 1.0.10.
  290. * Sun Feb 3 2008 Ville Skyttä <ville.skytta@iki.fi>
  291. - Add support for 7-zip, lzma and lzo in rpmdev-extract.
  292. * Fri Feb 1 2008 Ville Skyttä <ville.skytta@iki.fi>
  293. - Add ';;' to the init script template's reload action.
  294. * Sat Dec 8 2007 Ville Skyttä <ville.skytta@iki.fi>
  295. - Add fonts spec template from the Fedora Fonts SIG (#407781).
  296. - Add option to use macro style instead of shell style variables to newspec.
  297. - Prefer ~/.config/rpmdevtools/rmdevelrpms.conf over ~/.rmdevelrpmsrc in
  298. rmdevelrpms.
  299. * Fri Oct 12 2007 Lubomir Kundrak <lkundrak@redhat.com> - 6.4-1
  300. - Import the previous fix into CVS to resync, bump version
  301. * Fri Oct 12 2007 Lubomir Kundrak <lkundrak@redhat.com> - 6.3-1
  302. - Fix paths in qa-robot tools
  303. * Sat Sep 8 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.2-1
  304. - Sync deps with Fedora's new "assumed present in buildroots" packages list.
  305. * Thu Sep 6 2007 Ville Skyttä <ville.skytta@iki.fi>
  306. - Init script template cleanups.
  307. * Tue Aug 28 2007 Ville Skyttä <ville.skytta@iki.fi>
  308. - Update rpminfo to version 2004-07-07-02.
  309. * Fri Aug 10 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.1-1
  310. - Sync COPYING with http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
  311. * Mon Aug 6 2007 Ville Skyttä <ville.skytta@iki.fi>
  312. - Work around #250990 in rpmls and rpmdev-extract.
  313. - Clarify copyright info of rpmdev-* and rpmls.
  314. * Sat Jul 7 2007 Ville Skyttä <ville.skytta@iki.fi>
  315. - Fix Epoch handling in the 2-arg form of rpmdev-vercmp with yum < 3.1.2.
  316. - The long form of the list option in rmdevelrpms is --list-only, not --list.
  317. * Thu Jul 5 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.0-1
  318. - Remove check-{buildroot,rpaths*}, now included in rpm-build >= 4.4.2.1.
  319. - Drop explicit dependency on patch, pulled in by recent rpm-build.
  320. - Add cmake and scons to default devel package list in rpmdev-rmdevelrpms.
  321. - Add LSB comment block to init script template.
  322. * Wed Jun 27 2007 Ville Skyttä <ville.skytta@iki.fi>
  323. - Add 2-argument form for comparing EVR strings to rpmdev-vercmp
  324. (available only if rpmUtils.miscutils is available).
  325. * Sat Jun 16 2007 Ville Skyttä <ville.skytta@iki.fi>
  326. - Include rpmsodiff and dependencies (rpmargs, rpmelfsym, rpmfile, rpmpeek,
  327. rpmsoname) from ALT Linux's qa-robot package.
  328. - Include rpmls (#213778).
  329. * Fri Jun 15 2007 Ville Skyttä <ville.skytta@iki.fi>
  330. - Update spectool to 1.0.9 (#243731).
  331. * Wed Apr 11 2007 Ville Skyttä <ville.skytta@iki.fi>
  332. - Add --list-only option to rmdevelrpms (Thorsten Leemhuis).
  333. * Tue Mar 13 2007 Ville Skyttä <ville.skytta@iki.fi>
  334. - BR perl(ExtUtils::MakeMaker) by default in perl spec template.
  335. - Drop deprecated backwards compatibility with fedora-rpmdevtools.
  336. - Update URL.
  337. * Wed Nov 8 2006 Ville Skyttä <ville.skytta@iki.fi>
  338. - Arch-qualify output of matched packages in rmdevelrpms and allow
  339. arch-qualified packages in the config file.
  340. * Wed Oct 25 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.3-1
  341. - Update spectool to 1.0.8, fixes #212108.
  342. * Mon Oct 2 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.2-1
  343. - Skip *.jar.so.debug in check-buildroot (#208903).
  344. - Treat yasm and *-static as devel packages in rmdevelrpms.
  345. * Sat Sep 9 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.1-1
  346. - Re-add PHP PEAR spec template, more improvements to it (#198706,
  347. Christopher Stone, Remi Collet).
  348. * Tue Aug 22 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.0-2
  349. - Migrate rmdevelrpms config when upgrading from fedora-rpmdevtools.
  350. * Sun Aug 20 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.0-1
  351. - Re-rename almost everything to rpmdev-*, with backwards compat symlinks.
  352. - Don't encourage %%ghost'ing *.pyo in Python spec template, add some comments.
  353. - Drop PHP PEAR spec template, it's not ready yet.
  354. * Wed Aug 2 2006 Ville Skyttä <ville.skytta@iki.fi>
  355. - Treat *-sdk as devel packages in rmdevelrpms (#199909).
  356. - Don't assume compface is a devel package in rmdevelrpms.
  357. * Thu Jul 20 2006 Ville Skyttä <ville.skytta@iki.fi>
  358. - Mark things that are not needed for noarch module packages in the Perl
  359. spec template.
  360. * Wed Jul 19 2006 Ville Skyttä <ville.skytta@iki.fi>
  361. - Move option arguments to "find" before non-option ones in Perl spec template.
  362. - Drop python-abi dependency from Python spec template (#189947).
  363. * Tue Jul 18 2006 Ville Skyttä <ville.skytta@iki.fi>
  364. - Add PHP PEAR spec template (#198706, Christopher Stone).
  365. * Mon Jul 17 2006 Ville Skyttä <ville.skytta@iki.fi>
  366. - Drop fedora- prefix everywhere, add backcompat symlinks for execubtables.
  367. - Move %%{_sysconfdir}/fedora to %%{_sysconfdir}/rpmdevtools and
  368. %%{_datadir}/fedora to %%{_datadir}/rpmdevtools.
  369. - Move spec templates to %%{_sysconfdir}/rpmdevtools, mark as config.
  370. - Bump version to 5.0.
  371. * Sun Jul 16 2006 Ville Skyttä <ville.skytta@iki.fi>
  372. - Drop fedora-kmodhelper.
  373. - Drop fedora-installdevkeys and GPG keys, modify rpmchecksig to use
  374. the system rpmdb.
  375. * Sat Jul 15 2006 Ville Skyttä <ville.skytta@iki.fi>
  376. - Sort rmdevelrpms' output.
  377. * Fri Jul 7 2006 Ville Skyttä <ville.skytta@iki.fi>
  378. - Improve ruby spec template (#180066, David Lutterkort).
  379. * Mon Jun 5 2006 Ville Skyttä <ville.skytta@iki.fi>
  380. - Add manual pages for rmdevelrpms, diffarchive and extract.
  381. - Trim pre-2005 changelog entries.
  382. - Autotoolize source tree.
  383. * Tue May 16 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.6-1
  384. - Add spec template for library packages (#185606, Ignacio Vazquez-Abrams).
  385. * Sun Feb 26 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.5-1
  386. - Improve diffarchive and extract error messages.
  387. * Fri Feb 24 2006 Ville Skyttä <ville.skytta@iki.fi>
  388. - Update spectool to 1.0.7 (#162253).
  389. * Thu Feb 9 2006 Ville Skyttä <ville.skytta@iki.fi>
  390. - Add file(1) based archive type detection to fedora-extract.
  391. * Wed Feb 8 2006 Ville Skyttä <ville.skytta@iki.fi>
  392. - Add "diff file lists only" option to diffarchive.
  393. * Sun Feb 5 2006 Ville Skyttä <ville.skytta@iki.fi>
  394. - Add Ruby spec template (#180066, Oliver Andrich) and make newrpmspec
  395. use it for ruby-*.
  396. * Sat Feb 4 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.4-2
  397. - Fix rpath checker tests with bash 3.1 (#178636, Enrico Scholz).
  398. * Fri Dec 30 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.4-1
  399. - Update spectool to 1.0.6 (#176521).
  400. * Wed Dec 28 2005 Ville Skyttä <ville.skytta@iki.fi>
  401. - Update spectool to 1.0.5 (#162253), require wget for it.
  402. - Add disttags to spec templates.
  403. * Thu Oct 27 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.3-1
  404. - check-rpaths-worker: detect when RPATH references the parent directory
  405. of an absolute path (#169298, Enrico Scholz).
  406. - Add regression test for check-rpaths* (#169298, Enrico Scholz).
  407. - Honor user's indent-tabs-mode setting in fedora-init.el (#170902).
  408. * Fri Oct 7 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.2-1
  409. - check-buildroot: grep for buildroot as a fixed string, not a regexp.
  410. - Update FSF's address in copyright notices.
  411. - check-rpaths-worker: allow multiple $ORIGIN paths in an RPATH and allow
  412. RPATHs which are relative to $ORIGIN (#169298, Enrico Scholz).
  413. - check-rpaths-worker: give out an hint about usage and the detected issues
  414. at the first detected error (Enrico Scholz).
  415. - Remove some redundancy from the Perl spec template.
  416. - Teach fedora-newrpmspec to detect and use different specfile variants.
  417. - Use fedora-newrpmspec in fedora-init.el.
  418. * Fri Jul 8 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.1-1
  419. - Drop more pre-FC2 compat stuff from Perl spec template.
  420. - Treat gcc-gfortran as a devel package in rmdevelrpms.
  421. - Drop fedora.us GPG key.
  422. * Thu Mar 24 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.0-1
  423. - Make fedora-diffarchive work better with archives containing dirs without
  424. read/execute permissions.
  425. - Sync "Epoch: 0" drops with Fedora Extras CVS.
  426. - Include Nils Philippsen's spectool.
  427. - Own (%%ghost'd) more dirs from the site-lisp dir hierarchies.
  428. - Drop trigger support pre-FC2 Emacs and XEmacs packages.
  429. - Drop rpm-spec-mode.el patch, no longer needed for FC2 Emacs and later.
  430. - Update URLs.
  431. - Drop developer GPG keys from the package, add Fedora Extras key.
  432. - Drop fedora-pkgannfmt, it's no longer relevant.
  433. - Remove pre-FC2 compatibility stuff from Perl spec template.
  434. - Don't try to remove gcc-java and related packages by default in rmdevelrpms.
  435. - Remove "full featured" spec template, convert newrpmspec to use -minimal.
  436. * Sun Feb 6 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.3.1-1
  437. - Make buildrpmtree and wipebuildtree less dependent on a specific
  438. configuration (#147014, Ignacio Vazquez-Abrams).
  439. * Tue Jan 18 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.3.0-1
  440. - Remove 0.fdr. prefixes and epoch 0's from all spec templates.
  441. - Add try-restart action to init script template.
  442. - Remove deprecated fedora-diffrpm and fedora-unrpm.
  443. - Install check-* to %%{_prefix}/lib/rpm instead of %%{_libdir}/rpm (bug 2351).
  444. - Check both %%{_prefix}/lib and %%{_prefix}/lib64 in the xemacs trigger.
  445. - Update rpminfo to 2004-07-07-01 and include it in the tarball.