deluge-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Name: deluge
  4. Version: 1.3.1
  5. Release: 1%{?_dist_release}
  6. Summary: A GTK+ BitTorrent client with support for DHT, UPnP, and PEX
  7. Summary(ja): DHT・UPnP・PEX をサポートした GTK+ BitTorrent クライアント
  8. Group: Applications/Internet
  9. License: GPLv3 with exceptions
  10. URL: http://deluge-torrent.org/
  11. Source0: http://download.deluge-torrent.org/source/%{version}/%{name}-%{version}.tar.gz
  12. ## The scalable icon needs to be installed to the proper place.
  13. Patch0: %{name}-scalable-icon-dir.diff
  14. Patch1: 010_new_release_check.patch
  15. Patch10: workaround_build.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildArch: noarch
  18. BuildRequires: desktop-file-utils
  19. BuildRequires: python-devel
  20. BuildRequires: python-setuptools
  21. ## The build script checks for the libtorrent module and skips compiling the
  22. ## in-tarball one if this is found.
  23. BuildRequires: libtorrent-rasterbar-python >= 0.14.9
  24. Requires: gnome-python
  25. ## Required for the proper ownership of icon dirs.
  26. Requires: hicolor-icon-theme
  27. Requires: notify-python
  28. Requires: pygtk2-libglade
  29. Requires: pyOpenSSL
  30. Requires: python-chardet
  31. Requires: python-mako
  32. Requires: python-setuptools
  33. Requires: python-simplejson
  34. Requires: python-twisted
  35. Requires: pyxdg
  36. Requires: libtorrent-rasterbar-python >= 0.14.9
  37. %description
  38. Deluge is a new BitTorrent client, created using Python and GTK+. It is
  39. intended to bring a native, full-featured client to Linux GTK+ desktop
  40. environments such as GNOME and Xfce.
  41. %description -l ja
  42. Deluge は Python と GTK+ を用いて作成された新しい BitTorrent クライアントです。
  43. GNOME や Xfce のような Linux の GTK+ デスクトップ環境にネイティブかつフル機能の
  44. クライアントを提供することを意図しています。
  45. %package flags
  46. Summary: Country flags for peer location display in Deluge
  47. Group: Applications/Internet
  48. License: GPLv3
  49. Requires: %{name} = %{version}-%{release}
  50. %description flags
  51. The %{name}-flags package contains optional country flags which are used to
  52. display the location of peers in the "Peers" information tab.
  53. %prep
  54. %setup -qn "%{name}-%{version}"
  55. #%patch0 -p0 -b .fix-scalable-icon-dir
  56. %patch1 -p1
  57. %patch10 -p1
  58. %build
  59. CFLAGS="%{optflags}" %{__python} setup.py build
  60. %install
  61. rm -rf %{buildroot}
  62. %{__python} setup.py install -O1 --skip-build --root %{buildroot}
  63. desktop-file-install --vendor vine \
  64. --dir %{buildroot}%{_datadir}/applications \
  65. --copy-name-to-generic-name \
  66. --add-mime-type=application/x-bittorrent \
  67. --delete-original \
  68. --remove-category=Application \
  69. %{buildroot}%{_datadir}/applications/%{name}.desktop
  70. ## NOTE: The lang files should REEEAALLLY be in a standard place such as
  71. ## /usr/share/locale or similar. It'd make things so much nicer for
  72. ## the packaging. :O
  73. ## A bit of sed magic to mark the translation files with %%lang, taken from
  74. ## find-lang.sh (part of the rpm-build package) and tweaked somewhat. We
  75. ## cannot (unfortunately) call find-lang directly since it's not on a
  76. ## "$PREFIX/share/locale/"-ish directory tree.
  77. pushd %{buildroot}
  78. find -type f -o -type l \
  79. | sed '
  80. s:%{buildroot}%{python_sitelib}::
  81. s:^\.::
  82. s:\(.*/deluge/i18n/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:
  83. s:^\([^%].*\)::
  84. s:%lang(C) ::
  85. /^$/d' \
  86. > %{name}.filelist
  87. ## We've got the .mo files now; but we need the rest of the files in those
  88. ## dirs. We can't just glob in the %%files, as that would add duplicate
  89. ## entries for the .mo files which we've already marked with appropriate
  90. ## %%lang-fu.
  91. find ./%{python_sitelib}/%{name} -not -iname '%{name}.mo' -type f \
  92. | grep -v 'pixmaps/flags' | sed -e 's:^\./::' -e 's| |*|g' >> %{name}.filelist
  93. find ./%{python_sitelib}/%{name} -type d | grep -v 'pixmaps/flags' \
  94. | sed 's:^\./:%%dir :' >> %{name}.filelist
  95. ## Now we move that list back to our sources, so that '%%files -f' can find it
  96. ## properly.
  97. popd && mv %{buildroot}/%{name}.filelist .
  98. %clean
  99. rm -rf %{buildroot}
  100. %files -f %{name}
  101. %defattr(-,root,root,-)
  102. %doc ChangeLog LICENSE README
  103. %{python_sitelib}/
  104. %{_bindir}/%{name}
  105. %{_bindir}/%{name}-*
  106. %{_bindir}/%{name}d
  107. %{_datadir}/applications/vine-%{name}.desktop
  108. %{_datadir}/pixmaps/%{name}.*
  109. %{_datadir}/icons/hicolor/*/apps/%{name}.*
  110. %{_datadir}/icons/scalable/apps/
  111. %{_mandir}/man?/%{name}*
  112. %files flags
  113. %defattr(-,root,root,-)
  114. %doc LICENSE
  115. %{python_sitelib}/%{name}/data/pixmaps/flags/
  116. %post
  117. update-desktop-database &>/dev/null ||:
  118. touch --no-create %{_datadir}/icons/hicolor
  119. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  120. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  121. fi
  122. %postun
  123. update-desktop-database &> /dev/null ||:
  124. touch --no-create %{_datadir}/icons/hicolor
  125. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  126. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  127. fi
  128. %changelog
  129. * Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.1-1
  130. - new upstream release
  131. - added patch10 to work around building problem
  132. - disabled svn access
  133. * Sun Sep 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
  134. - new upstream release
  135. * Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.3-1
  136. - new upstream release
  137. * Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.1-1
  138. - new upstream release
  139. - added Requires: python-mako, notify-python, gnome-python
  140. - removed Requires: /bin/sh, dbus-python, dbus-x11
  141. - changed BuildRequires and Requires: libtorrent-rasterbar-python >= 0.14.9
  142. - applied new naming policy to spec
  143. * Tue Feb 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
  144. - rebuilt with python-2.6.4
  145. * Tue Jan 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
  146. - new upstream release
  147. - added Patch1 from Debian to disable update
  148. - added Requires: python-twisted, python-simplejson
  149. * Mon Sep 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.9-1
  150. - initial build for VineSeed
  151. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
  152. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  153. * Wed Jul 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-2
  154. - Fixed rb_libtorrent-python dependency, so as not to use the
  155. %%min_rblibtorrent_ver macro any more (#510264).
  156. * Wed Jun 17 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-1
  157. - Update to new upstream bug-fix release (1.1.9).
  158. - Do not hard-code minimum rb_libtorrent version. (We're only building against
  159. the system rb_libtorrent for Fedora 11+, which already has the necessary
  160. version.)
  161. * Wed May 27 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.8-1
  162. - Update to new upstream release (1.1.8) for bug-fixes and some translation
  163. updates. Adds dependency on chardet for fixing lots of bugs with torrents
  164. which are not encoded as UTF-8.
  165. - Add back the flags, in an optional -flags subpackage as per the new Flags
  166. policy (Package_Maintainers_Flags_Policy on the wiki).
  167. - Add LICENSE and README to installed documentation.
  168. * Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-2
  169. - Rebuild for the Boost 1.39.0 update.
  170. * Sat May 02 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-1
  171. - Update to new upstream bug-fix release (1.1.7).
  172. * Mon Apr 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.6-1
  173. - Update to new upstream bug-fix release (1.1.6)
  174. - Fix GPL version, add OpenSSL exception to License.
  175. - Remove libtool, openssl-devel, and boost-devel BuildRequires (were only
  176. necessary when building the in-tarball libtorrent copy).
  177. * Mon Mar 16 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.5-1
  178. - Update to new upstream bug-fix release (1.1.5)
  179. - Remove FIXME comment about parallel-compilation. We're not building the
  180. in-tarball libtorrent copy anymore, so no compilation (other than the python
  181. bytecode) happens and we no longer need to worry about this.
  182. * Tue Mar 10 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-2
  183. - Fix the installed location of the scalable (SVG) icon (#483443).
  184. + scalable-icon-dir.diff
  185. * Mon Mar 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-1
  186. - Update to new upstream bug-fix release (1.1.4)
  187. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
  188. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  189. * Sun Feb 15 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.3-1
  190. - Update to new upstream bug-fix release (1.1.3)
  191. * Sun Feb 01 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-2
  192. - Fix scalable icon directory ownership (#483443).
  193. * Sat Jan 31 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-1
  194. - Update to new upstream bug-fix release (1.1.2)
  195. * Sun Jan 25 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.1-1
  196. - Update to new upstream bug-fix release (1.1.1)
  197. * Sun Jan 11 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-1
  198. - Update to new upstream release (1.1.0 Final - yay!)
  199. - Drop the get_tracker_host patch (fixed upstream):
  200. - fix-get_tracker-host-if-no-tracker.patch
  201. * Fri Jan 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.4.rc3
  202. - Do not package the country flags data.
  203. - Resolves: #479265 (country flags should not be used in Deluge)
  204. * Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.3.rc3
  205. - Add patch from upstream SVN to fix an error where torrents are not shown (or
  206. possibly shown in "Error" states) due to a bad inet_aton call:
  207. + fix-get_tracker-host-if-no-tracker.patch
  208. - Resolves: #479097 (No torrent shown in menu); thanks to Mamoru Tasaka for
  209. the bug report.
  210. - Fix day of previous %%changelog entry.
  211. * Tue Jan 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.2.rc3
  212. - Update to new upstream release candidate (1.1.0 RC3)
  213. - Build against the system rb_libtorrent instead of using the in-tarball copy
  214. (requires rb_libtorrent 0.14+), and adjust dependencies accordingly. Drop
  215. the hacked setup.py script formerly used to enable this (fixed upstream):
  216. - fixed-setup.py
  217. - Make it a noarch package now that it's just python scripts and related
  218. data files (translations, images, etc.)
  219. * Mon Dec 29 2008 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.1.rc2
  220. - Update to new upstream release candidate (1.1.0 RC2)
  221. * Thu Dec 18 2008 Petr Machata <pmachata@redhat.com> - 1.0.7-2
  222. - Rebuild for new boost.
  223. * Tue Dec 16 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.7-1
  224. - Update to new upstream bug-fix release (1.0.7)
  225. - Remove CC-BY-SA license (the Tango WebUI images have been replaced by upstream).
  226. * Mon Dec 01 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.6-1
  227. - Update to new upstream release (1.0.6)
  228. - Adds Tango images to the WebUI data (CC-BY-SA) and some man pages.
  229. - Properly mark translation files with %%lang.
  230. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-3
  231. - Fix locations for Python 2.6
  232. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-2
  233. - Rebuild for Python 2.6
  234. * Thu Nov 13 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.5-1
  235. - Update to new upstream release (1.0.5)
  236. * Fri Oct 31 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.4-1
  237. - Update to new upstream release (1.0.4).
  238. * Fri Oct 24 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.3-1
  239. - Update to new upstream release (1.0.3)
  240. * Sun Oct 12 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.2-1
  241. - Update to new upstream release (1.0.2)
  242. - Drop multithreaded boost compilation patch (fixed upstream, again).
  243. - mt-boost-fix.patch
  244. * Sat Sep 27 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.0-1
  245. - Update to new upstream release (1.0.0 Final)
  246. - Apply patch from Mamoru Tasaka to build against the multi-threaded Boost
  247. libraries once more:
  248. + mt-boost-fix.patch
  249. - Resolves: #464151 (About 1.0.0 build failure)
  250. * Tue Sep 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.09-1
  251. - Update to new upstream release candidate (1.0.0 RC9)
  252. - Drop mt-boost patch (fixed upstream):
  253. - use-mt-boost.patch
  254. * Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.08-1
  255. - Update to new upstream release candidate (1.0.0 RC8)
  256. - Drop state_upgrade script from the documentation. (This is now handled
  257. automatically.)
  258. - Fix version in previous %%changelog entry.
  259. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.07-1
  260. - Update to new upstream release candidate (1.0.0 RC7)
  261. - Drop desktop file icon name hack (fixed upstream).
  262. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.06-1
  263. - Update to new upstream release candidate (1.0.0 RC6)
  264. - Drop desktop file icon name hack (fixed upstream).
  265. * Fri Aug 01 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.04-1
  266. - Update to new upstream release candidate (1.0.0 RC4)
  267. * Wed Jul 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-2
  268. - Add setuptools runtime dependency, to fix "No module named pkg_resources"
  269. error messages.
  270. * Mon Jul 21 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-1
  271. - Update to new upstream release candidate (1.0.0 RC3)
  272. - Re-add the blocklist plugin, at upstream's suggestion. (The rewrite is
  273. complete.)
  274. * Tue Jul 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.02-1
  275. - Update to new upstream release candidate (1.0.0 RC2)
  276. - Force building against the multithreaded Boost libs.
  277. + use-mt-boost.patch
  278. - Remove python-libtorrent Obsoletes. (It's been dead for 3 releases now; and
  279. is just clutter.)
  280. - Remove the blocklist plugin, at upstream's recommendation.
  281. * Tue Jun 24 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.3-1
  282. - Update to new upstream release (0.5.9.3)
  283. * Fri May 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.1-1
  284. - Update to new upstream release (0.5.9.1)
  285. * Fri May 02 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.0-1
  286. - Update to new upstream release (0.5.9.0)
  287. - Drop upstreamed default-preferences patch for disabling new version
  288. notifications:
  289. - default-prefs-no-release-notifications.patch
  290. * Tue Apr 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.9-1
  291. - Update to new upstream release (0.5.8.9)
  292. * Wed Mar 26 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.7-1
  293. - Update to new upstream release (0.5.8.7)
  294. * Mon Mar 17 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.6-1
  295. - Update to new upstream release (0.5.8.6)
  296. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.5-1
  297. - Update to new upstream release (0.5.8.5)
  298. * Sat Feb 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.4-1
  299. - Update to new upstream release (0.5.8.4)
  300. - Rebuild for GCC 4.3
  301. * Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.3-1
  302. - Update to new upstream security fix release (0.5.8.3), which includes a fix
  303. for a potential remotely-exploitable stack overflow with a malformed
  304. bencoded message.
  305. * Sat Jan 19 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.1-1
  306. - Update to new upstream bugfix release (0.5.8.1)
  307. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8-3
  308. - Add runtime dependency on dbus-x11 for the dbus-launch utility. Fixes bug
  309. 428106 (Missing BR dbus-x11).
  310. - Bump release to 3 to maintain a proper F8->F9+ upgrade path.
  311. * Mon Dec 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.8-1
  312. - Update to new upstream release (0.5.8)
  313. - Merge Mamoru Tasaka's no-release-notification patch into the default-prefs
  314. patch.
  315. * Sat Dec 29 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.98-1
  316. - Update to new upstream release candidate (0.5.8 RC2)
  317. * Mon Dec 24 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.95-1
  318. - Update to new upstream release candidate (0.5.8 RC1)
  319. - Completely suppress updates notification (bug 299601, 426642)
  320. * Sun Dec 09 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-2
  321. - Add missing icon cache %%post and %%postun scriptlets.
  322. - Add missing egg-info to the %%files list.
  323. * Fri Dec 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-1
  324. - Update to new upstream bug-fix release (0.5.7.1).
  325. - Sort %%files list (aesthetic-only change).
  326. * Wed Dec 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-3
  327. - Fix previous %%changelog Version.
  328. - Cleanup the installed .desktop file. Fixes bug 413101 (deluge fails to build
  329. in rawhide bad .desktop file.)
  330. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.7-2
  331. - Rebuild for deps
  332. * Tue Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-1
  333. - Update to new upstream release (0.5.7)
  334. * Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.96-1
  335. - Update to new upstream release candidate (0.5.7 RC2)
  336. - Drop plugin error patch (fixed upstream):
  337. - plugin-not-found-OK.patch
  338. * Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.95-1
  339. - Update to new upstream release candidate (0.5.7 RC)
  340. - Update Source0 url
  341. - Add upstream patch to prevent dying if plugin in prefs.state is not found on
  342. the filesystem:
  343. + plugin-not-found-OK.patch
  344. * Wed Oct 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.2-1
  345. - Update to new upstream bug-fix release (0.5.6.2)
  346. * Tue Oct 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.1-1
  347. - Update to new upstream bug-fix release (0.5.6.1)
  348. - Drop use-mt-boost build script patch (fixed upstream):
  349. - use-mt-boost.patch
  350. * Sat Oct 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6-1
  351. - Update to new upstream release (0.5.6)
  352. * Wed Oct 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5.95-1
  353. - Update to new upstream release candidate (0.5.6 RC1)
  354. * Thu Sep 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-2
  355. - Fix release on previous %%changelog entry.
  356. - Disable the version update notifications by default:
  357. + default-prefs-no-release-notifications.patch
  358. (Resolves bug 299601: Deluge alerts of new versions)
  359. * Wed Sep 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-1
  360. - Update to new upstream release (0.5.5)
  361. * Mon Sep 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1.95-1
  362. - Update to new upstream release candidate (0.5.5 RC1)
  363. * Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1-1
  364. - Update to new upstream release (0.5.4.1)
  365. - Build with new binutils to gain BuildID debugging goodness.
  366. * Mon Aug 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4-1
  367. - Update to new upstream release (0.5.4)
  368. * Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-2
  369. - Update License tag (GPLv2+).
  370. - Rebuild against new Boost libraries, adding a patch to build against the
  371. multi-threaded ("*-mt") libraries:
  372. + use-mt-boost.patch
  373. * Wed Jul 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-1
  374. - Update to new upstream release candidate (0.5.3)
  375. - Drop %%ifarch invocations for 64-bit builds. The internal setup script now
  376. properly determines this and adds the AMD64 compiler definition if necessary.
  377. * Fri Jul 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2.90-1
  378. - Update to new upstream release candidate (0.5.3 RC1)
  379. - Drop stale persistence fix patch (applied upstream):
  380. - fix-persistence-upgrade-rhbz_247927.patch
  381. * Wed Jul 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-2
  382. - Add patch to fix the existence of stale persistence files by automatically
  383. updating the deluge.deluge module name to deluge.core, or removing them if
  384. empty (bug 247927):
  385. + fix-persistence-upgrade-rhbz_247927.patch
  386. * Sun Jul 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-1
  387. - Update to new upstream release (0.5.2)
  388. - Update Summary and %%description to reflect new µTorrent-compatible Peer
  389. Exchange ("PEX") functionality.
  390. * Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0.90.2-2
  391. - Update to new upstream release (0.5.1 Beta 2)
  392. * Sun Apr 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-2
  393. - Make Deluge the upgrade path of the now-orphaned python-libtorrent package.
  394. * Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-1
  395. - Update to new upstream release (0.5.0).
  396. * Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.2-1
  397. - Update to new upstream release (0.5 RC2).
  398. - Drop IndexError exception-handling fix (applied upstream):
  399. - delugegtk.py-fix-IndexError-exception-handling.patch
  400. - Use the system libtool instead of the one from the sources to ensure
  401. that no unnecessary RPATH hacks are added to the final build.
  402. * Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-3
  403. - Add a patch (submitted upstream) to properly catch a thrown IndexError in
  404. state message updates. This should resolve the bug wherein the UI stops
  405. updating its details and torrent listing.
  406. + delugegtk.py-fix-IndexError-exception-handling.patch
  407. * Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-2
  408. - Drop unneeded 64bit-python_long patch; as it seems to cause more trouble than
  409. it's worth. Instead, pass -DAMD64 as a compiler flag on 64-bit arches.
  410. - 64bit-python_long patch
  411. (This should fix the bug where, even though torrents are active, they are not
  412. shown in the GtkTreeView listing.)
  413. * Tue Mar 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-1
  414. - Update to new upstream release (0.5 RC1).
  415. - Use rewritten setup.py instead of patching it so much, since it's easier to
  416. maintain across version upgrades and whatnot:
  417. + fixed-setup.py
  418. - Remove the setup.py patches (no longer needed, since I'm packaging my own):
  419. - setup.py-dont-store-the-install-dir.patch
  420. - setup.py-build-against-system-libtorrent.patch
  421. * Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.3-1
  422. - Update to new upstream release (0.5 Beta 3).
  423. - Add patch to fix storing of installation directory:
  424. + setup.py-dont-store-the-install-dir.patch
  425. (to be applied after setup.py-build-against-system-libtorrent.patch)
  426. * Sun Feb 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-2
  427. - Add patch to fix 64-bit python_long type.
  428. + 64bit-python_long.patch
  429. * Sat Feb 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-1
  430. - Update to new upstream release (0.5 Beta 2)
  431. - Add patch to force building against system copy of rb_libtorrent:
  432. + setup.py-build-against-system-libtorrent.patch
  433. - Remove python-libtorrent and a few other dependencies that are no longer
  434. used.
  435. * Fri Feb 23 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-6
  436. - Fix Source0 URL.
  437. * Wed Feb 21 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-5
  438. - Make notify-python dependency conditional (FC6+ only)
  439. - Strip the unneeded shebang lines from the plugin scripts, since they are not
  440. meant to be directly executed.
  441. * Wed Feb 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-4
  442. - Update .desktop file: Icon should not have the "-256" size suffix.
  443. - Add Requires: notify-python
  444. - Remove strict dependency on python 2.3+, since we're targetting FC5+
  445. only, which has 2.4+.
  446. * Wed Jan 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-3
  447. - Use install instead of the cp/find/chmod fiasco of earlier releases for
  448. clarity and proper permissions setting.
  449. - Be more consistent about use of %%{name} and other macros in file naming as
  450. well as whitespace between sections.
  451. * Sun Jan 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-2
  452. - Bump python-libtorrent dependency to 0.3.0-4, which contains a fix for
  453. 64-bit systems.
  454. * Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-1
  455. - Initial packaging for Fedora Extras.