epiphany-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371
  1. # gecko backend was removed 2.27.0
  2. %define with_gecko 0
  3. %define with_webkit 1
  4. %define gecko_version 1.9.1
  5. %define webkit_version 1.1.15
  6. ExclusiveArch: %ix86 ppc x86_64 alpha
  7. Summary: GNOME web browser based on Gecko/WebKit
  8. Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
  9. Name: epiphany
  10. Version: 2.30.6
  11. Release: 1%{?_dist_release}
  12. License: GPL
  13. Group: Applications/Internet
  14. URL: http://www.gnome.org/projects/epiphany/
  15. Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.30/%{name}-%{version}.tar.bz2
  16. Patch1: epiphany-2.26.2-gecko191.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires: gnome-icon-theme >= 2.30.0
  19. %if %{with_gecko}
  20. Requires: gecko-libs
  21. %endif
  22. Requires(post,pre,preun): GConf2
  23. Requires(post,postun): scrollkeeper, shared-mime-info
  24. %if %{with_gecko}
  25. BuildRequires: gecko-devel-unstable >= %{gecko_version}
  26. %endif
  27. %if %{with_webkit}
  28. BuildRequires: WebKit-gtk-devel >= %{webkit_version}
  29. %endif
  30. BuildRequires: glib2-devel >= 2.24.0
  31. BuildRequires: gtk2-devel >= 2.20.0
  32. BuildRequires: libxml2-devel >= 2.6.12
  33. BuildRequires: libxslt-devel >= 1.1.7
  34. BuildRequires: libnotify-devel >= 0.4.0
  35. BuildRequires: dbus-glib-devel >= 0.35
  36. BuildRequires: libsoup-devel >= 2.30.0
  37. BuildRequires: gnome-desktop-devel >= 2.30.0
  38. BuildRequires: GConf2-devel
  39. BuildRequires: nss-devel
  40. BuildRequires: avahi-gobject-devel >= 0.6.22
  41. BuildRequires: NetworkManager-devel
  42. BuildRequires: iso-codes
  43. BuildRequires: intltool >= 0.40
  44. BuildRequires: libICE-devel
  45. BuildRequires: libSM-devel
  46. BuildRequires: libgnome-keyring-devel
  47. BuildRequires: gobject-introspection-devel
  48. BuildRequires: gnome-doc-utils
  49. BuildRequires: seed-devel
  50. %description
  51. epiphany is a simple GNOME web browser based on the Mozilla rendering
  52. engine
  53. %description -l ja
  54. epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
  55. ウェブブラウザです。
  56. %prep
  57. %setup -q
  58. #patch1 -p1
  59. %build
  60. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
  61. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  62. %configure \
  63. %if %{with_gecko}
  64. --with-gecko=libxul-embedding \
  65. %endif
  66. %if %{with_webkit}
  67. --with-engine=webkit \
  68. %endif
  69. --enable-zeroconf \
  70. --enable-network-manager \
  71. --disable-scrollkeeper \
  72. --without-ca-file \
  73. --enable-introspection=yes \
  74. --enable-seed
  75. %__make %{?_smp_mflags}
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  79. make install DESTDIR=$RPM_BUILD_ROOT
  80. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  81. %find_lang %{name} --with-gnome
  82. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  83. rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
  84. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  85. %pre
  86. if [ "$1" -gt 1 ]; then
  87. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  88. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  89. for S in $SCHEMAS; do
  90. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
  91. done
  92. fi
  93. %post
  94. touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
  95. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  96. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  97. for S in $SCHEMAS; do
  98. gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
  99. done
  100. %preun
  101. if [ "$1" -eq 0 ]; then
  102. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  103. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  104. for S in $SCHEMAS; do
  105. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
  106. done
  107. fi
  108. %postun
  109. if [ $1 -eq 0 ] ; then
  110. touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
  111. gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
  112. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  113. scrollkeeper-update >& /dev/null ||:
  114. fi
  115. %posttrans
  116. gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
  117. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  118. scrollkeeper-update >& /dev/null ||:
  119. %clean
  120. rm -rf $RPM_BUILD_ROOT
  121. %files -f %{name}.lang
  122. %defattr(-,root,root,-)
  123. %doc AUTHORS ChangeLog* COPYING* NEWS README
  124. %{_sysconfdir}/gconf/schemas/epiphany*.schemas
  125. %{_bindir}/epiphany
  126. %{_includedir}/epiphany/*
  127. %{_libdir}/pkgconfig/epiphany*.pc
  128. %{_libdir}/girepository-1.0/Epiphany-2.29.typelib
  129. %if %{with_gecko}
  130. %{_libdir}/epiphany
  131. %endif
  132. %{_datadir}/gir-1.0/Epiphany-2.29.gir
  133. #{_datadir}/pygtk/*/defs/*
  134. %{_datadir}/applications/*.desktop
  135. %{_datadir}/epiphany
  136. %{_datadir}/gtk-doc/html/*
  137. %{_datadir}/icons/*
  138. %{_datadir}/aclocal/*
  139. %{_datadir}/dbus-1/services/*
  140. %{_mandir}/man1/epiphany.1*
  141. %changelog
  142. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.6-1
  143. - new upstream release
  144. - remove BuildRequires: gir-repository-devel
  145. * Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.2-2
  146. - rebuilt with rpm-4.8.1 for pkg-config
  147. * Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  148. - new upstream release
  149. - add BuildRequires: gobject-introspection-devel, seed-devel
  150. - add configure option (--enable-introspection=yes, --enable-seed)
  151. * Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  152. - new upstream release
  153. - add BuildRequires: gobject-introspection-devel, gir-repository-devel
  154. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  155. - add configure option (--without-ca-file)
  156. - remove unrecognized configure option (--with-engine)
  157. * Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
  158. - new upstream release
  159. - added BR: libICE-devel, libSM-devel and gnome-keyring-devel
  160. * Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  161. - new upstream release
  162. * Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  163. - run gtk-update-icon-cache in %%post/postun script.
  164. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  165. - new upstream release
  166. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  167. - rebuild with gecko-1.9.1
  168. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  169. - new upstream release
  170. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  171. - new upstream release
  172. - build with xulrunner-1.9.0.7
  173. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  174. - new upstream release
  175. * Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
  176. - build with gecko-1.9.0.3 instead of WebKit.
  177. - WebKit port is unstable yet.
  178. - enable zeroconf, NetworkManager support
  179. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
  180. - new upstream release
  181. * Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
  182. - build with WebKit instead of gecko.
  183. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
  184. - new upstream release
  185. - added %%pre and %%preun section
  186. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
  187. - new upstream release
  188. - rebuilt with firefox-2.0.0.6-0vl3
  189. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
  190. - add BuildRequires: gnome-python
  191. * Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  192. - new upstream release
  193. - rebuilt with new toolchain and firefox-2.0.0.4-0vl6
  194. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  195. - new upstream release
  196. * Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
  197. - source update
  198. - add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
  199. - add BuildRequires: pygtk2-devel
  200. * Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
  201. - new upstream release
  202. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  203. - rebuild with firefox-1.5.0.2-0vl4
  204. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  205. - new upstream release
  206. - build with firefox-1.5.0.2
  207. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  208. - new upstream release
  209. * Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
  210. - new upstream release
  211. - build with firefox-1.5.0.1
  212. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  213. - new upstream release
  214. - build with mozilla-1.7.12
  215. * Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
  216. - rebuild with mozilla-1.7.8
  217. * Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
  218. - new upstream release
  219. * Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
  220. - new upstream release
  221. - build with mozilla-1.7.7
  222. * Fri Apr 1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
  223. - rebuild with mozilla-1.7.6
  224. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  225. - new upstream release
  226. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
  227. - new upstream release
  228. - build with mozilla-1.7.5
  229. * Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  230. - new upstream release
  231. * Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
  232. - new upstream release
  233. * Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
  234. - rebuild with mozilla-1.7.3
  235. * Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
  236. - new upstream release
  237. - build with mozilla-1.7.2
  238. - add Patch10 to build with gnome-2.4
  239. * Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
  240. - new upstream version
  241. -- dropped patch10
  242. - changed URL
  243. * Fri Jan 9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
  244. - add alpha into ExclusiveArch
  245. * Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
  246. - rebuild with mozilla-1.5.1
  247. * Sat Dec 6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
  248. - new upstream release
  249. * Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
  250. - new upstream release
  251. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
  252. - fixed missing locale files
  253. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
  254. - new upstream release
  255. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
  256. - new upstream release
  257. * Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
  258. - new upstream release
  259. * Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
  260. - new upstream release
  261. - build with mozilla 1.4
  262. * Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
  263. - new upstream release
  264. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
  265. - build for Vine Linux
  266. * Mon Jun 2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
  267. - Rebuild to fix broken mozilla dep, patch for mozilla 1.4
  268. * Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
  269. - 0.6.1
  270. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
  271. - add patch to fix gint/gpointer conversion bugs for 64bit arches
  272. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
  273. - only build on arches mozilla is built on
  274. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
  275. - rebuild against new mozilla, make mozilla requires dynamic
  276. * Sun May 4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
  277. - update to 0.6.0
  278. - fix tyop in %%postun
  279. * Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
  280. - make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
  281. * Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
  282. - add some buildrequires, prereq GConf2
  283. - disable building nautilus view
  284. * Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
  285. - Initial build.