gamin-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define python_archlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
  3. Summary: Library providing the FAM File Alteration Monitor API
  4. Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
  5. Name: gamin
  6. Version: 0.1.10
  7. Release: 4%{?_dist_release}
  8. License: LGPLv2
  9. Group: System Environment/Daemons
  10. Source: gamin-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. URL: http://www.gnome.org/~veillard/gamin/
  13. Obsoletes: fam
  14. Provides: fam
  15. BuildRequires: glib2-devel, python, python-devel
  16. %description
  17. The Gamin library provides an API and ABI compatible file alteration
  18. monitor mechanism compatible with FAM but not dependent on a system wide
  19. daemon.
  20. %description -l ja
  21. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  22. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  23. パープログラムをオンデマンドに起動します。
  24. %package devel
  25. Summary: Development files for the Gamin library
  26. Summary(ja): Gamin ライブラリの開発用ファイル
  27. Group: Development/Libraries
  28. Requires: gamin = %{version}-%{release}
  29. Obsoletes: fam-devel
  30. Provides: fam-devel
  31. %description devel
  32. The Gamin library provides an API and ABI compatible file alteration
  33. monitor mechanism compatible with FAM but not dependent on a system wide
  34. daemon.
  35. %description devel -l ja
  36. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  37. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  38. パープログラムをオンデマンドに起動します。
  39. %package python
  40. Summary: Python bindings for the Gamin library
  41. Summary(ja): Gamin ライブラリ用の Python バインディング
  42. Group: Development/Libraries
  43. Requires: gamin = %{version}-%{release}
  44. Requires: python
  45. #Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)
  46. %description python
  47. The gamin-python package contains a module that allow monitoring of
  48. files and directories from the Python language based on the support
  49. of the gamin package.
  50. %description python -l ja
  51. gamin-python は gamin ライブラリを利用して Python 言語からファイルや
  52. ディレクトリのモニタリングを行うためのモジュールです。
  53. ## to build compat32 for x86_64 architecture support
  54. %package -n compat32-%{name}
  55. Summary: Library providing the FAM File Alteration Monitor API
  56. Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
  57. Group: System Environment/Daemons
  58. Requires: gamin = %{version}-%{release}
  59. %description -n compat32-%{name}
  60. The Gamin library provides an API and ABI compatible file alteration
  61. monitor mechanism compatible with FAM but not dependent on a system wide
  62. daemon.
  63. %description -n compat32-%{name} -l ja
  64. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  65. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  66. パープログラムをオンデマンドに起動します。
  67. %package -n compat32-%{name}-devel
  68. Summary: Development files for the Gamin library
  69. Summary(ja): Gamin ライブラリの開発用ファイル
  70. Group: Development/Libraries
  71. Requires: compat32-gamin = %{version}-%{release}
  72. %description -n compat32-%{name}-devel
  73. The Gamin library provides an API and ABI compatible file alteration
  74. monitor mechanism compatible with FAM but not dependent on a system wide
  75. daemon.
  76. %description -n compat32-%{name}-devel -l ja
  77. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  78. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  79. %prep
  80. %setup -q
  81. %build
  82. %configure
  83. %__make %{?_smp_mflags}
  84. %install
  85. rm -fr %{buildroot}
  86. %makeinstall
  87. ## remove unuse files
  88. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  89. rm -f $RPM_BUILD_ROOT%{python_archlib}/*.la
  90. %clean
  91. rm -fr %{buildroot}
  92. %post -p /sbin/ldconfig
  93. %postun -p /sbin/ldconfig
  94. %post -n compat32-%{name} -p /sbin/ldconfig
  95. %postun -n compat32-%{name} -p /sbin/ldconfig
  96. %files
  97. %defattr(-, root, root)
  98. %doc AUTHORS ChangeLog NEWS README Copyright TODO
  99. %doc doc/*.html
  100. %doc doc/*.gif
  101. %doc doc/*.txt
  102. %{_libdir}/lib*.so.*
  103. %{_libexecdir}/gam_server
  104. %files devel
  105. %defattr(-, root, root)
  106. %{_libdir}/lib*.so
  107. %{_libdir}/*a
  108. %{_includedir}/fam.h
  109. %{_libdir}/pkgconfig/gamin.pc
  110. %files python
  111. %defattr(-, root, root)
  112. %doc AUTHORS ChangeLog NEWS README Copyright TODO
  113. %{_libdir}/python*/site-packages/gamin.py*
  114. %{_libdir}/python*/site-packages/_gamin*
  115. %doc python/tests/*.py
  116. %doc doc/python.html
  117. %if %{build_compat32}
  118. %files -n compat32-%{name}
  119. %defattr(-, root, root)
  120. %{_libdir}/lib*.so.*
  121. %files -n compat32-%{name}-devel
  122. %defattr(-, root, root)
  123. %{_libdir}/lib*.so
  124. %{_libdir}/*a
  125. %{_libdir}/pkgconfig/gamin.pc
  126. %endif
  127. %changelog
  128. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 0.1.10-4
  129. - update Requires for python subpackage
  130. - drop directory dependency
  131. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.10-3
  132. - build with rpm-4.8.1-1 for pkg-config file
  133. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
  134. - rebuild with python-2.6
  135. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.10-1
  136. - new upstream release
  137. * Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.1.9-3
  138. - fix license tag to LGPLv2
  139. - import patches from Fedora development
  140. - Patch0: don't poll for non-existant watched files
  141. - Patch1: Fix a memory leak
  142. - Patch2: workaround for missing struct ucred in glibc headers
  143. (fixed x86_64/ppc compilation)
  144. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.9-2
  145. - spec in utf-8
  146. - removed *.la
  147. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.9-1
  148. - added compat32-* packages for x86_64 architecture support
  149. - applied new versioning policy
  150. * Wed Mar 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.9-0vl1
  151. - new upstream release
  152. - Patch10 was included in upstream, dropped
  153. * Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.8-0vl2
  154. - added Patch10 (<BTS:507>) which should be fixed in the new upstream release
  155. * Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.8-0vl1
  156. - new upstream release
  157. * Mon Sep 4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.1.7-0vl2
  158. - stop removing *.la
  159. * Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.7-0vl1
  160. - initial build for Vine Linux
  161. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2.1
  162. - bump again for double-long bug on ppc(64)
  163. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2
  164. - rebuilt for new gcc4.1 snapshot and glibc changes
  165. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  166. - rebuilt
  167. * Thu Oct 27 2005 Daniel Veillard <veillard@redhat.com> 0.1.7-1
  168. - hopefully fixes gam_server crashes
  169. - some portability fixes
  170. - removed a minor leak
  171. * Thu Sep 8 2005 Daniel Veillard <veillard@redhat.com> 0.1.6-1
  172. - revamp of the inotify back-end
  173. - memory leak fix
  174. - various fixes and cleanups
  175. * Tue Aug 9 2005 Daniel Veillard <veillard@redhat.com> 0.1.5-1
  176. - Improvement of configuration, system wide configuration files and
  177. per filesystem type default
  178. - Rewrite of the inotify back-end, reduce resources usage, tuning in
  179. case of busy resources
  180. - Documentation updates
  181. - Changes to compile inotify back-end on various architectures
  182. - Debugging output improvements
  183. * Tue Aug 2 2005 Daniel Veillard <veillard@redhat.com> 0.1.3-1
  184. - Fix to compile on older gcc versions
  185. - Inotify back-end changes and optimizations
  186. - Debug ouput cleanup, pid and process name reports
  187. - Dropped kernel monitor bugfix
  188. - Removed the old glist copy used for debugging
  189. - Maintain mounted filesystems knowledge, and per fstype preferences
  190. * Wed Jul 13 2005 Daniel Veillard <veillard@redhat.com> 0.1.2-1
  191. - inotify back end patches, ready for the new inotify support in kernel
  192. - lot of server code cleanup patches
  193. - fixed an authentication problem
  194. * Fri Jun 10 2005 Daniel Veillard <veillard@redhat.com> 0.1.1-1
  195. - gamin_data_conn_event fix
  196. - crash from bug gnome #303932
  197. - Inotify and mounted media #171201
  198. - mounted media did not show up on Desktop #159748
  199. - write may not be atomic
  200. - Monitoring a directory when it is a file
  201. - Portability to Hurd/Mach and various code cleanups
  202. - Added support for ~ as user home alias in .gaminrc
  203. * Thu May 12 2005 Daniel Veillard <veillard@redhat.com> 0.1.0-1
  204. - Close inherited file descriptors on exec of gam_server
  205. - Cancelling a monitor send back a FAMAcknowledge
  206. - Fixed for big files > 2GB
  207. - Bug when monitoring a non existing directory
  208. - Make client side thread safe
  209. - Unreadable directory fixes
  210. - Better flow control handling
  211. - Updated to latest inotify version: 0.23-6
  212. * Tue Mar 15 2005 Daniel Veillard <veillard@redhat.com> 0.0.26-1
  213. - Fix an include problem showing up with gcc4</li>
  214. - Fix the crash on failed tree assert bug #150471 based on patch from Dean Brettle
  215. - removed an incompatibility with SGI FAM #149822
  216. * Tue Mar 1 2005 Daniel Veillard <veillard@redhat.com> 0.0.25-1
  217. - Fix a configure problem reported by Martin Schlemmer
  218. - Fix the /media/* and /mnt/* mount blocking problems from 0.0.24 e.g. #142637
  219. - Fix the monitoring of directory using poll and not kernel
  220. * Fri Feb 18 2005 Daniel Veillard <veillard@redhat.com> 0.0.24-1
  221. - more documentation
  222. - lot of serious bug fixes including Gnome Desktop refresh bug
  223. - extending the framework for more debug (configure --enable-debug-api)
  224. - extending the python bindings for watching the same resource multiple times
  225. and adding debug framework support
  226. - growing the regression tests a lot based on python bindings
  227. - inotify-0.19 patch from John McCutchan
  228. - renamed python private module to _gamin to follow Python PEP 8
  229. * Tue Feb 8 2005 Daniel Veillard <veillard@redhat.com> 0.0.23-1
  230. - memory corruption fix from Mark on the client side
  231. - extending the protocol and API to allow skipping Exists and EndExists
  232. events to avoid deadlock on reconnect or when they are not used.
  233. * Mon Jan 31 2005 Daniel Veillard <veillard@redhat.com> 0.0.22-1
  234. - bit of python bindings improvements, added test
  235. - fixed 3 bugs
  236. * Wed Jan 26 2005 Daniel Veillard <veillard@redhat.com> 0.0.21-1
  237. - Added Python support
  238. - Updated for inotify-0.18
  239. * Thu Jan 6 2005 Daniel Veillard <veillard@redhat.com> 0.0.20-1
  240. - Frederic Crozat seems to have found the GList corruption which may fix
  241. #132354 and related problems
  242. - Frederic Crozat also fixed poll only mode
  243. * Fri Dec 3 2004 Daniel Veillard <veillard@redhat.com> 0.0.19-1
  244. - still chasing the loop bug, made another pass at checking GList,
  245. added own copy with memory poisonning of GList implementation.
  246. - fixed a compile issue when compiling without debug
  247. * Fri Nov 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.18-1
  248. - still chasing the loop bug, checked and cleaned up all GList use
  249. - patch from markmc to minimize load on busy apps
  250. * Wed Oct 20 2004 Daniel Veillard <veillard@redhat.com> 0.0.16-1
  251. - chasing #132354, lot of debugging, checking and testing and a bit
  252. of refactoring
  253. * Sat Oct 16 2004 Daniel Veillard <veillard@redhat.com> 0.0.15-1
  254. - workaround to detect loops and avoid the nasty effects, see RedHat bug #132354
  255. * Sun Oct 3 2004 Daniel Veillard <veillard@redhat.com> 0.0.14-1
  256. - Found and fixed the annoying bug where update were not received
  257. should fix bugs ##132429, #133665 and #134413
  258. - new mechanism to debug on-the-fly by sending SIGUSR2 to client or server
  259. - Added documentation about internals
  260. * Fri Oct 1 2004 Daniel Veillard <veillard@redhat.com> 0.0.13-1
  261. - applied portability fixes
  262. - hardened the code while chasing a segfault
  263. * Thu Sep 30 2004 Daniel Veillard <veillard@redhat.com> 0.0.12-1
  264. - potential fix for a hard to reproduce looping problem.
  265. * Mon Sep 27 2004 Daniel Veillard <veillard@redhat.com> 0.0.11-1
  266. - update to the latest version of inotify
  267. - inotify support compiled in by default
  268. - fix ABI FAM compatibility problems #133162
  269. * Tue Sep 21 2004 Daniel Veillard <veillard@redhat.com> 0.0.10-1
  270. - more documentation
  271. - Added support for a configuration file $HOME/.gaminrc
  272. - fixes FAM compatibility issues with FAMErrno and FamErrlist #132944
  273. * Wed Sep 1 2004 Daniel Veillard <veillard@redhat.com> 0.0.9-1
  274. - fix crash with konqueror #130967
  275. - exclude kernel (dnotify) monitoring for /mnt//* /media//*
  276. * Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.8-1
  277. - Fixes crashes of the gam_server
  278. - try to correct the kernel/poll switching mode
  279. * Tue Aug 24 2004 Daniel Veillard <veillard@redhat.com> 0.0.7-1
  280. - add support for both polling and dnotify simultaneously
  281. - fixes monitoring of initially missing files
  282. - load control on very busy resources #124361, desactivating
  283. dnotify and falling back to polling for CPU drain
  284. * Thu Aug 19 2004 Daniel Veillard <veillard@redhat.com> 0.0.6-1
  285. - fixes simple file monitoring should close RH #129974
  286. - relocate gam_server in $(libexec)
  287. * Thu Aug 5 2004 Daniel Veillard <veillard@redhat.com> 0.0.5-1
  288. - Fix a crash when the client binary forks the gam_server and an
  289. atexit handler is run.
  290. * Wed Aug 4 2004 Daniel Veillard <veillard@redhat.com> 0.0.4-1
  291. - should fix KDE build problems