gdk-pixbuf2-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # biarch support
  3. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  4. %define _query_suffix %{nil}
  5. %if %{build_compat32}
  6. %define _query_suffix -32
  7. %endif
  8. Name: gdk-pixbuf2
  9. Version: 2.22.1
  10. Release: 1%{?_dist_release}
  11. Summary: An image loading library
  12. Group: System Environment/Libraries
  13. License: LGPLv2+
  14. URL: http://www.gt.org
  15. Source0: http://download.gnome.org/sources/gdk-pixbuf/2.22/gdk-pixbuf-%{version}.tar.bz2
  16. BuildRequires: glib2-devel >= 2.26.0
  17. BuildRequires: libpng-devel
  18. BuildRequires: libjpeg-turbo-devel
  19. BuildRequires: libtiff-devel
  20. BuildRequires: jasper-devel
  21. BuildRequires: libX11-devel
  22. BuildRequires: gobject-introspection-devel
  23. # gdk-pixbuf does a configure time check which uses the GIO mime
  24. # layer; we need to actually have the mime type database.
  25. BuildRequires: shared-mime-info
  26. BuildRequires: gtk-doc
  27. ## BuildRequires: libtool >= 2.2.10
  28. BuildRequires: libtool
  29. BuildRequires: gettext
  30. # We also need MIME information at runtime
  31. Requires: shared-mime-info
  32. # gdk-pixbuf was included in gtk2 until 2.21.2
  33. Conflicts: gtk2 <= 2.21.2
  34. # https://bugzilla.gnome.org/show_bug.cgi?id=624712
  35. Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
  36. %description
  37. gdk-pixbuf is an image loading library that can be extended by loadable
  38. modules for new image formats. It is used by toolkits such as GTK+ or
  39. clutter.
  40. %package devel
  41. Summary: Development files for gdk-pixbuf
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: glib2-devel
  45. Requires: gobject-introspection-devel
  46. Requires: libpng-devel
  47. # gdk-pixbuf was included in gtk2 until 2.21.2
  48. Conflicts: gtk2-devel <= 2.21.2
  49. %description devel
  50. This package contains the libraries and header files that are needed
  51. for writing applications that are using gdk-pixbuf.
  52. %if %{build_compat32}
  53. #######################################################################
  54. # compat32
  55. %package -n compat32-%{name}
  56. Summary: An image loading library
  57. Group: System Environment/Libraries
  58. Requires(post): compat32-glib2 >= %{glib2_version}
  59. # gdk-pixbuf was included in gtk2 until 2.21.2
  60. Conflicts: compat32-gtk2 <= 2.21.2
  61. %description -n compat32-%{name}
  62. gdk-pixbuf is an image loading library that can be extended by loadable
  63. modules for new image formats. It is used by toolkits such as GTK+ or
  64. clutter.
  65. %package -n compat32-%{name}-devel
  66. Summary: Development files for gdk-pixbuf
  67. Group: Development/Libraries
  68. Requires: compat32-%{name} = %{version}-%{release}
  69. Requires: %{name} = %{version}-%{release}
  70. Requires: compat32-libpng-devel
  71. # gdk-pixbuf was included in gtk2 until 2.21.2
  72. Conflicts: compat32-gtk2-devel <= 2.21.2
  73. %description -n compat32-%{name}-devel
  74. This package contains the libraries and header files that are needed
  75. for writing applications that are using gdk-pixbuf.
  76. %endif
  77. %prep
  78. %setup -q -n gdk-pixbuf-%{version}
  79. ## %patch0 -p1 -b .libpng-linking
  80. %build
  81. libtoolize --copy --force
  82. autoreconf
  83. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  84. %configure $CONFIGFLAGS \
  85. --with-libjasper \
  86. --with-included-loaders=png \
  87. --enable-introspection=yes )
  88. make %{?_smp_mflags}
  89. %install
  90. make install DESTDIR=$RPM_BUILD_ROOT \
  91. RUN_QUERY_LOADER_TEST=false
  92. # Remove unpackaged files
  93. rm $RPM_BUILD_ROOT%{_libdir}/*.la
  94. rm $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.la
  95. touch $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  96. %if %{build_compat32}
  97. cp $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders \
  98. $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
  99. %endif
  100. %find_lang gdk-pixbuf
  101. %post
  102. /sbin/ldconfig
  103. gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
  104. %postun
  105. /sbin/ldconfig
  106. if [ $1 -gt 0 ]; then
  107. gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
  108. fi
  109. %if %{build_compat32}
  110. %post -n compat32-%{name}
  111. /sbin/ldconfig
  112. gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
  113. %postun -n compat32-%{name}
  114. /sbin/ldconfig
  115. if [ $1 -gt 0 ]; then
  116. gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
  117. fi
  118. %endif
  119. %files -f gdk-pixbuf.lang
  120. %defattr(-,root,root,-)
  121. %doc AUTHORS COPYING NEWS
  122. %{_libdir}/libgdk_pixbuf-2.0.so.*
  123. %{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
  124. %{_libdir}/girepository-1.0
  125. %dir %{_libdir}/gdk-pixbuf-2.0
  126. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
  127. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  128. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
  129. %ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  130. %{_bindir}/gdk-pixbuf-query-loaders
  131. %{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
  132. %files devel
  133. %defattr(-,root,root,-)
  134. %{_includedir}/gdk-pixbuf-2.0
  135. %{_libdir}/libgdk_pixbuf-2.0.so
  136. %{_libdir}/libgdk_pixbuf_xlib-2.0.so
  137. %{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
  138. %{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
  139. %{_bindir}/gdk-pixbuf-csource
  140. %{_datadir}/gtk-doc/html/*
  141. %{_datadir}/gir-1.0
  142. %{_mandir}/man1/gdk-pixbuf-csource.1.gz
  143. %if %{build_compat32}
  144. %files -n compat32-%{name}
  145. %defattr(-,root,root,-)
  146. %{_libdir}/libgdk_pixbuf-2.0.so.*
  147. %{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
  148. %dir %{_libdir}/gdk-pixbuf-2.0
  149. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
  150. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  151. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
  152. %ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  153. %{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
  154. %files -n compat32-%{name}-devel
  155. %defattr(-,root,root,-)
  156. %{_libdir}/libgdk_pixbuf-2.0.so
  157. %{_libdir}/libgdk_pixbuf_xlib-2.0.so
  158. %{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
  159. %{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
  160. %endif
  161. %changelog
  162. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
  163. - new upstream release
  164. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
  165. - new upstream release
  166. - add configure option (--enable-introspection=yes)
  167. - drop Patch0
  168. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
  169. - initial build for Vine Linux
  170. * Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
  171. - Require libpng for linking
  172. * Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
  173. - Rebuild with new gobject-introspection
  174. * Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
  175. - Update to 2.21.6
  176. * Fri Jul 2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
  177. - Also Require shared-mime-info for same reason
  178. * Fri Jul 2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
  179. - BR shared-mime-info; see comment above it
  180. * Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
  181. - Changes to support snapshot builds
  182. * Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
  183. - Update to 2.21.5
  184. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
  185. - Rename to gdk-pixbuf2 to avoid conflict with the
  186. existing gdk-pixbuf package
  187. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
  188. - Update to 2.21.4
  189. - Incorporate package review feedback
  190. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
  191. - Initial packaging