gprolog-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117
  1. Summary: GNU Prolog is a free Prolog compiler with constraint solving over Finite Domains
  2. Summary(ja): GNU Prolog: 有限領域の制約解決に適したフリーな Prolog コンパイラ
  3. Name: gprolog
  4. Version: 1.3.1
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Development/Languages
  8. Source: ftp://ftp.inria.fr/Projects/loco/%{name}/%{name}-%{version}.tar.gz
  9. URL: http://gprolog.inria.fr/
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. %description
  14. GNU Prolog is a native Prolog compiler with constraint solving over finite
  15. domains (FD) developed by Daniel Diaz (http://loco.inria.fr/~diaz).
  16. GNU Prolog is a very efficient native compiler producing (small) stand-alone
  17. executables. GNU-Prolog also offers a classical top-level+debugger.
  18. GNU Prolog conforms to the ISO standard for Prolog but also includes a lot
  19. of extensions (global variables, DCG, sockets, OS interface,...).
  20. GNU Prolog also includes a powerful constraint solver over finite domains
  21. with many predefined constraints+heuristics.
  22. More information can be found at http://www.gnu.org/software/prolog
  23. or better at http://gprolog.inria.fr.
  24. %description -l ja
  25. GNU Prolog は有限領域 (FD) の制約解決に適したネイティブ Prolog コンパイラで、
  26. Daniel Diaz (http://loco.inria.fr/~diaz) によって開発されました。
  27. GNU Prolog は (小さな) スタンドアロンの実行可能形式を生成する、非常に効率の
  28. 良いネイティブコンパイラです。
  29. GNU Prolog は Prolog の ISO 規格に準拠しているだけでなく、多くの拡張
  30. (グローバル変数、DCG、ソケット、OS インタフェース、……) も含んでいます。
  31. GNU Prolog は多くの定義済の制約条件と発見的手法を用いて、有限領域の問題に
  32. 対して強力な制約解決機能も提供します。
  33. 詳しい情報は http://www.gnu.org/software/prolog や http://gprolog.inria.fr
  34. (こちらの方が良い)で見つけることができます。
  35. %prep
  36. %setup -q
  37. %build
  38. cd src
  39. ./configure \
  40. --with-install-dir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version} \
  41. --without-links-dir \
  42. --with-examples-dir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/examples
  43. # --with-doc-dir=$RPM_BUILD_ROOT/usr/doc/gprolog-%{version}
  44. make
  45. %install
  46. rm -rf $RPM_BUILD_ROOT
  47. pushd src
  48. make install-strip
  49. popd
  50. mkdir $RPM_BUILD_ROOT%{_bindir}
  51. pushd $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/bin
  52. for i in *; do
  53. ln -s ../lib/%{name}-%{version}/bin/$i $RPM_BUILD_ROOT%{_bindir}/$i
  54. done
  55. popd
  56. rm -rf docs_to_install
  57. mkdir -p docs_to_install
  58. mv $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/doc/* docs_to_install
  59. rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/{COPYING,ChangeLog,NEWS,VERSION}
  60. #cd $RPM_BUILD_DIR/gprolog-1.2.17
  61. #cp README COPYING ChangeLog NEWS $RPM_BUILD_ROOT//usr/doc/gprolog-1.2.17
  62. %clean
  63. rm -rf $RPM_BUILD_ROOT
  64. %files
  65. %defattr(-,root,root)
  66. %doc README COPYING ChangeLog NEWS VERSION
  67. %doc docs_to_install/*
  68. #%doc doc/compil-scheme.pdf doc/debug-box.pdf
  69. #%doc doc/manual.*
  70. %{_bindir}/*
  71. %{_libdir}/%{name}-%{version}/bin
  72. %{_libdir}/%{name}-%{version}/examples
  73. %{_libdir}/%{name}-%{version}/include
  74. %{_libdir}/%{name}-%{version}/lib
  75. %changelog
  76. * Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-1
  77. - updated to 1.3.1
  78. - applied new versioning policy
  79. - spec in UTF-8
  80. * Tue Aug 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl3
  81. - rebuild for VinePlus/3.0 and VineSeedPlus
  82. - updated Japanese Summary and description
  83. - merged VinePlus/2.5 spec file
  84. * Fri Jul 23 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.16-1vl2
  85. - Added Summary(ja) and %%description -l ja.
  86. * Sat Feb 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl2
  87. - merged VinePlus spec file
  88. * Thu Feb 12 2004 by IKEDA Katsumi <ikedak@rg8.so-net.ne.jp>
  89. - 1.2.161vl1
  90. - Modified %Vendor, %Buildroot and %build.
  91. - Add %Distribution.
  92. - Remove %Packager and %Prefix.
  93. - added --with-examples-dir to ./configure
  94. - fixed %files section to exclude %{_libdir}/%{name}-%{version}/doc
  95. * Fri Feb 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl1
  96. - rebuild for Vine Linux
  97. - s/Copyright/License/
  98. - use more rpm macros
  99. * Tue Jul 25 2000 Daniel Diaz <Daniel.Diaz@inria.fr>
  100. - initial specfile