ntfs-3g-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266
  1. %bcond_with externalfuse
  2. Summary: Linux NTFS userspace driver
  3. Summary(ja): Linux NTFS ユーザ空間ドライバ
  4. Name: ntfs-3g
  5. Version: 2013.1.13
  6. Release: 1%{?_dist_release}
  7. License: GPL
  8. Group: System Environment/Base
  9. URL: http://www.ntfs-3g.org/
  10. Source0: http://tuxera.com/opensource/%{name}_ntfsprogs-%{version}.tgz
  11. Source1: 20-ntfs-config-write-policy.fdi
  12. Patch0: ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: libtool
  15. BuildRequires: libattr-devel
  16. BuildRequires: libconfig-devel
  17. BuildRequires: libgcrypt-devel
  18. BuildRequires: gnutls-devel
  19. BuildRequires: libuuid-devel
  20. %if %{with externalfuse}
  21. BuildRequires: fuse-devel
  22. Requires: fuse
  23. %endif
  24. %description
  25. The ntfs-3g driver is an open source, GPL licensed, third generation
  26. Linux NTFS driver. It provides full read-write access to NTFS, excluding
  27. access to encrypted files, writing compressed files, changing file
  28. ownership, access right.
  29. Technically it's based on and a major improvement to the third
  30. generation Linux NTFS driver, ntfsmount. The improvements include
  31. functionality, quality and performance enhancements.
  32. ntfs-3g features are being merged to ntfsmount. In the meanwhile,
  33. ntfs-3g is currently the only free, as in either speech or beer, NTFS
  34. driver for Linux that supports unlimited file creation and deletion.
  35. %package devel
  36. Summary: Development files and libraries for ntfs-3g
  37. Summary(ja): ntfs-3g の開発ファイルとライブラリ
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. Provides: ntfsprogs-devel = %{version}-%{release}
  41. Obsoletes: ntfsprogs-devel < 2.0.0-3
  42. %description devel
  43. Headers and libraries for developing applications that use ntfs-3g
  44. functionality.
  45. %package -n ntfsprogs
  46. Summary: NTFS filesystem libraries and utilities
  47. Summary(ja): NTFS ファイルシステム用ライブラリおよびユーティリティ
  48. Group: System Environment/Base
  49. Provides: ntfsprogs-gnomevfs = %{version}-%{release}
  50. Obsoletes: ntfsprogs-gnomevfs < 2.0.0-3
  51. %description -n ntfsprogs
  52. The ntfsprogs package currently consists of a library and utilities
  53. such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
  54. (for a full list of included utilities see man 8 ntfsprogs after
  55. installation).
  56. %prep
  57. %setup -q -n %{name}_ntfsprogs-%{version}
  58. %patch0 -p1 -b .unsupported
  59. %build
  60. %configure --disable-static \
  61. --disable-ldconfig \
  62. %{?with_ externalfuse:--with-fuse=external} \
  63. --exec-prefix=/ \
  64. --bindir=/bin \
  65. --sbindir=/sbin \
  66. --libdir=/%{_lib} \
  67. --enable-crypto \
  68. --enable-extras
  69. make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. mkdir -p $RPM_BUILD_ROOT/sbin
  73. make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
  75. rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.a
  76. # make the symlink an actual copy to avoid confusion
  77. rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  78. cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  79. # make compatibility symlinks
  80. ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
  81. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
  82. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
  83. ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
  84. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  85. ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
  86. ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
  87. # Put the .pc file in the right place.
  88. mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  89. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  90. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
  91. cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
  92. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
  93. rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.la
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %post -p /sbin/ldconfig
  97. %postun -p /sbin/ldconfig
  98. %files
  99. %defattr(-,root,root,-)
  100. %doc AUTHORS ChangeLog COPYING CREDITS NEWS README
  101. /sbin/mount.lowntfs-3g
  102. /sbin/mount.ntfs
  103. %attr(4754,root,root) /sbin/mount.ntfs-3g
  104. /sbin/mount.ntfs-fuse
  105. /bin/lowntfs-3g
  106. /bin/ntfs-3g
  107. /bin/ntfs-3g.probe
  108. /bin/ntfs-3g.secaudit
  109. /bin/ntfs-3g.usermap
  110. /bin/ntfsmount
  111. %{_bindir}/ntfs-3g
  112. %{_bindir}/ntfsmount
  113. /%{_lib}/libntfs-3g.so.*
  114. %{_datadir}/hal/fdi/policy/10osvendor/20-ntfs-config-write-policy.fdi
  115. %{_mandir}/man8/mount.lowntfs-3g.*
  116. %{_mandir}/man8/mount.ntfs-3g.*
  117. %{_mandir}/man8/ntfs-3g*
  118. %files devel
  119. %defattr(-,root,root,-)
  120. %{_includedir}/ntfs-3g/
  121. /%{_lib}/libntfs-3g.so
  122. %{_libdir}/pkgconfig/*.pc
  123. %files -n ntfsprogs
  124. %doc AUTHORS COPYING CREDITS ChangeLog NEWS README
  125. /bin/ntfscat
  126. /bin/ntfscluster
  127. /bin/ntfscmp
  128. /bin/ntfsfix
  129. /bin/ntfsinfo
  130. /bin/ntfsls
  131. # extras
  132. /bin/ntfsck
  133. /bin/ntfsdecrypt
  134. /bin/ntfsdump_logfile
  135. /bin/ntfsmftalloc
  136. /bin/ntfsmove
  137. /bin/ntfstruncate
  138. /bin/ntfswipe
  139. /sbin/fsck.ntfs
  140. /sbin/mkfs.ntfs
  141. /sbin/mkntfs
  142. /sbin/ntfsclone
  143. /sbin/ntfscp
  144. /sbin/ntfslabel
  145. /sbin/ntfsresize
  146. /sbin/ntfsundelete
  147. %{_mandir}/man8/mkntfs.8*
  148. %{_mandir}/man8/mkfs.ntfs.8*
  149. %{_mandir}/man8/ntfs[^m][^o]*.8*
  150. %changelog
  151. * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2013.1.13-1
  152. - new upstream release
  153. * Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
  154. - new upstream release
  155. - merge ntfsprogs
  156. - add Obsoletes and Provides ntfsprogs*
  157. - add BR: for ntfsprogs
  158. * Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
  159. - new upstream release
  160. - fix %%files (add lowntfs-3g)
  161. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
  162. - new upstream release
  163. - use internal fuse-lite, remove BR: fuse-devel and R: fuse
  164. - move binaries to /bin
  165. - move libraries to /%%{_lib}
  166. - add fdi file to enable hal automounting
  167. * Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
  168. - new upstream release
  169. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
  170. - new upstream release
  171. * Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
  172. - new upstream release
  173. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
  174. - new upstream release
  175. * Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
  176. - initial build for Vine Linux
  177. * Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
  178. - bump to 1.516
  179. - fix bugzilla 232031
  180. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
  181. - bump to 1.417
  182. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
  183. - bump to 1.416
  184. - drop patch0, upstreamed
  185. * Wed Apr 4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
  186. - allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
  187. * Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
  188. - bump to 1.328
  189. - drop patch, use --disable-ldconfig instead
  190. * Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
  191. - 1.0 release!
  192. * Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
  193. - symlink to mount.ntfs
  194. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
  195. - bump to 20070118
  196. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
  197. - bump to latest version for all active dists
  198. * Wed Jan 3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
  199. - bump to latest version (note that upstream fixed their date mistake)
  200. * Wed Nov 1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
  201. - add an obsoletes for ntfsprogs-fuse
  202. - make some convenience symlinks
  203. * Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
  204. - add some extra Provides
  205. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
  206. - add explicit Requires on fuse
  207. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
  208. - fixed versioning (bumped epoch, since it now shows as older)
  209. - change sbin symlink to actual copy to be safe
  210. * Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
  211. - Initial package for Fedora Extras