stunnel-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582
  1. %bcond_with systemd
  2. %bcond_with crypto_policies
  3. Summary: An SSL-encrypting socket wrapper
  4. Name: stunnel
  5. Version: 5.59
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: internet
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: iwaim
  11. License: GPLv2
  12. URL: https://www.stunnel.org/
  13. Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
  14. Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
  15. Source2: Certificate-Creation
  16. Source3: sfinger.xinetd
  17. Source4: stunnel-sfinger.conf
  18. Source5: pop3-redirect.xinetd
  19. Source6: stunnel-pop3s-client.conf
  20. Source7: stunnel@.service
  21. Source100: stunnel.init
  22. Patch0: stunnel-5.50-authpriv.patch
  23. Patch1: stunnel-5.50-systemd-service.patch
  24. Patch3: stunnel-5.56-system-ciphers.patch
  25. Patch4: stunnel-5.56-coverity.patch
  26. Patch5: stunnel-5.56-default-tls-version.patch
  27. Patch6: stunnel-5.56-curves-doc-update.patch
  28. BuildRoot: %{_tmppath}/stunnel-root
  29. # util-linux is needed for rename
  30. BuildRequires: openssl-devel
  31. BuildRequires: pkgconfig
  32. BuildRequires: util-linux
  33. %if %{with systemd}
  34. %{?systemd_requires}
  35. %else
  36. Requires(post): chkconfig
  37. Requires(preun): chkconfig /sbin/service
  38. Requires(postun): /sbin/service
  39. %endif
  40. %if %{with systemd}
  41. %global pidfile %{_rundir}/stunnel.pid
  42. %else
  43. %global pidfile %{_localstatedir}/run/stunnel.pid
  44. %endif
  45. # Do not generate provides for private libraries
  46. %global __provides_exclude_from ^%{_libdir}/stunnel/.*$
  47. %description
  48. Stunnel is a socket wrapper which can provide SSL (Secure Sockets
  49. Layer) support to ordinary applications. For example, it can be used
  50. in conjunction with imapd to create an SSL secure IMAP server.
  51. %debug_package
  52. %prep
  53. %setup -q
  54. %patch0 -p1
  55. %patch1 -p1
  56. %if %{with crypto_policies}
  57. %patch3 -p1
  58. %endif
  59. %patch4 -p1
  60. %patch5 -p1
  61. %patch6 -p1
  62. # Fix a testcase with system-ciphers support
  63. sed -i '/client = yes/a \\ ciphers = PSK' tests/recipes/014_PSK_secrets
  64. # modify systemd service unit
  65. sed -i '/Type=forking/a \\PrivateTmp=true' tools/stunnel.service.in
  66. %build
  67. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  68. if pkg-config openssl ; then
  69. CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
  70. LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
  71. fi
  72. %configure --disable-fips --enable-ipv6 --with-ssl=%{_prefix} \
  73. CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{pidfile}\"'"
  74. make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
  78. touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
  79. make install DESTDIR=$RPM_BUILD_ROOT
  80. # Move the translated man pages to the right subdirectories, and strip off the
  81. # language suffixes.
  82. for lang in pl ; do
  83. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
  84. mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
  85. rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
  86. done
  87. mkdir -p srpm-docs
  88. cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
  89. %if %{with systemd}
  90. mkdir -p %{buildroot}%{_unitdir}
  91. cp %{buildroot}%{_datadir}/doc/stunnel/examples/%{name}.service %{buildroot}%{_unitdir}/%{name}.service
  92. cp %{SOURCE7} %{buildroot}%{_unitdir}/%{name}@.service
  93. %else
  94. install -d -m755 %{buildroot}%{_initdir}
  95. install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
  96. install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
  97. cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
  98. ENABLED=0
  99. EOF
  100. %endif
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %post
  104. %if %{with systemd}
  105. %systemd_post %{name}.service
  106. %else
  107. /sbin/chkconfig --add stunnel
  108. %endif
  109. %preun
  110. %if %{with systemd}
  111. %systemd_preun %{name}.service
  112. %else
  113. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  114. /sbin/service stunnel stop /dev/null 2>/dev/null ||:
  115. /sbin/chkconfig --del stunnel
  116. fi
  117. %endif
  118. %postun
  119. %if %{with systemd}
  120. %systemd_postun_with_restart %{name}.service
  121. %else
  122. if [ $1 -gt 0 ]; then
  123. if /sbin/service stunnel status >/dev/null; then
  124. /sbin/service stunnel restart
  125. fi
  126. fi
  127. %endif
  128. %files
  129. %defattr(-,root,root)
  130. %doc AUTHORS.md BUGS.md CREDITS.md PORTS.md README.md TODO.md
  131. %doc tools/stunnel.conf-sample
  132. %doc srpm-docs/*
  133. %license COPY*
  134. %lang(en) %doc doc/en/*
  135. %lang(po) %doc doc/pl/*
  136. %{_bindir}/stunnel
  137. %exclude %{_bindir}/stunnel3
  138. %exclude %{_datadir}/doc/stunnel
  139. %{_libdir}/stunnel
  140. %exclude %{_libdir}/stunnel/libstunnel.la
  141. %{_mandir}/man8/stunnel.8*
  142. %lang(pl) %{_mandir}/pl/man8/stunnel.8*
  143. %dir %{_sysconfdir}/%{name}
  144. %dir %{_sysconfdir}/%{name}/conf.d
  145. %exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
  146. %exclude %{_sysconfdir}/stunnel/stunnel.pem
  147. %if %{with systemd}
  148. %{_unitdir}/%{name}*.service
  149. %else
  150. %{_initdir}/stunnel
  151. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  152. %endif
  153. %changelog
  154. * Thu May 06 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.59-1
  155. - new upstream release.
  156. - diabled crypto-policies (not implemented for Vine Linux).
  157. * Sun Feb 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.58-1
  158. - new upstream release.
  159. - uodated patches.
  160. * Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.56-1
  161. - new upstream release.
  162. - replaced all patches.
  163. - added systemd support (disabled as default).
  164. * Sat Dec 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.49-1
  165. - new upstream release.
  166. - updated Patch0,1.
  167. * Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 5.32-2
  168. - rebuid with OpenSSL 1.0.2k
  169. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.32-1
  170. - new upstream release.
  171. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.31-1
  172. - new upstream release.
  173. * Fri Nov 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
  174. - new upstream release.
  175. - fixed dates in %%changelog.
  176. - updated all patches.
  177. * Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
  178. - initial build for Vine Linux
  179. *Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
  180. - 884183: support for full relro.
  181. *Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
  182. - New upstream realease 4.54
  183. - Updated local patches
  184. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
  185. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  186. * Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
  187. - New upstream realease 4.53
  188. - Updated local patches
  189. * Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
  190. - New upstream realease 4.52
  191. - Updated local patches
  192. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
  193. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  194. * Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
  195. - New upstream realease 4.50
  196. - Updated local patches
  197. * Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
  198. - New upstream realease 4.44
  199. - Updated local patches
  200. * Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
  201. - New upstream realease 4.42
  202. - Updated local patches
  203. - Fixes #732069
  204. * Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
  205. - New upstream realease 4.41
  206. - Updated local patches to match the new release
  207. * Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
  208. - New upstream realease 4.37
  209. - Updated local patches to match the new release
  210. * Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
  211. - New upstream realease 4.35
  212. - Updated authpriv and sample patches to match the new release
  213. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
  214. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  215. * Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
  216. - New upstream realease 4.34
  217. - Updated authpriv and sample patches to match the new release
  218. * Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
  219. - New upstream realease 4.33
  220. - Updated authpriv and sample patches to match the new release
  221. - Addresses bz 580117 (inted mode support issue)
  222. * Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
  223. - New upstream realease 4.32
  224. - Updated authpriv and sample patches to match the new release
  225. * Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
  226. - New upstream realease 4.31
  227. - Updated authpriv and sample patches to match the new release
  228. * Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
  229. - New upstream realease 4.30
  230. - Updated authpriv and sample patches for the new release
  231. * Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
  232. - New upstream realease 4.29
  233. - Updated authpriv and sample patches for the new release
  234. - Modified spec file to include dist tag
  235. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
  236. - rebuilt with new openssl
  237. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
  238. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  239. * Sun May 3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
  240. - Fix the previous patch.
  241. * Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
  242. - Avoid aliasing undefined by ISO C
  243. * Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
  244. - Update to stunnel-4.27.
  245. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
  246. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  247. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
  248. - disable openssl upstream fips mode
  249. * Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
  250. - Update to stunnel-4.26.
  251. * Sun Jun 8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
  252. - Use a clearer error message if the service name is unknown in "accept"
  253. Resolves: #450344
  254. * Mon Jun 2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
  255. - Update to stunnel-4.25
  256. * Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
  257. - Drop stunnel3
  258. Resolves: #442842
  259. * Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
  260. - Update to stunnel-4.24
  261. * Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
  262. - Update to stunnel-4.22
  263. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
  264. - Autorebuild for GCC 4.3
  265. * Tue Dec 4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
  266. - Rebuild with openssl-0.9.8g
  267. * Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
  268. - Revert the port to NSS, wait for NSS-based stunnel 5.x instead
  269. Resolves: #301971
  270. - Mark localized man pages with %%lang (patch by Ville Skyttä)
  271. Resolves: #322281
  272. * Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
  273. - Port to NSS
  274. * Mon Dec 4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
  275. - Update BuildRequires for the separate tcp_wrappers-devel package
  276. * Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
  277. - Update to stunnel-4.20
  278. * Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
  279. - Update to stunnel-4.19
  280. * Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
  281. - Update to stunnel-4.18
  282. - Remove unused stunnel.cnf from the src.rpm
  283. - Fix some rpmlint warnings
  284. * Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
  285. - rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
  286. (#203001)
  287. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
  288. - rebuild
  289. * Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
  290. - Update to stunnel-4.15
  291. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
  292. - bump again for double-long bug on ppc(64)
  293. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
  294. - rebuilt for new gcc4.1 snapshot and glibc changes
  295. * Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
  296. - Use pthread threading to fix crash on x86_64 (#179236)
  297. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  298. - rebuilt
  299. * Wed Nov 9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
  300. - Rebuild with newer openssl
  301. * Thu Nov 3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
  302. - Update to stunnel-4.14
  303. - Override changed default pid file location, keep it in %%{_localstatedir}/run
  304. * Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
  305. - Update to stunnel-4.13
  306. * Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
  307. - Update to stunnel-4.12
  308. * Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
  309. - Enable IPv6 (#169050, patch by Peter Bieringer)
  310. - Don't ship another copy of man pages in HTML
  311. * Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
  312. - Update to stunnel-4.11
  313. - Fix int/size_t mismatches in stack_info ()
  314. - Update Certificate-Creation for /etc/pki
  315. * Wed Jun 1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
  316. - Fix inetd mode
  317. - Remove unnecessary Requires: and BuildRequires:
  318. - Clean up the spec file
  319. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
  320. - update to 4.10
  321. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
  322. - add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
  323. coreutils (#133961)
  324. * Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
  325. - update to 4.08
  326. - build stunnel as a PIE binary
  327. * Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
  328. - Convert man pages to UTF-8
  329. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  330. - rebuilt
  331. * Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
  332. - move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
  333. * Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
  334. - update to 4.05
  335. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  336. - rebuilt
  337. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  338. - rebuilt
  339. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
  340. - Fix libtool
  341. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  342. - rebuilt
  343. * Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
  344. - fix xinetd configuration samples
  345. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
  346. - rebuild
  347. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  348. - rebuilt
  349. * Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
  350. - update to 4.04
  351. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
  352. - use pkgconfig for information about openssl, if available
  353. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  354. - update to 4.03
  355. * Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
  356. - update to 4.02
  357. * Fri Oct 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
  358. - don't create a dummy cert
  359. * Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
  360. - update to 4.00
  361. - remove textutils and fileutils as buildreqs, add automake/autoconf
  362. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  363. - automated rebuild
  364. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  365. - automated rebuild
  366. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
  367. - rebuild in new environment
  368. * Wed Jan 2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
  369. - update to 3.22, correcting a format-string vulnerability
  370. * Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
  371. - update to 3.21a
  372. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
  373. - log using LOG_AUTHPRIV facility by default (#47289)
  374. - make permissions on stunnel binary 0755
  375. - implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
  376. * Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
  377. - update to 3.19 to avoid problems with stunnel being multithreaded, but
  378. tcp wrappers not being thrad-safe
  379. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  380. - update to 3.17
  381. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  382. - update to 3.16
  383. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  384. - update to 3.15
  385. - enable tcp-wrappers support
  386. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  387. - remove explicit requirement on openssl (specific version isn't enough,
  388. we have to depend on shared library version anyway)
  389. * Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  390. - update to 3.14
  391. * Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
  392. - depend on make (#33148)
  393. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  394. - rebuild in new environment
  395. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  396. - update to 3.13 to get pthread, OOB, 64-bit fixes
  397. - don't need sdf any more
  398. * Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  399. - pull in sdf to build the man page (#22892)
  400. * Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  401. - update to 3.11
  402. - chuck the SIGHUP patch (went upstream)
  403. - chuck parts of the 64-bit clean patch (went upstream)
  404. * Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  405. - update to 3.10
  406. - more 64-bit clean changes, hopefully the last bunch
  407. * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  408. - change piddir from the default /var/stunnel to /var/run
  409. - clean out pid file on SIGHUP
  410. * Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
  411. - update to 3.9 to get a security fix
  412. * Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
  413. - change all unsigned longs to u_int32_t when dealing with network
  414. addresses
  415. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  416. - make stunnel.pem also be (missingok)
  417. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  418. - move to Applications/Internet group
  419. - clean up %%post script
  420. - make stunnel.pem %%ghost %%config(noreplace)
  421. - provide a sample file for use with xinetd
  422. * Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  423. - FHS compliance fixes
  424. - modify defaults
  425. * Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  426. - update to 3.8
  427. - do not create certificate if one already exists
  428. * Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  429. - update to 3.7
  430. - add patch to find /usr/share/ssl
  431. - change some perms
  432. * Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  433. - Modify spec file to match Red Hat standards
  434. * Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
  435. - Updated to 3.4a
  436. - Patched for OpenSSL 0.9.4
  437. - Cleaned up files section
  438. * Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
  439. - Updated to 3.3
  440. * Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
  441. - Initial RPMification