wpa_supplicant-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305
  1. Summary: WPA/WPA2/IEEE 802.1X Supplicant
  2. Name: wpa_supplicant
  3. Version: 0.7.3
  4. Release: 2%{?_dist_release}
  5. License: BSD
  6. Group: System Environment/Base
  7. URL: http://w1.fi/wpa_supplicant/
  8. Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
  9. Source1: %{name}.build-config
  10. Source2: %{name}.conf
  11. Source3: %{name}.init.d
  12. Source4: %{name}.sysconfig
  13. Source6: %{name}.logrotate
  14. # import from Fedora package
  15. # distro specific customization and not suitable for upstream,
  16. # works around busted drivers
  17. Patch0: wpa_supplicant-assoc-timeout.patch
  18. # ensures that debug output gets flushed immediately to help diagnose driver
  19. # bugs, not suitable for upstream
  20. Patch1: wpa_supplicant-flush-debug-output.patch
  21. # disto specific customization for log paths, not suitable for upstream
  22. Patch2: wpa_supplicant-dbus-service-file-args.patch
  23. # quiet an annoying and frequent syslog message
  24. Patch3: wpa_supplicant-quiet-scan-results-message.patch
  25. # recover from streams of driver disconnect messages (iwl3945)
  26. Patch4: wpa_supplicant-squelch-driver-disconnect-spam.patch
  27. # allow more private key encryption algorithms
  28. Patch5: wpa_supplicant-openssl-more-algs.patch
  29. # Send PropertyChanged notificationes when the BSS list changes
  30. Patch7: wpa_supplicant-bss-changed-prop-notify.patch
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. BuildRequires: qt4-devel
  33. BuildRequires: qt4-designer
  34. BuildRequires: openssl-devel
  35. BuildRequires: readline-devel
  36. BuildRequires: dbus-devel
  37. BuildRequires: libnl-devel
  38. Requires(post): chkconfig
  39. Requires(preun): chkconfig
  40. %description
  41. wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
  42. for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
  43. component that is used in the client stations. It implements key negotiation
  44. with a WPA Authenticator and it controls the roaming and IEEE 802.11
  45. authentication/association of the wlan driver.
  46. %package gui
  47. Summary: Graphical User Interface for %{name}
  48. Summary(ja): wpa_supplicant のグラフィカルユーザインタフェース
  49. Group: Applications/System
  50. %description gui
  51. Graphical User Interface for wpa_supplicant written using QT4
  52. %description -l ja gui
  53. QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
  54. %prep
  55. %setup -q
  56. %patch0 -p1 -b .assoc-timeout
  57. %patch1 -p1 -b .flush-debug-output
  58. %patch2 -p1 -b .dbus-service-file
  59. %patch3 -p1 -b .quiet-scan-results-msg
  60. %patch4 -p1 -b .disconnect-spam
  61. %patch5 -p1 -b .more-openssl-algs
  62. %patch7 -p1 -b .bss-changed-prop-notify
  63. %build
  64. pushd wpa_supplicant
  65. cp %{SOURCE1} ./.config
  66. CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ;
  67. CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ;
  68. make %{_smp_mflags}
  69. PATH=$PATH:%{_libdir}/qt4/bin QTDIR=%{_libdir}/qt4 make wpa_gui-qt4 %{_smp_mflags}
  70. popd
  71. %install
  72. rm -rf %{buildroot}
  73. # init scripts
  74. install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
  75. install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
  76. install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
  77. # config
  78. install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
  79. # binary
  80. install -d %{buildroot}/%{_sbindir}
  81. install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
  82. install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
  83. install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
  84. install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
  85. install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  86. install -D -m 0644 %{name}/dbus/fi.epitest.hostap.WPASupplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
  87. # gui
  88. install -d %{buildroot}/%{_bindir}
  89. install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
  90. # running
  91. mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
  92. # man pages
  93. install -d %{buildroot}%{_mandir}/man{5,8}
  94. install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
  95. install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
  96. # some cleanup in docs
  97. rm -f %{name}/doc/.cvsignore
  98. rm -rf %{name}/doc/docbook
  99. %clean
  100. rm -rf %{buildroot}
  101. %post
  102. if [ $1 = 1 ]; then
  103. chkconfig --add %{name}
  104. fi
  105. %preun
  106. if [ $1 = 0 ]; then
  107. service %{name} stop > /dev/null 2>&1
  108. killall -TERM wpa_supplicant >/dev/null 2>&1
  109. /sbin/chkconfig --del %{name}
  110. fi
  111. %files
  112. %defattr(-, root, root)
  113. %doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
  114. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  115. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  116. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  117. %{_sysconfdir}/rc.d/init.d/%{name}
  118. %{_sysconfdir}/dbus-1/system.d/%{name}.conf
  119. %{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
  120. %{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  121. %{_sbindir}/wpa_passphrase
  122. %{_sbindir}/wpa_supplicant
  123. %{_sbindir}/wpa_cli
  124. %dir %{_localstatedir}/run/%{name}
  125. %dir %{_sysconfdir}/%{name}
  126. %{_mandir}/man8/*
  127. %{_mandir}/man5/*
  128. %files gui
  129. %defattr(-, root, root)
  130. %{_bindir}/wpa_gui
  131. %changelog
  132. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
  133. - rebuild with openssl-1.0.0c
  134. - add BuildRequires: qt4-designer, libnl-devel
  135. * Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
  136. - new upstream release
  137. - update patches
  138. - change License to BSD due to linkage against OpsnSSL since there is no
  139. OpenSSL exception in upstream GPLv2 license text.
  140. - build with qt4
  141. - update build config
  142. * Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
  143. - new upstream release
  144. - remove hostap/madwifi/prism54 drivers, use 'wext' instead.
  145. - drop upstream patches
  146. - import some fedora patches
  147. - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
  148. - Better scanning behavior on resume from suspend/hibernate
  149. - Better interaction with newer kernels and drivers
  150. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
  151. - start wpa_supplicant by default.
  152. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
  153. - new upstream release
  154. - import some fedora patches
  155. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
  156. - rebuild with new openssl
  157. * Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
  158. - new upstream release
  159. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
  160. - initial build for Vine Linux based on FC package.
  161. * Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
  162. - Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
  163. - Fix up madwifi-ng private ioctl()s for r1331 and later
  164. - Update madwifi headers to r1475
  165. * Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
  166. - Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
  167. * Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
  168. - Fix control interface key obfuscation a bit
  169. * Sun Apr 2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
  170. - Work around older & incorrect drivers that return null-terminated SSIDs
  171. * Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
  172. - Add patch to make orinoco happy with WEP keys
  173. - Enable Prism54-specific driver
  174. - Disable ipw-specific driver; ipw2x00 should be using WEXT instead
  175. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
  176. - Increase association timeout, mainly for drivers that don't
  177. fully support WPA ioctls yet
  178. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
  179. - Add additional BuildRequires #rh181914#
  180. - Add prereq on chkconfig #rh182905# #rh182906#
  181. - Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
  182. * Wed Mar 1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
  183. - Install wpa_passphrase too #rh183480#
  184. * Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
  185. - Don't expose private data on the control interface unless requested
  186. * Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
  187. - Downgrade to 0.4.8 stable release rather than a dev release
  188. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
  189. - Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
  190. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
  191. - Move initscript to /etc/rc.d/init.d
  192. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
  193. - bump again for double-long bug on ppc(64)
  194. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
  195. - rebuilt for new gcc4.1 snapshot and glibc changes
  196. * Sun Feb 5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
  197. - Update to 0.5.1
  198. - Add WE auth fallback to actually work with older drivers
  199. * Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
  200. - Bring package into Fedora Core
  201. - Add ap_scan control interface patch
  202. - Enable madwifi-ng driver
  203. * Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
  204. - upgrade to 0.4.7
  205. - added package w/ wpa_gui in it
  206. * Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
  207. - upgrade to 0.4.6
  208. - adding ctrl interface changes recommended
  209. by Hugo Paredes <hugo.paredes@e-know.org>
  210. * Sun Oct 9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
  211. - upgrade to 0.4.5
  212. - updated config file wpa_supplicant is built with
  213. especially, the ipw2100 driver changed to just ipw
  214. and enabled a bunch more EAP
  215. - disabled dist tag
  216. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
  217. - fix typo in init script
  218. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
  219. - fixing init script using fedora-extras' template
  220. - removing chkconfig default startup
  221. * Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
  222. - upgrade to 0.4.2
  223. - new sample conf file that will use any unrestricted AP
  224. - make sysconfig config entry
  225. - new BuildRoot for Fedora Extras
  226. - adding dist tag to Release
  227. * Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
  228. - upgrade to 0.3.8
  229. * Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
  230. - compile ipw driver in
  231. * Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
  232. - upgrade to 0.3.6
  233. * Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
  234. - fixing init script
  235. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
  236. - fixing init script
  237. - adding post/preun items to add/remove via chkconfig
  238. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
  239. - adding sysV scripts
  240. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
  241. - Initial RPM release.