clang-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. # Documentation install path
  6. %global llvmdocdir() %{_docdir}/%1-%{version}
  7. %define _unpackaged_files_terminate_build 1
  8. Summary: A C language family front-end for LLVM
  9. Summary(ja): LLVM の C 言語フロントエンド
  10. Name: clang
  11. Version: 13.0.1
  12. Release: 1%{?_dist_release}
  13. Group: programming
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: NCSA
  17. URL: https://llvm.org/
  18. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
  19. Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
  20. # multilib fixes
  21. Source11: clang-config.h
  22. # Patches for clang
  23. Patch0: 0001-PATCH-clang-Reorganize-gtest-integration.patch
  24. Patch1: 0002-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
  25. Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
  26. Patch3: 0001-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
  27. Patch4: 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
  28. Patch5: 0001-PATCH-clang-Fix-scan-build-py-executable-lookup-path.patch
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  30. BuildRequires: cmake
  31. BuildRequires: ninja
  32. BuildRequires: llvm-devel = %{version}
  33. BuildRequires: llvm-static = %{version}
  34. BuildRequires: libatomic
  35. BuildRequires: libxml2-devel
  36. BuildRequires: perl
  37. BuildRequires: ncurses-devel
  38. BuildRequires: python3
  39. BuildRequires: python3-devel
  40. Requires: llvm = %{version}-%{release}
  41. # clang requires gcc, clang++ requires libstdc++-devel
  42. Requires: libstdc++-devel
  43. # LLVM is not supported on PPC64
  44. # http://llvm.org/bugs/show_bug.cgi?id=3729
  45. ExcludeArch: ppc64
  46. %description
  47. clang: noun
  48. 1. A loud, resonant, metallic sound.
  49. 2. The strident call of a crane or goose.
  50. 3. C-language family front-end toolkit.
  51. The goal of the Clang project is to create a new C, C++, Objective C
  52. and Objective C++ front-end for the LLVM compiler. Its tools are built
  53. as libraries and designed to be loosely-coupled and extensible.
  54. %Package libs
  55. Summary: Runtime library for clang
  56. Summary(ja): Clang のランタイムライブラリ
  57. Group: system
  58. %description libs
  59. Runtime library for clang.
  60. %description libs -l ja
  61. Clang のランタイムライブラリです.
  62. %package devel
  63. Summary: Header files for clang
  64. Summary(ja): Clang のヘッダファイル
  65. Group: programming
  66. Requires: clang = %{version}-%{release}
  67. %description devel
  68. This package contains header files for the Clang compiler.
  69. %description devel -l ja
  70. Clang コンパイラのヘッダファイル集です.
  71. %package analyzer
  72. Summary: A source code analysis framework
  73. Summary(ja): ソースコード分析フレームワーク
  74. License: NCSA
  75. Group: programming
  76. Requires: clang = %{version}-%{release}
  77. # not picked up automatically since files are currently not instaled
  78. # in standard Python hierarchies yet
  79. Requires: python3
  80. %description analyzer
  81. The Clang Static Analyzer consists of both a source code analysis
  82. framework and a standalone tool that finds bugs in C and Objective-C
  83. programs. The standalone tool is invoked from the command-line, and is
  84. intended to run in tandem with a build of a project or code base.
  85. %package -n python3-clang
  86. Summary: Python3 bindings for clang
  87. Group: programming
  88. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  89. Requires: python3
  90. %description -n python3-clang
  91. Python3 bindings for clang
  92. %package tools-extra
  93. Summary: Extra tools for clang
  94. Group: programming
  95. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  96. %description tools-extra
  97. A set of extra tools built using Clang's tooling API.
  98. %debug_package
  99. %prep
  100. %setup -T -q -b 1 -n clang-tools-extra-%{version}.src
  101. %autopatch -m200 -p2
  102. # failing test case
  103. rm test/clang-tidy/checkers/altera-struct-pack-align.cpp
  104. pathfix%{python3_version}.py -i %{__python3} -pn \
  105. clang-tidy/tool/*.py \
  106. clang-include-fixer/find-all-symbols/tool/run-find-all-symbols.py
  107. %setup -q -n clang-%{version}.src
  108. %autopatch -M200 -p2
  109. # failing test case
  110. rm test/CodeGen/profile-filter.c
  111. pathfix%{python3_version}.py -i %{__python3} -pn \
  112. tools/clang-format/*.py \
  113. tools/clang-format/git-clang-format \
  114. utils/hmaptool/hmaptool \
  115. tools/scan-view/bin/scan-view
  116. sed -i -e 's/"i686-linux-gnu",/"i686-linux-gnu","i686-vine-linux","i686-vine-linux-gnu",/' lib/Driver/ToolChains/Gnu.cpp
  117. sed -i -e 's/"x86_64-linux-gnu",/"x86_64-linux-gnu","x86_64-vine-linux","x86_64-vine-linux-gnu",/' lib/Driver/ToolChains/Gnu.cpp
  118. sed -i -e 's/"ld"/"ld.gold"/' include/clang/Driver/ToolChain.h
  119. %build
  120. # lto builds with gcc 11 fail while running the lit tests.
  121. %define _lto_cflags %{nil}
  122. %ifarch s390 s390x %{arm} %ix86
  123. # Decrease debuginfo verbosity to reduce memory consumption during final library linking
  124. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  125. %endif
  126. %cmake \
  127. -GNinja \
  128. -DLLVM_PARALLEL_LINK_JOBS=1 \
  129. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  130. -DCMAKE_BUILD_TYPE=Release \
  131. -DPYTHON_EXECUTABLE=%{__python3} \
  132. -DCMAKE_INSTALL_RPATH:BOOL=";" \
  133. -DLLVM_EXTERNAL_CLANG_TOOLS_EXTRA_SOURCE_DIR=../clang-tools-extra-%{version}.src \
  134. %if 0%{?__isa_bits} == 64
  135. -DLLVM_LIBDIR_SUFFIX=64 \
  136. %else
  137. -DLLVM_LIBDIR_SUFFIX= \
  138. %endif
  139. \
  140. -DLLVM_TABLEGEN_EXE:FILEPATH=%{_bindir}/llvm-tblgen \
  141. -DCLANG_ENABLE_ARCMT:BOOL=ON \
  142. -DCLANG_ENABLE_STATIC_ANALYZER:BOOL=ON \
  143. -DCLANG_ENABLE_ARCMT:BOOL=ON \
  144. -DCLANG_ENABLE_STATIC_ANALYZER:BOOL=ON \
  145. -DCLANG_INCLUDE_DOCS:BOOL=ON \
  146. -DCLANG_INCLUDE_TESTS:BOOL=ON \
  147. -DCLANG_PLUGIN_SUPPORT:BOOL=ON \
  148. \
  149. -DCLANG_INCLUDE_DOCS:BOOL=ON \
  150. -DCLANG_PLUGIN_SUPPORT:BOOL=ON \
  151. -DENABLE_LINKER_BUILD_ID:BOOL=ON \
  152. -DLLVM_ENABLE_EH=ON \
  153. -DLLVM_ENABLE_RTTI=ON \
  154. -DLLVM_BUILD_DOCS=ON \
  155. -DLLVM_ENABLE_SPHINX=OFF \
  156. -DCLANG_LINK_CLANG_DYLIB=ON \
  157. \
  158. -DCLANG_LINK_CLANG_DYLIB=ON \
  159. -DCLANG_BUILD_EXAMPLES:BOOL=OFF \
  160. -DBUILD_SHARED_LIBS=OFF \
  161. -DCLANG_REPOSITORY_STRING="Vine Linux %{version}-%{release}" \
  162. -DCLANG_DEFAULT_UNWINDLIB=libgcc
  163. %cmake_build
  164. %install
  165. rm -rf %{buildroot}
  166. %cmake_install
  167. # remove static libraries
  168. rm -fv %{buildroot}%{_libdir}/libclang*.a
  169. # install clang python bindings
  170. mkdir -p %{buildroot}%{python3_sitelib}/clang/
  171. install -p -m644 bindings/python/clang/* %{buildroot}%{python3_sitelib}/clang/
  172. # install scanbuild-py to python sitelib.
  173. mv %{buildroot}%{_prefix}/lib/{libear,libscanbuild} %{buildroot}%{python3_sitelib}
  174. mv -v %{buildroot}%{_includedir}/clang/Config/config{,-%{__isa_bits}}.h
  175. install -m 0644 %{SOURCE11} %{buildroot}%{_includedir}/clang/Config/config.h
  176. # TODO: Package html docs
  177. rm -Rvf %{buildroot}%{_docdir}/clang/html
  178. rm -Rvf %{buildroot}%{_datadir}/clang/clang-doc-default-stylesheet.css
  179. rm -Rvf %{buildroot}%{_datadir}/clang/index.js
  180. # remove git integration
  181. rm -vf %{buildroot}%{_bindir}/git-clang-format
  182. # remove editor integrations (bbedit, sublime, emacs, vim)
  183. rm -vf %{buildroot}%{_datadir}/clang/clang-format-bbedit.applescript
  184. rm -vf %{buildroot}%{_datadir}/clang/clang-format-sublime.py*
  185. rm -vf %{buildroot}%{_datadir}/clang/clang-format.el
  186. rm -vf %{buildroot}%{_datadir}/clang/clang-format.py*
  187. # remove diff reformatter
  188. rm -vf %{buildroot}%{_datadir}/clang/clang-format-diff.py*
  189. rm -f %{buildroot}%{_datadir}/clang/bash-autocomplete.sh
  190. rm -f %{buildroot}%{_datadir}/clang/clang-rename.el
  191. rm -f %{buildroot}%{_datadir}/clang/clang-rename.py
  192. rm -f %{buildroot}%{_datadir}/clang/clang-include-fixer.el
  193. rm -f %{buildroot}%{_datadir}/clang/clang-include-fixer.py
  194. # Remove clang-tidy headers. We don't ship the libraries for these.
  195. rm -Rvf %{buildroot}%{_includedir}/clang-tidy/
  196. %if %{with test}
  197. %check
  198. %ctest check-clang
  199. %endif
  200. %clean
  201. rm -rf %{buildroot}
  202. %files
  203. %defattr(-,root,root,-)
  204. #doc %{llvmdocdir clang}/
  205. %{_bindir}/clang
  206. %{_bindir}/clang++
  207. %{_bindir}/clang-%{ver_suffix}
  208. %{_bindir}/clang-cl
  209. %{_bindir}/clang-cpp
  210. %files libs
  211. %defattr(-,root,root,-)
  212. %{_libdir}/clang
  213. %{_libdir}/libclang.so.*
  214. %{_libdir}/libclang-cpp.so.*
  215. %files devel
  216. %defattr(-,root,root,-)
  217. #doc %{llvmdocdir clang-devel}/
  218. %{_libdir}/libclang.so
  219. %{_libdir}/libclang-cpp.so
  220. %{_includedir}/clang
  221. %{_includedir}/clang-c
  222. %dir %{_datadir}/clang/
  223. %{_libdir}/cmake/*
  224. %files analyzer
  225. %defattr(-,root,root,-)
  226. %{_bindir}/analyze-build
  227. %{_bindir}/intercept-build
  228. %{_bindir}/scan-build
  229. %{_bindir}/scan-build-py
  230. %{_bindir}/scan-view
  231. %{_libexecdir}/ccc-analyzer
  232. %{_libexecdir}/c++-analyzer
  233. %{_libexecdir}/analyze-c++
  234. %{_libexecdir}/analyze-cc
  235. %{_libexecdir}/intercept-c++
  236. %{_libexecdir}/intercept-cc
  237. %{_datadir}/scan-view
  238. %{_datadir}/scan-build
  239. %{_mandir}/man1/scan-build.1.*
  240. %{python3_sitelib}/libear
  241. %{python3_sitelib}/libscanbuild
  242. %files -n python3-clang
  243. %{python3_sitelib}/clang/
  244. %files tools-extra
  245. %{_bindir}/c-index-test
  246. %{_bindir}/clang*
  247. %exclude %{_bindir}/clang
  248. %exclude %{_bindir}/clang++
  249. %exclude %{_bindir}/clang-%{ver_suffix}
  250. %exclude %{_bindir}/clang-cl
  251. %exclude %{_bindir}/clang-cpp
  252. %{_bindir}/diagtool
  253. %{_bindir}/find-all-symbols
  254. %{_bindir}/hmaptool
  255. %{_bindir}/modularize
  256. %{_bindir}/pp-trace
  257. %{_bindir}/run-clang-tidy
  258. %{_datadir}/clang/clang-tidy-diff.py*
  259. %{_datadir}/clang/run-find-all-symbols.py*
  260. %changelog
  261. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  262. - new upstream release.
  263. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  264. - new upstream release.
  265. - refreshed patches.
  266. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  267. - new upstream release.
  268. - refreshed patches.
  269. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  270. - devided clang from llvm.
  271. - new upstream release.
  272. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  273. - enabled to build utils.
  274. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  275. - new upstream release.
  276. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  277. - new upstream release.
  278. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  279. - rebuilt with libffi-3.3.
  280. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  281. - new upstream release.
  282. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  283. - new upstream release.
  284. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  285. - dropped all patches.
  286. - switched build-system to ninja.
  287. - switched python to python3.
  288. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  289. - new upstream release.
  290. - added OpenMP.
  291. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  292. - fixed %%files.
  293. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  294. - new upstream release.
  295. - dropped Patch0, 4, 5, 100 and 200.
  296. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  297. - renamed a subpackage "llvm-libs".
  298. - added a subpackage "lld".
  299. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  300. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  301. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  302. - new upstream release.
  303. - dropped Patch1 and 2: fixed in upstream.
  304. - imported Patch0, 3-5, 100 and 200 from rawhide.
  305. - disabled Patch1002: no longer needed?
  306. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  307. - new upstream release.
  308. - switched to cmake.
  309. - disable ocaml binding as default.
  310. - updated Patch1000 and 1002.
  311. - disabled Patch1000 as default.
  312. - cleanup patches.
  313. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  314. - rebuild with gcc-5.4.0
  315. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  316. - new upstream release
  317. - added BR: ocaml-ctypes
  318. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  319. - new upstream release
  320. - dropt Patch 1, 201 and 1001
  321. - updated Patch 1000
  322. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  323. - updated to 3.5.1
  324. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  325. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  326. - obsoleted clang-doc
  327. - built with ocaml 4.02.1
  328. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  329. - fix <BTS:2832>
  330. - fix configure option "--with-c-include-dirs"
  331. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  332. - update Patch1001: clang-3.5.0-driver-lib64.patch
  333. - update Patch1002: clang-3.5.0-driver-vine.patch
  334. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  335. - update to 3.5.0
  336. - remove Patch11 (clang-hardfloat-hack.patch)
  337. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  338. - rebuild with libffi-3.0.13
  339. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  340. - update to 3.3
  341. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  342. - ld.gold (patch1000,1001)
  343. - add /%{_lib} to ld search path
  344. - add support *-vine-linux gcc (patch1002)
  345. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  346. - update to 3.1
  347. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  348. - updated to 3.0 release
  349. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  350. - added patch 2-4 to support -O4 link-time optimization
  351. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  352. - disable -fno-var-tracking-assignments on ppc
  353. (seems like gcc-4.4.5 still doesn't support this)
  354. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  355. - new upstream release
  356. - add BR: libffi-devel
  357. - add R: libffi-devel to -devel
  358. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  359. - initial build for Vine Linux
  360. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  361. - Update to final 2.7 release
  362. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  363. - Update to first 2.7 pre-release
  364. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  365. - Update to 2.6 pre-release2
  366. - -devel subpackage now virtually provides -static
  367. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  368. - Disable var tracking assignments on PPC
  369. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  370. - Don't adjust clang include dir; files there are noarch (bz#521893)
  371. - Enable clang unit tests
  372. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  373. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  374. - Package Clang's static analyzer tools
  375. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  376. - PIC is now enabled by default; explicitly disable on %%{ix86}
  377. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  378. - First 2.6 prerelease
  379. - Enable Clang front-end
  380. - Enable debuginfo generation
  381. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  382. - Disable assertions (needed by OpenGTL, bz#521261)
  383. - Align spec file with upstream build instructions
  384. - Enable unit tests
  385. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  386. - Only disable PIC on %%ix86; ppc actually needs it
  387. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  388. - Disable use of position-independent code on 32-bit platforms
  389. (buggy in LLVM <= 2.5)
  390. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  391. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  392. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  393. - Remove build scripts; they require the build directory to work
  394. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  395. - Update to 2.5
  396. - Package build scripts (bug #457881)
  397. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  398. - Patched build process for the OCaml binding
  399. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  400. - Update to 2.4
  401. - Package Ocaml binding
  402. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  403. - Add dependency on groff
  404. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  405. - LLVM 2.3
  406. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  407. - fix license tags
  408. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  409. - Fix compilation problems with gcc 4.3
  410. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  411. - Autorebuild for GCC 4.3
  412. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  413. - Fix review comments
  414. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  415. - Initial version