compiler-rt-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: LLVM "compiler-rt" runtime libraries
  6. Summary(ja): LLVM "compiler-rt" ランタイムライブラリ
  7. Name: compiler-rt
  8. Version: 13.0.1
  9. Release: 1%{?_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: NCSA
  14. URL: https://llvm.org/
  15. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
  16. # patches
  17. Patch0: 0001-PATCH-compiler-rt-Workaround-libstdc-limitation-wrt..patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: cmake
  20. BuildRequires: ninja
  21. BuildRequires: python3
  22. BuildRequires: python3-devel
  23. BuildRequires: llvm-devel = %{version}
  24. BuildRequires: llvm-static = %{version}
  25. Requires: clang = %{version}-%{release}
  26. # LLVM is not supported on PPC64
  27. # http://llvm.org/bugs/show_bug.cgi?id=3729
  28. ExcludeArch: ppc64
  29. %description
  30. The compiler-rt project is a part of the LLVM project. It provides
  31. implementation of the low-level target-specific hooks required by
  32. code generation, sanitizer runtimes and profiling library for code
  33. instrumentation, and Blocks C language extension.
  34. %debug_package
  35. %prep
  36. %autosetup -n compiler-rt-%{version}.src -p2
  37. pathfix%{python3_version}.py -i %{__python3} -pn lib/hwasan/scripts/hwasan_symbolize
  38. %build
  39. %cmake \
  40. -GNinja \
  41. -DCMAKE_BUILD_TYPE=Release \
  42. -DCMAKE_INSTALL_RPATH=";" \
  43. %if 0%{?__isa_bits} == 64
  44. -DLLVM_LIBDIR_SUFFIX=64 \
  45. %else
  46. -DLLVM_LIBDIR_SUFFIX= \
  47. %endif
  48. -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
  49. %cmake_build
  50. %install
  51. rm -rf %{buildroot}
  52. %cmake_install
  53. # compiler-rt
  54. # move sanitizer lists to better place
  55. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/share
  56. mv -v %{buildroot}%{_datadir}/*list.txt %{buildroot}%{_libdir}/clang/%{version}/share/
  57. # move sanitizer libs to better place
  58. %global libclang_rt_installdir lib/linux
  59. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib
  60. mv -v %{buildroot}%{_prefix}/%{libclang_rt_installdir}/*clang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
  61. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib/linux/
  62. pushd %{buildroot}%{_libdir}/clang/%{version}/lib
  63. for i in *.a *.so
  64. do
  65. ln -s ../$i linux/$i
  66. done
  67. %if %{with test}
  68. %check
  69. #cmake_build --target check-compiler-rt
  70. %endif
  71. %clean
  72. rm -rf %{buildroot}
  73. %files
  74. %license LICENSE.TXT
  75. %{_includedir}/*
  76. %{_libdir}/clang/%{version}/lib/*
  77. %{_libdir}/clang/%{version}/share/*
  78. %ifarch x86_64 aarch64
  79. %{_bindir}/hwasan_symbolize
  80. %endif
  81. %changelog
  82. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  83. - new upstream release.
  84. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  85. - new upstream release.
  86. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  87. - new upstream release.
  88. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  89. - devided compiler-rt from llvm.
  90. - new upstream release.
  91. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  92. - enabled to build utils.
  93. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  94. - new upstream release.
  95. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  96. - new upstream release.
  97. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  98. - rebuilt with libffi-3.3.
  99. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  100. - new upstream release.
  101. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  102. - new upstream release.
  103. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  104. - dropped all patches.
  105. - switched build-system to ninja.
  106. - switched python to python3.
  107. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  108. - new upstream release.
  109. - added OpenMP.
  110. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  111. - fixed %%files.
  112. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  113. - new upstream release.
  114. - dropped Patch0, 4, 5, 100 and 200.
  115. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  116. - renamed a subpackage "llvm-libs".
  117. - added a subpackage "lld".
  118. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  119. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  120. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  121. - new upstream release.
  122. - dropped Patch1 and 2: fixed in upstream.
  123. - imported Patch0, 3-5, 100 and 200 from rawhide.
  124. - disabled Patch1002: no longer needed?
  125. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  126. - new upstream release.
  127. - switched to cmake.
  128. - disable ocaml binding as default.
  129. - updated Patch1000 and 1002.
  130. - disabled Patch1000 as default.
  131. - cleanup patches.
  132. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  133. - rebuild with gcc-5.4.0
  134. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  135. - new upstream release
  136. - added BR: ocaml-ctypes
  137. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  138. - new upstream release
  139. - dropt Patch 1, 201 and 1001
  140. - updated Patch 1000
  141. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  142. - updated to 3.5.1
  143. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  144. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  145. - obsoleted clang-doc
  146. - built with ocaml 4.02.1
  147. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  148. - fix <BTS:2832>
  149. - fix configure option "--with-c-include-dirs"
  150. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  151. - update Patch1001: clang-3.5.0-driver-lib64.patch
  152. - update Patch1002: clang-3.5.0-driver-vine.patch
  153. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  154. - update to 3.5.0
  155. - remove Patch11 (clang-hardfloat-hack.patch)
  156. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  157. - rebuild with libffi-3.0.13
  158. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  159. - update to 3.3
  160. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  161. - ld.gold (patch1000,1001)
  162. - add /%{_lib} to ld search path
  163. - add support *-vine-linux gcc (patch1002)
  164. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  165. - update to 3.1
  166. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  167. - updated to 3.0 release
  168. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  169. - added patch 2-4 to support -O4 link-time optimization
  170. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  171. - disable -fno-var-tracking-assignments on ppc
  172. (seems like gcc-4.4.5 still doesn't support this)
  173. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  174. - new upstream release
  175. - add BR: libffi-devel
  176. - add R: libffi-devel to -devel
  177. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  178. - initial build for Vine Linux
  179. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  180. - Update to final 2.7 release
  181. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  182. - Update to first 2.7 pre-release
  183. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  184. - Update to 2.6 pre-release2
  185. - -devel subpackage now virtually provides -static
  186. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  187. - Disable var tracking assignments on PPC
  188. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  189. - Don't adjust clang include dir; files there are noarch (bz#521893)
  190. - Enable clang unit tests
  191. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  192. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  193. - Package Clang's static analyzer tools
  194. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  195. - PIC is now enabled by default; explicitly disable on %%{ix86}
  196. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  197. - First 2.6 prerelease
  198. - Enable Clang front-end
  199. - Enable debuginfo generation
  200. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  201. - Disable assertions (needed by OpenGTL, bz#521261)
  202. - Align spec file with upstream build instructions
  203. - Enable unit tests
  204. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  205. - Only disable PIC on %%ix86; ppc actually needs it
  206. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  207. - Disable use of position-independent code on 32-bit platforms
  208. (buggy in LLVM <= 2.5)
  209. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  210. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  211. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  212. - Remove build scripts; they require the build directory to work
  213. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  214. - Update to 2.5
  215. - Package build scripts (bug #457881)
  216. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  217. - Patched build process for the OCaml binding
  218. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  219. - Update to 2.4
  220. - Package Ocaml binding
  221. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  222. - Add dependency on groff
  223. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  224. - LLVM 2.3
  225. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  226. - fix license tags
  227. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  228. - Fix compilation problems with gcc 4.3
  229. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  230. - Autorebuild for GCC 4.3
  231. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  232. - Fix review comments
  233. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  234. - Initial version