libomp-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: OpenMP runtime for clang
  6. Summary(ja): clang用OpenMPランタイム
  7. Name: libomp
  8. Version: 13.0.1
  9. Release: 1%{?_dist_release}
  10. Group: system
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: NCSA
  14. URL: https://llvm.org/
  15. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/openmp-%{version}.src.tar.xz
  16. # patches
  17. Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: cmake
  20. BuildRequires: ninja
  21. BuildRequires: libffi-devel >= 3.3
  22. BuildRequires: elfutils-libelf-devel
  23. # The AMDGCN device RTL requires clang and llvm-link to build
  24. BuildRequires: clang
  25. BuildRequires: llvm
  26. # libomptarget needs the llvm cmake files
  27. BuildRequires: llvm-devel
  28. BuildRequires: llvm-static
  29. %description
  30. The package contains the OpenMP runtime for clang.
  31. %package devel
  32. Summary: OpenMP header files
  33. Summary(ja): OpenMPヘッダファイル
  34. Group: programming
  35. Requires: clang-devel%{?isa} = %{version}
  36. %description devel
  37. The package contains the OpenMP header files.
  38. %debug_package
  39. %prep
  40. %autosetup -p2 -n openmp-%{version}.src
  41. %build
  42. # LTO causes build failures in this package. Disable LTO for now
  43. %define _lto_cflags %{nil}
  44. %cmake \
  45. -GNinja \
  46. -DLIBOMP_INSTALL_ALIASES=OFF \
  47. -DLIBOMP_HEADERS_INSTALL_PATH:PATH=%{_libdir}/clang/%{version}/include \
  48. %if 0%{?__isa_bits} == 64
  49. -DOPENMP_LIBDIR_SUFFIX=64 \
  50. %else
  51. -DOPENMP_LIBDIR_SUFFIX= \
  52. %endif
  53. %{nil}
  54. %cmake_build
  55. %install
  56. rm -rf %{buildroot}
  57. %cmake_install
  58. # Remove static libraries with equivalent shared libraries
  59. rm -f %{buildroot}%{_libdir}/libarcher_static.a
  60. %if %{with test}
  61. %check
  62. %cmake_build --target check-openmp
  63. %endif
  64. %clean
  65. rm -rf %{buildroot}
  66. %files
  67. %license LICENSE.TXT
  68. %{_libdir}/libarcher.so
  69. %{_libdir}/libomp.so
  70. %{_libdir}/libomptarget.so
  71. %ifnarch %{ix86} %{arm}
  72. %{_libdir}/libomptarget-amdgcn*.bc
  73. %{_libdir}/libomptarget.rtl.amdgpu.so
  74. %{_libdir}/libomptarget.rtl.cuda.so
  75. %{_libdir}/libomptarget.rtl.%{_arch}.so
  76. %endif
  77. %files devel
  78. %{_libdir}/clang/%{version}/include/omp.h
  79. %{_libdir}/clang/%{version}/include/omp-tools.h
  80. %{_libdir}/clang/%{version}/include/ompt.h
  81. %{_includedir}/ompt-multiplex.h
  82. %{_libdir}/cmake/openmp/FindOpenMPTarget.cmake
  83. %changelog
  84. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  85. - new upstream release.
  86. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  87. - new upstream release.
  88. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  89. - new upstream release.
  90. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  91. - devided libomp from llvm.
  92. - new upstream release.
  93. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  94. - enabled to build utils.
  95. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  96. - new upstream release.
  97. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  98. - new upstream release.
  99. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  100. - rebuilt with libffi-3.3.
  101. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  102. - new upstream release.
  103. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  104. - new upstream release.
  105. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  106. - dropped all patches.
  107. - switched build-system to ninja.
  108. - switched python to python3.
  109. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  110. - new upstream release.
  111. - added OpenMP.
  112. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  113. - fixed %%files.
  114. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  115. - new upstream release.
  116. - dropped Patch0, 4, 5, 100 and 200.
  117. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  118. - renamed a subpackage "llvm-libs".
  119. - added a subpackage "lld".
  120. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  121. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  122. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  123. - new upstream release.
  124. - dropped Patch1 and 2: fixed in upstream.
  125. - imported Patch0, 3-5, 100 and 200 from rawhide.
  126. - disabled Patch1002: no longer needed?
  127. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  128. - new upstream release.
  129. - switched to cmake.
  130. - disable ocaml binding as default.
  131. - updated Patch1000 and 1002.
  132. - disabled Patch1000 as default.
  133. - cleanup patches.
  134. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  135. - rebuild with gcc-5.4.0
  136. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  137. - new upstream release
  138. - added BR: ocaml-ctypes
  139. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  140. - new upstream release
  141. - dropt Patch 1, 201 and 1001
  142. - updated Patch 1000
  143. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  144. - updated to 3.5.1
  145. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  146. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  147. - obsoleted clang-doc
  148. - built with ocaml 4.02.1
  149. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  150. - fix <BTS:2832>
  151. - fix configure option "--with-c-include-dirs"
  152. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  153. - update Patch1001: clang-3.5.0-driver-lib64.patch
  154. - update Patch1002: clang-3.5.0-driver-vine.patch
  155. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  156. - update to 3.5.0
  157. - remove Patch11 (clang-hardfloat-hack.patch)
  158. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  159. - rebuild with libffi-3.0.13
  160. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  161. - update to 3.3
  162. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  163. - ld.gold (patch1000,1001)
  164. - add /%{_lib} to ld search path
  165. - add support *-vine-linux gcc (patch1002)
  166. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  167. - update to 3.1
  168. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  169. - updated to 3.0 release
  170. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  171. - added patch 2-4 to support -O4 link-time optimization
  172. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  173. - disable -fno-var-tracking-assignments on ppc
  174. (seems like gcc-4.4.5 still doesn't support this)
  175. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  176. - new upstream release
  177. - add BR: libffi-devel
  178. - add R: libffi-devel to -devel
  179. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  180. - initial build for Vine Linux
  181. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  182. - Update to final 2.7 release
  183. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  184. - Update to first 2.7 pre-release
  185. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  186. - Update to 2.6 pre-release2
  187. - -devel subpackage now virtually provides -static
  188. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  189. - Disable var tracking assignments on PPC
  190. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  191. - Don't adjust clang include dir; files there are noarch (bz#521893)
  192. - Enable clang unit tests
  193. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  194. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  195. - Package Clang's static analyzer tools
  196. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  197. - PIC is now enabled by default; explicitly disable on %%{ix86}
  198. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  199. - First 2.6 prerelease
  200. - Enable Clang front-end
  201. - Enable debuginfo generation
  202. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  203. - Disable assertions (needed by OpenGTL, bz#521261)
  204. - Align spec file with upstream build instructions
  205. - Enable unit tests
  206. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  207. - Only disable PIC on %%ix86; ppc actually needs it
  208. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  209. - Disable use of position-independent code on 32-bit platforms
  210. (buggy in LLVM <= 2.5)
  211. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  212. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  213. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  214. - Remove build scripts; they require the build directory to work
  215. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  216. - Update to 2.5
  217. - Package build scripts (bug #457881)
  218. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  219. - Patched build process for the OCaml binding
  220. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  221. - Update to 2.4
  222. - Package Ocaml binding
  223. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  224. - Add dependency on groff
  225. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  226. - LLVM 2.3
  227. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  228. - fix license tags
  229. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  230. - Fix compilation problems with gcc 4.3
  231. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  232. - Autorebuild for GCC 4.3
  233. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  234. - Fix review comments
  235. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  236. - Initial version