nginx-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.2.7
  26. Release: 1%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 20130213
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
  48. %define nginx_accept_language_module_version 02262ce
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. %define passenger_version 3.0.19
  51. Source1020: passenger-%{passenger_version}.tar.gz
  52. %define upstream_fair_version 2131c73
  53. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  54. %define mod_wsgi_version 6975f0ec7eeb
  55. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  56. # removes -Werror in upstream build scripts. -Werror conflicts with
  57. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  58. Patch0: nginx-auto-cc-gcc.patch
  59. # configuration patch to match all the Vine Linux paths for logs, pid files
  60. # etc.
  61. Patch1: nginx-conf.patch
  62. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  63. BuildRequires: pcre-devel
  64. BuildRequires: zlib-devel
  65. BuildRequires: openssl-devel
  66. BuildRequires: gd-devel
  67. BuildRequires: perl
  68. BuildRequires: perl(ExtUtils::Embed)
  69. BuildRequires: libxml2-devel
  70. BuildRequires: libxslt-devel
  71. BuildRequires: curl-devel
  72. %if %{with geoip}
  73. BuildRequires: GeoIP-devel
  74. %endif
  75. %if "%{?_dist_release}" == "vl4"
  76. Requires: perl >= 5.8.6
  77. %else
  78. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  79. %endif
  80. # for /usr/sbin/useradd
  81. Requires(pre): shadow-utils
  82. Requires(post): chkconfig
  83. # for /sbin/service
  84. Requires(preun): chkconfig, initscripts
  85. Requires(postun): initscripts
  86. %if "%{_dist_release}" > "vl6"
  87. Requires(pre): www-common
  88. %endif
  89. Provides: webserver
  90. Vendor: Project Vine
  91. Distribution: Vine Linux
  92. Packager: daisuke
  93. %description
  94. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  95. proxy server written by Igor Sysoev.
  96. %description -l ja
  97. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  98. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  99. - HTTP(S) サーバ
  100. - HTTP(S) リバースプロキシサーバ
  101. - IMAP/POP3 プロキシサーバ
  102. %package passenger
  103. Summary: Nginx with mod_passenger support
  104. Summary(ja): Passenger サポート入りの Nginx
  105. Group: System Environment/Daemons
  106. BuildRequires: ruby, rubygem-rake
  107. Requires: ruby, rubygem-rake
  108. %if "%{_dist_release}" >= "vl7"
  109. BuildRequires: ruby-devel, ruby-rubygems
  110. Requires: ruby-rubygems
  111. %else
  112. BuildRequires: rubygems
  113. Requires: rubygems
  114. %endif
  115. Requires: nginx
  116. %description passenger
  117. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  118. This package contains nginx server with passenger support.
  119. %description -l ja passenger
  120. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  121. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  122. - HTTP(S) サーバ
  123. - HTTP(S) リバースプロキシサーバ
  124. - IMAP/POP3 プロキシサーバ
  125. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  126. %prep
  127. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  128. %patch0 -p0
  129. %patch1 -p1
  130. %build
  131. # nginx does not utilize a standard configure script. It has its own
  132. # and the standard configure options cause the nginx configure script
  133. # to error out. This is is also the reason for the DESTDIR environment
  134. # variable. The configure script(s) have been patched (Patch1 and
  135. # Patch2) in order to support installing into a build environment.
  136. export DESTDIR=%{buildroot}
  137. ## build with passenger
  138. ./configure \
  139. --user=%{nginx_user} \
  140. --group=%{nginx_group} \
  141. --prefix=%{nginx_datadir} \
  142. --sbin-path=%{_sbindir}/%{name} \
  143. --conf-path=%{nginx_confdir}/%{name}.conf \
  144. --error-log-path=%{nginx_logdir}/error.log \
  145. --http-log-path=%{nginx_logdir}/access.log \
  146. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  147. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  148. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  149. --pid-path=%{_localstatedir}/run/%{name}.pid \
  150. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  151. --with-file-aio \
  152. --with-ipv6 \
  153. --with-http_ssl_module \
  154. --with-http_realip_module \
  155. --with-http_addition_module \
  156. --with-http_xslt_module \
  157. --with-http_image_filter_module \
  158. --with-http_sub_module \
  159. --with-http_dav_module \
  160. --with-http_flv_module \
  161. --with-http_mp4_module \
  162. --with-http_gzip_static_module \
  163. --with-http_random_index_module \
  164. --with-http_secure_link_module \
  165. --with-http_stub_status_module \
  166. --with-http_perl_module \
  167. --with-http_degradation_module \
  168. %if %{with geoip}
  169. --with-http_geoip_module \
  170. %endif
  171. --with-mail \
  172. --with-mail_ssl_module \
  173. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  174. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  175. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  176. %if %{with wsgi}
  177. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  178. %endif
  179. --add-module=passenger-%{passenger_version}/ext/nginx \
  180. %ifarch i686
  181. --with-cpu-opt=pentiumpro \
  182. --with-zlib-asm=pentiumpro \
  183. --with-md5-asm \
  184. --with-sha1-asm \
  185. %endif
  186. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  187. make %{?_smp_mflags}
  188. mv objs/nginx objs/nginx.passenger
  189. ## build without passenger
  190. ./configure \
  191. --user=%{nginx_user} \
  192. --group=%{nginx_group} \
  193. --prefix=%{nginx_datadir} \
  194. --sbin-path=%{_sbindir}/%{name} \
  195. --conf-path=%{nginx_confdir}/%{name}.conf \
  196. --error-log-path=%{nginx_logdir}/error.log \
  197. --http-log-path=%{nginx_logdir}/access.log \
  198. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  199. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  200. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  201. --pid-path=%{_localstatedir}/run/%{name}.pid \
  202. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  203. --with-file-aio \
  204. --with-ipv6 \
  205. --with-http_ssl_module \
  206. --with-http_realip_module \
  207. --with-http_addition_module \
  208. --with-http_xslt_module \
  209. --with-http_image_filter_module \
  210. --with-http_sub_module \
  211. --with-http_dav_module \
  212. --with-http_flv_module \
  213. --with-http_gzip_static_module \
  214. --with-http_random_index_module \
  215. --with-http_secure_link_module \
  216. --with-http_stub_status_module \
  217. --with-http_perl_module \
  218. %if %{with geoip}
  219. --with-http_geoip_module \
  220. %endif
  221. --with-mail \
  222. --with-mail_ssl_module \
  223. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  224. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  225. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  226. %if %{with wsgi}
  227. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  228. %endif
  229. %ifarch i686
  230. --with-cpu-opt=pentiumpro \
  231. --with-zlib-asm=pentiumpro \
  232. --with-md5-asm \
  233. --with-sha1-asm \
  234. %endif
  235. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  236. make %{?_smp_mflags}
  237. %install
  238. rm -rf %{buildroot}
  239. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  240. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  241. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  242. find %{buildroot} -type f -empty -exec rm -f {} \;
  243. find %{buildroot} -type f -exec chmod 0644 {} \;
  244. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  245. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  246. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  247. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  248. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  249. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  250. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  251. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  252. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  253. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  254. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  255. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  256. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  257. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  258. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  259. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  260. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  261. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  262. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  263. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  264. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  265. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  266. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  267. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  268. %if %{with wsgi}
  269. %{__install} -p -m 0644 \
  270. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  271. %{buildroot}%{nginx_confdir}
  272. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  273. %endif
  274. # upstream fair module document
  275. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  276. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  277. # convert to UTF-8 all files that give warnings.
  278. for textfile in CHANGES
  279. do
  280. mv $textfile $textfile.old
  281. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  282. rm -f $textfile.old
  283. done
  284. %clean
  285. rm -rf %{buildroot}
  286. %post
  287. if [ $1 == 1 ]; then
  288. /sbin/chkconfig --add %{name}
  289. fi
  290. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  291. %post passenger
  292. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  293. %preun
  294. if [ $1 = 0 ]; then
  295. /sbin/service %{name} stop >/dev/null 2>&1
  296. /sbin/chkconfig --del %{name}
  297. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  298. fi
  299. %preun passenger
  300. if [ $1 = 0 ]; then
  301. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  302. fi
  303. %postun
  304. if [ $1 == 2 ]; then
  305. /sbin/service %{name} upgrade || :
  306. fi
  307. %files
  308. %defattr(-,root,root,-)
  309. %doc LICENSE CHANGES README
  310. %doc README.upstream_fair
  311. %doc %{?with_wsgi:README.mod_wsgi}
  312. %{nginx_datadir}/
  313. %{_sbindir}/%{name}.normal
  314. %{_mandir}/man3/%{name}.3pm.gz
  315. %{_initrddir}/%{name}
  316. %dir %{nginx_confdir}
  317. %dir %{nginx_confdir}/conf.d
  318. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  319. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  320. %config(noreplace) %{nginx_confdir}/sites.d/*
  321. %config(noreplace) %{nginx_confdir}/win-utf
  322. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  323. %config(noreplace) %{nginx_confdir}/mime.types.default
  324. %config(noreplace) %{nginx_confdir}/fastcgi_params
  325. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  326. %config(noreplace) %{nginx_confdir}/koi-win
  327. %config(noreplace) %{nginx_confdir}/koi-utf
  328. %config(noreplace) %{nginx_confdir}/%{name}.conf
  329. %config(noreplace) %{nginx_confdir}/mime.types
  330. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  331. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  332. %config(noreplace) %{nginx_confdir}/scgi_params
  333. %config(noreplace) %{nginx_confdir}/scgi_params.default
  334. %config(noreplace) %{nginx_confdir}/uwsgi_params
  335. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  336. %if %{with wsgi}
  337. %config(noreplace) %{nginx_confdir}/wsgi_vars
  338. %endif
  339. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  340. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  341. %dir %{perl_vendorarch}/auto/%{name}
  342. %{perl_vendorarch}/%{name}.pm
  343. %{perl_vendorarch}/auto/%{name}/%{name}.so
  344. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  345. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  346. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  347. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  348. %files passenger
  349. %defattr(-,root,root,-)
  350. %doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
  351. %doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
  352. %doc passenger-%{passenger_version}/doc/Architectural\ overview.*
  353. %doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
  354. %doc passenger-%{passenger_version}/doc/template
  355. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  356. %doc passenger-%{passenger_version}/doc/images
  357. %{_sbindir}/%{name}.passenger
  358. %changelog
  359. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  360. - new upstream release
  361. - update passenger to 3.0.19
  362. - update ngx-fancyindex to upstream git master
  363. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  364. - new upstream release
  365. - update passenger to 3.0.17
  366. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  367. - rebuild with pcre-8.31
  368. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  369. - added http_geoip_module.
  370. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  371. - update to 1.2.4
  372. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  373. - update to 1.2.2
  374. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  375. - update to 1.2.1
  376. - change nginx user from nginx to www-data
  377. - R(pre): www-common
  378. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  379. - update to 1.2.0
  380. - update passenger to 3.0.12
  381. - drop http_upstream_keepalive
  382. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  383. - new upstream release
  384. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  385. - update to 1.0.12
  386. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  387. - update to 1.0.11
  388. - update passenger to 3.0.11
  389. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  390. - update to 1.0.10
  391. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  392. - update passenger to 3.0.9
  393. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  394. - update to 1.0.6
  395. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  396. - update to 1.0.4
  397. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  398. - add gnosek-nginx-upstream-fair module
  399. - add ngx_http_upstream_keepalive module
  400. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  401. - add nginx-passenger sub pakckage
  402. - use alternatives to choose nginx with or without passenger
  403. - add BR: ruby, rubygems, rubygem-rake
  404. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  405. - update to 1.0.2
  406. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  407. - update to 1.0.1
  408. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  409. - add bcond_with wsgi for mod_wsgi
  410. - add bcond_with passenger
  411. - you need to install rake.gem to build with this option.
  412. - add Provides: webserver
  413. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  414. - new upstream release 1.0.0!
  415. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  416. - rebuild with perl-5.12.3
  417. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  418. - update to 0.8.54
  419. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  420. - update to 0.8.53
  421. - add nginx_accept_language_module
  422. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  423. - update to 0.8.50
  424. - update ngx-fancyindex to 0.3
  425. - add BR: libxml2-devel, libxslt-devel
  426. - add scgi_params* and uwsgi_params* to %%files
  427. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  428. - update to 0.8.35 (development version)
  429. - add sites.d/ to store vitualhost settings
  430. - split out default server settings to sites.d/default
  431. - add fancyindex module
  432. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  433. - new upstream release
  434. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  435. - update to 0.7.62 (included security fix: VU#180065)
  436. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  437. - fix typo
  438. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  439. - add translated descriptions
  440. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  441. - update 404.html/50x.html to use powered by vine logo.
  442. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  443. - initial build for Vine Linux
  444. - update to 0.7.61
  445. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  446. - init script updates from Gena Makhomed
  447. - remove nginx-upstream-fair
  448. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  449. - update to 0.6.36
  450. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  451. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  452. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  453. - rebuild
  454. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  455. - update to 0.6.35
  456. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  457. - rebuild with new openssl
  458. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  459. - update to 0.6.34
  460. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  461. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  462. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  463. - update to 0.6.33
  464. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  465. - update to 0.6.32
  466. - nginx now supports DESTDIR so removed the patches that enabled it
  467. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  468. - init script fixes
  469. - resolve 'listen 80 default' [#447873]
  470. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  471. - update to 0.6.31
  472. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  473. - upate to new upstream stable branch 0.6
  474. - added 3rd party module nginx-upstream-fair
  475. - added default webpages
  476. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  477. - update init script to match recommended guidelines
  478. - add /etc/nginx/conf.d support [#443280]
  479. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  480. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  481. - add Requires for versioned perl (libperl.so)
  482. - drop silly file Requires
  483. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  484. - Autorebuild for GCC 4.3
  485. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  486. - update to 0.5.35
  487. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  488. - update to 0.5.34
  489. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  490. - Rebuild for deps
  491. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  492. - update to 0.5.33
  493. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  494. - updated to 0.5.32
  495. - fixed rpmlint UTF-8 complaints.
  496. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  497. - added --with-http_stub_status_module build option.
  498. - added --with-http_sub_module build option.
  499. - added use of pcre-config --cflags
  500. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  501. - Update to 0.5.31
  502. - specify license is BSD
  503. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  504. - Add BuildRequires: perl-devel - fixing rawhide build
  505. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  506. - Update to 0.5.30
  507. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  508. - Update to 0.5.29
  509. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  510. - Update to 0.5.28
  511. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  512. - Update to 0.5.27
  513. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  514. - Update to 0.5.26
  515. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  516. - Update to 0.5.19
  517. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  518. - Update to 0.5.17
  519. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  520. - Update to 0.5.16
  521. - add ownership of /usr/share/nginx/html (#233950)
  522. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  523. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  524. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  525. - fixed package review bugs (#233522) given by kevin@tummy.com
  526. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  527. - create patches to assist with building for Fedora
  528. - initial packaging for Fedora