ghc-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170
  1. %define pkg_name ghc
  2. %define pkg_version 8.4.3
  3. # %define pkg_subversion b
  4. %define pkg_release 1%{?_dist_release}
  5. %ifarch %{ix86}
  6. %define rpmarch i386
  7. %endif
  8. %ifarch x86_64
  9. %define rpmarch x86_64
  10. %endif
  11. Summary: A state-of-the-art, open source, compiler and interactive environment for the functional language Haskell
  12. Name: %{pkg_name}
  13. Version: %{pkg_version}
  14. Release: %{pkg_release}
  15. License: BSD-like
  16. Group: Applications/Languages
  17. URL: https://www.haskell.org/ghc
  18. # Source0: %{name}-%{version}%{pkg_subversion}-src.tar.bz2
  19. Source0: %{name}-%{version}-src.tar.xz
  20. Source1: macros.ghc
  21. # # https://phabricator.haskell.org/D4159
  22. # # ghc-pkg: recompute `abi-depends` for updated packages
  23. # Patch1: ghc-8.2.2-fix-shadowed_dependencies.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: ghc
  26. BuildRequires: gmp-devel
  27. BuildRequires: libffi-devel
  28. BuildRequires: ncurses-devel readline-devel freeglut-devel
  29. BuildRequires: gtk2-devel
  30. BuildRequires: python-sphinx
  31. Requires: gmp-devel
  32. Requires: libffi-devel
  33. Requires: freeglut
  34. Conflicts: ghc-bootstrap
  35. Conflicts: haskell-platform-base
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: ara_t
  39. %description
  40. The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
  41. compiler and interactive environment for the functional language Haskell.
  42. Highlights:
  43. - GHC supports the entire Haskell 2010 language plus a wide variety of
  44. extensions.
  45. - GHC has particularly good support for concurrency and parallelism,
  46. including support for Software Transactional Memory (STM).
  47. - GHC generates fast code, particularly for concurrent programs.
  48. - Take a look at GHC's performance on The Computer Language Benchmarks Game.
  49. GHC works on several platforms including Windows, Mac, Linux,
  50. most varieties of Unix, and several different processor architectures.
  51. There are detailed instructions for porting GHC to a new platform.
  52. - GHC has extensive optimisation capabilities, including inter-module
  53. optimisation.
  54. - GHC compiles Haskell code either directly to native code or using LLVM
  55. as a back-end.
  56. GHC can also generate C code as an intermediate target for porting to
  57. new platforms.
  58. The interactive environment compiles Haskell to bytecode,
  59. and supports execution of mixed bytecode/compiled programs.
  60. - Profiling is supported, both by time/allocation and various kinds of heap
  61. profiling.
  62. - GHC comes with several libraries, and thousands more are available on Hackage.
  63. #'
  64. %prep
  65. %{__rm} -rf ${RPM_BUILD_ROOT}
  66. %setup -q
  67. # %patch1 -p1 -b .fix-shadowed_dependencies
  68. %build
  69. %{_configure} \
  70. --prefix=%{_prefix} \
  71. --libdir=%{_libdir} \
  72. --docdir=%{_docdir}/%{name}-%{version} \
  73. --with-system-libffi
  74. %{__make} %{?_smp_mflags}
  75. %install
  76. %{make_install}
  77. %{__cp} ANNOUNCE LICENSE \
  78. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  79. # macros for building haskell-platform-related packages
  80. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_sysconfdir}/rpm
  81. %{__sed} -e "s/@GHC_VERSION@/%{version}/" %{SOURCE1} \
  82. > ${RPM_BUILD_ROOT}/%{_sysconfdir}/rpm/macros.ghc
  83. %clean
  84. %{__rm} -rf ${RPM_BUILD_ROOT}
  85. %post -p %{_syssbindir}/ldconfig
  86. %postun -p %{_syssbindir}/ldconfig
  87. %files
  88. %defattr(-, root, root)
  89. %{_bindir}/
  90. %{_libdir}/ghc-%{version}/
  91. %{_docdir}/ghc-%{version}/
  92. %{_mandir}/man1/
  93. %{_sysconfdir}/rpm/
  94. %changelog
  95. * Thu Jul 19 2018 Toshiaki Ara <ara_t@384.jp> 8.4.3-1
  96. - update to 8.4.3
  97. - drop Patch1 (fixed at upstream)
  98. * Thu May 17 2018 Toshiaki Ara <ara_t@384.jp> 8.4.2-1
  99. - update to 8.4.2
  100. - add /etc/rpm/macros.ghc
  101. * Sat Jan 06 2018 Toshiaki Ara <ara_t@384.jp> 8.2.2-1
  102. - update to 8.2.2
  103. - add Patch1 (ghc-8.2.2-fix-shadowed_dependencies.patch)
  104. * Tue Jan 31 2017 Toshiaki Ara <ara_t@384.jp> 8.0.1-1
  105. - update to 8.0.1
  106. - add Requires: libffi-devel
  107. - add Requires: freeglut
  108. - add BuildRequires: python-sphinx for building HTML documents
  109. - add Conflicts: ghc-bootstrap
  110. - add Conflicts: haskell-platform-base
  111. - delete BuildRequires: hscolour
  112. - delete bindist subpackage
  113. * Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-3
  114. - add Requires: gmp-devel
  115. * Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-2
  116. - correct SPEC file
  117. * Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
  118. - update to 7.10.3
  119. - add BuildRequires: texlive-collection-fontutils
  120. - add Requires: libffi
  121. - add Requires: freeglut
  122. - provide binary tarball for building haskell-platform
  123. * Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-5
  124. - rebuild with ghc-7.6.3-4
  125. * Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-4
  126. - add Patchs to use --with-system-libffi option
  127. * Fri Feb 12 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-3
  128. - empty
  129. * Mon Feb 08 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
  130. - add BuildRequires: dblatex
  131. - add BuildRequires: texlive-collection-bibtexextra
  132. - add BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  133. - change BuildRequires from ghc-bootstrap to ghc
  134. * Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
  135. - new package