vala-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437
  1. %global api_ver 0.38
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: A modern programming language for GNOME
  4. Summary(ja): GNOME 用のモダンなプログラミング言語
  5. Name: vala
  6. Version: 0.38.4
  7. Release: 1%{?_dist_release}
  8. Group: Development/Languages
  9. # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
  10. License: LGPLv2+ and BSD
  11. URL: http://live.gnome.org/Vala
  12. Source0: http://download.gnome.org/sources/vala/0.32/vala-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: glib2-devel
  15. BuildRequires: flex
  16. BuildRequires: bison
  17. BuildRequires: libxslt
  18. BuildRequires: graphviz-devel
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. Vala is a new programming language that aims to bring modern programming
  23. language features to GNOME developers without imposing any additional
  24. runtime requirements and without using a different ABI compared to
  25. applications and libraries written in C.
  26. valac, the Vala compiler, is a self-hosting compiler that translates
  27. Vala source code into C source and header files. It uses the GObject
  28. type system to create classes and interfaces declared in the Vala source
  29. code. It's also planned to generate GIDL files when gobject-
  30. introspection is ready.
  31. The syntax of Vala is similar to C#, modified to better fit the GObject
  32. type system.
  33. %package devel
  34. Summary: Development files for %{name}
  35. Summary(ja): %{name} の開発用ファイル
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: pkgconfig
  39. %description devel
  40. Vala is a new programming language that aims to bring modern programming
  41. language features to GNOME developers without imposing any additional
  42. runtime requirements and without using a different ABI compared to
  43. applications and libraries written in C.
  44. This package contains development files for %{name}. This is not necessary for
  45. using the %{name} compiler.
  46. %package tools
  47. Summary: Tools for creating projects and bindings for %{name}
  48. Summary(ja): %{name} のプロジェクト作成やバインディングのためのツール集
  49. Group: Development/Tools
  50. License: LGPLv2+
  51. Requires: %{name} = %{version}-%{release}
  52. Requires: gnome-common intltool libtool
  53. Provides: %{name}-vapigen = %{version}-%{release}
  54. Obsoletes: %{name}-vapigen < %{version}-%{release}
  55. %description tools
  56. Vala is a new programming language that aims to bring modern programming
  57. language features to GNOME developers without imposing any additional
  58. runtime requirements and without using a different ABI compared to
  59. applications and libraries written in C.
  60. This package contains tools to generate Vala projects, as well as API bindings
  61. from existing C libraries, allowing access from Vala programs.
  62. %package doc
  63. Summary: Documentation for %{name}
  64. Summary(ja): %{name} のドキュメント
  65. Group: Documentation
  66. License: LGPLv2+
  67. BuildArch: noarch
  68. Requires: %{name} = %{version}-%{release}
  69. Requires: devhelp
  70. Provides: %{name}-docs = %{version}-%{release}
  71. Obsoletes: %{name}-docs < %{version}-%{release}
  72. %description doc
  73. Vala is a new programming language that aims to bring modern programming
  74. language features to GNOME developers without imposing any additional
  75. runtime requirements and without using a different ABI compared to
  76. applications and libraries written in C.
  77. This package contains documentation in a devhelp HTML book.
  78. %package -n valadoc
  79. Summary: Vala documentation generator
  80. Summary(ja): Valaのドキュメントジェネレータ
  81. Group: Development/Tools
  82. License: LGPLv2+
  83. Requires: vala = %{version}-%{release}
  84. %description -n valadoc
  85. Valadoc is a documentation generator for generating API documentation from Vala
  86. source code.
  87. %package -n valadoc-devel
  88. Summary: Development files for valadoc
  89. Summary(ja): valadocを利用した開発のためのファイル群
  90. Group: Development/Libraries
  91. License: LGPLv2+
  92. Requires: valadoc = %{version}-%{release}
  93. %description -n valadoc-devel
  94. Valadoc is a documentation generator for generating API documentation from Vala
  95. source code.
  96. The valadoc-devel package contains libraries and header files for
  97. developing applications that use valadoc.
  98. %prep
  99. %setup -q
  100. %build
  101. %configure --enable-vapigen
  102. # Don't use rpath!
  103. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  104. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  105. make %{?_smp_mflags}
  106. # checks currently utilize installed Vala, not the one being compiled
  107. #%check
  108. #make check
  109. %install
  110. rm -rf $RPM_BUILD_ROOT
  111. make install DESTDIR=$RPM_BUILD_ROOT
  112. find %{buildroot}%{_libdir} -type f -name 'lib*.la' | xargs rm -f
  113. %clean
  114. rm -rf $RPM_BUILD_ROOT
  115. %post -p /sbin/ldconfig
  116. %postun -p /sbin/ldconfig
  117. %files
  118. %defattr(-,root,root,-)
  119. %doc AUTHORS ChangeLog COPYING NEWS README THANKS
  120. %{_bindir}/vala
  121. %{_bindir}/valac
  122. %{_bindir}/vala-%{api_ver}
  123. %{_bindir}/valac-%{api_ver}
  124. %{_datadir}/vala-%{api_ver}
  125. %{_datadir}/vala
  126. %{_libdir}/libvala-%{api_ver}.so.*
  127. %{_mandir}/*/valac*
  128. %files devel
  129. %defattr(-,root,root,-)
  130. %{_includedir}/vala-%{api_ver}
  131. %{_libdir}/libvala-%{api_ver}.so
  132. %{_libdir}/pkgconfig/libvala-%{api_ver}.pc
  133. %{_datadir}/aclocal/vala.m4
  134. %{_datadir}/aclocal/vapigen.m4
  135. %{_libdir}/pkgconfig/vapigen.pc
  136. %{_libdir}/pkgconfig/vapigen-%{api_ver}.pc
  137. %{_datadir}/vala/Makefile.vapigen
  138. %files tools
  139. %defattr(-,root,root,-)
  140. %{_bindir}/vala-gen-introspect
  141. %{_bindir}/vapicheck
  142. %{_bindir}/vapigen
  143. %{_bindir}/vala-gen-introspect-%{api_ver}
  144. %{_bindir}/vapicheck-%{api_ver}
  145. %{_bindir}/vapigen-%{api_ver}
  146. %{_libdir}/vala-%{api_ver}
  147. %{_mandir}/*/*gen*
  148. %files doc
  149. %defattr(-,root,root,-)
  150. %{_datadir}/devhelp/books/vala-%{api_ver}
  151. %files -n valadoc
  152. %defattr(-,root,root,-)
  153. %{_bindir}/valadoc*
  154. %{_libdir}/libvaladoc-%{api_ver}.so.*
  155. %{_libdir}/valadoc
  156. %{_datadir}/valadoc
  157. %{_mandir}/*/valadoc*
  158. %files -n valadoc-devel
  159. %{_libdir}/libvaladoc-%{api_ver}.so
  160. %{_libdir}/pkgconfig/valadoc-%{api_ver}.pc
  161. %{_includedir}/valadoc-%{api_ver}
  162. %changelog
  163. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38.4-1
  164. - new upstream release.
  165. - added subpackages "valadoc" and "valadoc-devel".
  166. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.32.1-1
  167. - new upstream release
  168. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.30.0-1
  169. - new upstream release
  170. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.1-1
  171. - new upstream release
  172. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.0-1
  173. - new upstream release
  174. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.2-1
  175. - new upstream release
  176. * Sat Nov 8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.26.1-1
  177. - new upstream release
  178. - moved tools subpackage to Development/Tools Group
  179. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
  180. - new upstream release
  181. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
  182. - new upstream release
  183. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
  184. - new upstream release
  185. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
  186. - new upstream release
  187. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
  188. - new upstream release
  189. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
  190. - new upstream release
  191. * Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
  192. - new upstream release
  193. * Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
  194. - new upstream release
  195. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
  196. - new upstream release
  197. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  198. - new upstream release
  199. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
  200. - new upstream release
  201. - remove BuildRequires: gtk2-devel, xulrunner-devel
  202. - add BuildRequires: glib2-devel, libxslt
  203. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
  204. - new upstream release
  205. - remove BuildRequires: devhelp
  206. * Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
  207. - new upstream release
  208. * Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  209. - new upstream release
  210. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
  211. - new upstream release
  212. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  213. - rebuilt with rpm-4.8.1 for pkg-config
  214. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
  215. - new upstream release
  216. - made -doc subpackage noarch
  217. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
  218. - new upstream release
  219. * Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
  220. - new upstream release
  221. * Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
  222. - new upstream release
  223. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
  224. - new upstream release
  225. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  226. - new upstream release
  227. - change BuildRequires: gecko-libs -> xulrunner-devel
  228. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
  229. - new upstream release
  230. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
  231. - new upstream release
  232. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
  233. - new upstream release
  234. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
  235. - initial build for Vine Linux
  236. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
  237. - Update to 0.7.5
  238. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
  239. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  240. * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
  241. - Patch broken ModuleInit attribute (upstream bug 587444)
  242. * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
  243. - Update to 0.7.4
  244. * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
  245. - Update to 0.7.3
  246. * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  247. - Update to 0.6.1
  248. * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
  249. - Update to 0.5.7
  250. * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
  251. - Update to 0.5.6
  252. * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
  253. - Update to 0.5.3
  254. * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
  255. - Fix bug in Emacs version detection
  256. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
  257. - Use buildsystem variables to determine available Emacs version
  258. - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
  259. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
  260. - Update to 0.5.2
  261. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  262. - Update to 0.5.1
  263. * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
  264. - Update to 0.3.5
  265. * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
  266. - Add vala-mode for editing Vala code in Emacs
  267. * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
  268. - Update to 0.3.4
  269. * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
  270. - Update to 0.3.3
  271. * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
  272. - Update to 0.3.2
  273. * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
  274. - Update to 0.2.0
  275. * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
  276. - Update to 0.1.7
  277. - -tool subpackage now requires gnome-common, intltool and libtoolize
  278. for out-of-the-box vala-gen-project support
  279. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
  280. - Autorebuild for GCC 4.3
  281. * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  282. - Update to 0.1.6
  283. - Revert vapi addition, needed declarations have been inlined (r846)
  284. - Rename -docs subpackage to -doc, to comply with guidelines
  285. * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
  286. - Manually add Gee vapi file to package (bz #428692)
  287. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
  288. - Backport patch to autodetect location of automake shared files
  289. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
  290. - Add build dependency on gtk2-devel
  291. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
  292. - Enable project generator tool
  293. * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
  294. - Update to 0.1.5
  295. * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
  296. - Add build dependency on devhelp
  297. * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
  298. - Update to 0.1.4
  299. - Put newly-added documentation in its own subpackage (depends on devhelp)
  300. * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
  301. - vapigen subpackage: add missing Require: on perl-XML-Twig
  302. * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
  303. - Split -vapigen subpackage. It is functionally self-contained and the license
  304. is more restricted
  305. - Updated license declarations
  306. * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
  307. - Licensing and URL updates
  308. * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
  309. - Enable binding generation tools
  310. * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
  311. - Update to 0.1.3
  312. * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
  313. - Update to 0.0.8
  314. * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
  315. - Update to 0.0.7
  316. * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
  317. - Update to 0.0.6
  318. * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
  319. - Initial package