123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152 |
- # This package is maintained on trac svn repository. Please do not change on local.
- # If you find a BUG, please report to Vine@vinelinux.org or mailing list or BTS.
- %define version 0.0.19
- Summary: bootstrap scripts to create a basic Vine Linux system
- Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
- Name: vbootstrap
- Version: %{version}
- Release: 1%{?_dist_release}
- License: public domain
- Group: Development/Tools
- Url: http://trac.vinelinux.org/wiki/VineBootstrap
- Source0: %{name}-%{version}.tar.bz2
- Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildArch: noarch
- BuildRequires: sed
- Requires: bash, apt
- Requires: unionfs-utils
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: daisuke, munepi
- %description
- vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
- system. It uses rpm and apt to install basic rpm package into a directory
- which can be chrooted into.
- %description -l ja
- vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
- 作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
- 以下に基本の rpm パッケージをインストールし、chroot できるようにします。
- %prep
- [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
- %setup
- %build
- %__make
- %install
- %__make DESTDIR=$RPM_BUILD_ROOT install
- %clean
- [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
- %files
- %defattr(-,root,root)
- %{_sbindir}/vbootstrap
- %{_sbindir}/vbuilder
- %dir %{_datadir}/vbootstrap
- %{_datadir}/vbootstrap/*
- %{_sysconfdir}/bash_completion.d/vbuilder
- %config(noreplace) %{_sysconfdir}/vbootstrap/vbuilder.conf
- %changelog
- * Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.19-1
- - remove Retry_vbootstrap-post() from the vbuilder script:
- the trick (implemented in 0.0.18-1) moved to vbootstrap/scripts/* instead
- * Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.18-1
- - vbuilder:Retry_vbootstrap-post(): pass --justdb option to rpm
- so that apt-get don't have to actually install packages again
- (this will help avoid creating annoying .rpmorig/.rpmnew files)
- * Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.17-1
- - add --help option to vbuilder
- - ensure all files/subdirectories under BUILT_RPMS_DIR
- (i.e. $HOME/vbuilder/{5.1,VineSeed}/{RPMS/{i686,ppc,x86_64},SRPMS}/*)
- have ownerships of the user/group who executed "sudo vbuilder"
- * Mon Feb 22 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.16-1
- - added Requires: unionfs-utils
- - updated vbuilder.sh.in
- - added --unionfs option
- - supported 5.1 (by iwai-san)
- * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.15-1
- - added vbuilder-bash-completion.sh
- * Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.14-1
- - updated vbuilder.sh.in
- - used __chroot_sh
- - improved some functions for mounting file systems
- - defined Retry_vbootstrap-post()
- * Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.13-1
- - updated vbuilder.sh.in
- - fixed /home/vbuilder/.rpmmacros for VineSeed_i386, VineSeed
- - improved some mounting processes
- - defined mount_cache_dir()
- * Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.12-1
- - added 4.2_i386
- - updated vbuilder.sh.in
- - supported 4.2_i386 chroot on x86_64
- * Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.11-1
- - updated vbuilder.sh.in
- - added Japanese translations for error messages
- - improved some mounting processes
- - defined some mount functions
- - defined apt-get-update() function
- - defined check-parameter() function
- * Tue Dec 29 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.10-1
- - updated vbuilder.sh.in
- - added --dist-upgrade option which provides a flag to build
- VineSeed bootstrap via stable relase version
- * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.9-1
- - fixed vbuilder.sh.in around --target option
- * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.8-1
- - updated vbuilder.sh.in
- - added --target option which gives a build target of source rpm
- * Sun Nov 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.7-1
- - updated vbuilder.sh.in
- * Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.6-1
- - updated vbuilder.sh.in, little
- * Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-1
- - updated vbuilder.sh.in and vbuilder.conf.in
- - extended to store built rpms on chroot env. in each arch. of home rpm dir.
- * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.4-1
- - added vine-release in BASE_PKGS of scripts/*
- - added vbuilder.conf
- - updated vbuilder.sh.in
- * Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-2
- - rebuilt to add signature
- * Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
- - support 5.0 (by daisuke-san)
- - update vbuilder.sh.in
- - check chroot archtecture
- * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
- - add vbuilder
- * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
- - initial build
|