accerciser-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148
  1. %{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
  2. %define pkg_version 3.12.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: An interactive Python accessibility explorer for the GNOME desktop.
  5. Summary(ja): GNOME デスクトップ用 Python アクセシビリティエクスプローラ
  6. Name: accerciser
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. Source0: http://ftp.gnome.org/pub/GNOME/sources/accerciser/3.12/%{name}-%{version}.tar.xz
  10. License: BSD
  11. Group: Desktop/Accessibility
  12. URL: http://live.gnome.org/Accerciser
  13. Requires: python3 >= 3.2
  14. Requires: python3-pygobject >= 2.90.3
  15. Requires: python3-pyatspi >= 2.5.2
  16. Requires: at-spi2-core
  17. Requires(post): desktop-file-utils
  18. Requires(postun): desktop-file-utils
  19. BuildRequires: python3-devel >= 3.2
  20. BuildRequires: python3-pygobject
  21. BuildRequires: pygobject3-devel
  22. BuildRequires: gtk3-devel
  23. BuildRequires: at-spi2-core-devel
  24. BuildRequires: python3-pyatspi
  25. BuildRequires: glib2-devel >= 2.26.0
  26. BuildRequires: docbook-dtds
  27. BuildRequires: yelp-tools
  28. BuildRequires: autoconf
  29. BuildRequires: gnome-common
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: Takemikaduchi
  34. %description
  35. Accerciser is an interactive Python accessibility explorer for the GNOME
  36. desktop. It uses AT-SPI to inspect and control widgets, allowing you to check
  37. if an application is providing correct information to assistive technologies
  38. and automated test frameworks. Accerciser has a simple plugin framework which
  39. you can use to create custom views of accessibility information.
  40. %prep
  41. %setup -q
  42. %build
  43. %configure --disable-static
  44. %{__make} %{?_smp_mflags}
  45. %install
  46. %{__rm} -rf ${RPM_BUILD_ROOT}
  47. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  48. %find_lang %{name} --with-gnome --all-name
  49. %clean
  50. %{__rm} -rf ${RPM_BUILD_ROOT}
  51. %post
  52. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  53. update-desktop-database & > /dev/null || :
  54. %postun
  55. if [ $1 -eq 0 ]; then
  56. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  57. update-desktop-database & > /dev/null || :
  58. glib-compile-schemas %{_datadir}/glib-2.0/schemas
  59. fi
  60. %posttrans
  61. glib-compile-schemas %{_datadir}/glib-2.0/schemas
  62. %files -f %{name}.lang
  63. %defattr(-,root,root)
  64. %doc AUTHORS COPYING ChangeLog NEWS README
  65. %{_bindir}/accerciser
  66. %{python3_sitelib}/accerciser
  67. %{_datadir}/applications/accerciser.desktop
  68. %{_datadir}/accerciser/*
  69. %{_datadir}/glib-2.0/schemas/*.xml
  70. %{_datadir}/icons/hicolor/*/apps/*
  71. %{_datadir}/icons/HighContrast/*/apps/*
  72. %{_mandir}/man1/accerciser.1.gz
  73. %changelog
  74. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  75. - new upstream release
  76. - remove BuildRequires: python3-pygobject-devel
  77. - add BuildRequires: python3-pygobject, pygobject3-devel
  78. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-2
  79. - change BuildRequires: python3-pygobject-devel instead of pygobject3
  80. - change BuildRequires: python3-pyatspi instead of pyatspi
  81. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  82. - new upstream release
  83. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  84. - new upstream release
  85. - add BuildRequires: autoconf, gnome-common
  86. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  87. - new upstream release
  88. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  89. - new upstream release
  90. - change BuildRequires: yelp-tools instead of gome-doc-utils
  91. * Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
  92. - new upstream release
  93. - remove BuildRequires: GConf2-devel
  94. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  95. - new upstream release
  96. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  97. - new upstream release
  98. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  99. - new upstream release
  100. - add BuildRequires: gtk3-devel, pygobject3-devel
  101. - change BuildRequires: at-spi2-core-devel instead of at-spi-devel
  102. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
  103. - new upstream release
  104. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  105. - new upstream release
  106. * Mon May 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
  107. - new upstream release
  108. * Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  109. - initial build for Vine Linux