authconfig-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743
  1. Summary: Command line tool for setting up authentication from network services
  2. Summary(ja): ネットワークサービスからの認証を設定するためのコマンドラインツール
  3. Name: authconfig
  4. Version: 6.2.8
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. ExclusiveOS: Linux
  8. Group: System Environment/Base
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. URL: https://fedorahosted.org/authconfig
  11. Source: https://fedorahosted.org/releases/a/u/%{name}/%{name}-%{version}.tar.bz2
  12. Patch10: authconfig-6.2.3-fprintd-pam.patch
  13. Patch11: authconfig-6.2.3-fix-broken-strings.patch
  14. Requires: pam
  15. Conflicts: samba-common < 3.0, samba-client < 3.0
  16. Conflicts: nss_ldap < 254
  17. BuildRequires: glib2-devel, python >= 2.4.1, python-devel
  18. BuildRequires: desktop-file-utils, intltool, gettext, perl-XML-Parser
  19. %description
  20. Authconfig is a command line utility which can configure a workstation
  21. to use shadow (more secure) passwords. Authconfig can also configure a
  22. system to be a client for certain networked user information and
  23. authentication schemes.
  24. %description -l ja
  25. authconfig はシャドウ(よりセキュリティーが高い)パスワードの設定をおこなう
  26. コマンドラインプログラムです。また、ネットワークを介したユーザ情報と認証
  27. サービスを利用するように設定することもできます。
  28. %package gtk
  29. Summary: Graphical tool for setting up authentication from network services
  30. Summary(ja): ネットワークサービスからの認証を設定するためのグラフィカルツール
  31. Group: System Environment/Base
  32. Requires: %{name} = %{version}-%{release}, pygtk2-libglade
  33. Requires: usermode-gtk
  34. %description gtk
  35. Authconfig-gtk is a GUI program which can configure a workstation
  36. to use shadow (more secure) passwords. Authconfig-gtk can also configure
  37. a system to be a client for certain networked user information and
  38. authentication schemes.
  39. %prep
  40. %setup -q -n %{name}-%{version}
  41. %patch10 -p1
  42. %patch11 -p1
  43. %build
  44. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  45. %configure
  46. make
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. make install DESTDIR=$RPM_BUILD_ROOT
  50. rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutilmodule.a
  51. rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutilmodule.la
  52. rm $RPM_BUILD_ROOT/%{_datadir}/%{name}/authconfig-tui.py
  53. ln -s authconfig.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/authconfig-tui.py
  54. %find_lang %{name}
  55. find $RPM_BUILD_ROOT%{_datadir} -name "*.mo" | xargs ./utf8ify-mo
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %post
  59. authconfig --updateall --nostart &>/dev/null ||:
  60. %post gtk
  61. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  62. %postun gtk
  63. if [ $1 -eq 0 ] ; then
  64. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  65. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  66. fi
  67. %posttrans gtk
  68. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  69. %triggerin -- authconfig <= 6.2.3
  70. if [ ! -e %{_sysconfdir}/pam.d/postlogin-ac ]; then
  71. authconfig --updateall --nostart >/dev/null 2>&1 || :
  72. fi
  73. if [ ! -e %{_sysconfdir}/pam.d/postlogin ]; then
  74. cd %{_sysconfdir}/pam.d; \
  75. ln -s postlogin-ac postlogin > /dev/null 2>&1 || :
  76. fi
  77. %files -f %{name}.lang
  78. %defattr(-,root,root,-)
  79. %doc COPYING NOTES TODO README.samba3
  80. %ghost %config(noreplace) %{_sysconfdir}/sysconfig/authconfig
  81. %ghost %config(noreplace) %{_sysconfdir}/pam.d/system-auth-ac
  82. %ghost %config(noreplace) %{_sysconfdir}/pam.d/password-auth-ac
  83. %ghost %config(noreplace) %{_sysconfdir}/pam.d/fingerprint-auth-ac
  84. %ghost %config(noreplace) %{_sysconfdir}/pam.d/smartcard-auth-ac
  85. %ghost %config(noreplace) %{_sysconfdir}/pam.d/postlogin-ac
  86. %{_bindir}/authconfig
  87. %{_bindir}/authconfig-tui
  88. %{_sbindir}/cacertdir_rehash
  89. %{_sbindir}/authconfig
  90. %{_sbindir}/authconfig-tui
  91. %{_mandir}/man8/*
  92. %{_mandir}/man5/*
  93. %{python_sitearch}/acutilmodule.so
  94. %dir %{_datadir}/%{name}
  95. %{_datadir}/%{name}/authconfig.py*
  96. %{_datadir}/%{name}/authconfig-tui.py*
  97. %{_datadir}/%{name}/authinfo.py*
  98. %{_datadir}/%{name}/shvfile.py*
  99. %{_datadir}/%{name}/dnsclient.py*
  100. %{_datadir}/%{name}/msgarea.py*
  101. %config(noreplace) %{_sysconfdir}/pam.d/authconfig
  102. %config(noreplace) %{_sysconfdir}/pam.d/authconfig-tui
  103. %config(noreplace) %{_sysconfdir}/security/console.apps/authconfig
  104. %config(noreplace) %{_sysconfdir}/security/console.apps/authconfig-tui
  105. %attr(700,root,root) %dir %{_localstatedir}/lib/%{name}
  106. %files gtk
  107. %defattr(-,root,root,-)
  108. %{_bindir}/authconfig-gtk
  109. %{_bindir}/system-config-authentication
  110. %{_sbindir}/authconfig-gtk
  111. %{_sbindir}/system-config-authentication
  112. %{_datadir}/%{name}/authconfig.glade
  113. %{_datadir}/%{name}/authconfig-gtk.py*
  114. %config(noreplace) %{_sysconfdir}/pam.d/authconfig-gtk
  115. %config(noreplace) %{_sysconfdir}/pam.d/system-config-authentication
  116. %config(noreplace) %{_sysconfdir}/security/console.apps/authconfig-gtk
  117. %config(noreplace) %{_sysconfdir}/security/console.apps/system-config-authentication
  118. %{_datadir}/applications/*
  119. %{_datadir}/icons/hicolor/*/*/*
  120. %changelog
  121. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.8-1
  122. - update to 6.2.8
  123. - remove Patch101 (authconfig-6.2.3-authinfo-vine.patch)
  124. * Sat Oct 13 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.4-1
  125. - update to 6.2.4
  126. - run "authconfig --updateall --nostart" on %%post script
  127. * Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.3-1
  128. - update to 6.2.3
  129. - update Patch10 (authconfig-6.2.3-fprintd-pam.patch)
  130. - update Patch11 (authconfig-6.2.3-fix-broken-strings.patch)
  131. - add Patch101 (authconfig-6.2.3-authinfo-vine.patch)
  132. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.4.10-6
  133. - rebuild with python-2.7.2
  134. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.10-5
  135. - rebuilt with rpm-4.8.1-3
  136. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 5.4.10-4
  137. - rebuilt with python-2.6.4
  138. * Sun Aug 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-3
  139. - update Patch11
  140. - old patch does not fix problem on some environment..
  141. * Fri Aug 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-2
  142. - add Patch10
  143. - Fingerprint auth requires fprintd-pam package not pam_fprintd
  144. - add Patch11 to fix broken help messages on some locale.
  145. * Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-1
  146. - new upstream release
  147. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.4-1
  148. - new upstream release
  149. - historical changelogs are following:
  150. * Tue Apr 05 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl4
  151. - added authconfig-4.6.1-authinfo.patch, by HOTTA Michihide <hotta@net-newbie.com>
  152. - added BuildRequires: desktop-file-utils
  153. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl3
  154. - rebuilt with python-2.4.1-0vl1
  155. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl2
  156. - rebuilt with python-2.3.3-0vl1
  157. * Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl1.1
  158. - rebuilt with python-2.3.3-0vl0.3 (for TestPkg)
  159. * Sun Feb 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1vl1
  160. - updated to 4.6.1
  161. - updated Patch0 and Source1
  162. - rebuild with new toolchains
  163. - Reqyires: glib2, BuildRequires: glib2-devel
  164. * Sat Jul 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl2
  165. - add vinized color palette
  166. * Thu Jul 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl1
  167. - rebuild for Vine Linux
  168. - based on Red Hat Linux 7.2, merged with Vine Linux package.
  169. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  170. - 3.0.3-1vl5
  171. - change checkbox color
  172. * Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 3.0.3-1vl4
  173. - add %patch1 to fix mandir
  174. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.0.3-1vl3
  175. - build with gcc-2.95.3
  176. - partially used rpmmacros
  177. * Thu Jul 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  178. - 3.0.3-1vl2
  179. - modified %files section to handle compressed man page
  180. * Thu May 11 2000 Jun Nishii <jun@vinelinux.org>
  181. - 3.0.3-1vl1
  182. - build for Vine
  183. * Tue Aug 5 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.4-1
  184. - do not call domainname when run with --nostart (#457697)
  185. * Fri Jun 6 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.3-1
  186. - remove the --enableldapssl alias and add some help to GUI tooltips
  187. to clear up some confusion (#220973)
  188. - add option --enablepreferdns to prefer DNS over NIS or WINS in
  189. hostname resolution
  190. * Tue Apr 8 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.2-1
  191. - read wins setting from nsswitch.conf correctly (#440459)
  192. - do not ignore --enablemd5/--disablemd5 options
  193. * Tue Mar 11 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.1-1
  194. - fixed backup directory in Makefile and spec (#437040)
  195. * Mon Mar 10 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.0-1
  196. - include config-util in console.apps files
  197. - add support for saving/restoring backups of configuration
  198. files affected by authconfig (#433776)
  199. - improve the authconfig manual page (#432023, #432938)
  200. * Tue Jan 29 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.21-1
  201. - correct the fix for bug #237956
  202. * Fri Jan 18 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.20-1
  203. - update translations
  204. * Wed Jan 9 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.19-1
  205. - support new sha256 and sha512 password hash algorithms
  206. - add support for pam_mkhomedir (#212790)
  207. - do not crash in authconfig --help (#237956) - thanks to Andy Shevchenko for
  208. the idea how to fix that
  209. - setup password hash algorithm in /etc/login.defs (#218652)
  210. - update translations
  211. * Tue Sep 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.18-1
  212. - improve krb5.conf handling (#238766)
  213. * Fri Aug 24 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.17-1
  214. - remove obsolete pam_krb5afs support (#250704)
  215. - add support for pam_access (#251360)
  216. - update translations
  217. * Tue Aug 21 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-3
  218. - license tag fix
  219. * Thu Aug 9 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-2
  220. - require newt-python (#251359)
  221. * Wed Jul 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-1
  222. - add support for winbind offline login (#232955)
  223. * Wed Jul 18 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.15-1
  224. - dnsclient fixes by Simo Sorce
  225. - add Categories to .desktop file (#245868)
  226. - fixed traceback when calling joinDomain (#245374)
  227. - disable smart card action setting when gnome-screensaver
  228. not installed (#209643)
  229. - do not change protocols and services in nsswitch.conf (#236669)
  230. * Tue Jun 12 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.14-1
  231. - authconfig.8 synopsis fixed (patch by Eric Raymond) (#220574)
  232. - drop explicit requirement on python version as it is now
  233. generated automatically
  234. - improve writing /etc/samba/smb.conf (based on patch by
  235. Simo Sorce)
  236. - merge changes upstream
  237. * Fri May 4 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-4
  238. - local nis domain is obtained from sysconfig/network (#235927)
  239. - set "local authorization is sufficient" on by default
  240. * Thu Apr 5 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-3
  241. - minor changes and cleanups for merge review (#225293)
  242. * Mon Mar 19 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-2
  243. - nss_ldap is now in /usr/lib (#232975)
  244. * Tue Dec 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.13-1
  245. - another traceback in --probe and other fixes (#218874)
  246. - make smbRealm a default realm when appropriate (#219300)
  247. - added missing languages in LINGUAS
  248. * Wed Nov 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.12-1
  249. - when pam_krb5 auth fails with smartcard login don't enforce it
  250. in the account stack (#214931)
  251. - updated translations (#216570)
  252. - winbind should be added only to user tables (#216862)
  253. * Fri Oct 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.11-1
  254. - fixed --smartcardaction command line option (#211552)
  255. * Fri Oct 6 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.10-1
  256. - fixed passwd PAM stack when PKCS11 enabled (#195960)
  257. - make authconfig --probe work again (#209676)
  258. * Mon Oct 2 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.9-1
  259. - updated translations (#207095)
  260. - correctly write pam_smb.conf with only one server specified (#208365)
  261. * Thu Sep 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.8-1
  262. - move options to another tab to fit on 800x600 screen (#207357)
  263. * Tue Sep 19 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.7-1
  264. - improve PAM setup for smart card login
  265. - support smart card login with kerberos (PKINIT)
  266. - add pam_pkcs11 to password PAM stack
  267. * Mon Sep 4 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.6-1
  268. - skip pam_unix for session for crond service
  269. - fixed a bug in saving when smartcard settings changed (#204838)
  270. - removed allow_ypbind setsebool as it is now handled in ypbind
  271. * Tue Aug 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.5-1
  272. - improve smart card related UI strings
  273. - removed possibility to set smart card type from authconfig-gtk
  274. as only coolkey will be supported for now
  275. * Thu Aug 24 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.4-1
  276. - pass options given to authconfig-gtk to authconfig (#203955)
  277. * Sun Jul 23 2006 Ray Strode <rstrode@redhat.com> - 5.3.3-2
  278. - write out new "wait_for_card" config option if we're
  279. forcing smart card authentication
  280. - add "use_uid" option to smart card pam_succeed_if line to
  281. work around bug where pam_succeed_if checks user information
  282. even in cases where the conditional doesn't depend on it.
  283. - remove unimplemented "logout" smart card removal action from
  284. settings
  285. - remove unnecessary "card_only" argument
  286. * Fri Jul 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.3-1
  287. - don't start sceventd when smartcard login is enabled
  288. - improve pam config for smartcard login
  289. * Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.2-1
  290. - don't require pam_pkcs11 to run
  291. * Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.1-1
  292. - screensavers should be authenticated by smartcard too
  293. - add feature to download a CA certificate for LDAP from
  294. an URL (#197103)
  295. - add pam_keyinit session module to the PAM configuration (#198638)
  296. * Fri Jul 7 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.0-1
  297. - added support for smartcard authentication
  298. - fixed parsing kerberos realms
  299. * Thu May 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.5-1
  300. - write ldap servers as URIs and not HOSTs (#191842)
  301. - fix a typo in --test output
  302. - updated summary, converted changelog to UTF-8
  303. * Fri May 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.4-1
  304. - added crond to the services restarted after firstboot (#187334)
  305. - when checking nscd status redirect output to /dev/null (#188555)
  306. * Tue Mar 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.3-1
  307. - make smb.conf and krb5.conf loading more robust (#185766)
  308. * Mon Feb 27 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.2-1
  309. - add try_first_pass option to pam_unix for better integration
  310. with individual service configurations (#182350)
  311. - updated translations
  312. * Mon Feb 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.1-1
  313. - don't crash in TUI when some options aren't set (#182151)
  314. * Fri Feb 3 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.0-1
  315. - redesigned GUI (#178112)
  316. - added man page for system-config-ac (#179584)
  317. - disable authentication of system accounts by network services
  318. by default, added option for changing that (#179009)
  319. - updated translations, new languages
  320. * Mon Jan 9 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.2-1
  321. - fixed regression when saving nsswitch.conf
  322. * Fri Jan 6 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.1-1
  323. - print warning if PAM module is missing when the PAM configuration
  324. is saved (#168880)
  325. * Fri Dec 23 2005 Tomas Mraz <tmraz@redhat.com>
  326. - make child dialog preset code more robust (#176462)
  327. * Sat Dec 17 2005 Tomas Mraz <tmraz@redhat.com> - 5.1.0-1
  328. - update only configuration files which settings were modified (#72290)
  329. * Mon Dec 5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.4-1
  330. - don't ignore krb5realm command line option (#174838)
  331. - read dns_lookup_realm and dns_lookup_kdc values correctly
  332. - the PAM configuration is now written in system-auth-ac file
  333. which is then symlinked from system-auth, the symlink is not
  334. overwritten so local PAM configuration is now possible (#165342)
  335. * Mon Nov 7 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.3-1
  336. - add symlinks to python scripts in sbindir
  337. - don't override nullok setting from system-auth (#96996)
  338. * Fri Oct 14 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.2-1
  339. - authinfo-tui.py is now symlink
  340. - reword the CA certificate message (#154317)
  341. - use include instead of pam_stack in pam config
  342. - don't break yp.conf with multiple domains (#127306)
  343. * Mon Sep 5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.1-1
  344. - fixed a few errors catched by pychecker
  345. * Sat Sep 3 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.0-1
  346. - C code completely rewritten in Python
  347. - some bugs fixed in the process (and no doubt new introduced)
  348. - TUI deprecated, opens only when run as authconfig-tui
  349. * Mon Jun 20 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.13-1
  350. - set domain and ypserver option correctly when multiple servers
  351. specified in kickstart (#159214)
  352. * Tue Apr 12 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.12-1
  353. - replaced deprecated gtk.TRUE/FALSE (#153034)
  354. - updated translations
  355. * Mon Mar 14 2005 Tomas Mraz <tmraz@redhat.com>
  356. - propagate the --enablewinbindauth option to the configuration (#151018)
  357. * Fri Mar 4 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.11-1
  358. - changed version propagation
  359. * Thu Mar 3 2005 Tomas Mraz <tmraz@redhat.com>
  360. - updated translations
  361. - fixed build on gcc4
  362. * Wed Feb 23 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.10-1
  363. - updated translations
  364. * Thu Feb 10 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.9-1
  365. - improved the code that writes tls_cacertdir to ldap.conf
  366. * Tue Jan 25 2005 Tomas Mraz <tmraz@redhat.com>
  367. - renamed functions in authconfigmodule to be more clear
  368. - implemented cacertdir for LDAP with TLS
  369. * Mon Jan 24 2005 Tomas Mraz <tmraz@redhat.com>
  370. - fixed a bug in authinfo_differs when called from python
  371. * Fri Dec 17 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.8-1
  372. - add option for making local authorization sufficient for local users
  373. this is attempt to 'solve/workaround' the problem with blocking local logins by
  374. pulling out network cable (#115181)
  375. * Wed Dec 15 2004 Tomas Mraz <tmraz@redhat.com>
  376. - remove dependency on nscd
  377. - don't show warning messages when switching options off
  378. * Mon Dec 6 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.7-1
  379. - updated translations
  380. - winbind in authconfig-gtk.py was setting the nsswitch.conf on the auth tab
  381. - use GtkComboBox instead of deprecated GtkOptionMenu
  382. - disable options with not installed binaries, remove unnecessary deps of
  383. authconfig-gtk
  384. * Thu Nov 18 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.6-1
  385. - merged patches from dist
  386. - fix versioning
  387. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 4.6.5-6
  388. - rebuild against python 2.4
  389. * Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
  390. - Fix setsebool patch to turn off boolean
  391. * Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
  392. - Add setsebool for NIS
  393. * Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
  394. - force broken_shadow option on network auth (#136760)
  395. * Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
  396. - force restart of autofs on firstboot call when using NIS (#133035, #124498)
  397. * Thu Oct 07 2004 Tomas Mraz <tmraz@redhat.com>
  398. - require python to install (#134654)
  399. * Mon Oct 04 2004 Jindrich Novy <jnovy@redhat.com> 4.6.5-1
  400. - updated translations from upstream
  401. - autogeneration of build stripts in prep phase
  402. * Thu Sep 30 2004 Jindrich Novy <jnovy@redhat.com>
  403. - fixed man page
  404. - added dependency on nscd
  405. * Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-6
  406. - regenerated build scripts
  407. * Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-5
  408. - fixed all po files to translate correctly messages with modified accelerators (#133742)
  409. - added translations for Arabic, Bulgarian and other languages (#133716, #133158)
  410. * Wed Sep 22 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-4
  411. - added "quiet" option to pam_success_if PAM module in sytem-auth (#133179)
  412. * Mon Sep 13 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-3
  413. - corrected package dependencies #132411
  414. - regenerated glade.strings.h #132369
  415. * Wed Aug 25 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-2
  416. - modified authconfig-gtk interface to fit lower resolution screens (#127175)
  417. - modified accelerators in authconfig-gtk (#125797)
  418. - updated package dependencies (#125306)
  419. * Tue Aug 24 2004 Jindrich Novy <jnovy@redhat.com>
  420. - updated configure scripts
  421. - warnfixes and minor hacks
  422. * Mon Jun 7 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.4-1
  423. - tweak account management to fix #55193 correctly
  424. - require anything we might want to run in the gui subpackage because it
  425. doesn't warn about missing things and you don't have a terminal to see
  426. error messages about missing commands
  427. - properly display the domain in the GUI join dialog (#124621)
  428. * Tue May 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.3-1
  429. - omit the "ads" or "rpc" when calling "net join", Samba's smarter now (#122802)
  430. - properly warn about missing "net" (samba-client) and libnss_winbind and
  431. pam_winbind (samba-common) in text mode (#122802)
  432. * Wed Apr 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.2-1
  433. - learn all about pam_passwdqc
  434. - preserve arguments to pam_cracklib and pam_passwdqc
  435. - short-circuit PAM authorization checks for users with UID < 100
  436. - remove redhat-config-authentication as a way to invoke the GUI tool (#115977)
  437. * Fri Feb 6 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.1-1
  438. - fix man page: --enableldapssl should be --enableldaptls
  439. - make --enableldapssl an alias for --enableldaptls
  440. * Thu Jan 8 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6-1
  441. - authconfig-gtk.py: require rhpl, which is required by the script (#104209)
  442. - both: require usermode (authconfig-gtk transitively), else leave a dangling
  443. symlink (#104209)
  444. - the great redhat-config-authentication/system-config-authentication renaming,
  445. as was foretold in the fedora-config-list archives
  446. * Wed Jan 7 2004 Nalin Dahyabhai <nalin@redhat.com>
  447. - preserve "compat" if it's used in /etc/nsswitch.conf
  448. * Tue Nov 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.4-1
  449. - add options for toggling krb5's use of DNS
  450. * Mon Nov 17 2003 Nalin Dahyabhai <nalin@redhat.com>
  451. - rework tui to include winbind options. there wasn't enough room in the old
  452. dialog to include the important options, so the whole thing's been reworked
  453. * Thu Nov 13 2003 Nalin Dahyabhai <nalin@redhat.com>
  454. - conflict with older versions of samba which expect different configuration
  455. * Mon Nov 10 2003 Nalin Dahyabhai <nalin@redhat.com>
  456. - initial support for configuring winbind
  457. * Tue Oct 28 2003 Nalin Dahyabhai <nalin@redhat.com>
  458. - make pam_cracklib requisite instead of required in generated PAM configs
  459. * Wed Oct 22 2003 Bill Nottingham <notting@redhat.com> 4.3.8-1
  460. - rebuild with current translations
  461. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-2
  462. - make the tarball name include the release number
  463. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-1
  464. - authconfig-gtk: condrestart certain additional services if invoked with
  465. the --firstboot flag (half of #91268, needs cooperating firstboot)
  466. - translation updates
  467. * Mon Jul 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.6-1
  468. - translation updates
  469. * Mon Jun 30 2003 Nalin Dahyabhai <nalin@redhat.com>
  470. - add 'redhat-config-authentication' as an alias for authconfig-gtk
  471. - make authconfig-gtk exec authconfig if gui startup fails and it looks like
  472. we're connected to a tty
  473. * Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
  474. - rebuilt
  475. * Mon May 5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.5-1
  476. - translation updates
  477. - close unusable file descriptors if locking fails
  478. * Tue Feb 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.4-1
  479. - learn how to toggle defaults/crypt_style in /etc/libuser.conf (#79337)
  480. * Fri Feb 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.3-1
  481. - look in /lib64 for modules for nsswitch and PAM by default on
  482. x86_64, ppc64, and s390x (#83049)
  483. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  484. - rebuilt
  485. * Mon Nov 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-1
  486. - update translations
  487. - update copyright strings (only took 10 months!)
  488. * Wed Oct 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.1-1
  489. - require a version of PAM (0.75-43) which supports $ISA
  490. - use $ISA in our own PAM config files
  491. * Tue Oct 22 2002 Nalin Dahyabhai <nalin@redhat.com>
  492. - add $ISA to the name of the directory in which we expect PAMs to be stored
  493. * Fri Sep 20 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3-1
  494. - build with -fPIC, necessary on some arches
  495. * Tue Sep 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-3
  496. - update translations
  497. * Thu Aug 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.2.12-2
  498. - Update translations
  499. * Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-1
  500. - modify spacing and layout in authconfig-gtk
  501. * Thu Aug 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-4
  502. - translation updates
  503. - rebuild to pick up dependency changes
  504. * Mon Jul 29 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-3
  505. - include the userhelper configuration file
  506. - require sufficiently-new pam package in the gui subpackage
  507. * Fri Jul 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-2
  508. - actually include the icon in the package
  509. - translation updates
  510. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-1
  511. - use desktop-file-install (#69376)
  512. - include an icon for the menu item (#68577)
  513. * Wed Jul 17 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-2
  514. - own the pkgdatadir
  515. - pull in translation updates
  516. * Mon Jun 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-1
  517. - add --enable-experimental to enable some of that experimental code
  518. - add --enable-local to enable local policies
  519. - update translations
  520. * Thu May 30 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-7
  521. - use the current revision of python by default
  522. - get the intltool/gettext situation sorted out
  523. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  524. - automated rebuild
  525. * Fri May 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-5
  526. - remove bogus buildrequires left over from when authconfig-gtk was C code
  527. - buildrequires python-devel in addition to python (to build the python module,
  528. but we still need python to byte-compile the python script)
  529. * Thu Apr 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-4
  530. - add missing translations back in
  531. - convert .mo files at install-time
  532. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-3
  533. - refresh translations
  534. * Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-2
  535. - actually add the .desktop files
  536. * Tue Apr 9 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-1
  537. - refresh translations
  538. - destroy the python object correctly
  539. * Tue Mar 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-2
  540. - add the .desktop file
  541. * Mon Mar 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-1
  542. - rework the auth stack logic to require all applicable auth modules
  543. * Fri Mar 1 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.6-1
  544. - allow pam_krb5afs to be used for account management, too
  545. * Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-3
  546. - refresh translations
  547. * Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-2
  548. - refresh translations
  549. * Tue Feb 12 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-1
  550. - actually free authInfo structures when asked to
  551. - use pam_krb5's account management facilities
  552. - conflict with versions of pam_krb5 which don't offer account management
  553. * Mon Feb 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.4-1
  554. - add python bindings for the back-end
  555. - redo the gui so that it exercises the python bindings
  556. - take a shot at getting authconfig to work in a firstboot container
  557. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-4
  558. - rebuild again
  559. * Wed Jan 30 2002 Tim Powers <timp@redhat.com> 4.2.3-3
  560. - rebuilt against new glib
  561. * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-2
  562. - rebuild in new environment
  563. * Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-1
  564. - add some more experimental options
  565. - clean up the glade files a bit
  566. - don't destroy a garbage pointer on main cancel, destroy the main dialog
  567. * Thu Jan 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-2
  568. - bump release and rebuild
  569. * Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-1
  570. - make setting of experimental options only possible through
  571. /etc/sysconfig/authconfig, to keep accidents from happening
  572. - add some more support for experimental stuff
  573. * Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.1-1
  574. - fix setting of LDAP TLS option in authconfig-gtk
  575. - change Apply to Ok, Close to Cancel, because that's how they work
  576. * Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-2
  577. - add the glade XML file to the -gtk subpackage (fix from katzj)
  578. * Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-1
  579. - port to glib2
  580. - move post code to the back-end
  581. - add a libglade GUI in a -gtk subpackage
  582. - set up to use userhelper