eog-plugins-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153
  1. %{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
  2. %define pkg_version 3.12.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: Plugins for eog
  5. Summary(ja): eog用のプラグイン
  6. Name: eog-plugins
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. Source0: http://download.gnome.org/sources/%{name}/3.12/%{name}-%{version}.tar.xz
  10. Source1: README.vine
  11. License: GPLv2+
  12. Group: Applications/Graphics
  13. URL: http://live.gnome.org/EyeOfGnome/Plugins
  14. BuildRequires: gtk3-devel
  15. BuildRequires: eog-devel
  16. BuildRequires: libexif-devel
  17. BuildRequires: libchamplain-devel, libchamplain-gtk-devel
  18. BuildRequires: libpeas-devel
  19. BuildRequires: gsettings-desktop-schemas-devel
  20. BuildRequires: libgdata-devel
  21. BuildRequires: python3-devel
  22. BuildRequires: postr
  23. Requires: eog
  24. Requires(postun,posttrans): glib2
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: Takemikaduchi
  29. %description
  30. It's a collection of plugins for use with the Eye of GNOME Image Viewer.
  31. %description -l ja
  32. Eye of GNOME イメージビューア用のプラグイン集
  33. %prep
  34. %setup -q
  35. %{__cp} %{SOURCE1} .
  36. %build
  37. %configure --with-plugins=map,exif-display,fit-to-width,pythonconsole,slideshowshuffle,postr,postasa,send-by-mail
  38. %{__make} %{?_smp_mflags}
  39. %install
  40. %{__rm} -rf ${RPM_BUILD_ROOT}
  41. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  42. # remove *.la
  43. %{__rm} -f ${RPM_BUILD_ROOT}/%{_libdir}/eog/plugins/*.la
  44. %find_lang %{name}
  45. %clean
  46. %{__rm} -rf ${RPM_BUILD_ROOT}
  47. %postun
  48. if [ $1 -eq 0 ]; then
  49. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  50. fi
  51. %posttrans
  52. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  53. %files -f %{name}.lang
  54. %defattr(-,root,root)
  55. %doc COPYING ChangeLog NEWS README README.vine
  56. %{_libdir}/eog/plugins
  57. %{_datadir}/eog/plugins/pythonconsole/config.ui
  58. %{_datadir}/glib-2.0/schemas/org.gnome.eog.plugins.exif-display.gschema.xml
  59. %{_datadir}/glib-2.0/schemas/org.gnome.eog.plugins.pythonconsole.gschema.xml
  60. %changelog
  61. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  62. - new upstream release
  63. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
  64. - rebuild with VineSeed environment
  65. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  66. - new upstream release
  67. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  68. - new upstream release
  69. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  70. - new upstream release
  71. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  72. - new upstream release
  73. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  74. - new upstream release
  75. - add BuildRequires: gsettings-desktop-schemas-devel
  76. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  77. - new upstream release
  78. - remove Patch0
  79. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
  80. - new upstream release
  81. * Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  82. - new upstream release
  83. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  84. - new upstream release
  85. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
  86. - new upstream release
  87. - add BuildRequires: postr
  88. * Sun Sep 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.1.2-2
  89. - enable postr (upload picture to Flickr)
  90. - enable postasa (upload picture to Picasa web)
  91. - enable send-by-mail (Send picture to friends by evolution mail)
  92. - add libgdata-devel to BR
  93. - add README.vine
  94. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
  95. - new upstream release
  96. - add BuildRequires: libpeas-devel
  97. - change BuildRequires: gtk3-devel instead of gtk2-devel
  98. - update Patch0
  99. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  100. - new upstream release
  101. - change BuildRequires: eog-devel instead of eog
  102. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  103. - rebuild with libchamplain-0.8
  104. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  105. - new upstream release
  106. * Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  107. - new upstream release
  108. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
  109. - initial build for Vine Linux
  110. - exclude postr plugin