gnome-do-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. %define mainver 0.8.3
  2. Name: gnome-do
  3. Version: 0.8.3.1
  4. Release: 2%{?_dist_release}
  5. Summary: An intelligent launcher tool for Gnome
  6. Summary(ja): Gnome 用の高機能ランチャー
  7. License: GPLv3+
  8. Group: Applications/Accessories
  9. URL: http://do.davebsd.com/
  10. Source0: http://edge.launchpad.net/do/0.8/%{mainver}/+download/gnome-do-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. # Various Mono dependencies are not available for ppc64; see bug 241850.
  13. ExcludeArch: ppc64
  14. BuildRequires: mono-devel, mono-addins
  15. BuildRequires: desktop-file-utils
  16. BuildRequires: ndesk-dbus
  17. BuildRequires: ndesk-dbus-glib
  18. BuildRequires: gtk-sharp2
  19. BuildRequires: notify-sharp-devel
  20. BuildRequires: gnome-sharp2, gnome-desktop-sharp2 >= 2.26
  21. BuildRequires: gnome-keyring-sharp-devel
  22. BuildRequires: gettext
  23. BuildRequires: perl-XML-Parser
  24. BuildRequires: intltool
  25. BuildRequires: gtk2-devel
  26. BuildRequires: desktop-file-utils
  27. BuildRequires: wnck-sharp
  28. Requires(pre): GConf2
  29. Requires(post): GConf2
  30. Requires(preun): GConf2
  31. Requires: gnome-keyring-sharp, gnome-desktop-sharp2
  32. Requires: pkgconfig
  33. Packager: kazutaka
  34. %description
  35. GNOME Do (Do) is an intelligent launcher tool that makes performing
  36. common tasks on your computer simple and efficient. Do not only
  37. allows you to search for items in your desktop environment
  38. (e.g. applications, contacts, bookmarks, files, music), it also
  39. allows you to specify actions to perform on search results
  40. (e.g. run, open, email, chat, play).
  41. %description -l ja
  42. GNOME Do (Do) は高機能なランチャーツールです。 PC を使った一
  43. 般的なタスクをシンプルかつ効率的に実行できるようにします。Do
  44. はデスクトップ環境の様々なアイテム(例えばアプリケーションや
  45. 連絡先、ブックマーク、ファイル、音楽等)の検索だけでなく、検索
  46. した結果をどう操作するのか(例えば開く、メールに添付、チャット、
  47. 再生する等)を指定することができます。
  48. %package devel
  49. Summary: Development files for GNOME Do
  50. SUmmary(ja): GNOME Do の開発用ファイル
  51. Group: Development/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: pkgconfig
  54. %description devel
  55. Development files for GNOME Do
  56. %description devel -l ja
  57. GNOME Do の開発用ファイルです。
  58. %prep
  59. %setup -q
  60. %build
  61. %configure
  62. make %{?_smp_mflags}
  63. %install
  64. rm -rf ${RPM_BUILD_ROOT}
  65. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  66. make install DESTDIR=${RPM_BUILD_ROOT}
  67. desktop-file-install \
  68. --dir ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart \
  69. --add-only-show-in=GNOME \
  70. ${RPM_BUILD_ROOT}%{_datadir}/applications/gnome-do.desktop
  71. desktop-file-install --delete-original \
  72. --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
  73. --remove-category Application \
  74. ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
  75. #own this dir:
  76. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}
  77. %find_lang %{name}
  78. %pre
  79. if [ "$1" -gt 1 ]; then
  80. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  81. gconftool-2 --makefile-uninstall-rule \
  82. %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
  83. fi
  84. %post
  85. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  86. gconftool-2 --makefile-install-rule \
  87. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  88. touch --no-create %{_datadir}/icons/hicolor
  89. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  90. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  91. fi
  92. %preun
  93. if [ "$1" -eq 0 ]; then
  94. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  95. gconftool-2 --makefile-uninstall-rule \
  96. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  97. fi
  98. %postun
  99. touch --no-create %{_datadir}/icons/hicolor
  100. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  101. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  102. fi
  103. %clean
  104. rm -rf ${RPM_BUILD_ROOT}
  105. %files -f %{name}.lang
  106. %defattr(-,root,root,-)
  107. %doc AUTHORS COPYING COPYRIGHT
  108. %{_bindir}/gnome-do/
  109. %{_libdir}/gnome-do/
  110. %{_datadir}/gnome-do/
  111. %config(noreplace) %{_sysconfdir}/xdg/autostart/gnome-do.desktop
  112. %config(noreplace) %{_sysconfdir}/gconf/schemas/*
  113. %{_datadir}/icons/hicolor/*/apps/gnome-do.*
  114. %{_datadir}/applications/*
  115. %files devel
  116. %defattr(-,root,root,-)
  117. %{_libdir}/pkgconfig/*
  118. %changelog
  119. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.3.1-2
  120. - rebuilt with mono-addins-0.5
  121. * Sun Jan 10 2010 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.3.1-1
  122. - new upstream release
  123. * Fri Jul 10 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.2-1
  124. - new upstream release
  125. - drop Patch0 (merged in upstream)
  126. * Fri Jun 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-3
  127. - change Group to Applications/Accessories
  128. * Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.1.3-2
  129. - add BuildRequires: wnck-sharp
  130. * Thu Jun 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-1
  131. - initial build for Vine Linux based on fedora development
  132. * Fri Apr 10 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-5
  133. - Fix .desktop issue, install in both autostart and applications
  134. - Rebuild for new gnome-desktop-sharp
  135. - Add missing gnome-desktop-sharp requires
  136. - Fix Ndesk-dbus Requires
  137. * Wed Apr 01 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-3
  138. - Add patch to fix issue where applications wasn't being indexed
  139. * Tue Mar 17 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-2
  140. - New upstream release
  141. * Tue Mar 3 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-4
  142. - Own _datadir/gnome-do
  143. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-3
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  145. * Sat Feb 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.8.0-2
  146. - Rebuild against new mono-addins
  147. * Fri Jan 30 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-1
  148. - New upstream release
  149. * Thu Jan 29 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1.0-3
  150. - Remove Tomboy dependency (bz #481183)
  151. - Updated description, from Do
  152. * Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6.1.0-2
  153. - rebuild against new gnome-sharp
  154. * Wed Oct 08 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.1.0-1
  155. - New Upstream Release
  156. * Fri Oct 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.1-1
  157. - New upstream release
  158. * Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.0-1
  159. - New upstream release
  160. * Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.5.0.1-4
  161. - New upstream release
  162. - Add gnome-desktop-sharp dependency
  163. * Wed Jun 04 2008 Caol叩n McNamara <caolanm@redhat.com> - 0.4.2.0-2
  164. - rebuild for dependancies
  165. * Tue Apr 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.4.2.0-1
  166. - New upstream release
  167. * Tue Apr 01 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-2
  168. - #439793 - correct URL
  169. * Sat Mar 29 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-1
  170. - Bump to 0.4.0.1
  171. - Hopefully bring an end to the endless dups of 432201
  172. * Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-2
  173. - Fix 432201
  174. * Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-1
  175. - Bump to 0.3.1
  176. * Wed Feb 06 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-5
  177. - #431589 - Force runtime dependency on ndesk-dbus(-glib)
  178. * Mon Feb 04 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-4
  179. - #431462 - Correctly pull in Tomboy runtime dependency
  180. * Fri Jan 25 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-3
  181. - autostart gnome-do in quiet mode with the user session
  182. - to invoke gnome-do use super+space
  183. * Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-2
  184. - Fix BuildRequires
  185. * Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-1
  186. - bump to 0.3.0.1
  187. - update patches
  188. * Sat Nov 17 2007 David Nielsen <david@lovesunix.net> - 0.0.2-2
  189. - updated libdir patch
  190. - cleaned up desktop-file-install invocation
  191. - correct BuildRequires
  192. * Mon Nov 12 2007 David Nielsen <david@lovesunix.net> - 0.0.2-1
  193. - Initial package