ConsoleKit-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293
  1. %define glib2_version 2.20.0
  2. %define dbus_version 1.2
  3. %define dbus_glib_version 0.80
  4. %define polkit_version 0.92
  5. Summary: System daemon for tracking users, sessions and seats
  6. Summary(ja): ユーザ、セッションおよび座席を捕捉するシステムデーモン
  7. Name: ConsoleKit
  8. Version: 0.4.1
  9. Release: 1%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Daemons
  12. URL: http://www.freedesktop.org/wiki/Software/ConsoleKit
  13. Source0: http://people.freedesktop.org/~mccann/dist/ConsoleKit-%{version}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: glib2-devel >= %{glib2_version}
  16. BuildRequires: dbus-devel >= %{dbus_version}
  17. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  18. BuildRequires: polkit-devel >= %{polkit_version}
  19. BuildRequires: pam-devel
  20. BuildRequires: libX11-devel
  21. BuildRequires: zlib-devel
  22. BuildRequires: xmlto
  23. Requires: dbus
  24. Requires: dbus-glib
  25. %description
  26. ConsoleKit is a system daemon for tracking what users are logged
  27. into the system and how they interact with the computer (e.g.
  28. which keyboard and mouse they use).
  29. It provides asynchronous notification via the system message bus.
  30. %package x11
  31. Summary: X11-requiring add-ons for ConsoleKit
  32. Summary(ja): X11 を必要とする ConsoleKit アドオン
  33. License: GPLv2+
  34. Group: System Environment/Daemons
  35. Requires: %name = %{version}-%{release}
  36. Requires: libX11
  37. %description x11
  38. ConsoleKit contains some tools that require Xlib to be installed,
  39. those are in this separate package so server systems need not install
  40. X. Applications (such as xorg-x11-xinit) and login managers (such as
  41. gdm) that need to register their X sessions with ConsoleKit needs to
  42. have a Requires: for this package.
  43. %package libs
  44. Summary: ConsoleKit libraries
  45. Summary(ja): ConsoleKit ライブラリ
  46. License: MIT
  47. Group: System Environment/Libraries
  48. Requires: pam
  49. Requires: dbus
  50. %description libs
  51. Libraries and a PAM module for interacting with ConsoleKit.
  52. %package devel
  53. Summary: Development libraries and headers for ConsoleKit
  54. Summary(ja): Development libraries and headers for ConsoleKit
  55. License: MIT
  56. Group: Development/Libraries
  57. Requires: dbus-devel
  58. Requires: pkgconfig
  59. %description devel
  60. Headers, libraries and API docs for ConsoleKit
  61. %package docs
  62. Summary: Developer documentation for ConsoleKit
  63. Summary(ja): ConsoleKit の開発用ドキュメント
  64. Group: Development/Libraries
  65. Requires: %name = %{version}-%{release}
  66. %description docs
  67. Developer documentation for ConsoleKit.
  68. %prep
  69. %setup -q
  70. %build
  71. %configure --with-pid-file=%{_localstatedir}/run/console-kit-daemon.pid --enable-pam-module --with-pam-module-dir=/%{_lib}/security --enable-docbook-docs --docdir=%{_datadir}/doc/%{name}-%{version}
  72. make
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. make install DESTDIR=$RPM_BUILD_ROOT
  76. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  77. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  78. rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.a
  79. rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
  80. # make sure we don't package a history log
  81. rm -f $RPM_BUILD_ROOT/%{_var}/log/ConsoleKit/history
  82. cp AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO \
  83. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
  84. #mkdir -p %{buildroot}%{_sysconfdir}/init.d
  85. #install -m 755 %{SOURCE10} %{buildroot}%{_sysconfdir}/init.d/ConsoleKit
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %post
  89. if [ -f /var/log/ConsoleKit/history ]; then
  90. chmod a+r /var/log/ConsoleKit/history
  91. fi
  92. %post libs -p /sbin/ldconfig
  93. %postun libs -p /sbin/ldconfig
  94. %files
  95. %defattr(-,root,root,-)
  96. %doc %dir %{_datadir}/doc/%{name}-%{version}
  97. %doc %{_datadir}/doc/%{name}-%{version}/[A-Z]*
  98. %{_sysconfdir}/dbus-1/system.d/*
  99. #%{_sysconfdir}/init.d/ConsoleKit
  100. %{_datadir}/dbus-1/system-services/*.service
  101. %{_datadir}/polkit-1/actions/*.policy
  102. %dir %{_sysconfdir}/ConsoleKit
  103. %dir %{_sysconfdir}/ConsoleKit/seats.d
  104. %dir %{_sysconfdir}/ConsoleKit/run-seat.d
  105. %dir %{_sysconfdir}/ConsoleKit/run-session.d
  106. %dir %{_prefix}/lib/ConsoleKit
  107. %dir %{_prefix}/lib/ConsoleKit/scripts
  108. %dir %{_prefix}/lib/ConsoleKit/run-seat.d
  109. %dir %{_prefix}/lib/ConsoleKit/run-session.d
  110. %dir %{_var}/run/ConsoleKit
  111. %attr(755,root,root) %dir %{_var}/log/ConsoleKit
  112. %config %{_sysconfdir}/ConsoleKit/seats.d/00-primary.seat
  113. %{_sbindir}/console-kit-daemon
  114. %{_sbindir}/ck-log-system-restart
  115. %{_sbindir}/ck-log-system-start
  116. %{_sbindir}/ck-log-system-stop
  117. %{_bindir}/ck-history
  118. %{_bindir}/ck-launch-session
  119. %{_bindir}/ck-list-sessions
  120. %{_prefix}/lib/ConsoleKit/scripts/*
  121. %files x11
  122. %defattr(-,root,root,-)
  123. %{_libexecdir}/*
  124. %files libs
  125. %defattr(-,root,root,-)
  126. %{_libdir}/lib*.so.*
  127. /%{_lib}/security/*.so
  128. %{_mandir}/man8/pam_ck_connector.8.gz
  129. %files devel
  130. %defattr(-,root,root,-)
  131. %{_libdir}/lib*.so
  132. %{_libdir}/pkgconfig/*
  133. %{_includedir}/*
  134. %{_datadir}/dbus-1/interfaces/org.freedesktop.ConsoleKit.*.xml
  135. %files docs
  136. %defattr(-,root,root,-)
  137. %doc %dir %{_datadir}/doc/%{name}-%{version}/spec
  138. %doc %{_datadir}/doc/%{name}-%{version}/spec/*
  139. %changelog
  140. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.1-1
  141. - new upstream release
  142. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-6
  143. - add patch11 to enable policy access to the Manager.GetSessions
  144. method in the default ConsoleKit.conf
  145. https://bugs.freedesktop.org/show_bug.cgi?id=20471
  146. http://bugzilla.gnome.org/show_bug.cgi?id=580259
  147. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-5
  148. - add patch10 to fix dbus permissions
  149. https://bugs.freedesktop.org/show_bug.cgi?id=19020
  150. (This patch is already committed to master)
  151. * Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-4
  152. - changed Group to System Environment/Daemons
  153. - changed x11 subpackage's Group to System Environment/Daemons
  154. - changed libs subpackage's Group to System Environment/Libraries
  155. - added %%post, %%postun section fo libs subpackage
  156. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.0-3
  157. - changed %%{_libdir}/ConsoleKit to %%{_prefix}/lib/ConsoleKit
  158. * Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-2
  159. - remove init script, console-kit-daemon is now launched from dbus.
  160. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-1
  161. - new upstream release
  162. * Tue Jul 1 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.2.10-3
  163. - fix Japanese description
  164. - spec in UTF-8
  165. - add Source10 (init.d script for console-kit-daemon);
  166. add %%post/%%preun scripts, until "initng" being introduced to Vine
  167. * Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.2.10-2
  168. - rebuilt with PolicyKit-0.8
  169. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.10-1
  170. - new upstream release
  171. - new versioning policy
  172. * Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-0vl1
  173. - initial build for Vine Linux
  174. * Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.3-2
  175. - Rebuild against new dbus-glib
  176. * Tue Sep 18 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.3-1
  177. - Update to 0.2.3
  178. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.2-1
  179. - Update to 0.2.2
  180. * Mon Aug 6 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.1-4
  181. - Update license field
  182. * Fri Jul 6 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.1-3
  183. - Add LSB header to init script (#246894)
  184. * Mon Apr 16 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-2
  185. - Set doc directory correctly
  186. * Mon Apr 16 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-1
  187. - Update to upstream release 0.2.1
  188. - Drop the patch to daemonize properly as that was merged upstream
  189. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-0.git20070402
  190. - Update to git snapshot to get a lot of bug fixes
  191. - Use libX11 rather than gtk2 to verify X11 sessions; update BR and R
  192. - Split X11-using bits into a new subpackage ConsoleKit-x11 (#233982)
  193. - Use correct location for PAM module on 64-bit (#234545)
  194. - Build developer documentation and put them in ConsoleKit-docs
  195. * Mon Mar 19 2007 David Zeuthen <davidz@redhat.com> - 0.2.0-2
  196. - BR gtk2-devel and make ConsoleKit Require gtk2 (could just be
  197. libX11 with a simple patch)
  198. * Mon Mar 19 2007 David Zeuthen <davidz@redhat.com> - 0.2.0-1
  199. - Update to upstream release 0.2.0
  200. - Daemonize properly (#229206)
  201. * Sat Mar 3 2007 David Zeuthen <davidz@redhat.com> - 0.1.3-0.git20070301.1
  202. - Allow caller to pass uid=0 in libck-connector
  203. * Thu Mar 1 2007 David Zeuthen <davidz@redhat.com> - 0.1.3-0.git20070301
  204. - Update to git snapshot
  205. - Drop all patches as they are committed upstream
  206. - New tool ck-list-sessions
  207. - New -libs subpackage with run-time libraries and a PAM module
  208. - New -devel subpackage with headers
  209. * Tue Feb 6 2007 David Zeuthen <davidz@redhat.com> - 0.1.0-5%{?dist}
  210. - Start ConsoleKit a bit earlier so it starts before HAL (98 -> 90)
  211. - Minimize stack usage so VIRT size is more reasonable (mclasen)
  212. - Make session inactive when switching to non-session (davidz)
  213. * Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-4
  214. - Don't mark initscripts %%config
  215. - Use proper lock and pid ile names
  216. * Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-3
  217. - More package review feedback
  218. * Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-2
  219. - Incorporate package review feedback
  220. * Thu Jan 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-1
  221. - Update to the first public release 0.1.0
  222. - Some spec cleanups
  223. * Mon Oct 23 2006 David Zeuthen <davidz@redhat.com> - 0.0.3-1
  224. - Initial build.