flex-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175
  1. Summary: A tool for creating scanners (text pattern recognizers).
  2. Summary(ja): スキャナ (テキストパターン認識器) 作成ツール
  3. Name: flex
  4. Version: 2.5.35
  5. Release: 2%{?_dist_release}
  6. License: BSD
  7. Group: Development/Tools
  8. URL: http://flex.sourceforge.net/
  9. Source: flex-%{version}.tar.bz2
  10. Patch0: flex-2.5.35-pic.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gettext info bison m4
  13. Requires: m4
  14. Requires(post): /sbin/install-info
  15. Requires(preun): /sbin/install-info
  16. %description
  17. The flex program generates scanners. Scanners are programs which can
  18. recognize lexical patterns in text. Flex takes pairs of regular
  19. expressions and C code as input and generates a C source file as
  20. output. The output file is compiled and linked with a library to
  21. produce an executable. The executable searches through its input for
  22. occurrences of the regular expressions. When a match is found, it
  23. executes the corresponding C code. Flex was designed to work with
  24. both Yacc and Bison, and is used by many programs as part of their
  25. build process.
  26. You should install flex if you are going to use your system for
  27. application development.
  28. %description -l ja
  29. flex はスキャナを生成するプログラムです.スキャナとは,
  30. テキストの語彙を認識するプログラムです.flex は正規表現と
  31. C のコードを入力とし,C のソースファイルを出力します.
  32. 出力されたファイルはコンパイルされ,ライブラリとリンクされて
  33. 実行ファイルが作られます.この実行ファイルは入力を調べ,正規表現に
  34. マッチするものがないか探します.もしマッチするものが見付かれば,
  35. 対応する C コードが実行されます.flex は yacc と bison と共に
  36. 動作する様設計されており,多くのプログラムを作成する際に使われます.
  37. アプリケーション開発を行う場合は flex をインストールして下さい.
  38. %prep
  39. %setup -q
  40. %patch0 -p1
  41. %build
  42. %configure --disable-dependency-tracking
  43. make
  44. %install
  45. rm -rf $RPM_BUILD_ROOT
  46. make DESTDIR=$RPM_BUILD_ROOT install
  47. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
  48. ( cd ${RPM_BUILD_ROOT}
  49. strip .%{_bindir}/flex
  50. ln -sf flex .%{_bindir}/lex
  51. ln -s flex.1 .%{_mandir}/man1/lex.1
  52. ln -s flex.1 .%{_mandir}/man1/flex++.1
  53. ln -s libfl.a .%{_libdir}/libl.a
  54. )
  55. %find_lang %{name}
  56. %check
  57. echo ============TESTING===============
  58. make check
  59. echo ============END TESTING===========
  60. %clean
  61. rm -rf $RPM_BUILD_ROOT
  62. %post
  63. /sbin/install-info %{_infodir}/flex.info.gz --dir-file=%{_infodir}/dir ||:
  64. %preun
  65. if [ $1 = 0 ]; then
  66. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
  67. fi
  68. %files -f %{name}.lang
  69. %defattr(-,root,root)
  70. %doc COPYING NEWS README
  71. %{_bindir}/*
  72. %{_mandir}/man1/*
  73. %{_libdir}/*.a
  74. %{_includedir}/FlexLexer.h
  75. %{_infodir}/flex.info*
  76. %changelog
  77. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.35-2
  78. - spec in utf-8
  79. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-1
  80. - new upstream release
  81. - updated Patch0, dropped Patch1
  82. * Tue Nov 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.33-5vl1
  83. - rebuilt with new toolchains
  84. - updated to 2.5.33 based on Fedora packages
  85. * Fri Mar 30 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-5
  86. - Make yy-prefixed variables available to scanner even with -P.
  87. * Fri Feb 2 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-4
  88. - Use %%find_lang to package locale files.
  89. * Wed Jan 31 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-3
  90. - Compile with -fPIC.
  91. * Fri Jan 19 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-1
  92. - Rebase to 2.5.33
  93. * Sat Jan 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl2
  94. - rebuild with gcc 3.3.6
  95. * Sun Jul 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl1
  96. - rebuild with new toolchains
  97. - based on Redhat Rawhide 2.5.4-30
  98. - Mon Nov 4 2002 Than Ngo <than@redhat.com> 2.5.4a-27
  99. - YY_NO_INPUT patch from Jean Marie
  100. - Tue Apr 2 2002 Than Ngo <than@redhat.com> 2.5.4a-23
  101. - More ISO C++ 98 fixes (#59670)
  102. - Wed Feb 20 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5.4a-21
  103. - More ISO C++ 98 fixes (#59670)
  104. - s/Copyright/License/
  105. * Mon Feb 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  106. - 2.5.4a-13vl1
  107. - based on 2.5.4a-13 from Rawhide
  108. - use better macros (%%{_tmppath})
  109. - added Japanese summary and description
  110. * Sat Sep 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  111. - Fix generation of broken code (conflicting isatty() prototype w/ glibc 2.2)
  112. This broke, among other things, the kdelibs 2.0 build
  113. - Fix source URL
  114. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  115. - FHS packaging (64bit systems need to use libdir).
  116. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  117. - automatic rebuild
  118. * Tue Jun 6 2000 Bill Nottingham <notting@redhat.com>
  119. - rebuild, FHS stuff.
  120. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  121. - handle compressed man pages
  122. * Fri Jan 28 2000 Bill Nottingham <notting@redhat.com>
  123. - add a libl.a link to libfl.a
  124. * Wed Aug 25 1999 Jeff Johnson <jbj@redhat.com>
  125. - avoid uninitialized variable warning (Erez Zadok).
  126. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  127. - auto rebuild in the new build environment (release 6)
  128. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  129. - build for 6.0 tree
  130. * Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
  131. - build root
  132. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  133. - translations modified for de, fr, tr
  134. * Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
  135. - updated from 2.5.4 to 2.5.4a
  136. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  137. - built against glibc
  138. * Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
  139. - Updated to v. 2.5.4