freetype-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A free and portable TrueType font rendering engine.
  3. Name: freetype
  4. Version: 1.3.1
  5. Release: 6%{?_dist_release}
  6. License: BSD-like
  7. Group: System Environment/Libraries
  8. URL: http://www.freetype.org
  9. Source: freetype-%{version}.tar.gz
  10. Source1: ttmkfdir.tar.gz
  11. Patch0: freetype-1.2-fixpath.patch
  12. Patch1: freetype-1.3.1-foundrynames.patch
  13. Patch2: freetype-1.3.1-ftdump-gcc3.patch
  14. Patch3: freetype-1.3.1-config.sub-x86_64.patch
  15. Patch4: freetype-1.3.1-ltconfig-compat32.patch
  16. Buildroot: %{_tmppath}/%{name}-%{version}-root
  17. Obsoletes: freetype-utils
  18. %description
  19. The FreeType engine is a free and portable TrueType font rendering
  20. engine, developed to provide TrueType support for a variety of
  21. platforms and environments. FreeType is a library which can open and
  22. manages font files as well as efficiently load, hint and render
  23. individual glyphs. FreeType is not a font server or a complete
  24. text-rendering library.
  25. %package utils
  26. Summary: Several utilities to manipulate and examine TrueType fonts.
  27. Group: Applications/Publishing
  28. %description utils
  29. This package contains several utilities which allow you to view and
  30. manipulate TrueType fonts. They are mainly useful for debugging and
  31. testing purposes, and are not required for using the FreeType
  32. library.
  33. %package devel
  34. Summary: Header files and static library for development with FreeType.
  35. Group: Development/Libraries
  36. %description devel
  37. The freetype-devel package contains the header files and static
  38. library needed to develop or compile applications which use the
  39. FreeType TrueType font rendering library.
  40. Install freetype-devel if you want to develop FreeType
  41. applications. If you simply want to run existing applications, you
  42. won't need this package.
  43. ## to build compat32 for x86_64 architecture support
  44. %package -n compat32-%{name}
  45. Summary: A free and portable TrueType font rendering engine.
  46. Group: System Environment/Libraries
  47. %description -n compat32-%{name}
  48. The FreeType engine is a free and portable TrueType font rendering
  49. engine, developed to provide TrueType support for a variety of
  50. platforms and environments. FreeType is a library which can open and
  51. manages font files as well as efficiently load, hint and render
  52. individual glyphs. FreeType is not a font server or a complete
  53. text-rendering library.
  54. %package -n compat32-%{name}-devel
  55. Summary: Header files and static library for development with FreeType.
  56. Group: Development/Libraries
  57. Requires: compat32-%{name} = %{version}
  58. %description -n compat32-%{name}-devel
  59. The freetype-devel package contains the header files and static
  60. library needed to develop or compile applications which use the
  61. FreeType TrueType font rendering library.
  62. Install freetype-devel if you want to develop FreeType
  63. applications. If you simply want to run existing applications, you
  64. won't need this package.
  65. %prep
  66. %setup -q
  67. mkdir ttmkfdir
  68. tar xz -C ttmkfdir -f %{SOURCE1}
  69. %patch0 -p1 -b .fixpath
  70. %patch1 -p1 -b .foundrynames
  71. %patch2 -p1 -b .ftdump-gcc3
  72. %patch3 -p1 -b .config.sub-x86_64
  73. %if %{build_compat32}
  74. %patch4 -p1 -b .ltconfig-compat32
  75. %endif
  76. %build
  77. %if %{build_compat32}
  78. export CC='gcc -m32'
  79. %endif
  80. ##libtoolize --copy --force
  81. ./configure --prefix=%{_prefix} \
  82. --with-cflags="$RPM_OPT_FLAGS" \
  83. --disable-debug \
  84. --enable-static --enable-shared \
  85. --with-locale-dir=%{_localedir} \
  86. --libdir=%{_libdir} \
  87. --x-libraries=%{_prefix}/X11R6/%{_lib} \
  88. --target=%{_target_platform}
  89. make
  90. %if 0
  91. make -C ttmkfdir CC="gcc $RPM_OPT_FLAGS"
  92. (cd contrib/ttf2pk
  93. ./configure --prefix=%{_prefix} \
  94. --mandir=%{_mandir} \
  95. --with-cflags="$RPM_OPT_FLAGS"
  96. make
  97. )
  98. %endif
  99. # --libdir=$RPM_BUILD_ROOT%{_libdir} \
  100. %install
  101. rm -rf $RPM_BUILD_ROOT
  102. make prefix=$RPM_BUILD_ROOT%{_prefix} \
  103. libdir=$RPM_BUILD_ROOT%{_libdir} \
  104. install \
  105. gnulocaledir=$RPM_BUILD_ROOT%{_localedir}
  106. %if 0
  107. install -m 755 ttmkfdir/ttmkfdir $RPM_BUILD_ROOT%{_bindir}
  108. %endif
  109. (cd $RPM_BUILD_ROOT%{_includedir}
  110. for i in freetype/*.h
  111. do
  112. ln -sf $i .
  113. done
  114. )
  115. %if 0
  116. (cd contrib/ttf2pk
  117. make prefix=$RPM_BUILD_ROOT%{_prefix} \
  118. mandir=$RPM_BUILD_ROOT%{_mandir} \
  119. install
  120. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ttf2pk
  121. cp data/* $RPM_BUILD_ROOT%{_datadir}/ttf2pk
  122. )
  123. %endif
  124. # remove unpackaged files
  125. rm -rf $RPM_BUILD_ROOT%{_bindir}
  126. %post -p /sbin/ldconfig
  127. %postun -p /sbin/ldconfig
  128. %if %{build_compat32}
  129. %post -n compat32-%{name} -p /sbin/ldconfig
  130. %postun -n compat32-%{name} -p /sbin/ldconfig
  131. %endif
  132. %clean
  133. rm -rf $RPM_BUILD_ROOT
  134. %if !%{build_compat32}
  135. %files
  136. %defattr(-,root,root)
  137. %{_libdir}/libttf.la
  138. %{_libdir}/libttf.so.*
  139. %{_datadir}/locale/*/LC_MESSAGES/*
  140. %doc README announce docs
  141. %if 0
  142. %files utils
  143. %defattr(-,root,root)
  144. %{_bindir}/*
  145. %{_mandir}/man1/*
  146. %{_datadir}/ttf2pk/
  147. %endif
  148. %files devel
  149. %defattr(-,root,root)
  150. %{_includedir}/*
  151. %{_libdir}/libttf.so
  152. %{_libdir}/libttf.a
  153. %endif
  154. ## to build compat32 for x86_64 architecture support
  155. %if %{build_compat32}
  156. %files -n compat32-%{name}
  157. %defattr(-,root,root)
  158. %{_libdir}/libttf.la
  159. %{_libdir}/libttf.so.*
  160. %files -n compat32-%{name}-devel
  161. %defattr(-,root,root)
  162. %{_libdir}/libttf.so
  163. %{_libdir}/libttf.a
  164. %endif
  165. %changelog
  166. * Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-6
  167. - obsolete freetype-utils
  168. * Thu Feb 23 2006 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5vl5
  169. - fixed libdir to configure and to make install
  170. * Mon Feb 13 2006 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5vl4
  171. - dropt libtoolize
  172. - added freetype-1.3.1-ftdump-gcc3.patch
  173. - added freetype-1.3.1-config.sub-x86_64.patch
  174. - added freetype-1.3.1-ltconfig-compat32.patch
  175. - added options --libdir, --x-libraries, --target to configure
  176. - added URL
  177. - changed Copyright to License
  178. - changed direct path strings to macros
  179. * Sat Mar 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-5vl3
  180. - rebuilt with new toolchains
  181. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  182. - 1.3.1-5vl2
  183. - rebuilt with new %%{_mandir} for VineSeed
  184. * Wed Aug 2 2000 Jun Nishii <jun@vinelinux.org>
  185. - 1.3.1-5vl1
  186. - follow RHL62
  187. * Sat Jan 22 2000 Jun Nishii <jun@vinelinux.org>
  188. - added %defattr
  189. * Tue Jan 11 2000 Jun Nishii <jun@vinelinux.org>
  190. - added bins from contrib/ttf2pk
  191. * Tue Nov 23 1999 Norihito Ohmori <ohmori@flatout.org>
  192. - modified for Vine Linux
  193. * Wed Nov 10 1999 Norihito Ohmori <nono@kondara.org>
  194. - add /usr/bin/{ftmetric,ftsbit,ftstrtto} to freetype-utils (jitterbug #88)
  195. * Mon Nov 8 1999 Toru Hoshina <t@kondara.org>
  196. - be a NoSrc :-P
  197. * Wed Oct 14 1999 Norihito Ohmori <nono@kondara.org>
  198. - freetype-current dated Oct 12 1999.
  199. * Sat Oct 9 1999 Toru Hoshina <t@kondara.org>
  200. - freetype-current dated Oct 3 1999.
  201. * Thu Aug 19 1999 Preston Brown <pbrown@redhat.com>
  202. - newer ttmkfdir that works better, moved ttmkfdir to /usr/bin from /usr/sbin
  203. - freetype utilities moved to subpkg, X dependency removed from main pkg
  204. - libttf.so symlink moved to devel pkg
  205. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  206. - strip binaries
  207. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  208. - auto rebuild in the new build environment (release 5)
  209. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  210. - fixed the %doc file list
  211. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  212. - Injected new description and group.
  213. * Mon Feb 15 1999 Preston Brown <pbrown@redhat.com>
  214. - added ttmkfdir
  215. * Tue Feb 02 1999 Preston Brown <pbrown@redhat.com>
  216. - update to 1.2
  217. * Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
  218. - call libtoolize to sanitize config.sub and get ARM support
  219. - dispoze of the patch (not necessary anymore)
  220. * Wed Oct 21 1998 Preston Brown <pbrown@redhat.com>
  221. - post/postun sections for ldconfig action.
  222. * Tue Oct 20 1998 Preston Brown <pbrown@redhat.com>
  223. - initial RPM, includes normal and development packages.