gtk+-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647
  1. # Note that this is NOT a relocatable package
  2. %define ver 1.2.10
  3. %define rel 2%{?_dist_release}
  4. %define debug off
  5. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  6. Name: gtk+
  7. Version: %{ver}
  8. Release: %{rel}
  9. License: LGPL
  10. Group: System Environment/Libraries
  11. URL: http://www.gtk.org
  12. Obsoletes: gtk
  13. BuildRequires: glib-devel >= 1.2.10
  14. BuildRequires: libX11-devel libXext-devel libXi-devel
  15. BuildRequires: linuxdoc-tools automake14 autoconf213
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Source: ftp://ftp.gimp.org/pub/gtk/v1.2/%{name}-%{ver}.tar.gz
  18. Source1: gtkrc-default
  19. Source2: gtkrc.ja-vine
  20. #
  21. # merged RH patches.
  22. #
  23. Patch1: gtk+-1.2.6-ahiguti.patch
  24. Patch5: gtk+-1.2.8-wrap-alnum.patch
  25. ## Supress alignment warnings on ia64
  26. Patch10: gtk+-1.2.10-alignment.patch
  27. ## Improve exposure compression
  28. Patch11: gtk+-1.2.10-expose.patch
  29. ## Handle focus tracking for embedded window properly
  30. Patch12: gtk+-1.2.10-focus.patch
  31. ## Find gtkrc files for the current encoding better
  32. Patch13: gtk+-1.2.10-encoding.patch
  33. ## Don't screw up CTEXT encoding for UTF-8
  34. Patch14: gtk+-1.2.10-ctext.patch
  35. ## Don't warn about missing fonts for UTF-8
  36. Patch15: gtk+-1.2.10-utf8fontset.patch
  37. ## Accept KP_Enter as a synonym for Return everywhere
  38. Patch16: gtk+-1.2.10-kpenter.patch
  39. ## Allow theme switching to work properly when no windows are realized
  40. Patch17: gtk+-1.2.10-themeswitch.patch
  41. ## Fix crash when switching themes
  42. Patch18: gtk+-1.2.10-pixmapref.patch
  43. ## Fix computation of width of missing characters
  44. Patch19: gtk+-1.2.10-missingchar.patch
  45. # Fix sizes of Ukrainian fontsets
  46. Patch20: gtk+-1.2.10-ukfont.patch
  47. # Fix file selection delete-dir when changing directory problem
  48. # also, fix memory corruption problem when changing directories.
  49. Patch21: gtk+-1.2.10-deletedir.patch
  50. # Improve warning for missing fonts
  51. Patch22: gtk+-1.2.10-fontwarning.patch
  52. # Allow themes to make scrollbar trough always repaint
  53. Patch23: gtk+-1.2.10-troughpaint.patch
  54. # Fix a crash that can happen in some apps when the current
  55. # locale is not supported by XLib.
  56. Patch24: gtk+-1.2.10-localecrash.patch
  57. # Use lib64 in X11R6 path if it exists.
  58. Patch25: gtk+-1.2.10-xlibs.patch
  59. # Patch from CVS to fix b.g.o #56349
  60. Patch26: gtk+-1.2.10-dndorder.patch
  61. # Patch from CVS to fix b.g.o #94812
  62. Patch27: gtk+-1.2.10-clistfocusrow.patch
  63. # Fix GTK+ to obey X server's default bell volume
  64. Patch28: gtk+-1.2.10-bellvolume.patch
  65. # Hack up the configure scripts to deal with some obscure
  66. # breakage with ancient libtool
  67. Patch29: gtk+-1.2.10-libtool.patch
  68. # Add a dependency on libgdk to libgtk
  69. Patch30: gtk+-1.2.10-gtkgdkdep.patch
  70. # Add x86_64
  71. Patch31: gtk+-1.2.10-config.sub-x86_64.patch
  72. #
  73. # Vine-specific patches.
  74. #
  75. # This is still necessary.
  76. Patch101: gtk+-1.2.3-eventmask.patch
  77. Patch102: gtk+-1.2.8-fontselector.patch
  78. Patch103: gtk+-1.2.6-event_send.patch
  79. # Security Patch
  80. Patch110: gtk+-1.2.8-gtkmod.patch
  81. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  82. Summary(ja): X 上の GUI を作成ライブラリ: GIMP ツールキット(GTK+)
  83. %description
  84. The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating
  85. graphical user interfaces for the X Window System. GTK+ was originally
  86. written for the GIMP (GNU Image Manipulation Program) image processing
  87. program, but is now used by several other programs as well.
  88. If you are planning on using the GIMP or another program that uses GTK+,
  89. you'll need to have the gtk+ package installed.
  90. %description -l ja
  91. gtk+ パッケージは, X ウィンドウ・システム上で GUI を作成するための GIMP
  92. ツールキット (GTK+) を含んでいます。GTK+ は、画像処理プログラム GIMP
  93. (GNU Image Manipulation Program) のために作られましたが、現在は他の様々な
  94. プログラムで用いられています。
  95. もし、GTK+ を使う GIMP や他のプログラムを用いる予定ならば、この gtk+
  96. パッケージをインストールしてください。
  97. %package -n compat32-%{name}
  98. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  99. Summary(ja): X 上の GUI を作成ライブラリ: GIMP ツールキット(GTK+)
  100. Group: System Environment/Libraries
  101. Requires: %{name} = %{version}
  102. %description -n compat32-%{name}
  103. The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating
  104. graphical user interfaces for the X Window System. GTK+ was originally
  105. written for the GIMP (GNU Image Manipulation Program) image processing
  106. program, but is now used by several other programs as well.
  107. If you are planning on using the GIMP or another program that uses GTK+,
  108. you'll need to have the gtk+ package installed.
  109. %description -n compat32-%{name} -l ja
  110. gtk+ パッケージは, X ウィンドウ・システム上で GUI を作成するための GIMP
  111. ツールキット (GTK+) を含んでいます。GTK+ は、画像処理プログラム GIMP
  112. (GNU Image Manipulation Program) のために作られましたが、現在は他の様々な
  113. プログラムで用いられています。
  114. もし、GTK+ を使う GIMP や他のプログラムを用いる予定ならば、この gtk+
  115. パッケージをインストールしてください。
  116. %package devel
  117. Summary: Development tools for GTK+ (GIMP ToolKit) applications.
  118. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  119. Group: Development/Libraries
  120. Requires: %{name} = %{version}
  121. Requires: glib-devel
  122. Requires: libX11-devel
  123. Requires: libXext-devel
  124. Requires: libXi-devel
  125. Obsoletes: gtk-devel
  126. Requires(post): /sbin/install-info
  127. Requires(preun): /sbin/install-info
  128. %description devel
  129. The gtk+-devel package contains the static libraries and header files
  130. needed for developing GTK+ (GIMP ToolKit) applications. The gtk+-devel
  131. package contains glib (a collection of routines for simplifying the
  132. development of GTK+ applications), GDK (the General Drawing Kit, which
  133. simplifies the interface for writing GTK+ widgets and using GTK+ widgets
  134. in applications), and GTK+ (the widget set).
  135. Install gtk+-devel if you need to develop GTK+ applications. You'll also
  136. need to install the gtk+ package.
  137. %description devel -l ja
  138. gtk+-devel には、GTK+ (GIMP ToolKit) アプリケーションを開発するのに必要
  139. な静的ライブラリやヘッダファイルを含んでいます。gtk+-devel パッケージには
  140. glib (GTK+ アプリケーション開発を簡単にするルーチン集), GDK (アプリケーシ
  141. ョン中でGTK+ ウィジッドを書いたり用いたりするのを簡単にするドローキット)
  142. そして、GTK+ (ウィジッド・セット) を含んでいます。
  143. もし、GTK+ アプリケーションを開発するなら、gtk+-devel パッケージをインスト
  144. ールしてください。gtk+ パッケージもインストールしておく必要があります。
  145. %package -n compat32-%{name}-devel
  146. Summary: Development tools for GTK+ (GIMP ToolKit) applications.
  147. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  148. Group: Development/Libraries
  149. Requires: %{name}-devel = %{version}
  150. Requires: compat32-%{name} = %{version}
  151. %description -n compat32-%{name}-devel
  152. The gtk+-devel package contains the static libraries and header files
  153. needed for developing GTK+ (GIMP ToolKit) applications. The gtk+-devel
  154. package contains glib (a collection of routines for simplifying the
  155. development of GTK+ applications), GDK (the General Drawing Kit, which
  156. simplifies the interface for writing GTK+ widgets and using GTK+ widgets
  157. in applications), and GTK+ (the widget set).
  158. Install gtk+-devel if you need to develop GTK+ applications. You'll also
  159. need to install the gtk+ package.
  160. %description -n compat32-%{name}-devel -l ja
  161. gtk+-devel には、GTK+ (GIMP ToolKit) アプリケーションを開発するのに必要
  162. な静的ライブラリやヘッダファイルを含んでいます。gtk+-devel パッケージには
  163. glib (GTK+ アプリケーション開発を簡単にするルーチン集), GDK (アプリケーシ
  164. ョン中でGTK+ ウィジッドを書いたり用いたりするのを簡単にするドローキット)
  165. そして、GTK+ (ウィジッド・セット) を含んでいます。
  166. もし、GTK+ アプリケーションを開発するなら、gtk+-devel パッケージをインスト
  167. ールしてください。gtk+ パッケージもインストールしておく必要があります。
  168. %prep
  169. %setup -q
  170. %patch1 -p1 -b .ahiguti
  171. %patch5 -p1 -b .alnum
  172. %patch10 -p1 -b .alignment
  173. %patch11 -p1 -b .expose
  174. %patch12 -p1 -b .focus
  175. %patch13 -p1 -b .encoding
  176. %patch14 -p1 -b .ctext
  177. %patch15 -p1 -b .utf8fontset
  178. %patch16 -p1 -b .kpenter
  179. %patch17 -p1 -b .themeswitch
  180. %patch18 -p1 -b .pixmapref
  181. %patch19 -p1 -b .missingchar
  182. %patch20 -p1 -b .ukfont
  183. %patch21 -p1 -b .deletedir
  184. %patch22 -p1 -b .fontwarning
  185. %patch23 -p0 -b .troughpaint
  186. %patch24 -p1 -b .localecrash
  187. %patch25 -p1 -b .xlibs
  188. %patch26 -p0 -b .dndorder
  189. %patch27 -p0 -b .clistfocusrow
  190. %patch28 -p1 -b .bellvolume
  191. %patch29 -p1 -b .libtool
  192. %patch31 -p1 -b .x86_64
  193. %patch101 -p1 -b .nocore
  194. %patch102 -p1 -b .fontsel
  195. %patch103 -p1 -b .event_send
  196. %patch110 -p1 -b .gtkmod
  197. #libtoolize --force
  198. #aclocal-1.4
  199. automake-1.4
  200. autoconf-2.13
  201. autoheader-2.13
  202. %build
  203. if [ %{debug} = "on" ] ; then
  204. export CFLAGS="$RPM_OPT_FLAGS -g"
  205. else
  206. export CFLAGS="$RPM_OPT_FLAGS"
  207. fi
  208. # gcc-2.95.3 with '-O2' option causes problems on Alpha
  209. %ifarch alpha
  210. export CFLAGS="-O -mieee"
  211. %endif
  212. AUTOMAKE=automake-1.4 %configure --with-xinput=xfree --with-native-locale
  213. if [ "$SMP" != "" ]; then
  214. (make "MAKE=make -k -j $SMP"; exit 0)
  215. make AUTOMAKE=automake-1.4
  216. else
  217. make AUTOMAKE=automake-1.4
  218. fi
  219. %install
  220. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  221. %makeinstall
  222. # rename gtk-config to gtk-config-32 if build_compat32 option is enabled
  223. %if %{build_compat32}
  224. mv $RPM_BUILD_ROOT%{_bindir}/gtk-config $RPM_BUILD_ROOT%{_bindir}/gtk-config-32
  225. %endif
  226. #
  227. # Make cleaned-up versions of examples and tutorial for installation
  228. #
  229. ./mkinstalldirs tmpdocs/tutorial
  230. install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
  231. for dir in examples/*; do
  232. if [ -d $dir ]; then
  233. ./mkinstalldirs tmpdocs/$dir
  234. for file in $dir/*; do
  235. case $file in
  236. *pre1.2.7)
  237. ;;
  238. *)
  239. install -m 0644 $file tmpdocs/$dir
  240. ;;
  241. esac
  242. done
  243. fi
  244. done
  245. install -m 444 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/gtk/gtkrc
  246. install -m 444 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/gtk/gtkrc.ja
  247. %find_lang %{name}
  248. # remove unneeded files
  249. %__rm -f %{buildroot}%{_libdir}/lib{gdk,gtk}.la
  250. %clean
  251. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  252. %post -p /sbin/ldconfig
  253. %postun -p /sbin/ldconfig
  254. %post -n compat32-%{name} -p /sbin/ldconfig
  255. %postun -n compat32-%{name} -p /sbin/ldconfig
  256. %post devel
  257. /sbin/install-info %{_infodir}/gdk.info.gz %{_infodir}/dir
  258. /sbin/install-info %{_infodir}/gtk.info.gz %{_infodir}/dir
  259. %preun devel
  260. if [ $1 = 0 ]; then
  261. /sbin/install-info --delete %{_infodir}/gdk.info.gz %{_infodir}/dir
  262. /sbin/install-info --delete %{_infodir}/gtk.info.gz %{_infodir}/dir
  263. fi
  264. %files -f %{name}.lang
  265. %defattr(-, root, root)
  266. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  267. %{_libdir}/libgtk-1.2.so.*
  268. %{_libdir}/libgdk-1.2.so.*
  269. %{_datadir}/themes/Default
  270. %config %{_sysconfdir}/gtk/*
  271. %files devel
  272. %defattr(-, root, root)
  273. %{_libdir}/lib*.so
  274. %{_libdir}/*.a
  275. %{_libdir}/pkgconfig
  276. %{_mandir}/man1/*
  277. %{_includedir}/*
  278. %{_infodir}/*info*
  279. %{_datadir}/aclocal/*
  280. %{_bindir}/*
  281. %doc tmpdocs/tutorial
  282. %doc tmpdocs/examples
  283. %if %{build_compat32}
  284. %files -n compat32-%{name}
  285. %defattr(-, root, root)
  286. %{_libdir}/libgtk-1.2.so.*
  287. %{_libdir}/libgdk-1.2.so.*
  288. %files -n compat32-%{name}-devel
  289. %defattr(-, root, root)
  290. %{_libdir}/lib*.so
  291. %{_libdir}/*.a
  292. %{_libdir}/pkgconfig
  293. %{_bindir}/*
  294. %endif
  295. %changelog
  296. * Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.10-2
  297. - spec in utf-8
  298. * Mon Jun 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-1
  299. - applied new versioning policy
  300. - rebuilt with xorg-x11 7.3 (updated denepdancies)
  301. * Wed May 24 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl10
  302. - rename gtk-config to gtk-config-32 if build_compat32 option is enabled
  303. * Mon Mar 06 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.10-0vl9
  304. - added compat32-* packages for x86_64 architecture support
  305. * Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.10-0vl8
  306. - added gtk+-1.2.10-config.sub-x86_64.patch
  307. * Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl7
  308. - rebuild
  309. - not run libtoolize --force, aclocal-1.4
  310. - remove %%{_libdir}/lib{gdk,gtk}.la
  311. - compress info files by brp-compress
  312. * Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.10-0vl6
  313. - merge more RH patches (Patch26-Patch29)
  314. * Mon Oct 27 2003 Owen Taylor <otaylor@redhat.com> 1:1.2.10-28.1
  315. - Cave like a cheap house of cards and add gdk-pixbuf dependency (#105613)
  316. - Add gtkrc.*.utf8 RC files for CJK (#84593)
  317. - Add a dependency on libgdk to libgtk (#106677)
  318. * Thu Feb 13 2003 Elliot Lee <sopwith@redhat.com> 1.2.10-26
  319. - Run libtoolize/auto* to get an updated libtool that recognizes ppc64
  320. * Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com> 1.2.10-24
  321. - Add a couple of patches from GNOME CVS, fixing a crash
  322. with CList focus row tracking, and a place where DND
  323. would get confused.
  324. - Obey the system bell volume (#74802)
  325. - Ship the pkg-config files
  326. * Mon Nov 4 2002 Tim Waugh <twaugh@redhat.com> 1.2.10-23
  327. - Don't install files not shipped.
  328. - Fix gtk-config output for multilib archs.
  329. * Wed Dec 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.10-0vl5
  330. - merge more RH patches (Patch20-Patch25)
  331. - rawhide's changelog since last merge (except "automated rebuild") are:
  332. - Thu Aug 22 2002 Owen Taylor <otaylor@redhat.com>
  333. - Fix a crash that can happen in some apps when the current
  334. locale is not supported by XLib. (#72157)
  335. - Fri Jul 26 2002 Owen Taylor <otaylor@redhat.com>
  336. - Fix a small memory leak in the .encoding patch (Kjartan Maraas)
  337. - Fri Jul 19 2002 Alexander Larsson <alexl@redhat.com>
  338. - Add troughpaint patch
  339. - Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
  340. - Fix UTF-8 font specification not to pick up *-c-* fonts
  341. - Thu May 16 2002 Alex Larsson <alexl@redhat.com>
  342. - Require automake 1.4
  343. - Wed Apr 17 2002 Owen Taylor <otaylor@redhat.com>
  344. - Fix problem with incorrect directory contents when changing directories (#63726)
  345. - Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
  346. - Fix filesel delete-filename-on-dir-change problem
  347. - Improve warning for missing fontset elements
  348. - Thu Apr 11 2002 Owen Taylor <otaylor@redhat.com>
  349. - Fix ukrainian font sizes, minor tweak to russian fonts (#63135)
  350. - Own /etc/gtk/ as well as the files in it (#63139)
  351. * Thu Mar 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl4
  352. - changed default theme to BeCool.
  353. * Mon Oct 15 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl3
  354. - Merged several RH patches.
  355. * Mon Aug 13 2001 Owen Taylor <otaylor@redhat.com>
  356. - Fix problem with width computation for missing characters
  357. * Sun Aug 12 2001 Owen Taylor <otaylor@redhat.com>
  358. - Fix refcounting problem in gtk_style_copy() that might affect
  359. theme switching. (#51580)
  360. * Wed Aug 8 2001 Owen Taylor <otaylor@redhat.com>
  361. - Add fix for theme switching in nautilus sidebar tabs
  362. (and other similar situations)
  363. * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
  364. - Accept KP_Enter as well as Return (#21111)
  365. * Wed Jul 11 2001 Owen Taylor <otaylor@redhat.com>
  366. - Further improve exposure compression code
  367. * Tue Jul 10 2001 Owen Taylor <otaylor@redhat.com>
  368. - Omit warnings about character sets not found in fontset,
  369. if current locale is UTF-8 based. (Hack!)
  370. * Tue Jul 3 2001 Owen Taylor <otaylor@redhat.com>
  371. - Add patch for alignment warnings on ia64
  372. - Add from Alex to vastly improve expose compression
  373. - Add patch to fix focus tracking for embedded windows
  374. - Add patch by Pablo Saratxaga to improve encoding handling
  375. - Add patch to not screw up CTEXT for UTF-8 locales
  376. * Tue Jul 17 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
  377. - 1.2.10-0vl2
  378. - change CFLAGS on alpha (gcc-2.95.3 with -O2 causes problems)
  379. * Tue Apr 3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl1
  380. - New upstream release.
  381. * Wed Mar 7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.9-0vl1
  382. - New upstream release.
  383. * Wed Feb 14 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl6
  384. - correct configure for stablity
  385. * Tue Feb 13 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl5
  386. - correct configure (for --enable-xinput)
  387. - add DESTDIR patch for po/Makefile.in.in
  388. * Wed Feb 7 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl4
  389. - add gtk+-1.2.8-gtktextwcfix.patch
  390. * Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  391. - 1.2.8-0vl2
  392. - applied security patch (http://www.securityfocus.com/bid/2165)
  393. * Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  394. - updated to 1.2.8
  395. * Fri Feb 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  396. - added fontselector based on kondara's patch
  397. * Thu Feb 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  398. - updated to 1.2.7
  399. - remove morioka marged to the original gtk source tree.
  400. Tue Dec 28 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
  401. - added event_send patch to be more stable when switching themes.
  402. * Sat Dec 11 1999 Jun Nishii <jun@flatout.org>
  403. - smaller fontset in gtkrc.ja
  404. * Thu Nov 25 1999 Jun NISHII <jun@flatout.org>
  405. - use morioka patch instead of fontsel patches
  406. * Sat Oct 23 1999 Jun Nishii <jun@flatout.org>
  407. - gtk+-1.2.6-1vl2
  408. - added fontsel patches from gtk/gnome-ML
  409. * Tue Oct 12 1999 Jun Nishii <jun@flatout.org>
  410. - gtk+-1.2.6-1vl1
  411. * Thu Sep 30 1999 Jun Nishii <jun@flatout.org>
  412. - gtk+-1.2.5-1vl2
  413. - with wordwrap patch
  414. * Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
  415. - gtk+-1.2.5-1vl1
  416. * Fri Sep 11 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  417. [gtk+-1.2.4-1vl2]
  418. - removed fontsel patch.
  419. * Fri Sep 6 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  420. [gtk+-1.2.4-1vl1]
  421. - install gzipped info.
  422. - changed release tag with 'vl.'
  423. * Fri Sep 3 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  424. [gtk+-1.2.4-1]
  425. - Update for GTK+-1.2.4.
  426. - bzip2 source.
  427. - use %{sysconfdir} as /etc.
  428. * Sun Aug 22 1999 Jun Nishii <jun@flatout.org>
  429. - bzip2 source
  430. * Sat Aug 21 1999 Jun Nishii <jun@flatout.org>
  431. - build for Vine-1.9
  432. - merge fontset patch
  433. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  434. - Update for GTK+-1.2.3
  435. - Patches that will be in GTK+-1.2.4
  436. - Patch to keep GTK+ from coredumping on X IO errors
  437. - Patch to improve compatilibity with GTK-1.2.1 (allow
  438. event mask to be set on realized widgets)
  439. * Mon Apr 19 1999 Michael Fulbright <drmike@redhat.com>
  440. - fixes memory leak
  441. * Mon Apr 12 1999 Owen Taylor <otaylor@redhat.com>
  442. - The important bug fixes that will be in GTK+-1.2.2
  443. * Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
  444. - patches from owen to handle various gdk bugs
  445. * Sun Mar 28 1999 Michael Fulbright <drmike@redhat.com>
  446. - added XFree86-devel requirement for gtk+-devel
  447. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  448. - version 1.2.1
  449. * Wed Mar 17 1999 Michael Fulbright <drmike@redhat.com>
  450. - removed /usr/info/dir.gz file from package
  451. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  452. - Version 1.2.0
  453. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  454. - version 1.2.0pre2, patched to use --sysconfdir=/etc
  455. * Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
  456. - patched in Owen's patch to fix Metal theme
  457. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  458. - bumped up to 1.1.15
  459. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  460. - bumped up to 1.1.14
  461. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  462. - bumped up to 1.1.13
  463. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  464. - bumped up to 1.1.12
  465. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  466. - added Theme directory to file list
  467. - up to 1.1.7 for GNOME freeze
  468. * Sun Oct 25 1998 Shawn T. Amundson <amundson@gtk.org>
  469. - Fixed Source: to point to v1.1
  470. * Tue Aug 04 1998 Michael Fulbright <msf@redhat.com>
  471. - change %postun to %preun
  472. * Mon Jun 27 1998 Shawn T. Amundson
  473. - Changed version to 1.1.0
  474. * Thu Jun 11 1998 Dick Porter <dick@cymru.net>
  475. - Removed glib, since it is its own module now
  476. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  477. - Split out glib package
  478. * Tue Apr 8 1998 Shawn T. Amundson <amundson@gtk.org>
  479. - Changed version to 1.0.0
  480. * Tue Apr 7 1998 Owen Taylor <otaylor@gtk.org>
  481. - Changed version to 0.99.10
  482. * Thu Mar 19 1998 Shawn T. Amundson <amundson@gimp.org>
  483. - Changed version to 0.99.9
  484. - Changed gtk home page to www.gtk.org
  485. * Thu Mar 19 1998 Shawn T. Amundson <amundson@gimp.org>
  486. - Changed version to 0.99.8
  487. * Sun Mar 15 1998 Marc Ewing <marc@redhat.com>
  488. - Added aclocal and bin stuff to file list.
  489. - Added -k to the SMP make line.
  490. - Added lib/glib to file list.
  491. * Fri Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
  492. - Changed version to 0.99.7
  493. * Fri Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
  494. - Updated ftp url and changed version to 0.99.6
  495. * Thu Mar 12 1998 Marc Ewing <marc@redhat.com>
  496. - Reworked to integrate into gtk+ source tree
  497. - Truncated ChangeLog. Previous Authors:
  498. Trond Eivind Glomsrod <teg@pvv.ntnu.no>
  499. Michael K. Johnson <johnsonm@redhat.com>
  500. Otto Hammersmith <otto@redhat.com>