jpackage-utils-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616
  1. # Copyright (c) 2000-2008, JPackage Project
  2. # All rights reserved.
  3. #
  4. # Redistribution and use in source and binary forms, with or without
  5. # modification, are permitted provided that the following conditions
  6. # are met:
  7. #
  8. # 1. Redistributions of source code must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. # 2. Redistributions in binary form must reproduce the above copyright
  11. # notice, this list of conditions and the following disclaimer in the
  12. # documentation and/or other materials provided with the
  13. # distribution.
  14. # 3. Neither the name of the JPackage Project nor the names of its
  15. # contributors may be used to endorse or promote products derived
  16. # from this software without specific prior written permission.
  17. #
  18. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  19. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  20. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  21. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  22. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  23. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  24. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  25. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  26. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  27. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  28. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  29. #
  30. %define gcj_support 1
  31. %define distver 1.7
  32. %define section free
  33. Name: jpackage-utils
  34. Version: 1.7.4
  35. Release: 2jpp2%{?_dist_release}
  36. Summary: JPackage utilities
  37. License: JPackage License
  38. URL: http://www.jpackage.org/
  39. Source0: %{name}-%{version}.tar.bz2
  40. Patch0: %{name}-enable-gcj-support.patch
  41. Group: System Environment/Base
  42. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  43. BuildArch: noarch
  44. %description
  45. Utilities for the JPackage Project <http://www.jpackage.org/>:
  46. * %{_bindir}/build-classpath
  47. build the Java classpath in a portable manner
  48. * %{_bindir}/build-jar-repository
  49. build a jar repository in a portable manner
  50. * %{_bindir}/rebuild-jar-repository
  51. rebuild a jar repository in a portable manner
  52. (after a jvm change...)
  53. * %{_bindir}/build-classpath-directory
  54. build the Java classpath from a directory
  55. * %{_bindir}/diff-jars
  56. show jar content differences
  57. * %{_bindir}/jvmjar
  58. install jvm extensions
  59. * %{_bindir}/create-jar-links
  60. create custom jar links
  61. * %{_bindir}/clean-binary-files
  62. remove binary files from sources
  63. * %{_bindir}/check-binary-files
  64. check for presence of unexpected binary files
  65. * %{_datadir}/java-utils/java-functions
  66. shell script functions library for Java
  67. applications
  68. * %{_sysconfdir}/java/jpackage-release
  69. string identifying the currently installed
  70. JPackage release
  71. * %{_sysconfdir}/java/java.conf
  72. system-wide Java configuration file
  73. * %{_sysconfdir}/rpm/macros.jpackage
  74. RPM macros for Java packagers and developers
  75. * %{_docdir}/%{name}-%{version}/jpackage-policy
  76. Java packaging policy for packagers and
  77. developers
  78. It contains also the License, man pages, documentation, XSL files of general
  79. use with maven2, a header file for spec files etc.
  80. %prep
  81. %setup -q
  82. %patch0 -p0
  83. %build
  84. echo "JPackage release %{distver} (%{distribution}) for %{buildarch}" \
  85. > etc/jpackage-release
  86. %install
  87. rm -rf $RPM_BUILD_ROOT
  88. # Pull macros out of macros.jpackage and emulate them during install for
  89. # smooth bootstrapping experience.
  90. for dir in \
  91. jvmdir jvmjardir jvmprivdir \
  92. jvmlibdir jvmdatadir jvmsysconfdir \
  93. jvmcommonlibdir jvmcommondatadir jvmcommonsysconfdir \
  94. javadir jnidir javadocdir mavendepmapdir; do
  95. export _${dir}=$(rpm --eval $(%{__grep} -E "^%_${dir}\b" \
  96. misc/macros.jpackage | %{__awk} '{ print $2 }'))
  97. done
  98. install -dm 755 ${RPM_BUILD_ROOT}%{_bindir}
  99. install -dm 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/{java,rpm}
  100. %if %{gcj_support}
  101. install -dm 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/java/security
  102. install -dm 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/java/security/security.d
  103. %endif
  104. install -dm 755 ${RPM_BUILD_ROOT}${_jvmdir}
  105. install -dm 755 ${RPM_BUILD_ROOT}${_jvmjardir}
  106. install -dm 755 ${RPM_BUILD_ROOT}${_jvmprivdir}
  107. install -dm 755 ${RPM_BUILD_ROOT}${_jvmlibdir}
  108. install -dm 755 ${RPM_BUILD_ROOT}${_jvmdatadir}
  109. install -dm 755 ${RPM_BUILD_ROOT}${_jvmsysconfdir}
  110. install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommonlibdir}
  111. install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommondatadir}
  112. install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommonsysconfdir}
  113. install -dm 755 ${RPM_BUILD_ROOT}${_javadir}
  114. install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-utils
  115. install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-ext
  116. install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-{1.3.1,1.4.0,1.4.1,1.4.2}
  117. install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-{1.5.0,1.6.0,1.7.0}
  118. install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}
  119. install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-ext
  120. install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-{1.3.1,1.4.0,1.4.1,1.4.2}
  121. install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-{1.5.0,1.6.0,1.7.0}
  122. install -dm 755 ${RPM_BUILD_ROOT}${_javadocdir}
  123. install -dm 755 ${RPM_BUILD_ROOT}${_mavendepmapdir}
  124. install -pm 755 bin/* ${RPM_BUILD_ROOT}%{_bindir}
  125. install -pm 644 etc/font.properties ${RPM_BUILD_ROOT}%{_sysconfdir}/java
  126. # Create an initial (empty) depmap
  127. echo -e "<dependencies>\\n" \
  128. > ${RPM_BUILD_ROOT}${_mavendepmapdir}/maven2-depmap.xml
  129. echo -e "</dependencies>\\n" \
  130. >> ${RPM_BUILD_ROOT}${_mavendepmapdir}/maven2-depmap.xml
  131. cat > etc/java.conf << EOF
  132. # System-wide Java configuration file -*- sh -*-
  133. #
  134. # JPackage Project <http://www.jpackage.org/>
  135. # Location of jar files on the system
  136. JAVA_LIBDIR=${_javadir}
  137. # Location of arch-specific jar files on the system
  138. JNI_LIBDIR=${_jnidir}
  139. # Root of all JVM installations
  140. JVM_ROOT=${_jvmdir}
  141. # You can define a system-wide JVM root here if you're not using the
  142. # default one.
  143. #
  144. # If you have the a base JRE package installed
  145. # (e.g. java-1.7.0-icedtea):
  146. #JAVA_HOME=\$JVM_ROOT/jre
  147. #
  148. # If you have the a devel JDK package installed
  149. # (e.g. java-1.7.0-icedtea-devel):
  150. #JAVA_HOME=\$JVM_ROOT/java
  151. # Options to pass to the java interpreter
  152. JAVACMD_OPTS=
  153. EOF
  154. install -pm 644 etc/java.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/java
  155. install -pm 644 etc/jpackage-release ${RPM_BUILD_ROOT}%{_sysconfdir}/java
  156. install -pm 644 java-utils/* ${RPM_BUILD_ROOT}${_javadir}-utils
  157. install -pm 644 misc/macros.jpackage ${RPM_BUILD_ROOT}%{_sysconfdir}/rpm
  158. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
  159. install -pm 644 man/* ${RPM_BUILD_ROOT}%{_mandir}/man1
  160. %{__mkdir_p} ${RPM_BUILD_ROOT}${_javadir}-utils/xml
  161. install -pm 644 xml/* ${RPM_BUILD_ROOT}${_javadir}-utils/xml
  162. cat <<EOF > %{name}-%{version}.files
  163. %{_bindir}/*
  164. %{_mandir}/man1/*
  165. %dir %{_sysconfdir}/java
  166. %if %{gcj_support}
  167. %{_sysconfdir}/java/security
  168. %endif
  169. %dir ${_jvmdir}
  170. %dir ${_jvmjardir}
  171. %dir ${_jvmprivdir}
  172. # %dir ${_jvmlibdir}
  173. %dir ${_jvmdatadir}
  174. %dir ${_jvmsysconfdir}
  175. %dir ${_jvmcommonlibdir}
  176. %dir ${_jvmcommondatadir}
  177. %dir ${_jvmcommonsysconfdir}
  178. %dir ${_javadir}
  179. %dir ${_javadir}-*
  180. %dir ${_jnidir}
  181. %dir ${_jnidir}-*
  182. %dir ${_javadocdir}
  183. %dir ${_mavendepmapdir}
  184. ${_javadir}-utils/*
  185. %config %{_sysconfdir}/java/jpackage-release
  186. %config(noreplace) %{_sysconfdir}/java/java.conf
  187. %config(noreplace) %{_sysconfdir}/java/font.properties
  188. %config(noreplace) %{_sysconfdir}/rpm/macros.jpackage
  189. %config(noreplace) ${_mavendepmapdir}/maven2-depmap.xml
  190. EOF
  191. %clean
  192. rm -rf $RPM_BUILD_ROOT
  193. %files -f %{name}-%{version}.files
  194. %defattr(-,root,root,-)
  195. %doc LICENSE.txt HEADER.JPP doc/* etc/httpd-javadoc.conf
  196. %changelog
  197. * Wed Apr 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.4-2jpp2
  198. - changed Group to System Environment/Base
  199. * Wed Apr 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-2jpp1
  200. - use new versioning policy
  201. * Thu Mar 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-2jpp0vl1
  202. - initial build for Vine Linux
  203. * Tue Jan 22 2008 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.4-2jpp.2
  204. - Replace GCJ security directory.
  205. * Tue Jan 22 2008 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.4-2jpp.1
  206. - Import jpackage-utils 1.7.4-2jpp.
  207. * Mon Jan 21 2008 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.4
  208. - Remove AutoReqProv.
  209. - Remove Requires and BuildRequires.
  210. - Wrap export, install and maven lines at 80 columns.
  211. - Add jre option to java.conf comment.
  212. - Related: rhbz#428520
  213. - Remove commented jpackage.org sections.
  214. - Remove duplicate files from files list.
  215. - Remove trailing whitespace.
  216. - Remove rebuild-security-providers.
  217. - Resolves: rhbz#260161
  218. * Fri Jan 04 2008 Ralph Apel <r.apel at r-apel.de> - 0:1.7.4-2jpp
  219. - Fix Bug 293
  220. * Wed Dec 19 2007 Ville Skyttä <scop at jpackage.org> - 0:1.7.4-1jpp
  221. - Terminate functions with %%{nil} in macros.jpackage.
  222. - Make %%jpackage_script install the script with 0755 permissions.
  223. - Use exec in java-functions' run().
  224. * Wed Jun 20 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.3
  225. - Add 1.7.0 directories.
  226. * Fri May 25 2007 Jason Corley <jason.corley@gmail.com> - 0:1.7.3-2jpp
  227. - change distribution and vendor to macros
  228. - rebuild in mock
  229. * Thu Jan 11 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.2
  230. - Add 1.6.0 directories missed in merge.
  231. - Resolves: rhbz#221262
  232. * Mon Dec 11 2006 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.1
  233. - Import version 0:1.7.3-1jpp from jpackage.org.
  234. - Change release numbering format to Xjpp.Y.fc7.
  235. - Resolves: rhbz#218936
  236. * Sat Nov 11 2006 Ville Skyttä <scop at jpackage.org> - 0:1.7.3-1jpp
  237. - Add Java 1.6.0 dirs.
  238. * Mon Oct 23 2006 Deepak Bhole <dbhole@redhat.com> 1.7.2-1jpp
  239. - Added maven2 depmap related macros.
  240. * Tue Sep 19 2006 Fernando Nasser <fnasser@jpackage.org> 0:1.7.1-1jpp
  241. - Add new scripts from Deepak Bhole
  242. - Add documentation from Jason Corley
  243. - Add XLT file shared by maven2 packages
  244. * Fri Nov 04 2005 Fernando Nasser <fnasser@jpackage.org> 0:1.7.0-1jpp
  245. - Initial 1.7 release (eq. to 1.6.6)
  246. - Add Copyright notice and license as header
  247. * Sun Sep 18 2005 David Walluck <david@jpackage.org> 0:1.6.6-1jpp
  248. - always define macros
  249. * Sat Sep 17 2005 David Walluck <david@jpackage.org> 0:1.6.5-2jpp
  250. - clean tarball
  251. * Sat Sep 17 2005 David Walluck <david@jpackage.org> 0:1.6.5-1jpp
  252. - fix conditional macros
  253. - merge nim's and robert's changes
  254. * Mon Aug 22 2005 David Walluck <david@jpackage.org> 0:1.6.4-1jpp
  255. - long needed s/All/Some in error messages
  256. * Fri Jan 28 2005 Nicolas Mailhot <nim at jpackage.org> - 0:1.6.3-1jpp
  257. - prefer full JVM to JRE when not specified (my bad, sorry)
  258. - remove LICENSE.txt as it does not seem to exist in the jpp16 branch anymore
  259. * Sat Jan 15 2005 Nicolas Mailhot <nim at jpackage.org> - 0:1.6.2-1jpp
  260. - Happy new year jpackagers!
  261. - No longer define JAVA_HOME in default shipped java.conf (me)
  262. - Search if $JVM_ROOT/jre or $JVM_ROOT/java exist in functions if JAVA_HOME is
  263. not defined in java.conf (me)
  264. - Source ~/.java/java.conf in addition to /etc/java/java.conf in functions
  265. (me)
  266. - Make find-jar use the same error code as build-classpath (Joe Wortmann)
  267. (note however find-jar was never intended to use directly in scripts, it's
  268. a low-level way to test the search engine)
  269. - Change macros slightly so they no longer wreak havoc on x86_64 systems
  270. (Thomas Fitzsimmons for Red Hat)
  271. This is probably only a short-term fix since we've yet to decide how to
  272. handle real x86_64 JVMs cleanly.
  273. * Thu Dec 16 2004 Robert Ottenhag <support@bea.com> - 0:1.6.3-1jpp
  274. - Move the systemPrefs stuff into a separate new package java-systemprefs
  275. * Wed Dec 15 2004 Robert Ottenhag <support@bea.com> - 0:1.6.2-1jpp
  276. - Reapply all updates from 1.5.40-1jpp o 1.5.42-1jpp
  277. + Add support for splitting the installation of Java VMs/SDK/JREs
  278. according to FHS 2.3 in its architecture dependent, architecture
  279. independent, and configuration parts. Added new macros and dirs
  280. - %%{_jvmlibdir}, defined as %%{_libdir}/jvm, equal to %%{_jvmdir},
  281. - %%{_jvmdatadir}, defined as %%{_datadir}/jvm
  282. - %%{_jvmsysconfdir}, defined as %%{_sysconfdir}/jvm
  283. + Add support for splitting the installation of Java VMs/SDK/JREs
  284. in its common architecture dependent, architecture
  285. independent, and configuration parts. Added new macros and dirs
  286. - %%{_jvmcommonlibdir}, defined as %%{_libdir}/jvm-commmon
  287. - %%{_jvmcommondatadir}, defined as %%{_datadir}/jvm-commmon
  288. - %%{_jvmcommonsysconfdir}, defined as %%{_sysconfdir}/jvm-commmon
  289. + Ensure that a global systemPrefs database used by
  290. java.util.prefs.FileSystemPreferences exists at
  291. /etc/.java/.systemPrefs, or create an empty one if not, and
  292. symlink to it from %%{_jvmcommonsysconfdir}/java/jre/systemprefs.
  293. * Sat Dec 4 2004 Ville Skyttä <scop at jpackage.org> - 0:1.6.1-1jpp
  294. - java-functions (set_jvm_dirs): try "java -fullversion" before
  295. "java -version" for performance, improve regexps, use sed from $PATH.
  296. - Include correct specfile in tarball.
  297. * Tue Nov 2 2004 Nicolas Mailhot <nim@jpackage.org> - 0:1.6.0-2jpp
  298. - fix missing %%{_jnidir} in file list
  299. * Tue Oct 12 2004 Ville Skyttä <scop at jpackage.org> - 0:1.6.0-1jpp
  300. - Start preparing for JPackage 1.6:
  301. - License change: jpackage-utils >= 1.6.0 is available under the (BSD-like)
  302. JPackage License. See included LICENSE.txt.
  303. - Remove support for Java < 1.4 (dirs only for now).
  304. - Remove java_home.list and support for it.
  305. - Add support for installing macros.jpackage into Asianux's rpm config,
  306. thanks to Robert Ottenhag for the info.
  307. * Sun Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:1.5.38-2jpp
  308. - Rebuild with ant-1.6.2
  309. * Mon Jun 7 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.38-1jpp
  310. - Update java_home.list with Sun's default 1.5.0beta2 location.
  311. - Nuke extra copy of java.conf from tarball.
  312. * Wed May 26 2004 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> - 0:1.5.37-1jpp
  313. - add the --preserve-naming switch to build-jar-repository, and document it
  314. (following a discussion with Chip Turner)
  315. * Thu May 6 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.36-1jpp
  316. - Fix bootstrap problem by ensuring that build time macro expansion for
  317. %%{_sysconfdir}/java.conf uses macros defined in this package and does not
  318. rely on the macros being already defined.
  319. - Include correct spec file in tarball.
  320. * Tue May 04 2004 David Walluck <david@jpackage.org> 0:1.5.35-1jpp
  321. - expand macros in %%{_sysconfdir}/java.conf
  322. * Fri Mar 26 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.34-1jpp
  323. - Update java_home.list with Sun's default 1.4.2_04, 1.4.1_07, 1.3.1_10
  324. and 1.3.1_11 locations.
  325. * Tue Feb 09 2004 David Walluck <david@anti-microsoft.org> 0:1.5.33-1jpp
  326. - update for J2SE 1.5.0 Beta 1
  327. * Tue Jan 13 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.32-1jpp
  328. - Fix java-functions location in diff-jars.
  329. - Add (X)Emacs mode cookies to java.conf and java-functions.
  330. - Micro-performance improvement to set_javacmd.
  331. - Insert macros.jpackage before anything starting with "~/" in rpmrc's.
  332. - Include example httpd.conf snippet for javadocs.
  333. * Mon Dec 29 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.31-1jpp
  334. - Update java_home.list with Sun's default 1.4.2_03, 1.4.1_06 and 1.4.0_04
  335. locations.
  336. * Thu Nov 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> - 0:1.5.30-1jpp
  337. - Add a minimalist xfonset entry to the default font.properties
  338. * Tue Oct 21 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.29-1jpp
  339. - Update java_home.list with Sun's default 1.4.2_02 and 1.4.1_05 locations.
  340. * Fri Oct 17 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.28-1jpp
  341. - Make package bootstrappable, thanks to Markus Pilzecker for ideas.
  342. * Sun Aug 31 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.27-1jpp
  343. - Update jpackage-1.5-policy wrt. jvm-private and speling fixxes.
  344. * Sat Aug 30 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.26-1jpp
  345. - Add %%{_jvmprivdir} (== %%{_libdir}/jvm-private), a directory for
  346. JVM-private stuff (eg. JCE policy jars).
  347. - Update java_home.list with Sun's default 1.4.2_01 location.
  348. * Thu Aug 14 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.25-1jpp
  349. - Update java_home.list.
  350. - Save .spec in UTF-8.
  351. * Tue Jun 10 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.24-1jpp
  352. - fix more symlinks/copy corner cases
  353. * Tue Jun 10 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.23-1jpp
  354. - debug 1.5.22
  355. * Tue Jun 10 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.22-1jpp
  356. - more correct java version detection regexp, courtesy of Scott Brickner
  357. - allow creation of harlink/copy jar repositories since tomcat4 seems to need
  358. this (reported by Greg Barton)
  359. * Sun May 18 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.21-1jpp
  360. - fix a bug in jar repository handling
  361. - remove unused APPDIR in jar resolution
  362. - add doc for jpackage 1.5 policy
  363. * Tue May 16 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.20-1jpp
  364. - remove unneeded and brittle complexity
  365. * Tue May 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.19-1jpp
  366. - fix new jar repository scripts (more corner cases)
  367. - create symlinks for not-found extensions to allow a later repository rebuild
  368. - create symlinks as [extension].jar, for example [jsse][jcert].jar
  369. - allow both extension split and collapsing
  370. (one jar -> one directory of jars or the other way round)
  371. * Tue May 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.18-1jpp
  372. - fix new scripts
  373. * Tue May 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.17-1jpp
  374. - add initial java repository support
  375. * Sat May 10 2003 David Walluck <david@anti-microsoft.org> 0:1.5.16-1jpp
  376. - %%jpackage_script macro fix
  377. - add %%doc to file list
  378. - add %%config(noreplace) to jpackage-release in file list to shut up rpmlint
  379. * Wed May 7 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.15-1jpp
  380. - fix error message in java dir computation
  381. * Sun Apr 26 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.14-3jpp
  382. - use java fonts if available first
  383. * Sat Apr 26 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.14-1jpp
  384. - add java font config
  385. * Wed Apr 23 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-5jpp
  386. - use quotes in 'test -f'
  387. * Mon Apr 21 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-4jpp
  388. - use hardcoded file list for %%postun and %%triggerin
  389. * Thu Apr 17 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-3jpp
  390. - don't use quotes around the 'find' command in %%postun and %%triggerin
  391. - don't add a 'macrofiles:' line in %%triggerin to rpmrc if one isn't
  392. already there
  393. * Tue Apr 15 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-2jpp
  394. - try to support macros.jpackage on RedHat 9
  395. * Mon Apr 14 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-1jpp
  396. - change CLASSPATH to _CLASSPATH and JARS to _JARS
  397. - clean up trailing ':' in _CLASSPATH
  398. * Mon Apr 14 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.12-1jpp
  399. - remove build-classpath dependency on David's stuff since it fails horribly
  400. when people actually use it
  401. - try to actually fix triggers
  402. * Sat Apr 12 2003 David Walluck <david@anti-microsoft.org> 0:1.5.11-3jpp
  403. - don't remove macros.jpackage from rpmrc on jpackage-utils upgrade
  404. * Sat Apr 12 2003 David Walluck <david@anti-microsoft.org> 0:1.5.11-2jpp
  405. - remove argouml.log from tarball
  406. * Fri Apr 11 2003 David Walluck <david@anti-microsoft.org> 0:1.5.11-1jpp
  407. - add build-classpath-directory
  408. - add epoch
  409. * Thu Apr 10 2003 David Walluck <david@anti-microsoft.org> 1.5.10-1jpp
  410. - back to using %%{_libdir}/rpm/rpmrc for macros.jpackage
  411. - add %%{_javadir}--1.4.2 and %%{_jnidir}-1.4.2 directories
  412. - update package description
  413. - add JAVACMD_OPTS to java.conf
  414. - use new external java.conf
  415. - update build-classpath and java-functions to support directories in
  416. CLASSPATH
  417. * Mon Mar 24 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.9-1jpp
  418. - more symlinks handling
  419. * Wed Mar 19 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.7-1jpp
  420. - register new jvm alternatives
  421. - allow use of build-classpath for incomplete paths
  422. * Tue Mar 11 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.6-1jpp
  423. - resurect borked icon/menu handling
  424. - hopefuly support jni jars (arch-dependant jars)
  425. * Thu Feb 13 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.4-3jpp
  426. - extract jar resolving logic from classpath builder
  427. - hopefully integrate classpath builder in set_classpath macro
  428. * Wed Feb 12 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.3-1jpp
  429. - add classpath builder
  430. * Wed Feb 12 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.2-1jpp
  431. - New reorg
  432. * Tue Feb 11 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.1-1jpp
  433. - add some extension handling
  434. - fix some macros broken in 1.5.0
  435. * Tue Feb 11 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.0-1jpp
  436. - use a tar source file
  437. - use lsb locations
  438. - prepare for multi-jvm extensions support
  439. * Mon Feb 10 2003 David Walluck <david@anti-microsoft.org> 1.4.8-1jpp
  440. - better installation of macros
  441. - update %%description to list all files currently included in this package
  442. - jpackage-release in %%{_sysconfdir}, not /etc (I hope this is more
  443. correct)
  444. * Sun Feb 09 2003 David Walluck <david@anti-microsoft.org> 1.4.7-1jpp
  445. - fix sed in %%jpackage_script when paths to jars contain '/'
  446. - fix typo in macros documentation
  447. - add jpackage-policy
  448. - add jpackage-release
  449. * Wed Feb 05 2003 David Walluck <david@anti-microsoft.org> 1.4.6-1jpp
  450. - macro bugfixes
  451. - instead of tarball we now use %%{SOURCEn} format
  452. * Fri Jan 31 2003 David Walluck <david@anti-microsoft.org> 1.4.5-1jpp
  453. - add macros.jpackage (DO NOT attempt to use this until we figure something
  454. out, but I would still like to get some feedback about how it looks so far)
  455. * Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 1.4.4-1jpp
  456. - fix exiting on failed `which` (Ville Skyttä <scop at jpackage.org>)
  457. * Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 1.4.3-2jpp
  458. - fix release tag in %%changelog
  459. * Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 1.4.3-1jpp
  460. - java-functions changes:
  461. + set_jvm: look for javac first to avoid erroneously setting
  462. JAVA_HOME to the location of the jre unless we have to
  463. + set_jvm: follow symlinks to avoid erroneously setting JAVA_HOME to
  464. /usr/bin
  465. + set_jvm: export JAVA_HOME
  466. - changed to use install instead of mkdir and cp
  467. - remove %%attr and rely on install to set the permissions instead
  468. * Sat Jan 25 2003 Ville Skyttä <scop at jpackage.org> - 1.4.2-1jpp
  469. - java-functions changes:
  470. + Prevent non-success exit code from "which" in set_jvm, it can now
  471. be used when building RPMs.
  472. + Use set_jvm in set_javacmd.
  473. + Use set_javacmd and $JAVACMD in run.
  474. - Fix Group tag.
  475. * Sat Dec 28 2002 Ville Skyttä <scop at jpackage.org> - 1.4.1-1jpp
  476. - Add Sun's 1.4.0_03 and BEA JRockit 7.0SP1 default RPM locations.
  477. * Thu Nov 21 2002 Ville Skyttä <scop at jpackage.org> - 1.4-1jpp
  478. - Fix diff-jars when diffing 2 jars with same basename (#635202).
  479. - Add IBM's 1.4 default RPM location to jvm.list.
  480. * Fri Nov 8 2002 Ville Skyttä <scop at jpackage.org> - 1.3-6jpp
  481. - Add Sun's 1.3.1_06 default RPM location.
  482. * Sat Oct 19 2002 Ville Skyttä <scop at jpackage.org> 1.3-5jpp
  483. - Add Sun's 1.4.1_01 and 1.3.1_05 default RPM locations.
  484. * Tue Sep 17 2002 Ville Skyttä <scop at jpackage.org> 1.3-4jpp
  485. - Add Sun's 1.4.1 default rpm location.
  486. * Thu Sep 12 2002 Ville Skyttä <scop at jpackage.org> 1.3-3jpp
  487. - Add Sun's 1.4.0_02 and new BEA JRockit locations.
  488. * Sat Jun 29 2002 Ville Skyttä <scop at jpackage.org> 1.3-2jpp
  489. - Add section macro.
  490. * Sat Jun 29 2002 Ville Skyttä <scop at jpackage.org> 1.3-1jpp
  491. - Add some variants of Sun J2SE java homes as well as JRockit.
  492. - Add Distribution tag.
  493. * Fri May 3 2002 Nicolas Mailhot <nmailhot@users.sourceforge.net> 1.2-1jpp
  494. Add some stuff to please jakarta ant developpers :
  495. - OSX java home
  496. - new function set_javacmd with AIX hack included
  497. * Wed Dec 19 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.1-1jpp
  498. - java-functions: centralized configuration
  499. - java-functions: jvm list lookup
  500. - diff-jars: fixed typo
  501. - diff-jars: used /tmp for files
  502. - corrected changelog
  503. * Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.0-1jpp
  504. - first JPackage release