phonon-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227
  1. Summary: Multimedia framework api
  2. Summary(ja): マルチメディアフレームワーク API
  3. Name: phonon
  4. Version: 4.3.80
  5. Release: 2%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://phonon.kde.org/
  9. Source0: ftp://ftp.kde.org/pub/kde/unstable/phonon/phonon-%{version}.tar.bz2
  10. Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
  11. Source11: hi16-phonon-gstreamer.png
  12. Source12: hi22-phonon-gstreamer.png
  13. Source13: hi32-phonon-gstreamer.png
  14. Source14: hi48-phonon-gstreamer.png
  15. Source15: hi64-phonon-gstreamer.png
  16. Source16: hi128-phonon-gstreamer.png
  17. # Prefer PulseAudio
  18. # This one was easiest to port, but doesn't seem to work by itself as-is
  19. # maybe we can just wait for the improvie PA support to land.
  20. Patch1: phonon-4.3.50-xine_pulseaudio.patch
  21. ## Mandriva/upstreamable patches
  22. Patch50: phonon-4.2.0-ogg-mime-type.patch
  23. Patch51: phonon-4.3.50-fix-decodebin-usage.patch
  24. Patch52: phonon-4.3.50-gstreamer-fix-seekable-query-failed.patch
  25. Patch53: phonon-4.3.50-phonon-allow-stop-empty-source.patch
  26. Patch54: phonon-4.3.80-fix-gstreamer-pulseaudio-deadlock.patch
  27. ## Upstream patches
  28. # http://bugs.kde.org/223662
  29. Patch100: phonon-4.3.80-kde223662.patch
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. BuildRequires: automoc4 >= 0.9.86
  32. BuildRequires: cmake >= 2.6.0
  33. BuildRequires: glib2-devel
  34. BuildRequires: gstreamer-devel
  35. BuildRequires: gstreamer-plugins-base-devel
  36. BuildRequires: libxcb-devel
  37. BuildRequires: libxml2-devel
  38. BuildRequires: qt4-devel >= 4.4.0
  39. BuildRequires: xine-lib-devel
  40. BuildRequires: pulseaudio-libs-devel
  41. #BuildRequires: pulseaudio-libs-devel >= 0.9.21
  42. Requires: phonon-backend >= %{version}
  43. Requires: qt4 >= 4.6.0
  44. %description
  45. Phonon is a cross-platform portable Multimedia Support Abstraction,
  46. which allows you to play multiple audio or video formats with the same
  47. quality on all platforms, no matter which underlying architecture is
  48. used.
  49. %package backend-gstreamer
  50. Summary: Gstreamer phonon backend
  51. Group: System Environment/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: gstreamer-plugins-good
  54. Obsoletes: %{name}-backend-gst < 4.2.0-4
  55. Provides: %{name}-backend-gst = %{version}-%{release}
  56. Provides: phonon-backend = %{version}-%{release}
  57. %description backend-gstreamer
  58. %{summary}.
  59. %package backend-xine
  60. Summary: xine phonon backend
  61. Group: System Environment/Libraries
  62. Requires: %{name} = %{version}-%{release}
  63. Provides: phonon-backend = %{version}-%{release}
  64. %description backend-xine
  65. %{summary}.
  66. %package devel
  67. Summary: Development files for phonon
  68. Group: Development/Libraries
  69. Requires: %{name} = %{version}-%{release}
  70. Requires: qt4-devel >= 4.6.0
  71. %description devel
  72. Header files for developing applications using phonon
  73. %prep
  74. %setup -q
  75. %patch1 -p1 -b .xine_pulseaudio
  76. %patch50 -p0 -b .ogg-mime-type
  77. %patch51 -p0 -b .fix-decodebin-usage
  78. %patch52 -p1 -b .gstreamer-fix-seekable-query-failed
  79. %patch53 -p1 -b .phonon-allow-stop-empty-source
  80. %patch54 -p1 -b .gstreamer-pulseaudio-deadlock
  81. %patch100 -p3 -b .kde223662
  82. %build
  83. %ifarch x86_64
  84. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  85. %endif
  86. mkdir -p %{_target_platform}
  87. pushd %{_target_platform}
  88. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  89. %cmake \
  90. -DUSE_INSTALL_PLUGIN=TRUE \
  91. ..
  92. popd
  93. make %{?_smp_mflags} -C %{_target_platform}
  94. %install
  95. rm -rf $RPM_BUILD_ROOT
  96. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  97. # symlink for qt/phonon compatibility
  98. ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
  99. # move the oxygen-only phonon-xine icons to hicolor
  100. test -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor && exit 0
  101. mv $RPM_BUILD_ROOT%{_datadir}/icons/oxygen \
  102. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
  103. # gstreamer icons
  104. install -D -m 0644 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/phonon-gstreamer.svg
  105. install -D -m 0644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/phonon-gstreamer.png
  106. install -D -m 0644 %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/phonon-gstreamer.png
  107. install -D -m 0644 %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/phonon-gstreamer.png
  108. install -D -m 0644 %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/phonon-gstreamer.png
  109. install -D -m 0644 %{SOURCE15} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/64x64/apps/phonon-gstreamer.png
  110. install -D -m 0644 %{SOURCE16} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/phonon-gstreamer.png
  111. %clean
  112. rm -rf $RPM_BUILD_ROOT
  113. %post -p /sbin/ldconfig
  114. %postun -p /sbin/ldconfig
  115. %posttrans backend-gstreamer
  116. %gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  117. %posttrans backend-xine
  118. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  119. %postun backend-gstreamer
  120. if [ $1 -eq 0 ] ; then
  121. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  122. fi
  123. %postun backend-xine
  124. if [ $1 -eq 0 ] ; then
  125. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  126. fi
  127. %files
  128. %defattr(-,root,root)
  129. %doc COPYING.LIB
  130. %{_libdir}/*.so.*
  131. %{_datadir}/dbus-1/interfaces/*
  132. # kde4-specific dirs
  133. %dir %{_libdir}/kde4/plugins/phonon_backend
  134. %dir %{_datadir}/kde4/services/phononbackends
  135. %files backend-gstreamer
  136. %defattr(-,root,root,-)
  137. %{_libdir}/kde4/plugins/phonon_backend/phonon_gstreamer.so
  138. %{_datadir}/kde4/services/phononbackends/gstreamer.desktop
  139. %{_datadir}/icons/hicolor/*/apps/phonon-gstreamer.*
  140. %files backend-xine
  141. %defattr(-,root,root,-)
  142. %{_libdir}/kde4/plugins/phonon_backend/phonon_xine.so
  143. %{_datadir}/kde4/services/phononbackends/xine.desktop
  144. %{_datadir}/icons/hicolor/*/apps/phonon-xine.*
  145. %files devel
  146. %defattr(-,root,root)
  147. %dir %{_includedir}/KDE
  148. %{_includedir}/KDE/Phonon/
  149. %{_includedir}/phonon/
  150. %{_libdir}/*.so
  151. %{_libdir}/pkgconfig/*.pc
  152. %changelog
  153. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
  154. - added qmake path to PATH (if x86_64)
  155. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
  156. - new upstream release
  157. - built with new toolchain
  158. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
  159. - added Patch102 and 103 from FC
  160. * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
  161. - fix for '#' in filenames
  162. * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
  163. - restore patches to the xine backend
  164. * Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
  165. - added Patch100 and 101 from FC
  166. * Tue Mar 3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
  167. - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
  168. - added backend sub-pakcages
  169. * Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
  170. - new upstream release
  171. - add BuildPrereq: cmake
  172. * Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
  173. - new upstream release
  174. * Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
  175. - new upstream release
  176. - update %%files
  177. - add BuildPrereq: xine-lib-devel libxcb-devel
  178. * Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
  179. - new upstream release
  180. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
  181. - added script to append qmake path
  182. - added option -DLIB_INSTALL_DIR at cmake
  183. * Tue Oct 7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
  184. - initial release for VineSeed