texinfo-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389
  1. %define extraver a
  2. %define _infodir /usr/share/info
  3. Summary: Tools needed to create Texinfo format documentation files.
  4. Summary(ja): Texinfo ドキュメントを作成する為に使うツール群
  5. Name: texinfo
  6. Version: 4.8
  7. Release: 1%{?_dist_release}
  8. License: GPL
  9. Group: Applications/Publishing
  10. URL: http://www.gnu.org/software/texinfo/
  11. Source0: ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}%{?extraver:%extraver}.tar.bz2
  12. Source1: info-dir
  13. Patch1: texinfo-fix.patch
  14. Patch3: texinfo-4.3-zlib.patch
  15. Prereq: install-info
  16. Prefix: %{_prefix}
  17. Buildroot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: autoconf libtool ncurses-devel zlib-devel
  19. # Redifine this to "dir" in the info directory isn't compressed
  20. %define __spec_install_post /usr/lib/rpm/brp-strip \; /usr/lib/rpm/brp-strip-comment-note \; rm -f
  21. %description
  22. Texinfo is a documentation system that can produce both online
  23. information and printed output from a single source file. The GNU
  24. Project uses the Texinfo file format for most of its documentation.
  25. Install texinfo if you want a documentation system for producing both
  26. online and print documentation from the same source file and/or if you
  27. are going to write documentation for the GNU Project.
  28. %description -l ja
  29. Texinfo は,単一ソースファイルから,オンラインドキュメントと
  30. 印刷用ファイルを出力することの出来るドキュメントシステムです.
  31. GNU Project では,殆どのドキュメントでこの Texinfo フォーマットを
  32. 採用しています.
  33. 単一ソースファイルからオンラインドキュメントと印刷用ファイルを出力
  34. したい場合,あるいは GNU Project 用にドキュメントを書こうと思っている
  35. 場合は,この texinfo をインストールして下さい.
  36. %package -n info
  37. Summary: A stand-alone TTY-based reader for GNU texinfo documentation.
  38. Summary(ja): TTY ベースのスタンドアロン GNU texinfo ドキュメントリーダ
  39. Group: System Environment/Base
  40. # By making info prereq bash, other packages which have triggers based on
  41. # info don't run those triggers until bash is in place as well. This is an
  42. # ugly method of doing it (triggers which fire on set intersection would
  43. # be better), but it's the best we can do for now. Talk to Erik before
  44. # removing this.
  45. Prereq: bash install-info
  46. Requires: install-info
  47. %description -n info
  48. The GNU project uses the texinfo file format for much of its
  49. documentation. The info package provides a standalone TTY-based
  50. browser program for viewing texinfo files.
  51. %description -n info -l ja
  52. GNU Project では殆どのドキュメントに texinfo 形式を採用しています.
  53. この info パッケージには texinfo ファイルを読む TTY ベースの
  54. ブラウザプログラムが収められています.
  55. %package -n install-info
  56. Summary: info file installer
  57. Summary(ja): info ファイルのインストーラー
  58. Group: System Environment/Base
  59. Conflicts: info < 4.0b-3vl2
  60. %description -n install-info
  61. info file installer.
  62. %description -n install-info -l ja
  63. info ファイルのインストーラーです.
  64. %prep
  65. %setup -q
  66. #%%patch1 -p1
  67. %patch3 -p1 -b .zlib
  68. %build
  69. %configure --mandir=%{_mandir} --infodir=%{_infodir}
  70. make %{?_smp_mflags}
  71. make -C util LIBS=%{_libdir}/libz.a
  72. %install
  73. rm -rf ${RPM_BUILD_ROOT}
  74. mkdir -p ${RPM_BUILD_ROOT}/{etc,sbin}
  75. %makeinstall
  76. ( cd ${RPM_BUILD_ROOT}
  77. gzip -n -9f .%{_infodir}/*info*
  78. gzip -n -9f .%{_mandir}/*/*
  79. install -m644 ${RPM_SOURCE_DIR}/info-dir ./etc/info-dir
  80. ln -sf /etc/info-dir ${RPM_BUILD_ROOT}%{_infodir}/dir
  81. for i in makeinfo texindex info install-info ; do
  82. strip .%{_bindir}/$i
  83. done
  84. mv -f .%{_bindir}/install-info ./sbin
  85. )
  86. %find_lang %name
  87. %clean
  88. rm -rf ${RPM_BUILD_ROOT}
  89. %post
  90. /sbin/install-info %{_infodir}/texinfo.gz %{_infodir}/dir
  91. %preun
  92. if [ $1 = 0 ]; then
  93. /sbin/install-info --delete %{_infodir}/texinfo.gz %{_infodir}/dir
  94. fi
  95. %post -n info
  96. /sbin/install-info %{_infodir}/info-stnd.info.gz %{_infodir}/dir
  97. %preun -n info
  98. if [ $1 = 0 ]; then
  99. /sbin/install-info --delete %{_infodir}/info-stnd.info.gz %{_infodir}/dir
  100. fi
  101. %files -f %{name}.lang
  102. %defattr(-,root,root)
  103. %doc AUTHORS ChangeLog INSTALL INTRODUCTION NEWS README TODO
  104. %{_bindir}/makeinfo
  105. %{_bindir}/texindex
  106. %{_bindir}/texi2dvi
  107. %{_datadir}/texinfo
  108. %{_infodir}/texinfo*
  109. %{_mandir}/man1/makeinfo.1*
  110. %{_mandir}/man1/texindex.1*
  111. %{_mandir}/man1/texi2dvi.1*
  112. %{_mandir}/man5/texinfo.5*
  113. %files -n info
  114. %defattr(-,root,root)
  115. #%config(missingok) /etc/X11/applnk/Utilities/info.desktop
  116. #%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
  117. #%config(noreplace) %{_infodir}/dir
  118. %doc info/README
  119. %{_bindir}/info
  120. %{_bindir}/infokey
  121. %{_infodir}/info.info*
  122. %{_infodir}/info-stnd.info*
  123. %{_mandir}/man1/info.1*
  124. %{_mandir}/man1/infokey.1*
  125. %{_mandir}/man5/info.5*
  126. %files -n install-info
  127. %defattr(-,root,root)
  128. %config(noreplace) %verify(not md5 size mtime) /etc/info-dir
  129. %config(noreplace) %{_infodir}/dir
  130. %{_syssbindir}/install-info
  131. %{_mandir}/man1/install-info.1*
  132. %changelog
  133. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.8-1vl5
  134. - applied new versioning policy, spec in utf-8
  135. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.8-0vl1
  136. - new upstream release (4.8a)
  137. - move /etc/info-dir, %%{_infodir}/dir to install-info package
  138. - add URL
  139. - not apply patch1
  140. * Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.7-0vl2
  141. - rebuilt for x86_64 architecture support
  142. * Thu Jul 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7-0vl1
  143. - new upstream release
  144. * Sat Dec 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2-5vl1
  145. - updated to 4.2 based on 4.2-5
  146. * Mon Sep 2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-5
  147. - Fix crash w/ MALLOC_CHECK_ == 2 (#72831)
  148. * Tue Jul 2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
  149. - Add infokey (#67728)
  150. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  151. - automated rebuild
  152. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  153. - automated rebuild
  154. * Tue Apr 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  155. - 4.2
  156. * Mon Apr 7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.1-1vl4
  157. - rebuild
  158. * Fri Nov 29 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1-1vl3
  159. - /usr/info -> /usr/share/info (defined on the first line of this spec)
  160. (rpm-4.0.4-18vl11 and later will define so, though)
  161. * Sun Mar 17 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl2
  162. - rewrote changelog at 4.0b-3vl4 (fixed typo)
  163. - rebuild
  164. * Sat Mar 16 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl1
  165. - updated texinfo-4.1
  166. - fixed broken changelog ;P
  167. * Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 4.0b-3vl4
  168. - updated on zlib (security Fix.)
  169. * Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0b-3vl3
  170. - just rebuild with new release number.
  171. * Mon Feb 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl2
  172. - Oops the spec was in Shift-JIS. Fixed.
  173. * Mon Feb 11 2002 akira yamada <akira@vinelinux.org> 4.0b-3vl2
  174. - %{_syssbindir}/install-info is separated from info package.
  175. - added autoconf, libtool, ncurses-devel, zlib-devel to BuildRequires.
  176. * Mon Jan 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl1
  177. - based on 4.0b-3 from Rawhide and built for Vine Linux
  178. - added Japanese summary and description
  179. - fixed rpm macros
  180. * Tue Aug 7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0b-3
  181. - Don't create the desktop file - we don't install it anyway.
  182. * Sat Jul 21 2001 Tim Powers <timp@redhat.com>
  183. - remove the info viewer from the menus, it's cluttering things
  184. * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  185. - 4.0b
  186. * Tue Apr 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0a-1
  187. - Update to 4.0a, the patch looks sane
  188. * Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
  189. - langify
  190. - don't create desktop file in spec file
  191. * Tue Jan 23 2001 Preston Brown <pbrown@redhat.com>
  192. - danish translation added
  193. * Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  194. - Rebuild to get rid of 0777 dirs
  195. * Wed Nov 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  196. - Fix recognition of .?o extensions in texi2dvi, Bug #20498
  197. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  198. - FHS packaging (64bit systems need to use %%_libdir not /usr/lib).
  199. * Sat Aug 19 2000 Trond Eivind Glomsr <teg@redhat.com>
  200. - really do it - #16120
  201. * Mon Aug 14 2000 Helge Deller <hdeller@redhat.com>
  202. - gzip man-pages, #16120
  203. * Mon Aug 7 2000 Tim Waugh <twaugh@redhat.com>
  204. - List man-pages in %%files.
  205. * Fri Aug 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  206. - Add Swedish and German translations to desktop file, Bug #15366
  207. * Thu Aug 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  208. - mark /etc/info-dir %%verify(not md5 size mime), Bug #14826
  209. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  210. - automatic rebuild
  211. * Wed Jun 28 2000 Bill Nottingham <notting@redhat.com>
  212. - fix build wackiness with info page compressing
  213. * Fri Jun 16 2000 Bill Nottingham <notting@redhat.com>
  214. - fix info-dir symlink
  215. * Thu May 18 2000 Preston Brown <pbrown@redhat.com>
  216. - use FHS paths for info.
  217. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  218. - rebuild with current ncurses
  219. * Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
  220. - wmconfig -> desktop
  221. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  222. - fix descriptions
  223. * Wed Jan 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  224. - move info-stnd.info* to the info package, /sbin/install-info it
  225. in %post (Bug #6632)
  226. * Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
  227. - recompile to eliminate ncurses foul-up.
  228. * Tue Nov 9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
  229. - 4.0
  230. - handle RPM_OPT_FLAGS
  231. * Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
  232. - import version 3.12h into 6.1 tree from HJLu
  233. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  234. - auto rebuild in the new build environment (release 4)
  235. * Wed Mar 17 1999 Erik Troan <ewt@redhat.com>
  236. - hacked to use zlib to get rid of the requirement on gzip
  237. * Wed Mar 17 1999 Matt Wilson <msw@redhat.com>
  238. - install-info prerequires gzip
  239. * Thu Mar 11 1999 Cristian Gafton <gafton@redhat.com>
  240. - version 3.12f
  241. - make /usr/info/dir to be a %config(noreplace)
  242. * Wed Nov 25 1998 Jeff Johnson <jbj@redhat.com>
  243. - rebuild to fix docdir perms.
  244. * Thu Sep 24 1998 Cristian Gafton <gafton@redhat.com>
  245. - fix allocation problems in install-info
  246. * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
  247. - /sbin/install-info should not depend on /usr/lib/libz.so.1 -- statically
  248. link with /usr/lib/libz.a.
  249. * Fri Aug 07 1998 Erik Troan <ewt@redhat.com>
  250. - added a prereq of bash to the info package -- see the comment for a
  251. description of why that was done
  252. * Tue Jun 09 1998 Prospector System <bugs@redhat.com>
  253. - translations modified for de
  254. * Tue Jun 9 1998 Jeff Johnson <jbj@redhat.com>
  255. - add %attr to permit non-root build.
  256. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  257. - translations modified for de, fr, tr
  258. * Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
  259. - added %clean
  260. - manhattan build
  261. * Wed Mar 04 1998 Cristian Gafton <gafton@redhat.com>
  262. - upgraded to version 3.12
  263. - added buildroot
  264. * Sun Nov 09 1997 Donnie Barnes <djb@redhat.com>
  265. - moved /usr/info/dir to /etc/info-dir and made /usr/info/dir a
  266. symlink to /etc/info-dir.
  267. * Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
  268. - added wmconfig entry for info
  269. * Wed Oct 01 1997 Donnie Barnes <djb@redhat.com>
  270. - stripped /sbin/install-info
  271. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  272. - added info-dir to filelist
  273. * Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
  274. - added patch from sopwith to let install-info understand gzip'ed info files
  275. - use skeletal dir file from texinfo tarball (w/ bash entry to reduce
  276. dependency chain) instead (and install-info command everywhere else)
  277. - patches install-info to handle .gz names correctly
  278. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  279. - built against glibc
  280. * Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
  281. - patched install-info.c for glibc.
  282. - added /usr/bin/install-info to the filelist
  283. * Tue Feb 18 1997 Michael Fulbright <msf@redhat.com>
  284. - upgraded to version 3.9.